+ Responder ao Tópico



  1. #1

    Padrão Problemas com PPPoE no MK

    Galera, estou com um probleminha no PPPoE do meu mikrotik (Ou eu que não esotu sabendo configurar)

    Bom é o seguinte, tenho meu mikrotik ligado a um router cisco 2501.
    No mikrotik tenho um ip lan 189.108.xxx.xxx com a ip route apontado para o cisco.
    Faço um bridge no mk para que todos os clientes com ips publicos funcionem tendo o roteador cisco como full gateway.
    Tenho outros clientes numa nat configurado em 192.168.0.0/16 agora surgiu um problema
    estavamos querendo passar o sistema para pppoe.
    Bom os clientes de dos ips NAT 192.168.0.0/16 consegui fazer colocar pppoe neles.
    Agora os de ip publico não.
    Crio no ppp secrets um usuario no local address coloca o ip do cisco que é o full gateway e no remote address coloco o ip do cliente, e quano disco ele ate conecta mais naum navega, nem pinga, já quebrei a cabeça e não consegui ajuda eim lugar algum pro enquanto. Espero que me ajudem. Obrigado.

  2. #2



  3. #3

    Padrão

    Amigo o teu problema esta no pool de ip's que voce esta criando para os clientes, quando o cliente loga qual ip, mask, gateway q ele captura?? ta muito confuso este teu pool.. explica melhor..

  4. #4

    Padrão

    Bom o ip que ele pegar é um IP publcio dentro da faixa que eu coloco pra ele
    por exemplo 189.100.220.101 e o gateway eu coloco o ip do roteador da cisco que é meu full gateway 189.100.220.97 e a mascara é 255.255.255.248 mais não coloco isso e nenhum pool.
    apenas nas configurações do secret do ppp no mikotik.



  5. #5

    Padrão

    Ja que está utilizando ip válidos no pppoe, no remote address coloca o ip valido do cliente, em local address vc coloca o ip valido do mk que será o servidor pppoe(pode colocar sempre o mesmo já que sua rede é valida), em dns coloca um ip de dns válido tbm de preferencia de dentro da sua rede para nao dar muitos saltos, verifique se do mk pinga para fora se tudo ocorrer bem tranquilo.
    Caso queira ips dinamicos válidos para cada cliente é necessario criar um pool com os ips validos que quer distribuir, a mascara nao importa pois o pppoe deixa vc com mascara /32 ou 255.255.255.255.
    Com isso acredito que após a conexao, já seja possivel pingar o mk apartir do cliente e o cliente apartir do mk, se seu dns estiver configurado corretamente estará resolvendo os endereços, e sua configuracao foi feita com sucesso!
    Ainda não testei isso na pratica para ver se os pacotes recebidos com destino a um cliente de ip valido cheguem diretamente para ele, acredito que isso é possivel utilizando a opção routes no secrets.

    Espero ter ajudado!
    Abs!
    Última edição por darklinux3; 04-04-2009 às 18:22.

  6. #6

    Padrão

    Tenho pppoe aqui e repasso ips válidos por ele, tudo que o dark falou está corretíssimo.

    Só esqueceu de avisar pra deixar a interface q recebe o link como 'proxy-arp'


    Espero ter ajudado!

    Abs.



  7. #7

    Padrão

    Citação Postado originalmente por xnetinho Ver Post
    Tenho pppoe aqui e repasso ips válidos por ele, tudo que o dark falou está corretíssimo.

    Só esqueceu de avisar pra deixar a interface q recebe o link como 'proxy-arp'


    Espero ter ajudado!

    Abs.
    Como faço pra ativar essa opção de proxy-arp?
    Obrigado.

  8. #8



  9. #9

    Padrão

    Citação Postado originalmente por darklinux3 Ver Post
    interface set wlan1 arp=proxy-arp
    Na minha interface que recebe o link o ARP está como ENABLE
    só queria saber pra que, que funciona esse proxy-arp, qual sua função.
    E eu tenho um bridge interligando todas as interfaces, tenho que colocar proxy-arp na bridge ou só na interface que recebo o link?
    Obrigado

  10. #10

    Smile

    Justamente parar deixar sua interface transparente, na entrega de pacotes para os ips validos da rede.



  11. #11

    Padrão

    Citação Postado originalmente por darklinux3 Ver Post
    Justamente parar deixar sua interface transparente, na entrega de pacotes para os ips validos da rede.
    Mais tenho que colocar na bridge ou na interface que recebo o link?

  12. #12

    Padrão

    pessoal, dando uma olhada aqui no forum, ví que este "Proxy-arp" parece ser uma gambiarra, alguém se habilita a complementar ?



  13. #13

    Padrão

    Citação Postado originalmente por vhemi Ver Post
    Mais tenho que colocar na bridge ou na interface que recebo o link?
    Tem que ser na interface que recebe os links...

  14. #14

    Padrão

    Verdade, ja ouvi falar que é um sistema com falhas, bom não seria falhas a palavra certa, mais dá pra entender que é uma opção menos viavel em questões de segurança.
    Bom, eu fiz os teste e deu certo.
    Agora queria saber se existe outras soluções para esse problema, pois não estou contente sabendo que tenho que abrir mão da segurança pra usar esse tipo de protocolo.



  15. #15