+ Responder ao Tópico



  1. #1

    Red face Não consigo gravar com cdrecord no Debian

    Seguinte:
    Eu coloco p/ gravar assim >>> cdrecord -v -fs=16M dev=/dev/scd0 -data /home/amde/AMDE.txt

    Aki vai o log da gravação:

    wodim: No write mode specified.
    wodim: Asuming -tao mode.
    wodim: Future versions of wodim may have different drive dependent default s.
    TOC Type: 1 = CD-ROM
    scsidev: '/dev/scd0'
    devname: '/dev/scd0'
    scsibus: -2 target: -2 lun: -2
    Linux sg driver version: 3.5.27
    Wodim version: 1.1.2
    SCSI buffer size: 64512
    atapi: 1
    Device type : Removable CD-ROM
    Version : 5
    Response Format: 2
    Capabilities :
    Vendor_info : 'Optiarc '
    Identification : 'DVD RW AD-7200S '
    Revision : '1.06'
    Device seems to be: Generic mmc2 DVD-R/DVD-RW.
    Current: 0x000A (CD-RW)
    Profile: 0x002B (DVD+R/DL)
    Profile: 0x001B (DVD+R)
    Profile: 0x001A (DVD+RW)
    Profile: 0x0016 (DVD-R/DL layer jump recording)
    Profile: 0x0015 (DVD-R/DL sequential recording)
    Profile: 0x0014 (DVD-RW sequential recording)
    Profile: 0x0013 (DVD-RW restricted overwrite)
    Profile: 0x0012 (DVD-RAM)
    Profile: 0x0011 (DVD-R sequential recording)
    Profile: 0x0010 (DVD-ROM)
    Profile: 0x000A (CD-RW) (current)
    Profile: 0x0009 (CD-R)
    Profile: 0x0008 (CD-ROM) (current)
    Profile: 0x0002 (Removable disk)
    Using generic SCSI-3/mmc CD-R/CD-RW driver (mmc_cdr).
    Driver flags : MMC-3 SWABAUDIO BURNFREE
    Supported modes: TAO PACKET SAO SAO/R96R RAW/R96R
    Drive buf size : 866304 = 846 KB
    Beginning DMA speed test. Set CDR_NODMATEST environment variable if device
    communication breaks or freezes immediately after that.
    FIFO size : 16777216 = 16384 KB
    Track 01: data 0 MB padsize: 598 KB
    Total size: 0 MB (00:04.02) = 302 sectors
    Lout start: 1 MB (00:06/02) = 302 sectors
    Current Secsize: 2048
    ATIP info from disk:
    Indicated writing power: 3
    Reference speed: 6
    Is not unrestricted
    Is erasable
    Disk sub type: High speed Rewritable (CAV) media (1)
    ATIP start of lead in: -11240 (97:32/10)
    ATIP start of lead out: 359849 (79:59/74)
    1T speed low: 4 1T speed high: 10
    2T speed low: 4 2T speed high: 0 (reserved val 6)
    power mult factor: 1 5
    recommended erase/write power: 5
    A1 values: 24 1A D8
    A2 values: 26 B2 4A
    Disk type: Phase change
    Manuf. index: 27
    Manufacturer: Prodisc Technology Inc.
    Blocks total: 359849 Blocks current: 359849 Blocks remaining: 359547
    Speed set to 1764 KB/s
    Starting to write CD/DVD at speed 10.0 in real TAO mode for single sessio n.
    Last chance to quit, starting real write 0 seconds. Operation starts.
    Waiting for reader process to fill input buffer ... input buffer ready.
    Performing OPC...
    Starting new track at sector: 0
    Track 01: 0 of 0 MB written.
    WARNING: padding up to secsize.
    Track 01: writing 598 KB of pad data.
    Track 01: Total bytes read/written: 44/614400 (300 sectors).
    Writing time: 5.350s
    Average write speed 1.8x.
    Fixating...
    Fixating time: 31.526s
    BURN-Free was never needed.

    Eu entendo que gravou td ok, mas qndo vou ver no cd não tem nda gravado...

    OBS: Minha gravadora é sata!!! Meu Kernel >>> 2.6.21-2-686

    Alguem pode me ajudar?!!!!!!!!!
    Última edição por gabysmc; 17-04-2009 às 17:26.

  2. #2

    Padrão

    verifique se não é um gravador dual-layer aqui eu não conseguia gravar por isso, midia single-layer com gravador dual - agora, POR QUE não reconhece a midia, não soube dizer.



  3. #3

    Unhappy

    eu n tinha atentado p isso, e minha gravadora é genérica, creio q n eh dual,vou checar, mas pensei q gravadora dual gravava single, e o single n grava dual, n seria assim?!!!

  4. #4

    Padrão

    cara, acho que você não leu direito o resultado do comando
    Código :
    Track 01:    0 of    0 MB written.

    0 de 0 é 0 (zero)

    se você quer gravar com eficiência primeiro deve gerar o iso do que quer gravar, e depois passar para o cdrecord, usando a mesma linha que postou, mas trocando o arquivo .txt por um arquivo de imagem.



  5. #5

    Unhappy

    aaaaaaa... ok ok... ignorância minha, tô aprendendo... agora gerei o iso e mandei gravar dai ele apareceu
    Código :
    [COLOR=red][FONT=&quot]Track 01: data    25 MB[/FONT][/COLOR]


    Mas não consigo montar o cd p ver se ele gravou mesmo... ele me mostra o seguinte erro:

    mount: wrong fs type, bad option, bad superblock on /dev/scd0,
    missing codepage or other error
    In some cases useful info is found in syslog - try
    dmesg | tail or so

    E esse erro se n me engano é qndo ele n consegue montar pq n tem nda no cd neh?!!!

    e o dmesg | tail :

    end_request: I/O error, dev sr0, sector 0
    Buffer I/O error on device sr0, logical block 0
    end_request: I/O error, dev sr0, sector 0
    Buffer I/O error on device sr0, logical block 0
    UDF-fs: No VRS found
    Unable to identify CD-ROM format.
    UDF-fs: No VRS found
    Unable to identify CD-ROM format.
    UDF-fs: No VRS found
    Unable to identify CD-ROM format.

    Esse poderia ser a mídia neh?!! mas ja tentei com outras...

    HELP-ME!!

  6. #6

    Padrão

    cara, vai depender de como você gerou o iso, se o iso foi gerado corretamente pode ser problema na midia ou no drive.



  7. #7

    Padrão

    hmmm... gerei o iso da seguinte forma: mkisofs -o /caminho/imagem.iso -JrT /caminho/pasta_com_arquivos/



  8. #8

    Padrão

    por linha de comando não lembro como eu fazia.

    se estiver usando KDE experimente gerar o iso pelo k3b.



  9. #9

    Padrão

    tô sem modo gráfico... mas vlw a força aeh!!!

  10. #10

    Padrão

    Citação Postado originalmente por gabysmc Ver Post
    hmmm... gerei o iso da seguinte forma: mkisofs -o /caminho/imagem.iso -JrT /caminho/pasta_com_arquivos/
    experimente assim:

    gerar *iso
    mkisofs -J -L -l -r -T -V "Nome" -o /path/arquivo_destino.iso /path/arquivo_origem


    gravar cdrom:

    cdrecord -v /dev/cdrom speed=4 /path/arquivo.iso


    gravação de dvd's
    growisofs -dvd-compat -Z /dev/cdrom=/path/imagem.iso


    usando cdrecord:
    cdrecord -dev=/dev/cdrom -speed=4 -v -dao -pad XXX-DVD.iso

    ps: o meu LG gravava cdrom "normal", mas dvd.. nem matando. E troquei duas vezes, zerinho, na loja. Dai desisti.



  11. #11

    Unhappy

    eu fiz como vc disse:

    gerar *iso
    mkisofs -J -L -l -r -T -V "Nome" -o /path/arquivo_destino.iso /path/arquivo_origem

    gravar cdrom:

    cdrecord -v /dev/cdrom speed=4 /path/arquivo.iso

    e no final do log apareceu assim:
    Código :
    wodim: Tema 1 tem duração desconhecida.  
     wodim: Utilize tsize = opção em SAO modo a especificar faixa tamanho.

  12. #12

    Talking

    Bom, consegui fazer funcionar... Vamos ao problema: eu estava remotamente na máquina, então pedia pra colocarem a mídia para poder fazer os testes, só que eu pedia CD e colocavam DVD, por isso não conseguia gravar nada, mas de inicio o problema era as mídias de cds regravavel que tinham lá, dai pedi pra comprar mídias novas e compraram DVD, e esqueceram de me avisar...

    Gravei assim:

    Para gravar CD:
    cdrecord -v speed=8 dev=/dev/cdrom -data arquivo.iso

    Para gravar DVD é necessário o growisofs, então:
    apt-get install dvd+rw-tools

    Para gravar DVD:

    growisofs -dvd-compat -speed=2 -Z /dev/cdrom=arquivosiso

    VALEU!!!