Página 3 de 16 PrimeiroPrimeiro 12345678 ... ÚltimoÚltimo
+ Responder ao Tópico



  1. #41

    Padrão

    Após o PHP já temos todas as configurações ''básicas'' para que o Thunder rode, ai vamos entrar nas configurações específicas das interfaces,segurança,squid.conf,regras do Mk de mangle e firewall filter, limites de trafego, configurações em que o Mk ajudará muito o server não ficar sobrecarregado, e ai sim, é só esperar os clientes fazerem os comentários ( rsssssss )

    Vou relatar a vocês a resposta de um cliente meu quando pelo msn pedi para ele testar um vídeo do youtube, quando instalei o Thunder, a resposta dele foi:

    huuuuuuuuuaaaaaaaaaaaaaaaaaaaaauuuuuuuuuuuu (rssss)

    Vamos em frente...

  2. #42

    Padrão

    Citação Postado originalmente por rodrigomanga Ver Post
    sou burro ou não achei o passo a passo do thunder cache? ou isso aqui é o forum da matéria? sei lá, daqui a pouco e vejo.

    Parabéns por ter feito um passo a passo, isso ajuda bastante e comunidade, e divulga ainda mais o Thunder Cahe, q é um sistema open source sem fins lucrativos. Faço o sistema no meu tempo vago, com objetivo de melhorar o cache da minha lan house.

    O legal é q o sistema é otimo pra provedores, e tem um desempenho excelente, quem não usou, teste!

    Só não recomendo o plugin do orkut para usuários leigos, pois precisa de varias modificações no sistema, para que o desempenho seja bom, senão seu server vai travar!
    amigo, se vc e que fas isso, e se realmente faz o que promete o sistema, vc simplesmente e o mesias para nos provedores pequenos, eu ainda não testei, mas se realmente faz o que promete, vou mandar fazer uma estatua tua aqui no meu provedor, e tambem lan house ehehhehe..
    que deu te ilumine, se não tiver ganhos materiai´s como tem gente ganhando em cima do que tu ta fazendo, pod estar serto, ta gerando um carma enormeee. tu vai ser muito iluminado... ehhee hare baba.



  3. #43
    Moderador Avatar de Magal
    Ingresso
    Mar 2007
    Localização
    Rio de Janeiro
    Posts
    2.043
    Posts de Blog
    118

    Padrão

    É isso ai Roberto, sempre contribuindo com o fórum. Parabéns.

    Abs

    Magal

  4. #44

    Padrão

    Citação Postado originalmente por Magal Ver Post
    É isso ai Roberto, sempre contribuindo com o fórum. Parabéns.

    Abs

    Magal
    Esse aqui é TÉCNICO do meu time !!!!!!!!!!


    Abração.



  5. #45

    Padrão

    Olá pessoal, bom dia a todos!

    Será que o nosso manual está tão bom assim que ainda não apareceu nem uma dúvida da galera? Ontem um amigo nosso atravéz do msn me pediu uma ajuda para integrar o MK dele ao debian, e para a minha surpresa e a dele não fiz nada, já estava funcionando perfeitamente com ping '''0'''' do Mk para o debian.

    Um outro detalhe não menos importante para a perfeita integração do Mk ao server é fazer uma regra no firewall filter aceitando toda a conexão da faixa de ip's do server, que no caso seria 192.168.10.0/24, por que percebi que algumas regras de bloqueio de vírus bloqueiam ou limitam alguns vídeos dependendo de qual porta eles usem.

    Essa regra deve ficar antes da regra do bloqueio de vírus.

    Abração e bom fianl de seman a todos

  6. #46

    Padrão Obrigado Roberto

    Citação Postado originalmente por Roberto21 Ver Post
    Olá pessoal, bom dia a todos!

    Será que o nosso manual está tão bom assim que ainda não apareceu nem uma dúvida da galera? Ontem um amigo nosso atravéz do msn me pediu uma ajuda para integrar o MK dele ao debian, e para a minha surpresa e a dele não fiz nada, já estava funcionando perfeitamente com ping '''0'''' do Mk para o debian.

    Um outro detalhe não menos importante para a perfeita integração do Mk ao server é fazer uma regra no firewall filter aceitando toda a conexão da faixa de ip's do server, que no caso seria 192.168.10.0/24, por que percebi que algumas regras de bloqueio de vírus bloqueiam ou limitam alguns vídeos dependendo de qual porta eles usem.

    Essa regra deve ficar antes da regra do bloqueio de vírus.

    Abração e bom fianl de seman a todos
    Mas o Thunder não funcionou, eh pedi pro Paulo Jr, o mesmo que lá no forum do thundercache, mas pra surpresa dele, td configurado certinho... no Debian-Server, mas as regras do NAT (as que estão no inicio do post) não deu certo.... estou usando o MK 3.23.

    Se alguem tiver uma solução pra isso agradeço.

    Mas uma vez obrigado, Roberto, Paulo Jr, Rodrigo Manga eh todos aqueles que fazem deste forum uma referencia.... obrigado por nos ajudar...



  7. #47

    Padrão

    Daqui a pouco estarei no msn para te ajudar, depois disso você vai compartilhar aqui com os colegas o que foi e a solução...Chego já.

    OBS: Um colega me perguntou hoje no msn se era vantagem instalar o Thunder por que ele faria dois downloads simultâneos fazendo com que o link fique no gargalo rapidamente.

    Quero dizer aos colegas que esse problema não existe no ThunderCache, ele não tem essa falha, e para quem não está antenado e atualizado com o ThunderCache está perdendo uma oportunidade de se atualizar hen...vamos lá pessoal o Thunder é o sonho dourado dos provedores.

  8. #48

    Padrão Agradecimento e dano honra e meritos!

    Caro amigo Roberto21 , desde de já agradeço sua atenção a a este forum para com uma "tremenda" ajuda a todos que estão a necessitar dessas config's ae.

    Sou muito noob, noob mesmo mais estou começando a sair do berço, hehehehehe...

    Não há palavras tanto e elogios quanto de agradecimento pelas pessoas que gostam e setem um grande prazer em ajudar e tirar um tempo tanto para passar as regras quanto para tirar duvidas das mesmas.

    Mais ta bom de tanta babação né! hehehehehehe!

    Abraços! E que Deus lhe abençoe e a todos de bom coração e boa vontade nesse forum.



  9. #49

    Padrão

    Boa Noite

    Eu estava usando o proxy paralelo na versão 2.9.27 e estava uma maravilha, resolvi comprar a licença do mk e atualizei para a versão 3.23, mas ando tendo problemas para colocar o thundercache.

    Alguem ai conseguiu colocar o thunder para funcionar nesta versão?

    Segui as regras do roberto que esta na primeira pagina e so esta mostrando os videos do youtube que ja estavam no cache. Entrei no proxy atraves do telnet do mk e vi que ele não esta pingando para fora, mas quando mudo o dnsname em /etc/resolv.conf (de 192.168.10.253 p/ o meu dns)ele começa a pingar para fora, mas depois disso nada funciona(nem a propagando no msn). Tente colocar os dois dns juntos mais não consegui.

    Alguem poderia me dar uma ideia, talvez esse seja o problema de algumas pessoas aqui no forum

    abraços a todos

    Obrigado Roberto pela Contribuição

    Bruno Cabrini

  10. #50

    Padrão

    Bruno, acabamos de colocar o Thunder do amigo Ney para funfar 100% e é a versão 23 também...algo errado vc fez lá...se quizer estou no msn agora.

    Abração.



  11. #51

    Padrão Tah Funfando uma Maravilha!!!

    Boa Noite ou Bom Dia.....

    São quase 1h da manha, eh o Roberto, esta aqui me dando td ajuda, eh graças a perseverança dele.... tudo deu certo o thundercache, ta funfando uma maravilha.... Pessoal do Under, vamos começar a preparar os seus servidores... pra implantar o thunder....

    Roberto, mais uma vez obrigado.....


  12. #52

    Padrão

    Pois é Ney, percebo agora uma boa vontade das pessoas em ajudar nos problemas com o Thunder, coisa que não existia antes de eu resolver ajudar a TODOS a colocar essa ferramenta execelente para funcionar, mas isso é bom, por que a coisa começa a ficar transparente, e não entrelinhas.

    Um abração.



  13. #53

    Padrão

    Olá a todos


    Ñ desmerecendo o M4D3, vc boto pocando.
    foi atraves de suas explicações que eu concegui colocar o proxy paralelo para rodar, muito obrido.

  14. #54
    MODERADOR-CHEFE Avatar de osmano807
    Ingresso
    Aug 2008
    Localização
    Araguari - Minas Gerais
    Posts
    1.985
    Posts de Blog
    5

    Padrão

    Bom, mas e o consumo de memória? Aqui eu adaptei (bom, eu escrevi do zero mas tirando como base o thunder) para Windows (SquidNT), e só o downloader.php consome 16Mb de memória. Estou vendo se eu faço um donwloader em c++, mas eu estou sem compilador e vai em delphi mesmo.

    Se consegui depois eu posto como instalar no Windows.

    Ah, tem alguma biblioteca para download, tipo a libcurl, mas atualizada para Delphi?



  15. #55

    Padrão

    Um coisa legal que estou percebendo é dedicação da pessoas em correr atrás pra colocar o thunder pra rodar, algus com dificuldades no Linux ( que para quem ainda não tinha muito conhecimento o thunder esta impulsionando as pessoas a estudarem mais ) e no redirecionamento para o mk. Vi isso no emepenho do amigo neydorado ( até a 1 hora da manha ). Bom ...... gostaria de dar uma opinião, no caso do amigo neidourado, postar as regras que ele usou no mk de forma bem detalhada para que os demais possam ver o exemplo dele e adaptar a realidade de cada um ( por favor sem ctrl C + ctrl V ).
    Sucessos moçada ........

  16. #56

    Padrão

    Parabéns Roberto e sucesso pra voce !!



  17. #57

    Padrão

    Citação Postado originalmente por Roberto21 Ver Post
    Olá Pessoal, boa noite!

    Adiantando nosso tópico, vou fazer essa noite mesmo a configuração basica do thunder.conf, seguinte:

    As configurações do thunder.conf são só essas, mas alguns detalhes e atenção fará toda a diferença:

    $cache_dir = "/var/www/thunder"; ( aqui o diretório onde os arquivos são armazenados)
    $disk_max = 98; // in percent ( aqui o total do HD usado pelo thunder no caso 98%)
    $cache_scr = "/etc/squid";
    $server_ip = "192.168.10.250"; ( aqui o endereço ip do thunder)
    $cache_url = "http://$server_ip/thunder";
    $download_speed = 512; // kbytes ( aqui a velocidade dos downloads )
    $logadd_on = false;
    $redir = "301:"; // keep empty if you need a internal rewriter (aqui foi mudado para 301 explicarei)
    $proxy_host = ""; // keep it empty if you dont need proxy
    $proxy_port = "5128"; (aqui a porta usada pelo thunder e pelo squid)
    // advanced params - IF YOU DONT KNOW, DONT TOUCH!
    $packet_size = 200; // in bytes
    $packet_delay = 2000; // time in micro second
    $download_timeout = 10;

    Aconselho não mexer no resto a não ser que saiba o que está fazendo

    Vamos comentar as mudanças:

    #Acho que a maioria não precisará mexer no diretório do Thunder nem no tamanho de espaço usado pelo Hd, mas se precisar e souber o que está fazendo pode mexer.

    # Se você for alterar a faixa de IP do squid e das interfaces terá que mudar aqui também.

    #Aqui você define a velocidade de download do arquivos pelo Thunder, o meu está setado em 512, mas tenho 6M de link e esse valor é o suficiente para mim, originalmente vem com 256, altere de acordo com seu link, lembrando que ao começar a fazer um download de um vídeo o Thunder só para o download quando o vídeo for carregado totalmente, independente se o cliente fecha o vídeo no meio ou não, fazendo assim seu link ficar ocupado com esse download, então moderação com esse valor, a não ser que você tenha link suficiente.


    DICA DO FORUM DO THUNDERCACHE ONDE FACILITOU MUITO A MARCAÇÃO NO MANGLE POSTADO POR '''ThunderBRZ'''

    com a nova versao nao é necessario esse trampo todo !!!
    é só colocar no thunder.conf a opcao 301 no redirect q ele repassa pro cliente a nova URL !!!
    ae é so fazer um mangle marcando o dominio do seu apache !!!

    A opção default é 302.

    # se for mudar a porta do proxy squid terá que mudar aqui também

    Essas são as configurações básicas do Thunder.conf, essas não devemos alterar muita coisa não até o final.


    Continua ...resolv.conf


    Olá,

    Onde encontro o arquivo, thunder.conf, ñ estou conseguindo encontrá-lo.

    Obrigado.

  18. #58

    Padrão

    Citação Postado originalmente por rps67 Ver Post
    Um coisa legal que estou percebendo é dedicação da pessoas em correr atrás pra colocar o thunder pra rodar, algus com dificuldades no Linux ( que para quem ainda não tinha muito conhecimento o thunder esta impulsionando as pessoas a estudarem mais ) e no redirecionamento para o mk. Vi isso no emepenho do amigo neydorado ( até a 1 hora da manha ). Bom ...... gostaria de dar uma opinião, no caso do amigo neidourado, postar as regras que ele usou no mk de forma bem detalhada para que os demais possam ver o exemplo dele e adaptar a realidade de cada um ( por favor sem ctrl C + ctrl V ).
    Sucessos moçada ........

    Pessoal, favor seguuir a risca o que o Roberto postou anteriomente no post, eh depois no MK 3.23, essa eh a minha versão.

    Depois no MK, poe essas regras...

    Conf MK
    #
    / ip firewall mangle
    add chain=forward protocol=tcp content="X-Cache: HIT" action=mark-connection new-connection-mark=forward-hits \
    passthrough=yes comment="CACHE FULL" disabled=no
    add chain=forward connection-mark=forward-hits action=mark-packet new-packet-mark=cache-hits passthrough=yes comment="" \
    disabled=no
    add chain=postrouting dscp=48 action=mark-connection new-connection-mark=proxy-hits passthrough=yes comment="" disabled=no
    add chain=postrouting connection-mark=proxy-hits action=mark-packet new-packet-mark=proxy-squid passthrough=yes comment=""
    disabled=no
    add chain=forward protocol=tcp content="THUNDER: THUNDER" action=mark-connection new-connection-mark=thunder-connection \
    passthrough=yes comment="THUNDER CACHE FULL" disabled=no
    add chain=forward protocol=tcp connection-mark=thunder-connection action=mark-packet new-packet-mark=thunder-packs \
    passthrough=yes comment="" disabled=no

    / queue tree
    add name="cache_hits" parent=global-out packet-mark=proxy-squid limit-at=1000000 queue=thunder priority=8 \
    max-limit=3000000 burst-limit=0 burst-threshold=0 burst-time=0s disabled=no
    add name="cache-antigo" parent=global-out packet-mark=cache-hits limit-at=1000000 queue=default priority=8 \
    max-limit=2000000 burst-limit=0 burst-threshold=0 burst-time=0s disabled=no
    add name="ThunderCache" parent=global-out packet-mark=thunder-packs limit-at=1000000 queue=thunder priority=8 \
    max-limit=3000000 burst-limit=0 burst-threshold=0 burst-time=0s disabled=no


    /ip firewall nat

    add action=masquerade chain=srcnat comment=NAT-HadNet disabled=no \
    out-interface=pppoe-out1


    add action=masquerade chain=srcnat comment="NAT DEBIAN-SERVER" disabled=no \
    src-address=!192.168.10.250

    add action=dst-nat chain=dstnat comment="proxy for HTTP requests" disabled=no \
    dst-address=!192.168.10.250 dst-port=80 protocol=tcp src-address=\
    172.16.0.0/16 to-addresses=192.168.10.250 to-ports=3128

    Em vermelho negrito eh o NAT do meu DSL. então caso ja tenha o seu NAT. não use esta regra.

    Importante: Não use Ctrl C + Ctrl V



  19. #59

    Padrão

    Citação Postado originalmente por Roberto21 Ver Post
    Bruno, acabamos de colocar o Thunder do amigo Ney para funfar 100% e é a versão 23 também...algo errado vc fez lá...se quizer estou no msn agora.

    Abração.
    Opa Roberto, Boa Noite

    Desmanchei tudo que eu havia feito e fiz novamente e ai resolveu funcionar. eu devia ter feito algo errado e não estava achando o erro.

    Gostaria de agradecer a atenção e agradecer o topico mais uma vez.

    Abraços.

  20. #60

    Padrão

    Roberto,

    Você estar usando o thunder para o orkut?

    Eu retirei porque o mesmo ficava sem se comunicar em 2 horas de uso...

    Hoje estou usando ele, mas meu server é reiniciado toda madrugada.