Página 3 de 3 PrimeiroPrimeiro 123
+ Responder ao Tópico



  1. #41

    Padrão

    Isto pode está sendo um bug da versão pois pela ordem(/queue simple move testes [/queue simple find dynamic]) o testes, por vir primeiro, vai sobrepor os dynamics, por vir depois.
    Faça um upgrade ou mesmo um downgrade. Ou mesmo instale um para testes e confirmará que pode está sendo um problema da versão.

  2. #42

    Padrão

    Citação Postado originalmente por NetoGO23 Ver Post
    Estou usando a 3.25!

    Rodei ele varias vezes manualmente para fazer teste e ele não sobe.

    Agora com essa ai ele vai para o fim

    /queue simple move LIBERAR_BANDA
    Neste caso aqui ele não teve referência para sobrepor alguma regra. E ele tem que ter uma referência que, de preferência, tem que está no topo da tabela.



  3. #43

    Padrão

    Citação Postado originalmente por Raniel Ver Post
    Peço desculpas aí pela falta de atenção. Não sabia que usava hotspot ou pppoe.
    Mas seguindo a linha de raciocínio:
    Já que todas as queues são criadas dinamicamente, o que temos que fazer é mover a regra subindo através das dynamics. Então o nosso script ficaria de tal forma:
    Código :
    /queue simple move testes [/queue simple find dynamic];
    Qualquer coisa...
    Amigo estou tentando aqui essa script na versao 3.30 e não esta funcionando tambem, teria que modificar alguma coisa?

  4. #44

    Padrão

    Crie variáveis. Com ela será fácil mover qualquer queue.



  5. #45

  6. #46

    Padrão

    # Para ir para posição zero
    /queues simple LiberaTudo 0

    #Para mover para o final

    /queues simple LiberaTudo



  7. #47

    Padrão Re: Dica! Script para mudar todas queues

    opa..
    estou tentando modificar o script para mudar os parent das minhas redes..
    hj possuo varios aps por RB e quero fazer um queue para o ap e dentro dele cadastrar todos os clientes..
    ja tenho todos clientes cadastrados nas rbs..
    ex:
    AP_192.168.0.0/24 com 30 clientes com parent=none
    AP_192.168.10.0/24 com 30 clientes com parent=none

    preciso passar todos queues do primeiro ap para um parent=paiAP1
    e em seguida passar todos clientes do segundo ap para um parent=paiAP2

    nao sei se ficaria mais ou menos isso.. mas nao rodou...

    /queue simple
    add name="MUDAR PARENT" policy=ftp,reboot,read,write,p olicy,test,winbox,password source=\
    "/queue simple set [/queue simple find priority=8] parent=Clientes_StaClara]"


    o problema esta tmbm quando tenho varias classes de ips para o mesmo ap, ou quando tenho classes quebradas.. ex um /26

    podes me ajudar?

    obrigado

  8. #48

    Padrão Re: Dica! Script para mudar todas queues

    Alguém sabe como fazer esse regra funcionar na versão 5.6 do mk? Pois tentei aqui mais não funcionou.



  9. #49

    Padrão Re: Dica! Script para mudar todas queues

    Citação Postado originalmente por alamdias Ver Post
    Eu novamente.

    Nessa dica, vai um SCRIPT que pode ser alterado de várias formas, a fim de atender suas necessidades. Aqui acho muito útil pois, depois da meia noite, rodo todo mundo para 450k

    É uma ferramenta boa para testes de banda etc.. e gerenciamento dos clientes.

    Primeiro SCRIPT
    Função. Muda Incodicionalmente TODAS as queues, com base em uma busca onde TODAS as queues que tiverem o atributo PRIORITY=8 No meu caso, todas são 8, então a busca vai retornar 100%, ou seja TODAS

    /system script

    add name="GERAL PARA 256K" policy=ftp,reboot,read,write,policy,test,winbox,password source=\
    "/queue simple set [/queue simple find priority=8] max-limit=100000/256000]"


    Esse script diz de uma forma leiga:

    "/queue simple set [/queue simple find priority=8] max-limit=100000/256000]"
    ^^^^^MUDE ^^^^QUEM FOR PRIORITY=8 ^^PARA 100k UP / 256k down

    Daí você pode ter script de 100, 200 300 600k, da forma que quiser.

    Mas e se eu quiser mudar somente as queues dos meus clientes que tem 128k/128k, para 256/256?
    Basta mudarmos a busca.

    add name="128k/128k PARA 256k/256k" policy=ftp,reboot,read,write,policy,test,winbox,password source=\
    "/queue simple set [/queue simple find max-limit=128000/128000] max-limit=256000/256000"


    Nesse caso acima, o SET vai mudar todas que tiverem up/down = 128000 e vai mudar para 256/256.

    Não esqueça de fazer um script ao contrário, para retornar ao normal, logo ficaria assim:

    add name="256k/256k PARA 128k/128k" policy=ftp,reboot,read,write,policy,test,winbox,password source=\
    "/queue simple set [/queue simple find max-limit=256000/256000] max-limit=128000/128000"


    Observação: Cuidado com K (maiusculo) e k (minusculo).

    Basicamente, é tudo baseado no FIND. Sabendo fazer a busca certa, dá pra fazer de tudo.

    Daí é só fazer um agendamento para seu script rodar em determinados horários, ou utilizar o TRAFFIC MONITOR, para ver se o link estiver folgado, liberar mais banda para os clientes.

    Qualquer dúvida, estamos aí !

    Abraços
    Como fazer essa regra funcionar na v5.6 do mk?

  10. #50

    Padrão Re: Dica! Script para mudar todas queues

    Fiz este script e funcionou legal:
    /queue simple move [find name=LIBERA_BANDA] 0
    Mas quando um usuario do hotspot faz login, cria uma regra que assume a posição 0, daí o script move a regra para uma posição diferente, e as vezes move para o final.
    Porém se eu digitar este comando noterminal, daí funciona corretamente.



  11. #51

    Padrão Re: Dica! Script para mudar todas queues

    Galera, nao axei uma solução para esse problema meu, mas bolei outra q funciona muito bem:
    Coloco a regra LIBERA_BANDA na posição 0, em em profiles do hotspot coloco este script pra executar sempre q o usuario loga, assim todas as regras de hotspot q sao dinamicas vao para o final da lista.
    :foreach i in=[queue simple find dynamic=yes] do={ queue simple move $i }
    Funciona perfeitamente.