Página 2 de 15 PrimeiroPrimeiro 1234567 ... ÚltimoÚltimo
+ Responder ao Tópico

PCC



  1. #21

    Padrão

    Amigos, queria tirar uma opinião com vocês: tenho um server pc com Mk 3.20 que faz o balanceamento, hotspot e controle de banda.. faço o balanceamento marcando os pacotes de cada faixa de ip no mangle... estava pensando em comprar um RB só para fazer o balanceamento e colocá-la antes desse pc.. será que a Rb vai rodar legal fazendo só isso?

  2. #22

    Padrão

    Citação Postado originalmente por ricardofjayme Ver Post
    Amigos, queria tirar uma opinião com vocês: tenho um server pc com Mk 3.20 que faz o balanceamento, hotspot e controle de banda.. faço o balanceamento marcando os pacotes de cada faixa de ip no mangle... estava pensando em comprar um RB só para fazer o balanceamento e colocá-la antes desse pc.. será que a Rb vai rodar legal fazendo só isso?
    Pode comprar q roda tranquilo, logico compre uma rb com maior potencia de processamento e memoria, como a rb450G ou a rb493ha etc



  3. #23

    Padrão

    Citação Postado originalmente por cristianoduarte Ver Post
    Amigo, estou fazendo este balenceamento com link de 4 mb e um de 6mb, tem como manipular esta carga, pq o de 4mb ta fica sempre no talo. Obrigado

    sim tem sim, basta vc dividir a regra aumentando o link de 6MB para duas marcacoes assim ele vai jogar 2x para o mesmo link de 6MB

  4. #24

    Padrão

    Citação Postado originalmente por tiagomatias Ver Post
    sim tem sim, basta vc dividir a regra aumentando o link de 6MB para duas marcacoes assim ele vai jogar 2x para o mesmo link de 6MB

    Tiago,

    Se não for pedir de mais, tem como você postas as regas e posição delas, pois, no meu acso estou com problemas com videos. segui tudo e ainda não resolveu.Obs. não uso thudercache nem proxy

    Agradeço anteciapado



  5. #25

    Padrão problemas com vidoes youtube e outros

    Citação Postado originalmente por cristianoduarte Ver Post
    Tiago,

    Se não for pedir de mais, tem como você postas as regas e posição delas, pois, no meu acso estou com problemas com videos. segui tudo e ainda não resolveu.Obs. não uso thudercache nem proxy

    Agradeço anteciapado
    Boa tarde cristianoduarte,
    esse balanceamento esta muito melhor doque os demais que a mikrotik tem hoje, mas com alguns problemas que devem ser corrigidos breve pela mikrotik, e um deles é os videos que as vezes tem q se precisar F5/Refresh para poder carregar o video principalmente do youtube.

    o melhor lugar para poder acompanhar o andamento desse balanceamento veja no forum da mikrotik no seguinte endereço:
    >>>>> MikroTik RouterOS • View topic - New firewall matcher PCC

    mas vou postar os script q postei lá balanceando 7 link

    Código :
    My interfaces
    Interfaces WANs:
    ether1, ether2, ether3, ether4, ether5, ether6 and ether7
    LAN Interface: ether9-Clientes
     
    My mangle
    /ip firewall mangle
    add action=accept chain=prerouting comment="out load DST" disabled=no dst-address-list=rede-interna in-interface=ether9-Clientes
    add action=mark-connection chain=input comment=ether1_conn connection-state=new disabled=no in-interface=ether1 new-connection-mark=ether1_conn passthrough=yes
    add action=mark-connection chain=input comment=ether2_conn connection-state=new disabled=no in-interface=ether2 new-connection-mark=ether2_conn passthrough=yes
    add action=mark-connection chain=input comment=ether3_conn connection-state=new disabled=no in-interface=ether3 new-connection-mark=ether3_conn passthrough=yes
    add action=mark-connection chain=input comment=ether4_conn connection-state=new disabled=no in-interface=ether4 new-connection-mark=ether4_conn passthrough=yes
    add action=mark-connection chain=input comment=ether5_conn connection-state=new disabled=no in-interface=ether5 new-connection-mark=ether5_conn passthrough=yes
    add action=mark-connection chain=input comment=ether6_conn connection-state=new disabled=no in-interface=ether6 new-connection-mark=ether6_conn passthrough=yes
    add action=mark-connection chain=input comment=ether7_conn connection-state=new disabled=no in-interface=ether7 new-connection-mark=ether7_conn passthrough=yes
    add action=mark-routing chain=output comment=to_ether1 connection-mark=ether1_conn connection-state=new disabled=no new-routing-mark=to_ether1 passthrough=no
    add action=mark-routing chain=output comment=to_ether2 connection-mark=ether2_conn connection-state=new disabled=no new-routing-mark=to_ether2 passthrough=no
    add action=mark-routing chain=output comment=to_ether3 connection-mark=ether3_conn connection-state=new disabled=no new-routing-mark=to_ether3 passthrough=no
    add action=mark-routing chain=output comment=to_ether4 connection-mark=ether4_conn connection-state=new disabled=no new-routing-mark=to_ether4 passthrough=no
    add action=mark-routing chain=output comment=to_ether5 connection-mark=ether5_conn connection-state=new disabled=no new-routing-mark=to_ether5 passthrough=no
    add action=mark-routing chain=output comment=to_ether6 connection-mark=ether6_conn connection-state=new disabled=no new-routing-mark=to_ether6 passthrough=no
    add action=mark-routing chain=output comment=to_ether7 connection-mark=ether7_conn connection-state=new disabled=no new-routing-mark=to_ether7 passthrough=no
    add action=mark-connection chain=prerouting comment=ether1_conn disabled=no dst-address-type=!local in-interface=ether9-Clientes new-connection-mark=ether1_conn passthrough=yes per-connection-classifier=both-addresses-and-ports:7/0
    add action=mark-connection chain=prerouting comment=ether2_conn disabled=no dst-address-type=!local in-interface=ether9-Clientes new-connection-mark=ether2_conn passthrough=yes per-connection-classifier=both-addresses-and-ports:7/1
    add action=mark-connection chain=prerouting comment=ether3_conn disabled=no dst-address-type=!local in-interface=ether9-Clientes new-connection-mark=ether3_conn passthrough=yes per-connection-classifier=both-addresses-and-ports:7/2
    add action=mark-connection chain=prerouting comment=ether4_conn disabled=no dst-address-type=!local in-interface=ether9-Clientes new-connection-mark=ether4_conn passthrough=yes per-connection-classifier=both-addresses-and-ports:7/3
    add action=mark-connection chain=prerouting comment=ether5_conn disabled=no dst-address-type=!local in-interface=ether9-Clientes new-connection-mark=ether5_conn passthrough=yes per-connection-classifier=both-addresses-and-ports:7/4
    add action=mark-connection chain=prerouting comment=ether6_conn disabled=no dst-address-type=!local in-interface=ether9-Clientes new-connection-mark=ether6_conn passthrough=yes per-connection-classifier=both-addresses-and-ports:7/5
    add action=mark-connection chain=prerouting comment=ether7_conn disabled=no dst-address-type=!local in-interface=ether9-Clientes new-connection-mark=ether7_conn passthrough=yes per-connection-classifier=both-addresses-and-ports:7/6
    add action=mark-routing chain=prerouting comment=to_ether1 connection-mark=ether1_conn disabled=no in-interface=ether9-Clientes new-routing-mark=to_ether1 passthrough=no
    add action=mark-routing chain=prerouting comment=to_ether2 connection-mark=ether2_conn disabled=no in-interface=ether9-Clientes new-routing-mark=to_ether2 passthrough=no
    add action=mark-routing chain=prerouting comment=to_ether3 connection-mark=ether3_conn disabled=no in-interface=ether9-Clientes new-routing-mark=to_ether3 passthrough=no
    add action=mark-routing chain=prerouting comment=to_ether4 connection-mark=ether4_conn disabled=no in-interface=ether9-Clientes new-routing-mark=to_ether4 passthrough=no
    add action=mark-routing chain=prerouting comment=to_ether5 connection-mark=ether5_conn disabled=no in-interface=ether9-Clientes new-routing-mark=to_ether5 passthrough=no
    add action=mark-routing chain=prerouting comment=to_ether6 connection-mark=ether6_conn disabled=no in-interface=ether9-Clientes new-routing-mark=to_ether6 passthrough=no
    add action=mark-routing chain=prerouting comment=to_ether7 connection-mark=ether7_conn disabled=no in-interface=ether9-Clientes new-routing-mark=to_ether7 passthrough=no
     
    My NAT
    /ip firewall nat
    add action=masquerade chain=srcnat comment="" disabled=no out-interface=ether1
    add action=masquerade chain=srcnat comment="" disabled=no out-interface=ether2
    add action=masquerade chain=srcnat comment="" disabled=no out-interface=ether3
    add action=masquerade chain=srcnat comment="" disabled=no out-interface=ether4
    add action=masquerade chain=srcnat comment="" disabled=no out-interface=ether5
    add action=masquerade chain=srcnat comment="" disabled=no out-interface=ether6
    add action=masquerade chain=srcnat comment="" disabled=no out-interface=ether7
     
    My route
    /ip route
    add comment=link1 disabled=no distance=1 dst-address=0.0.0.0/0 gateway=189.19.x.x scope=30 target-scope=10
    add comment=link2 disabled=no distance=2 dst-address=0.0.0.0/0 gateway=192.168.1.1 scope=30 target-scope=10
    add comment=link1 disabled=no distance=1 dst-address=0.0.0.0/0 gateway=189.19.86.1 routing-mark=to_ether1 scope=30 target-scope=10
    add comment=link2 disabled=no distance=1 dst-address=0.0.0.0/0 gateway=192.168.1.1 routing-mark=to_ether2 scope=30 target-scope=10
    add comment=link3 disabled=no distance=1 dst-address=0.0.0.0/0 gateway=10.1.1.1 routing-mark=to_ether3 scope=30 target-scope=10
    add comment=link6 disabled=no distance=1 dst-address=0.0.0.0/0 gateway=172.16.253.253 routing-mark=to_ether6 scope=30 target-scope=10
    add comment=link5 disabled=no distance=5 dst-address=0.0.0.0/0 gateway=192.168.5.1 scope=30 target-scope=10
    add comment=link3 disabled=no distance=3 dst-address=0.0.0.0/0 gateway=10.1.1.1 scope=30 target-scope=10
    add comment=link4 disabled=no distance=4 dst-address=0.0.0.0/0 gateway=200.161.x.x scope=30 target-scope=10
    add comment=link6 disabled=no distance=6 dst-address=0.0.0.0/0 gateway=172.16.253.253 scope=30 target-scope=10
    add comment=link4 disabled=no distance=1 dst-address=0.0.0.0/0 gateway=200.161.x.x routing-mark=to_ether4 scope=30 target-scope=10
    add comment=link5 disabled=no distance=1 dst-address=0.0.0.0/0 gateway=192.168.5.1 routing-mark=to_ether5 scope=30 target-scope=10
    add comment=link7 disabled=no distance=7 dst-address=0.0.0.0/0 gateway=172.16.254.252 scope=30 target-scope=10
    add comment=link7 disabled=no distance=1 dst-address=0.0.0.0/0 gateway=172.16.254.252 routing-mark=to_ether7 scope=30 target-scope=10

  6. #26

    Padrão

    bom dia a todos quero agradecer o post com relação ao pcc, consegui colocar pra rodar com 5links, mas uso aqui o squid como proxy paralelo, e quando ativo ele a rede para de navegar, desativo roda que é uma beleza, acho que é sóum detalhe basico que ainda nao percebi se alguem poder dar uma dica, segue a regra do direcionamento para o linux

    add action=dst-nat chain=dstnat comment="Redirecionamento Para Debian Squid" disabled=no dst-address-list=!Sem_Proxy dst-port=80 in-interface=Clientes \
    protocol=tcp src-address=!10.106.1.2 to-addresses=10.106.1.2 to-ports=3128

    e se alguem ainda nao conseguiu colocar o pcc pra rodar eu ajudo sem problemas, semana que vem vou fazer a certificação do mk em sp dae vou ajudar sempre que puder assim como muitos aqui.


    Sds



  7. #27

    Padrão

    Citação Postado originalmente por powernetscm Ver Post
    bom dia a todos quero agradecer o post com relação ao pcc, consegui colocar pra rodar com 5links, mas uso aqui o squid como proxy paralelo, e quando ativo ele a rede para de navegar, desativo roda que é uma beleza, acho que é sóum detalhe basico que ainda nao percebi se alguem poder dar uma dica, segue a regra do direcionamento para o linux

    add action=dst-nat chain=dstnat comment="Redirecionamento Para Debian Squid" disabled=no dst-address-list=!Sem_Proxy dst-port=80 in-interface=Clientes \
    protocol=tcp src-address=!10.106.1.2 to-addresses=10.106.1.2 to-ports=3128

    e se alguem ainda nao conseguiu colocar o pcc pra rodar eu ajudo sem problemas, semana que vem vou fazer a certificação do mk em sp dae vou ajudar sempre que puder assim como muitos aqui.


    Sds
    Bom dia Paulo,

    como vc mesma já disse esta começando com mikrotik, então n deve saber ainda que quando se faz marcação de pacotes com mark-routing n se pode na mesma maquina redirecionar os clientes para um proxy externo e nem interno, neste caso a solução esta sendo fazer o balanceamento em uma maquina separado e depois jogar para outro servidor controlar os clientes e por sua vez redirecionar para o proxy externo.

    Sempre é bom se manter atualizado fazendo cursos, fiz o meu em Julho/Agosto de 2007 com o pessoal do méxico e argentina.

    abraços

  8. #28

    Padrão

    agora que consegui rodar o pcc(Tipo de Balance), estou tendo problemas com banco sera que so marcando o ssl e direcionando para apenas um link resolve? ou tem mais algum problema



  9. #29

    Padrão

    Resolvi os problemas de youtube e outros, fazendo uma marcação para cada 1MB utilizo um link de 4 mb e outro de 6mb de operadoras diferentes. Fiz então 10 marcações e direcionei 4 marcações para o link de 4mb e 6 para o link de 6mb, sendo colocadas na ordem tipo:

    Link 1 4mb: 10/0, 10/1, 10/2, 10/3
    Link 2 6mb: 10/4, 10/5, 10/6, 10/7, 10/8, 10/9
    Última edição por cristianoduarte; 23-07-2009 às 19:32.

  10. #30

    Padrão PCC

    amigo poste sua regras pra quem estiver com os problemas verificar e corrigir eu começo o meus testes semana que vem com pcc pra 6 links e vou postar como ficara o balaceamento se vou ter melhoria nos que uso hoje atualmente...vlw...



  11. #31

    Padrão

    Citação Postado originalmente por cristianoduarte Ver Post
    Resolvi os problemas de youtube e outros, fazendo uma marcação para cada 1MB utilizo um link de 4 mb e outro de 6mb de operadoras diferentes. Fiz então 10 marcações e direcionei 4 marcações para o link de 4mb e 6 para o link de 6mb, sendo colocadas na ordem tipo:

    Link 1 4mb: 10/1, 10/2, 10/3, 10/4
    Link 2 6mb: 10/5, 10/6, 10/7, 10/8, 10/9, 10/10
    Amigo, começo errado...

    10/0, 10/1.....10/9

    Começa pelo zero...

  12. #32

    Padrão

    Citação Postado originalmente por powernetscm Ver Post
    agora que consegui rodar o pcc(Tipo de Balance), estou tendo problemas com banco sera que so marcando o ssl e direcionando para apenas um link resolve? ou tem mais algum problema
    amigo a respeito dos sites de bando apenas tive problema com um banco, e o mesmo se chama BRADESCO, existe algumas formas de se resolver o problema, eu utilizo tirando a faixa de IP do banco que esta com problema para n passar pelo balanceamento, desta forma ele sai pela rota padrao do seu mikrotik.
    Eu criei um address-list com nome de loopback e coloquei a faixa de IP do bradesco para n passar pelo loadbalced a mesma 'e esta abaixo.

    /ip firewall mangle
    add action=accept chain=prerouting comment="FORA DO LOADBALACED" disabled=no dst-address-list=loopback in-interface=ether9-Clientes
    /ip firewall address-list
    add address=200.155.80.0-200.155.255.255 comment="BRADESCO" disabled=no list=loopback

    coloque ela na mesma ordem que mostra no wiki
    PCC - MikroTik Wiki



  13. #33

    Padrão

    Citação Postado originalmente por cristianoduarte Ver Post
    Resolvi os problemas de youtube e outros, fazendo uma marcação para cada 1MB utilizo um link de 4 mb e outro de 6mb de operadoras diferentes. Fiz então 10 marcações e direcionei 4 marcações para o link de 4mb e 6 para o link de 6mb, sendo colocadas na ordem tipo:

    Link 1 4mb: 10/1, 10/2, 10/3, 10/4
    Link 2 6mb: 10/5, 10/6, 10/7, 10/8, 10/9, 10/10

    A respeito dos videos do youtube se resvolveram apartir da versap 3.27 do mikrotik, pelo menos no meu n consta mais problemas

  14. #34

    Padrão

    Citação Postado originalmente por catvbrasil Ver Post
    Amigo, começo errado...

    10/0, 10/1.....10/9

    Começa pelo zero...
    Eai meu patrao, como andas as coisas por ai ?

    faz tempo q n falo com vc....

    cara esse novo load esta uma mao na roda, comprei 2 rb 493HA e uni todos em duas rb, com redundacia entre Brasiltelecom e Embratel ficou show, depois posto as fotos de como ficou.

    abracos meu peixe, felicidades



  15. #35

    Padrão

    Citação Postado originalmente por tiagomatias Ver Post
    Eai meu patrao, como andas as coisas por ai ?

    faz tempo q n falo com vc....

    cara esse novo load esta uma mao na roda, comprei 2 rb 493HA e uni todos em duas rb, com redundacia entre Brasiltelecom e Embratel ficou show, depois posto as fotos de como ficou.

    abracos meu peixe, felicidades
    OPa!! Já estava usando a algum tempo aqui e funciona perfeito, inclusive me parece que os pacotes que passam pelo cache, saem por suas rotas normalmente... To usando ele com redundância, links e cache e tá show... Já vamos migrar todos para esse novo esquema. Tiago, em breve darei mais notícias e novidades. Estou indo em Dallas e quando voltar haverá umas novidades muito boas... rssssss

  16. #36

    Padrão

    Citação Postado originalmente por catvbrasil Ver Post
    OPa!! Já estava usando a algum tempo aqui e funciona perfeito, inclusive me parece que os pacotes que passam pelo cache, saem por suas rotas normalmente... To usando ele com redundância, links e cache e tá show... Já vamos migrar todos para esse novo esquema. Tiago, em breve darei mais notícias e novidades. Estou indo em Dallas e quando voltar haverá umas novidades muito boas... rssssss
    Opa, n esquece dos velhos amigos se precisar de mao de obra estamos ai



  17. #37

    Padrão

    Amigo, estou testando as regras para ver o bradesco

  18. #38

    Padrão

    Citação Postado originalmente por catvbrasil Ver Post
    Amigo, começo errado...

    10/0, 10/1.....10/9

    Começa pelo zero...
    Sim amigo desculpe, postei errado sim. Obrigado por me alertar



  19. #39

    Padrão

    qual melhor forma que o pessoal testando ae ja viu que é melhor o both adress ou o outro both addreses and both ports

  20. #40

    Padrão

    Citação Postado originalmente por powernetscm Ver Post
    qual melhor forma que o pessoal testando ae ja viu que é melhor o both adress ou o outro both addreses and both ports
    O both-address é a melhor forma, o both-address and both-ports é excelente que ele se usando um gerenciador de download se pode unir os links dando uma taxa de transferencia da largura de todos os links, mas ao mesmo tempo da problemas de paginas começar a expirar precisando se precionar F5 para poder abrir novamente, tanto que o pessoal do suporte da mikrotik orientou a usar both-address no lugar do both-address and both-port

    abraços