+ Responder ao Tópico

PCC



  1. Pessoal fiz o balanceamento PCC 4 adsl roteado, estao balanceando tranquilo downloads perfeito agora navegacao lenta!!

    hardware para balanceamento
    Routerboard 450, Dedicado ao PCC

    wlan1 - 4 mega
    wlan2 - 1 mega
    wlan3 - 1 mega
    wlan4 - 1 mega

    segue exports

    /ip address
    add address=10.0.0.254/24 broadcast=10.0.0.255 comment="" disabled=no \
    interface=Local network=10.0.0.0
    add address=192.168.0.1/24 broadcast=192.168.0.255 comment="" disabled=no \
    interface=wlan1 network=192.168.0.0
    add address=192.168.1.1/24 broadcast=192.168.1.255 comment="" disabled=no \
    interface=wlan2 network=192.168.1.0
    add address=192.168.2.1/24 broadcast=192.168.2.255 comment="" disabled=no \
    interface=wlan3 network=192.168.2.0
    add address=192.168.3.1/24 broadcast=192.168.3.255 comment="" disabled=no \
    interface=wlan4 network=192.168.3.0

    /ip route
    add check-gateway=ping comment="" disabled=no distance=1 dst-address=\
    0.0.0.0/0 gateway=192.168.0.254 routing-mark=to_wlan1 scope=30 \
    target-scope=10
    add check-gateway=ping disabled=no distance=1 dst-address=0.0.0.0/0 gateway=\
    192.168.1.254 routing-mark=to_wlan2 scope=30 target-scope=10
    add check-gateway=ping disabled=no distance=1 dst-address=0.0.0.0/0 gateway=\
    192.168.2.254 routing-mark=to_wlan3 scope=30 target-scope=10
    add check-gateway=ping comment="" disabled=no distance=1 dst-address=\
    0.0.0.0/0 gateway=192.168.3.254 routing-mark=to_wlan4 scope=30 \
    target-scope=10
    add check-gateway=ping comment="" disabled=no distance=1 dst-address=\
    0.0.0.0/0 gateway=192.168.3.254 scope=30 target-scope=10
    add check-gateway=ping comment="" disabled=no distance=2 dst-address=\
    0.0.0.0/0 gateway=192.168.0.254 scope=30 target-scope=10
    add check-gateway=ping comment="" disabled=no distance=3 dst-address=\
    0.0.0.0/0 gateway=192.168.1.254 scope=30 target-scope=10
    add check-gateway=ping comment="" disabled=no distance=4 dst-address=\
    0.0.0.0/0 gateway=192.168.2.254 scope=30 target-scope=10

    /ip firewall nat
    add action=masquerade chain=srcnat comment="MASCARAMENTO PCC" disabled=no \
    out-interface=Local src-address=10.0.0.0/24
    add action=masquerade chain=srcnat comment="" disabled=no out-interface=wlan1
    add action=masquerade chain=srcnat comment="" disabled=no out-interface=wlan2
    add action=masquerade chain=srcnat comment="" disabled=no out-interface=wlan3
    add action=masquerade chain=srcnat comment="" disabled=no out-interface=wlan4

    /ip firewall mangle
    add action=mark-connection chain=input comment="" disabled=no in-interface=\
    wlan1 new-connection-mark=wlan1_conn passthrough=yes
    add action=mark-connection chain=input comment="" disabled=no in-interface=\
    wlan2 new-connection-mark=wlan2_conn passthrough=yes
    add action=mark-connection chain=input comment="" connection-state=new \
    disabled=no in-interface=wlan3 new-connection-mark=wlan3_conn \
    passthrough=yes
    add action=mark-connection chain=input comment="" connection-state=new \
    disabled=no in-interface=wlan4 new-connection-mark=wlan4_conn \
    passthrough=yes
    add action=mark-routing chain=output comment="" connection-mark=wlan1_conn \
    disabled=no new-routing-mark=to_wlan1 passthrough=no
    add action=mark-routing chain=output comment="" connection-mark=wlan2_conn \
    disabled=no new-routing-mark=to_wlan2 passthrough=no
    add action=mark-routing chain=output comment="" connection-mark=wlan3_conn \
    disabled=no new-routing-mark=to_wlan3 passthrough=no
    add action=mark-routing chain=output comment="" connection-mark=wlan4_conn \
    disabled=no new-routing-mark=to_wlan4 passthrough=no
    add action=accept chain=prerouting comment="SEM BALANCE" disabled=no \
    dst-address-list=sem_balance in-interface=Local
    add action=accept chain=prerouting comment="" disabled=no dst-address=\
    192.168.0.0/24 in-interface=Local
    add action=accept chain=prerouting comment="" disabled=no dst-address=\
    192.168.1.0/24 in-interface=Local
    add action=accept chain=prerouting comment="" disabled=no dst-address=\
    192.168.2.0/24 in-interface=Local
    add action=accept chain=prerouting comment="" disabled=no dst-address=\
    192.168.3.0/24 in-interface=Local
    add action=mark-connection chain=prerouting comment="" disabled=no \
    dst-address-type=!local in-interface=Local new-connection-mark=wlan1_conn \
    passthrough=yes per-connection-classifier=both-addresses:3/0
    add action=mark-connection chain=prerouting comment="" disabled=no \
    dst-address-type=!local in-interface=Local new-connection-mark=wlan2_conn \
    passthrough=yes per-connection-classifier=both-addresses:3/1
    add action=mark-connection chain=prerouting comment="" disabled=no \
    dst-address-type=!local in-interface=Local new-connection-mark=wlan3_conn \
    passthrough=yes per-connection-classifier=both-addresses:3/2
    add action=mark-connection chain=prerouting comment="" disabled=no \
    dst-address-type=!local in-interface=Local new-connection-mark=wlan4_conn \
    passthrough=yes per-connection-classifier=both-addresses:3/3
    add action=mark-routing chain=prerouting comment="" connection-mark=\
    wlan1_conn disabled=no in-interface=Local new-routing-mark=to_wlan1 \
    passthrough=no
    add action=mark-routing chain=prerouting comment="" connection-mark=\
    wlan2_conn disabled=no in-interface=Local new-routing-mark=to_wlan2 \
    passthrough=no
    add action=mark-routing chain=prerouting comment="" connection-mark=\
    wlan3_conn disabled=no in-interface=Local new-routing-mark=to_wlan3 \
    passthrough=no
    add action=mark-routing chain=prerouting comment="" connection-mark=\
    wlan4_conn disabled=no in-interface=Local new-routing-mark=to_wlan4 \
    passthrough=no
    add action=mark-packet chain=prerouting comment=MSN disabled=no \
    new-packet-mark=msn-out passthrough=yes protocol=tcp src-port=1863
    add action=mark-packet chain=prerouting comment="" disabled=no dst-port=1863 \
    new-packet-mark=msn-in passthrough=no protocol=tcp
    add action=change-mss chain=forward comment="" disabled=no new-mss=1360 \
    protocol=tcp tcp-flags=syn
    Última edição por diegovilela01; 16-04-2010 às 13:37.

  2. Mude a forma dos modem de roteado para bridge, você ganhar mais desempenho com isso, agora caso n resolver, teste cada link para ver se esta tendo as velocidades nominal

    Citação Postado originalmente por diegovilela01 Ver Post
    Pessoal fiz o balanceamento PCC 4 adsl roteado, estao balanceando tranquilo downloads perfeito agora navegacao lenta!!

    hardware para balanceamento
    Routerboard 450, Dedicado ao PCC

    wlan1 - 4 mega
    wlan2 - 1 mega
    wlan3 - 1 mega
    wlan4 - 1 mega

    segue exports

    /ip address
    add address=10.0.0.254/24 broadcast=10.0.0.255 comment="" disabled=no \
    interface=Local network=10.0.0.0
    add address=192.168.0.1/24 broadcast=192.168.0.255 comment="" disabled=no \
    interface=wlan1 network=192.168.0.0
    add address=192.168.1.1/24 broadcast=192.168.1.255 comment="" disabled=no \
    interface=wlan2 network=192.168.1.0
    add address=192.168.2.1/24 broadcast=192.168.2.255 comment="" disabled=no \
    interface=wlan3 network=192.168.2.0
    add address=192.168.3.1/24 broadcast=192.168.3.255 comment="" disabled=no \
    interface=wlan4 network=192.168.3.0

    /ip route
    add check-gateway=ping comment="" disabled=no distance=1 dst-address=\
    0.0.0.0/0 gateway=192.168.0.254 routing-mark=to_wlan1 scope=30 \
    target-scope=10
    add check-gateway=ping disabled=no distance=1 dst-address=0.0.0.0/0 gateway=\
    192.168.1.254 routing-mark=to_wlan2 scope=30 target-scope=10
    add check-gateway=ping disabled=no distance=1 dst-address=0.0.0.0/0 gateway=\
    192.168.2.254 routing-mark=to_wlan3 scope=30 target-scope=10
    add check-gateway=ping comment="" disabled=no distance=1 dst-address=\
    0.0.0.0/0 gateway=192.168.3.254 routing-mark=to_wlan4 scope=30 \
    target-scope=10
    add check-gateway=ping comment="" disabled=no distance=1 dst-address=\
    0.0.0.0/0 gateway=192.168.3.254 scope=30 target-scope=10
    add check-gateway=ping comment="" disabled=no distance=2 dst-address=\
    0.0.0.0/0 gateway=192.168.0.254 scope=30 target-scope=10
    add check-gateway=ping comment="" disabled=no distance=3 dst-address=\
    0.0.0.0/0 gateway=192.168.1.254 scope=30 target-scope=10
    add check-gateway=ping comment="" disabled=no distance=4 dst-address=\
    0.0.0.0/0 gateway=192.168.2.254 scope=30 target-scope=10

    /ip firewall nat
    add action=masquerade chain=srcnat comment="MASCARAMENTO PCC" disabled=no \
    out-interface=Local src-address=10.0.0.0/24
    add action=masquerade chain=srcnat comment="" disabled=no out-interface=wlan1
    add action=masquerade chain=srcnat comment="" disabled=no out-interface=wlan2
    add action=masquerade chain=srcnat comment="" disabled=no out-interface=wlan3
    add action=masquerade chain=srcnat comment="" disabled=no out-interface=wlan4

    /ip firewall mangle
    add action=mark-connection chain=input comment="" disabled=no in-interface=\
    wlan1 new-connection-mark=wlan1_conn passthrough=yes
    add action=mark-connection chain=input comment="" disabled=no in-interface=\
    wlan2 new-connection-mark=wlan2_conn passthrough=yes
    add action=mark-connection chain=input comment="" connection-state=new \
    disabled=no in-interface=wlan3 new-connection-mark=wlan3_conn \
    passthrough=yes
    add action=mark-connection chain=input comment="" connection-state=new \
    disabled=no in-interface=wlan4 new-connection-mark=wlan4_conn \
    passthrough=yes
    add action=mark-routing chain=output comment="" connection-mark=wlan1_conn \
    disabled=no new-routing-mark=to_wlan1 passthrough=no
    add action=mark-routing chain=output comment="" connection-mark=wlan2_conn \
    disabled=no new-routing-mark=to_wlan2 passthrough=no
    add action=mark-routing chain=output comment="" connection-mark=wlan3_conn \
    disabled=no new-routing-mark=to_wlan3 passthrough=no
    add action=mark-routing chain=output comment="" connection-mark=wlan4_conn \
    disabled=no new-routing-mark=to_wlan4 passthrough=no
    add action=accept chain=prerouting comment="SEM BALANCE" disabled=no \
    dst-address-list=sem_balance in-interface=Local
    add action=accept chain=prerouting comment="" disabled=no dst-address=\
    192.168.0.0/24 in-interface=Local
    add action=accept chain=prerouting comment="" disabled=no dst-address=\
    192.168.1.0/24 in-interface=Local
    add action=accept chain=prerouting comment="" disabled=no dst-address=\
    192.168.2.0/24 in-interface=Local
    add action=accept chain=prerouting comment="" disabled=no dst-address=\
    192.168.3.0/24 in-interface=Local
    add action=mark-connection chain=prerouting comment="" disabled=no \
    dst-address-type=!local in-interface=Local new-connection-mark=wlan1_conn \
    passthrough=yes per-connection-classifier=both-addresses:3/0
    add action=mark-connection chain=prerouting comment="" disabled=no \
    dst-address-type=!local in-interface=Local new-connection-mark=wlan2_conn \
    passthrough=yes per-connection-classifier=both-addresses:3/1
    add action=mark-connection chain=prerouting comment="" disabled=no \
    dst-address-type=!local in-interface=Local new-connection-mark=wlan3_conn \
    passthrough=yes per-connection-classifier=both-addresses:3/2
    add action=mark-connection chain=prerouting comment="" disabled=no \
    dst-address-type=!local in-interface=Local new-connection-mark=wlan4_conn \
    passthrough=yes per-connection-classifier=both-addresses:3/3
    add action=mark-routing chain=prerouting comment="" connection-mark=\
    wlan1_conn disabled=no in-interface=Local new-routing-mark=to_wlan1 \
    passthrough=no
    add action=mark-routing chain=prerouting comment="" connection-mark=\
    wlan2_conn disabled=no in-interface=Local new-routing-mark=to_wlan2 \
    passthrough=no
    add action=mark-routing chain=prerouting comment="" connection-mark=\
    wlan3_conn disabled=no in-interface=Local new-routing-mark=to_wlan3 \
    passthrough=no
    add action=mark-routing chain=prerouting comment="" connection-mark=\
    wlan4_conn disabled=no in-interface=Local new-routing-mark=to_wlan4 \
    passthrough=no
    add action=mark-packet chain=prerouting comment=MSN disabled=no \
    new-packet-mark=msn-out passthrough=yes protocol=tcp src-port=1863
    add action=mark-packet chain=prerouting comment="" disabled=no dst-port=1863 \
    new-packet-mark=msn-in passthrough=no protocol=tcp
    add action=change-mss chain=forward comment="" disabled=no new-mss=1360 \
    protocol=tcp tcp-flags=syn



  3. Citação Postado originalmente por tiagomatias Ver Post
    Mude a forma dos modem de roteado para bridge, você ganhar mais desempenho com isso, agora caso n resolver, teste cada link para ver se esta tendo as velocidades nominal


    estava querendo deixa o maior como bridge e o restante roteado ficara legal? outra coisa faco os teste direto funciona bem, link de 1 mega da 800kbps
    Última edição por diegovilela01; 16-04-2010 às 19:11.

  4. tiago a mudanca pra bridge em configuracoes e somente em ip-routes na alteracao do ip do route pra a interface?



  5. Citação Postado originalmente por diegovilela01 Ver Post
    tiago a mudanca pra bridge em configuracoes e somente em ip-routes na alteracao do ip do route pra a interface?
    vc mudando para bridge, as interfaces em mangle vai ser os PPPoE-out criado pelo mikrotik, em /ip route os gw use como GATEWAY-INTERFACE no lugar de IP.

    se vc tiver alguma particulariedade em deixar eme router, ai deixa como router, agora se for apenas modismo deixe como bridge todos os modem






Tópicos Similares

  1. PCC Balance de 3 a 16 links - Por: M4D3
    Por m4d3 no fórum Redes
    Respostas: 509
    Último Post: 30-05-2016, 12:59
  2. Ajuda PCC Mikrotik
    Por marsilba no fórum Redes
    Respostas: 5
    Último Post: 19-09-2009, 20:32
  3. Problemas depois de implementar PCC
    Por antonoel no fórum Redes
    Respostas: 2
    Último Post: 14-08-2009, 09:57
  4. Lentidão depois do PCC
    Por Evilazio no fórum Redes
    Respostas: 17
    Último Post: 04-08-2009, 22:56
  5. Respostas: 2
    Último Post: 24-07-2009, 19:11

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L