Página 6 de 15 PrimeiroPrimeiro ... 234567891011 ... ÚltimoÚltimo
+ Responder ao Tópico

PCC



  1. #101

    Padrão

    Por hora estou usando akee marcação por portas... segue abaixo o cenário:

    Proxy + Thunder
    1 Link marcado para porta 80 e outros
    1 Link como default para segurar p2p e outros
    1 Link marcado para sites de vídeos

    Caso algum usuário abra um p2p,o link default segura a bronca e não afeta a navegação.
    Caso algum usuário abra um site para ver vídeo,o link designado para isso segura a bronca.
    Caso algum usuário esteja apenas navegando,fazendo down(http,ftp etc),o link designado para a porta 80 segura a bronca.

    Nesse Caso do PCC pode ser feito algo semelhante?
    Explicando...


    Link-1 marcado para porta 80
    Link-2 marcado para porta 80
    Link-3 marcado para porta 80
    Link-4 marcado para ser default,assumindo assim os p2p e outros...
    Link-5 marcado para sites de vídeos etc


    Então ficaria assim na pratica...

    Cliente 1 entra e o PCC o jogara para o link 1 ... Cliente 2 entra e o PCC o jogara para o link 2
    Cliente 3 entra e o PCC o jogara para o link 3 ... Cliente 4 entra e o PCC o jogara para o link 1
    Cliente 5 entra e o PCC o jogara para o link 2 ... Cliente 6 entra e o PCC o jogara para o link 3

    e assim por diante...

    Entao a porta 80 ficaria bem balanceada entre os usuários,e as sujeiras como p2p e vídeos ficariam com links especificos...

    Nesse caso apenas Links 1,2 e 3 seriam marcados para o PCC,no entanto os 5 links serão marcados no mangle para redirecionar as suas devidas portas...

    É possivel esse cenário no PCC? Irei iniciar hoje a tarde alguns testes e gostaria dos cometários e sugestões dos colegas...

    Obrigado...
    Última edição por BillGates; 19-08-2009 às 10:58.

  2. #102

    Padrão

    Citação Postado originalmente por BillGates Ver Post
    Por hora estou usando akee marcação por portas... segue abaixo o cenário:

    Proxy + Thunder
    1 Link marcado para porta 80 e outros
    1 Link como default para segurar p2p e outros
    1 Link marcado para sites de vídeos

    Caso algum usuário abra um p2p,o link default segura a bronca e não afeta a navegação.
    Caso algum usuário abra um site para ver vídeo,o link designado para isso segura a bronca.
    Caso algum usuário esteja apenas navegando,fazendo down(http,ftp etc),o link designado para a porta 80 segura a bronca.

    Nesse Caso do PCC pode ser feito algo semelhante?
    Explicando...


    Link-1 marcado para porta 80
    Link-2 marcado para porta 80
    Link-3 marcado para porta 80
    Link-4 marcado para ser default,assumindo assim os p2p e outros...
    Link-5 marcado para sites de vídeos etc


    Então ficaria assim na pratica...

    Cliente 1 entra e o PCC o jogara para o link 1 ... Cliente 2 entra e o PCC o jogara para o link 2
    Cliente 3 entra e o PCC o jogara para o link 3 ... Cliente 4 entra e o PCC o jogara para o link 1
    Cliente 5 entra e o PCC o jogara para o link 2 ... Cliente 6 entra e o PCC o jogara para o link 3

    e assim por diante...

    Entao a porta 80 ficaria bem balanceada entre os usuários,e as sujeiras como p2p e vídeos ficariam com links especificos...

    Nesse caso apenas Links 1,2 e 3 seriam marcados para o PCC,no entanto os 5 links serão marcados no mangle para redirecionar as suas devidas portas...

    É possivel esse cenário no PCC? Irei iniciar hoje a tarde alguns testes e gostaria dos cometários e sugestões dos colegas...

    Obrigado...
    sim, tudo que vc disse dá para fazer sim, agora me responde uma coisa, para qual finalidade isso? se o loadbalaced pcc balancea de forma perfeita os links !



  3. #103

    Padrão

    Citação Postado originalmente por tiagomatias Ver Post
    sim, tudo que vc disse dá para fazer sim, agora me responde uma coisa, para qual finalidade isso? se o loadbalaced pcc balancea de forma perfeita os links !

    Antes eu trabalhava apenas com links adsl,hoje mesclo dedicado + adsl...

    Vamos dizer que temos 3 links ADSL balanceados (8MB/400k),ai por coincidencia varios usuarios de um dos links estajam fazendo download,outros em p2p,outros enviando fotos para o orkut etc...
    Como ficaria a navegação em geral nesse link? Nao ficaria sobrecarregada?

    Vlw...

  4. #104

    Padrão

    Obrigado pelo o pessoal que respondeu sobre a minha dúivda lá em cima do balanceamento e divisão de banda diferentes. Bom, eu queria deixar bem claro uma coisa:

    A questão não é pegar um script e copiar e colar no Mikrotik, o problema é que muita gente é novata no MK, o que é interessante num aprendizado é o how to passo a passo e não é o que acontece aqui, simplesmente um script com marcação de pacotes e rotas que para um leigo que esta começando a andar no mk fica dificil entender.

    Eu sugiro que os autores dos scripts coloquem os comentários do que estão fazendo, sei que isso é chato, mas até incentiva a leigo a estudar, pois ele vai descobrir como se comporta determinada regra. Foi esse metódo que Tom Swan no seu best seller "Tecle e Aprenda C", ensinou muita gente (inclusive eu) a apreder programar em C.

    Abraços



  5. #105

    Padrão

    Citação Postado originalmente por DSSS Ver Post
    Obrigado pelo o pessoal que respondeu sobre a minha dúivda lá em cima do balanceamento e divisão de banda diferentes. Bom, eu queria deixar bem claro uma coisa:

    A questão não é pegar um script e copiar e colar no Mikrotik, o problema é que muita gente é novata no MK, o que é interessante num aprendizado é o how to passo a passo e não é o que acontece aqui, simplesmente um script com marcação de pacotes e rotas que para um leigo que esta começando a andar no mk fica dificil entender.

    Eu sugiro que os autores dos scripts coloquem os comentários do que estão fazendo, sei que isso é chato, mas até incentiva a leigo a estudar, pois ele vai descobrir como se comporta determinada regra. Foi esse metódo que Tom Swan no seu best seller "Tecle e Aprenda C", ensinou muita gente (inclusive eu) a apreder programar em C.

    Abraços
    certo,
    nada melhor doque o wiki da propria mikrotik

    PCC - MikroTik Wiki

    tenho certeza absoluta que já tinha postado os links aonde qualquer iniciante possa ler e compreender as regras, mas para via das duvidas esta ai o link q ensina/explica cada linha, se divirta.
    Só para esclarecer uma coisa, aqui n foi feito em forma de how to, é simplesmente um topico sobre o balanceamento via PCC, quem conhece lendo uma vez apenas já sabe o q siguinifica as regras, e quem n conhece, já fiz o favor de postar aonde possa ler, aprender e compreender. Agora ter q ficar desenhando um cenaria para cada um q tiver duvida, fica complicado. Me perdoe a forma da expressao, mas leia o manual da mikrotik sobre filter rules, mangle etc que ao bater o olho nas regras saberá o q esta escrito. Isso serve para qualquer pessoa, how to como passo a passo do caminho das pedras n estará aprendendo nada.

  6. #106

    Padrão

    Citação Postado originalmente por BillGates Ver Post
    Antes eu trabalhava apenas com links adsl,hoje mesclo dedicado + adsl...

    Vamos dizer que temos 3 links ADSL balanceados (8MB/400k),ai por coincidencia varios usuarios de um dos links estajam fazendo download,outros em p2p,outros enviando fotos para o orkut etc...
    Como ficaria a navegação em geral nesse link? Nao ficaria sobrecarregada?

    Vlw...
    Por este motivo q a mikrotik desenvolveu o PCC para jogar um pacote para cada link via um algoritimo dela mesma, assim nunca vai saturar o link caso a carga seja dividida corretamente. N tem mas a necessidade de ficar jogando certos serviços em links separados.



  7. #107

    Padrão

    Citação Postado originalmente por tiagomatias Ver Post
    certo,
    nada melhor doque o wiki da propria mikrotik

    PCC - MikroTik Wiki

    tenho certeza absoluta que já tinha postado os links aonde qualquer iniciante possa ler e compreender as regras, mas para via das duvidas esta ai o link q ensina/explica cada linha, se divirta.
    Só para esclarecer uma coisa, aqui n foi feito em forma de how to, é simplesmente um topico sobre o balanceamento via PCC, quem conhece lendo uma vez apenas já sabe o q siguinifica as regras, e quem n conhece, já fiz o favor de postar aonde possa ler, aprender e compreender. Agora ter q ficar desenhando um cenaria para cada um q tiver duvida, fica complicado. Me perdoe a forma da expressao, mas leia o manual da mikrotik sobre filter rules, mangle etc que ao bater o olho nas regras saberá o q esta escrito. Isso serve para qualquer pessoa, how to como passo a passo do caminho das pedras n estará aprendendo nada.

    Certo Tiago, você não tem que me pedi perdão, pois na verdade você não me ofendeu , mas com certeza o Wiki do PCC explica tudinho (quase tudo)! Já tinha implementado auqi o PCC, mas não estava acertando configurar o balance dos links que eu te falei, mas agora esta ok. Eu fiz essa sujestão apenas para evitar perguntas repetitivas que acontecem ao longo desse tópico. Mas é isso ai, vou testar e ver como se comporta.

    Abraços e obrigado novamente.

  8. #108

    Padrão

    Citação Postado originalmente por tiagomatias Ver Post
    Por este motivo q a mikrotik desenvolveu o PCC para jogar um pacote para cada link via um algoritimo dela mesma, assim nunca vai saturar o link caso a carga seja dividida corretamente. N tem mas a necessidade de ficar jogando certos serviços em links separados.
    Obrigado pelas explicações tiago,irei fazer uns testes akee e comparar as duas formas de balance.

    Logo depois volto aqui e posto como foram os resultados...

    t+



  9. #109

    Padrão

    Amigos, tenho uma dúvida parecida com a do BillGates.
    Seguinte: Tenho 02 adsl 4megas e 01 de 2megas. (Brasil telecom)
    porém o up das mesmas é de 412k (se não me engano).
    Como o pessoal upa mta foto pelo orkut, manda e-mails pesados e videos no youtube o link fica no talo para UP e sobrando no Down, acontece de o msn não entrar e etc.
    Penso q ao usar o pcc e várias pessoas que upam cairem no mesmo link o problema ocorre-rá.
    Então penso q é válido por exemplo marcar a saida dos sites que o pessoal mais upa para uma adsl e o balanceamento para as outras duas.
    Então esquema ficaria assim:
    02 ADSL 4Mb -> Balanceador PCC -> MK controle <- Linux Squid -> ADSL 2Mb
    Clientes

    Esse Linux iria fazer o cache e via tcp_outgoing_address mandaria sites tipo youtube, orkut, hotmail para a adsl de 2Megas.

    Peço aos colegas que avaliem minha idéia e me digam se tem sentido, ou se só eu usar o PCC com os 3 links ficaria melhor.

  10. #110

    Padrão Rádio Uol

    Pessoal,

    Instalei o PCC aqui na minha rede, de início tive uns problemas com ID ALTA no emule e resolvi colocando as seguintes regras:

    Estou usando uma RB450.

    /ip firewall nat
    add action=masquerade chain=srcnat comment="BALANCEAMENTO 1x1" disabled=no \
    out-interface="MODEM #1"
    add action=masquerade chain=srcnat comment="" disabled=no out-interface=\
    "MODEM #2"
    add action=dst-nat chain=dstnat comment=DMZ disabled=no in-interface=\
    "MODEM #1" to-addresses=172.0.0.2
    add action=dst-nat chain=dstnat comment="" disabled=no in-interface=\
    "MODEM #2" to-addresses=172.0.0.2


    172.0.0.2 = MK(x86) autenticador.

    Ocorre que, estou tendo problemas com Rádio Uol, ela só funciona quando quer. Alguém mais está passando por isso?

    PS: Fiz o PCC hoje(21/08) de acordo com o Wiki da MK.


    Abs.
    Última edição por xnetinho; 21-08-2009 às 23:22.



  11. #111

    Padrão

    Citação Postado originalmente por fasseabra Ver Post
    Amigos, tenho uma dúvida parecida com a do BillGates.
    Seguinte: Tenho 02 adsl 4megas e 01 de 2megas. (Brasil telecom)
    porém o up das mesmas é de 412k (se não me engano).
    Como o pessoal upa mta foto pelo orkut, manda e-mails pesados e videos no youtube o link fica no talo para UP e sobrando no Down, acontece de o msn não entrar e etc.
    Penso q ao usar o pcc e várias pessoas que upam cairem no mesmo link o problema ocorre-rá.
    Então penso q é válido por exemplo marcar a saida dos sites que o pessoal mais upa para uma adsl e o balanceamento para as outras duas.
    Então esquema ficaria assim:
    02 ADSL 4Mb -> Balanceador PCC -> MK controle <- Linux Squid -> ADSL 2Mb
    Clientes

    Esse Linux iria fazer o cache e via tcp_outgoing_address mandaria sites tipo youtube, orkut, hotmail para a adsl de 2Megas.

    Peço aos colegas que avaliem minha idéia e me digam se tem sentido, ou se só eu usar o PCC com os 3 links ficaria melhor.
    vamos pensar como vc!!
    as suas adsl são todas com o mesmo UPload, o balanceamento PCC no algoritimo dela ela joga um pacote para cada link por vez, exemplo
    primeiro pacote cliente01 > adsl1
    segundo pacote cliente02 > adsl2
    terceiro pacote cliente03 > adsl3

    e por ai vai....

    pensando assim se vc tem 3 links com 400k de upload vc tem na verdade 1200k de upload para trabalhar.

    se vc fizer como esta pensando forçando sites q fazem bastante upload como orkut, youtube e msn para apenas uma adsl, vc vai ter apenas 400k de upload para trabalhar com todos esses serviços. Não ha vantagem alguma vc fazer isso.

    lógico que por algum conhecidencia acontecer que neste sorteio do algoritimo em jogar os clientes nos links como explicado acima, acontecer dele jogar a maioria dos clientes em apenas um link vai dar lentidão mesmo, mas fazer oq né, é melhor ele mesmo jogar os clientes em forma aleatoria pelo seu proprio algoritimo de balanceamento doque vc jogar tudo em um link apenas, pq vc n estará resolvendo o problema.

    Sua idéia seria valida se vc tivesse 1 link DEDICADO e varios adsl, assim vc faria com que os sites que precisa de mais UP para o link dedicado, mas no seu caso n é o q acontece.

  12. #112

    Padrão

    Obrigado amigo TiagoMatias, boa observação, vou colocar em prática todos os links no pcc , e se eu notar falta UP peço mais uma ADSL



  13. #113

    Padrão

    Citação Postado originalmente por tiagomatias Ver Post
    vamos pensar como vc!!
    as suas adsl são todas com o mesmo UPload, o balanceamento PCC no algoritimo dela ela joga um pacote para cada link por vez, exemplo
    primeiro pacote cliente01 > adsl1
    segundo pacote cliente02 > adsl2
    terceiro pacote cliente03 > adsl3

    e por ai vai....

    pensando assim se vc tem 3 links com 400k de upload vc tem na verdade 1200k de upload para trabalhar.

    se vc fizer como esta pensando forçando sites q fazem bastante upload como orkut, youtube e msn para apenas uma adsl, vc vai ter apenas 400k de upload para trabalhar com todos esses serviços. Não ha vantagem alguma vc fazer isso.

    lógico que por algum conhecidencia acontecer que neste sorteio do algoritimo em jogar os clientes nos links como explicado acima, acontecer dele jogar a maioria dos clientes em apenas um link vai dar lentidão mesmo, mas fazer oq né, é melhor ele mesmo jogar os clientes em forma aleatoria pelo seu proprio algoritimo de balanceamento doque vc jogar tudo em um link apenas, pq vc n estará resolvendo o problema.

    Sua idéia seria valida se vc tivesse 1 link DEDICADO e varios adsl, assim vc faria com que os sites que precisa de mais UP para o link dedicado, mas no seu caso n é o q acontece.

    Tiago duas perguntas simples: como é (desculpe sou novo nessa área) a regra no mangle para encaminhar todo o meu upload para o link full que eu tenho aqui? tenho algo similar como o que acontece nessa situação do nosso amigo, tenhos dois links 8Mbits com 516 de up e tenho um full de 2Mbits, e também se é possível utilizar o PCC e hotspot na mesma máquina ou é aconselhável dividilos?
    Última edição por DSSS; 22-08-2009 às 14:37.

  14. #114

    Padrão

    Tiago, implementei o pcc e ficou tudo certo, parece q esta funcionando mto bem. Tenho ainda algumas dúvidas.
    01 - Coloquei 02 adsl de 4Mb com os modens em router. Tem como colocar os modens no modo Bridge? Se sim o que eu preciso alterar ou verificar?
    02 - Estou tentando acessar o MK de minha casa pela minha adsl e não consigo, preciso criar alguma regra? pois coloquei DMZ nos modens direto p/ o MK e não acessa.

    Só isso, desculpe estar explorando seu conhecimento, mas caiu um raio na minha torre e queimou metade dos meus aparelhos, estou numa correria p/ arrumar tudo. Vlw.



  15. #115

    Padrão

    Citação Postado originalmente por fasseabra Ver Post
    Tiago, implementei o pcc e ficou tudo certo, parece q esta funcionando mto bem. Tenho ainda algumas dúvidas.
    01 - Coloquei 02 adsl de 4Mb com os modens em router. Tem como colocar os modens no modo Bridge? Se sim o que eu preciso alterar ou verificar?
    02 - Estou tentando acessar o MK de minha casa pela minha adsl e não consigo, preciso criar alguma regra? pois coloquei DMZ nos modens direto p/ o MK e não acessa.

    Só isso, desculpe estar explorando seu conhecimento, mas caiu um raio na minha torre e queimou metade dos meus aparelhos, estou numa correria p/ arrumar tudo. Vlw.
    Ola fasseabra,

    01 - apenas colocar o modem em bridge e criar o Discador PPPoE no mikrotik para discar sua adsl, não esquece de mudar no mangle que suas interfaces serão agora as interfaces PPPoE
    02 - já deveria acessar sim, bastaria colocar os modem em dmz apontando para os ips dos mikrotik, deve ser alguma coisa errado ou firewall nesta maquina q pode estar bloqueando o acesso externo, mas mudando so modem para bridge alem de vc ter um desempenho melhor no link acaba essa duvida de não acessar ele de fora por estar algo errado no dmz.

    abraços

  16. #116

    Padrão

    Citação Postado originalmente por DSSS Ver Post
    Tiago duas perguntas simples: como é (desculpe sou novo nessa área) a regra no mangle para encaminhar todo o meu upload para o link full que eu tenho aqui? tenho algo similar como o que acontece nessa situação do nosso amigo, tenhos dois links 8Mbits com 516 de up e tenho um full de 2Mbits, e também se é possível utilizar o PCC e hotspot na mesma máquina ou é aconselhável dividilos?
    o que vc pode fazer é antes das regras do PCC, fazer a marcação de pacotes para os sites/serviços que consome mais UPLOAD como exemplo msn, orkut, alguns sites de email etc e jogar eles no seu link dedicado, essa é uma das formas, outra é vc usar rotas staticas no /ip route filtrando os esses serviços que disse antes e forçar ele sair apenas pelo seu link dedicado.

    já fica uma mistura de loadbalaced pcc com rotas staticas



  17. #117

    Padrão

    Citação Postado originalmente por fasseabra Ver Post
    Tiago, implementei o pcc e ficou tudo certo, parece q esta funcionando mto bem. Tenho ainda algumas dúvidas.
    01 - Coloquei 02 adsl de 4Mb com os modens em router. Tem como colocar os modens no modo Bridge? Se sim o que eu preciso alterar ou verificar?
    02 - Estou tentando acessar o MK de minha casa pela minha adsl e não consigo, preciso criar alguma regra? pois coloquei DMZ nos modens direto p/ o MK e não acessa.

    Só isso, desculpe estar explorando seu conhecimento, mas caiu um raio na minha torre e queimou metade dos meus aparelhos, estou numa correria p/ arrumar tudo. Vlw.


    Referente a questão nº 2 já esta resolvida. consegui acessar o MK, não era nada, rs.

    Ref. a questão nº 1 vou verificar e mudar os modens p/ bridge, se pintar algum problema posto aki, Obrigado Tiago.
    Última edição por fasseabra; 25-08-2009 às 14:26.

  18. #118

    Padrão

    Citação Postado originalmente por tiagomatias Ver Post
    Ola fasseabra,

    01 - apenas colocar o modem em bridge e criar o Discador PPPoE no mikrotik para discar sua adsl, não esquece de mudar no mangle que suas interfaces serão agora as interfaces PPPoE
    02 - já deveria acessar sim, bastaria colocar os modem em dmz apontando para os ips dos mikrotik, deve ser alguma coisa errado ou firewall nesta maquina q pode estar bloqueando o acesso externo, mas mudando so modem para bridge alem de vc ter um desempenho melhor no link acaba essa duvida de não acessar ele de fora por estar algo errado no dmz.

    abraços
    Coloquei os modens em Bridge, só tive q lembrar de desmarcar o Default route, o resto foi só adaptar as interfaces no mangle. Vlw Tiago.

    Não estava conseguindo acessar o meu MK principal pois qdo digitava o IP do link caia no meu MK com PCC. Consegui resolver e vou postar pois posso ajudar alguém com essa mesma dificuldade.
    A estrutura esta assim:
    02 ADSL 4Mb => MK com PCC => MK principal => Clientes.

    1º - Mudei a porta do meu Winbox do MK com PCC.
    IP -> Sevices
    Alterei a porta default do winbox para a 8290.
    Agora para acessar o winbox do MK com PCC tenho q colocar 189.74.xx.xxx:8290

    2º - Criei uma regra redirecionando a porta default do winbox (8291) para o IP do MK principal. O IP 192.168.50.2 é a interface Link do MK principal.
    IP -> Firewall -> NAT
    add action=dst-nat chain=dstnat comment="" disabled=no dst-port=8291 in-interface=wan1-pppoe protocol=tcp to-addresses=192.168.50.2 to-ports=8291

    3º - Para acessar o MK principal o IP de onde eu estiver tem q estar fora do Balance. Seguindo o Script do Tiago tem no Mangle a regra "FORA DO LOADBALACED".
    Eu adicionei o IP de onde estou lá em IP -> Firewall - Address List.
    add address=189.72.239.109 comment="COLOCAR O IP PARA FICAR FORA DO BALANCE - BART" disabled=no list=loopback

    Depois é só alterar o IP qdo for preciso.

    Espero ter ajudado. Vlw galera.
    Última edição por fasseabra; 28-08-2009 às 01:23.



  19. #119

    Padrão

    olá a todos no foro, este é minha primeira participacion tenho estado lendo desde faz um tempo os pós e são muito interessantes, hare uso de um tradutor do site já que meu idioma é o espanhol...

    no que respecta ao balanço por PCC, em meu caso tenho uma ADSL de 4 mb e uma ADSL de 2 mb, minha dúvida é com respeito a que valores devo modificar neste tipo de balanceamiento para que o 60% do trafico de minha rede saia pela ADSL de 4 mb e o 40% do trafico saia pela ADSL de 2mb

    e outra dúvida é com respeito a: dst-address-type=!local

    !local pode ser qualquer palavra? ou a que se refere?

    agradecere as respostas

    saludos

  20. #120

    Padrão

    Citação Postado originalmente por mikrotikuser Ver Post
    olá a todos no foro, este é minha primeira participacion tenho estado lendo desde faz um tempo os pós e são muito interessantes, hare uso de um tradutor do site já que meu idioma é o espanhol...

    no que respecta ao balanço por PCC, em meu caso tenho uma ADSL de 4 mb e uma ADSL de 2 mb, minha dúvida é com respeito a que valores devo modificar neste tipo de balanceamiento para que o 60% do trafico de minha rede saia pela ADSL de 4 mb e o 40% do trafico saia pela ADSL de 2mb

    e outra dúvida é com respeito a: dst-address-type=!local

    !local pode ser qualquer palavra? ou a que se refere?

    agradecere as respostas

    saludos

    Olá amigo,
    Ref. a questão 1
    Ocorreto é vc somar as duas adsl 4 + 2 = 6Mb e dividir em 3 de 2Mb.
    Faça assim com os links as regras de INPUT, OUTPUT e PREROUTING com marcação de MARK ROUTING não mudam, não se acrecenta nada, o q vai acrecentar são as regras de PREROUTING com marcação de MARK CONNECTION, nelas que vc vai dividir o trafego por igual, no caso a divisão seria:
    2 marcação para 1 link de 4MB
    1 marcação para 1 link de 2MB
    (essa explicação foi copiada do Tiago nesse mesmo post).

    Ref. a questão 2.
    dst-address-type=!local
    Esta correto, a que ela se refere não sei explicar direito, mas acredito que seja a respeito dos destinos dos pacotes.