+ Responder ao Tópico

PCC



  1. #161

    Padrão

    Entao... eu entendi... mas se eu deixar both-address ele nao soma NEM com gerenciador de downloads... dai quando eu coloco both-address and ports dai sim ele soma

    Tem ideia?

  2. #162

    Padrão

    Citação Postado originalmente por thiagotgc Ver Post
    Entao... eu entendi... mas se eu deixar both-address ele nao soma NEM com gerenciador de downloads... dai quando eu coloco both-address and ports dai sim ele soma

    Tem ideia?
    Acho q vc n entendu ainda, o PCC ele balaceia o link, e não SOMA os links, a única forma de somar os links é usando both-address and port, e é OBRIGADO a vc usar um GERENCIADOR DE DOWNLOAD para que a SOMA DOS LINKS FUNCIONA. mesmo vc mudando para both-addres and ports vc n vai conseguir somar os links fazendo um download normal sem gerenciador.

    relatos testados por mim e mais algumas pessoas no forum internacional com both-address and ports acontecia de ficar expirando conexões, causeonado expiração de paginas etc. E de fato com apção both-address and ports ativa utilizando um gerenciador de download somava os links em um download.

    Obs. a última vez q testei o both-address and port foi na versão 3.27, n sei se corrigiram acima dela.

    abraços
    Última edição por tiagomatias; 30-09-2009 às 17:27. Razão: both-address and port



  3. #163

    Padrão

    Entao Tiagao, é que no outro tópico voce tava me ajudando e voce nao sabia por que sobrecarregava um link só, e nao "somava" (balanceia como queira).
    Dai resolvi mudar essa opção e deu certo.

    Até agora nao tive problemas com isso usando a versao 3.30

    Por enquanto ta perfeitinho!

    Usando os 2 Links de 2MB full.. Vlw

    http://img18.imageshack.us/img18/6820/semttulowg.png

  4. #164

    Padrão

    Citação Postado originalmente por thiagotgc Ver Post
    Entao Tiagao, é que no outro tópico voce tava me ajudando e voce nao sabia por que sobrecarregava um link só, e nao "somava" (balanceia como queira).
    Dai resolvi mudar essa opção e deu certo.

    Até agora nao tive problemas com isso usando a versao 3.30

    Por enquanto ta perfeitinho!

    Usando os 2 Links de 2MB full.. Vlw

    http://img18.imageshack.us/img18/6820/semttulowg.png
    ótimo, resolvido, talvez sirva para mais alguém o seu problema.

    abraços



  5. #165

    Padrão duvidas

    Citação Postado originalmente por tiagomatias Ver Post
    ótimo, resolvido, talvez sirva para mais alguém o seu problema.

    abraços
    caros colegas, primeiramente venho parabenizar pelo topico pois está sendo de grande ajuda pra todos.

    más tenho uma duvida, gostaria de saber se eu fizer um servidor MK com balanceamento e PCC para somar dois links de 1 mega, e entregar para meu gateway, um servidor slackware 12.1 somaria 2 megas?

  6. #166

    Padrão

    Citação Postado originalmente por NetLagos Ver Post
    caros colegas, primeiramente venho parabenizar pelo topico pois está sendo de grande ajuda pra todos.

    más tenho uma duvida, gostaria de saber se eu fizer um servidor MK com balanceamento e PCC para somar dois links de 1 mega, e entregar para meu gateway, um servidor slackware 12.1 somaria 2 megas?
    seguinte, oq seria somar ?
    na minha cabeça somaer seria fazer um único download e ele der o máximo da soma de todos os links. A forma do loadbalaced PCC fazer isso é usando both-addres and port, e usar um gerenciador de download ao se fazer um download. e como o seu slackware não vai fazer o download com gerenciador de download, ele não vai somar os links. (PONTO)

    Ai vai vem a pergunta, mas se eu fizer varios download com o slackware abrindo varias instacias de download, o PCC vai jogar cada instancia desses arquivos para um link separado e e vai dar a velocidade maxima de cada link, exemplo, dois circuitos de 2 MB se fazendo dois downloads ele vai dar a taxa de trabsferencia de cada link separado, em outras palavras dois download de 256kpbs.

    o pessoal confunde muito, balanceamento de link com soma de link.

    e hoje o PCC para somar o link tem q existir na parte do cliente uma ferramente de gerenciamento de download. como o downloadceleratior, orbit etc.

    espero ter sido claro a vc.

    abraços



  7. #167

    Padrão

    Citação Postado originalmente por tiagomatias Ver Post
    seguinte, oq seria somar ?
    na minha cabeça somaer seria fazer um único download e ele der o máximo da soma de todos os links. A forma do loadbalaced PCC fazer isso é usando both-addres and port, e usar um gerenciador de download ao se fazer um download. e como o seu slackware não vai fazer o download com gerenciador de download, ele não vai somar os links. (PONTO)

    Ai vai vem a pergunta, mas se eu fizer varios download com o slackware abrindo varias instacias de download, o PCC vai jogar cada instancia desses arquivos para um link separado e e vai dar a velocidade maxima de cada link, exemplo, dois circuitos de 2 MB se fazendo dois downloads ele vai dar a taxa de trabsferencia de cada link separado, em outras palavras dois download de 256kpbs.

    o pessoal confunde muito, balanceamento de link com soma de link.

    e hoje o PCC para somar o link tem q existir na parte do cliente uma ferramente de gerenciamento de download. como o downloadceleratior, orbit etc.

    espero ter sido claro a vc.

    abraços
    Grato Tiagomatias,

    vc foi bem claro na sua resposta, fiz a pergunta porque preciso aumentar a banda de entrada no meu servidor, só que é mais facil colocar outro link que fazer um Up no link atual, ai lendo o topico fiquei com duvidas se iria somar a banda, más vou fazer o teste dessa maneira que vc falou, onde eu coloco esse script do both-addres and port?

    desde já agradeço

  8. #168

    Padrão

    Citação Postado originalmente por tiagomatias Ver Post
    Não sei se reparou se n me engano aquele outro usa-se nas regras uma opção a mais chamado connection-state=new com essa opção ativa vc pode usar o hotspot na mesma maquina do loadbalaced, mas o ideal é colocar o loadbalaced em uma maquina diferente do hotspot, mas caso n possa, utilize da forma q te disse, nas outras regras do Luciano m4d3 está para funcionar junto.

    abraços
    amigo, coloquei essa opção no meu mais não vai, na hora que habilito o hotspot, a rede para, continua em abrir a pagina de autenticação ..
    segue as regras novamente ..

    Código :
    /ip firewall nat
    add action=passthrough chain=unused-hs-chain comment=\
        "place hotspot rules here" disabled=yes
    add action=masquerade chain=srcnat comment="masquerade hotspot network" \
        disabled=no src-address=10.10.10.0/24
    add action=masquerade chain=srcnat comment="Mascaramento do PCC" disabled=no \
        out-interface=Oi_UP_512
    add action=masquerade chain=srcnat comment="" disabled=no out-interface=\
        Oi_UP_256

    Código :
    /ip firewall mangle
    add action=mark-connection chain=input comment="" connection-state=new \
        disabled=no in-interface=Oi_UP_256 new-connection-mark=Oi_UP_256_conn \
        passthrough=yes
    add action=mark-connection chain=input comment="" connection-state=new \
        disabled=no in-interface=Oi_UP_512 new-connection-mark=Oi_UP_512_conn \
        passthrough=yes
    add action=mark-routing chain=output comment="" connection-mark=\
        Oi_UP_256_conn disabled=no new-routing-mark=to_Oi_UP_256_conn \
        passthrough=yes
    add action=mark-routing chain=output comment="" connection-mark=\
        Oi_UP_512_conn disabled=no new-routing-mark=to_Oi_UP_512_conn \
        passthrough=yes
    add action=accept chain=prerouting comment="" disabled=no dst-address=\
        189.80.16.80/29 in-interface=Rede_Local
    add action=accept chain=prerouting comment="" disabled=no dst-address=\
        189.80.219.80/29 in-interface=Rede_Local
    add action=mark-connection chain=prerouting comment="" disabled=no \
        dst-address-type=!local in-interface=Rede_Local new-connection-mark=\
        Oi_UP_512_conn passthrough=yes per-connection-classifier=\
        both-addresses:2/0
    add action=mark-connection chain=prerouting comment="" disabled=no \
        dst-address-type=!local in-interface=Rede_Local new-connection-mark=\
        Oi_UP_256_conn passthrough=yes per-connection-classifier=\
        both-addresses:2/1
    add action=mark-routing chain=prerouting comment="" connection-mark=\
        Oi_UP_512_conn disabled=no in-interface=Rede_Local new-routing-mark=\
        to_Oi_UP_512_conn passthrough=yes
    add action=mark-routing chain=prerouting comment="" connection-mark=\
        Oi_UP_256_conn disabled=no in-interface=Rede_Local new-routing-mark=\
        to_Oi_UP_256_conn passthrough=yes


    Código :
    ip>route
    add check-gateway=ping disabled=no distance=1 dst-address=0.0.0.0/0 gateway=\
        189.80.16.81 routing-mark=to_Oi_UP_256_conn scope=30 target-scope=10
    add check-gateway=ping disabled=no distance=2 dst-address=0.0.0.0/0 gateway=\
        189.80.16.81 scope=30 target-scope=10
    add check-gateway=ping disabled=no distance=1 dst-address=0.0.0.0/0 gateway=\
        189.80.219.81 routing-mark=to_Oi_UP_512_conn scope=30 target-scope=10
    add check-gateway=ping disabled=no distance=1 dst-address=0.0.0.0/0 gateway=\
        189.80.219.81 scope=30 target-scope=10

    Código :
    /ip address
    add address=10.10.10.1/24 broadcast=10.10.10.255 comment=\
        "Rede Local - Clientes Rua" disabled=no interface=Rede_Local network=\
        10.10.10.0
    add address=189.80.16.82/29 broadcast=189.80.16.87 comment="Link Oi 256" \
        disabled=no interface=Oi_UP_256 network=189.80.16.80
    add address=189.80.219.82/29 broadcast=189.80.219.87 comment="Link Oi 512" \
        disabled=no interface=Oi_UP_512 network=189.80.219.80



  9. #169

    Padrão

    É isso ai... ainda nao tem como somar os Down.... mas que isso ajuda.. ahhh ajuda sim!!!

  10. #170

    Padrão

    Citação Postado originalmente por NetLagos Ver Post
    Grato Tiagomatias,

    vc foi bem claro na sua resposta, fiz a pergunta porque preciso aumentar a banda de entrada no meu servidor, só que é mais facil colocar outro link que fazer um Up no link atual, ai lendo o topico fiquei com duvidas se iria somar a banda, más vou fazer o teste dessa maneira que vc falou, onde eu coloco esse script do both-addres and port?

    desde já agradeço
    de uma olhada no script do PCC q vc vai ver q tem essa opção lá para se mudar de both-address e both-address and ports



  11. #171

    Padrão

    Citação Postado originalmente por exclusivenet Ver Post
    amigo, coloquei essa opção no meu mais não vai, na hora que habilito o hotspot, a rede para, continua em abrir a pagina de autenticação ..
    segue as regras novamente ..

    Código :
    /ip firewall nat
    add action=passthrough chain=unused-hs-chain comment=\
        "place hotspot rules here" disabled=yes
    add action=masquerade chain=srcnat comment="masquerade hotspot network" \
        disabled=no src-address=10.10.10.0/24
    add action=masquerade chain=srcnat comment="Mascaramento do PCC" disabled=no \
        out-interface=Oi_UP_512
    add action=masquerade chain=srcnat comment="" disabled=no out-interface=\
        Oi_UP_256
    Código :
    /ip firewall mangle
    add action=mark-connection chain=input comment="" connection-state=new \
        disabled=no in-interface=Oi_UP_256 new-connection-mark=Oi_UP_256_conn \
        passthrough=yes
    add action=mark-connection chain=input comment="" connection-state=new \
        disabled=no in-interface=Oi_UP_512 new-connection-mark=Oi_UP_512_conn \
        passthrough=yes
    add action=mark-routing chain=output comment="" connection-mark=\
        Oi_UP_256_conn disabled=no new-routing-mark=to_Oi_UP_256_conn \
        passthrough=yes
    add action=mark-routing chain=output comment="" connection-mark=\
        Oi_UP_512_conn disabled=no new-routing-mark=to_Oi_UP_512_conn \
        passthrough=yes
    add action=accept chain=prerouting comment="" disabled=no dst-address=\
        189.80.16.80/29 in-interface=Rede_Local
    add action=accept chain=prerouting comment="" disabled=no dst-address=\
        189.80.219.80/29 in-interface=Rede_Local
    add action=mark-connection chain=prerouting comment="" disabled=no \
        dst-address-type=!local in-interface=Rede_Local new-connection-mark=\
        Oi_UP_512_conn passthrough=yes per-connection-classifier=\
        both-addresses:2/0
    add action=mark-connection chain=prerouting comment="" disabled=no \
        dst-address-type=!local in-interface=Rede_Local new-connection-mark=\
        Oi_UP_256_conn passthrough=yes per-connection-classifier=\
        both-addresses:2/1
    add action=mark-routing chain=prerouting comment="" connection-mark=\
        Oi_UP_512_conn disabled=no in-interface=Rede_Local new-routing-mark=\
        to_Oi_UP_512_conn passthrough=yes
    add action=mark-routing chain=prerouting comment="" connection-mark=\
        Oi_UP_256_conn disabled=no in-interface=Rede_Local new-routing-mark=\
        to_Oi_UP_256_conn passthrough=yes
    Código :
    ip>route
    add check-gateway=ping disabled=no distance=1 dst-address=0.0.0.0/0 gateway=\
        189.80.16.81 routing-mark=to_Oi_UP_256_conn scope=30 target-scope=10
    add check-gateway=ping disabled=no distance=2 dst-address=0.0.0.0/0 gateway=\
        189.80.16.81 scope=30 target-scope=10
    add check-gateway=ping disabled=no distance=1 dst-address=0.0.0.0/0 gateway=\
        189.80.219.81 routing-mark=to_Oi_UP_512_conn scope=30 target-scope=10
    add check-gateway=ping disabled=no distance=1 dst-address=0.0.0.0/0 gateway=\
        189.80.219.81 scope=30 target-scope=10
    Código :
    /ip address
    add address=10.10.10.1/24 broadcast=10.10.10.255 comment=\
        "Rede Local - Clientes Rua" disabled=no interface=Rede_Local network=\
        10.10.10.0
    add address=189.80.16.82/29 broadcast=189.80.16.87 comment="Link Oi 256" \
        disabled=no interface=Oi_UP_256 network=189.80.16.80
    add address=189.80.219.82/29 broadcast=189.80.219.87 comment="Link Oi 512" \
        disabled=no interface=Oi_UP_512 network=189.80.219.80
    Amigo sinceramente n testei esse script do pcc com hotspot na mesma maquina, sei q no site internacional tem um script adptado por eles para funcionar hotspot e pcc na mesma maquina, de uma procurada la e adpte seu pcc para o mesmo q o deles, ou faça pcc separado do hotspot

  12. #172

    Padrão ao consigo

    Grande tiagomatias, tenho uma web page em um servidor local, depois que coloquei o PCC rodar, não consigo acessar minha pagina externamente, quando desativo o PCC eu consigo acessar normalmente, tirei o ip que recebe as requisições externa com uma regra de accept e coloquei acima do PCC mais mesmo assim não vai de maneira alguma, tenho uma maquina exclusiva para o load, com 3 ADSL sendo 1 ip fixo(IP Profissional), meu load ta 100% poi fiço seguindo suas dicas, mais esse problema eu não consegui resolver...
    Se puder me dar uma mão eu agradeço!



  13. #173

    Padrão

    Citação Postado originalmente por rogeriodj Ver Post
    Grande tiagomatias, tenho uma web page em um servidor local, depois que coloquei o PCC rodar, não consigo acessar minha pagina externamente, quando desativo o PCC eu consigo acessar normalmente, tirei o ip que recebe as requisições externa com uma regra de accept e coloquei acima do PCC mais mesmo assim não vai de maneira alguma, tenho uma maquina exclusiva para o load, com 3 ADSL sendo 1 ip fixo(IP Profissional), meu load ta 100% poi fiço seguindo suas dicas, mais esse problema eu não consegui resolver...
    Se puder me dar uma mão eu agradeço!
    1 - qual esta sendo a rota padrão ?
    2 - poste a regra de redirecionamento de portas para esse servidor web
    3 - poste a regra de accept tirando o servidor web do balanceamento

  14. #174

    Padrão

    Citação Postado originalmente por tiagomatias Ver Post
    Amigo sinceramente n testei esse script do pcc com hotspot na mesma maquina, sei q no site internacional tem um script adptado por eles para funcionar hotspot e pcc na mesma maquina, de uma procurada la e adpte seu pcc para o mesmo q o deles, ou faça pcc separado do hotspot
    Tiago, muito obrigado .., vou tirar aqui da minha cabeça esse negocio de fazer o balance PCC e o hotspot na mesma maquina, vou começar a configurar um server novo para o hotspot agora, queria saber só se tem algum topico já aberto especifico, dizendo como fazer os 2 servidores se comunicar, para aproveitar o balance do primeiro servidor ?

    Ou eu teria um servidor normal, sendo que a WAN, seria a saida do loadbalance ? e a última, nesse servidor que será o load, eu poderia ter por exemplo um QoS também configurando juntamente com o load ? ou a maquina tem que ser especifica para load ?

    Agradeço desde já, e lá vai eu para a segunda madrugada seguida, lutando para montar esse sistema ..

    valeu a todos ..



  15. #175

    Padrão

    Citação Postado originalmente por exclusivenet Ver Post
    Tiago, muito obrigado .., vou tirar aqui da minha cabeça esse negocio de fazer o balance PCC e o hotspot na mesma maquina, vou começar a configurar um server novo para o hotspot agora, queria saber só se tem algum topico já aberto especifico, dizendo como fazer os 2 servidores se comunicar, para aproveitar o balance do primeiro servidor ?

    Ou eu teria um servidor normal, sendo que a WAN, seria a saida do loadbalance ? e a última, nesse servidor que será o load, eu poderia ter por exemplo um QoS também configurando juntamente com o load ? ou a maquina tem que ser especifica para load ?

    Agradeço desde já, e lá vai eu para a segunda madrugada seguida, lutando para montar esse sistema ..

    valeu a todos ..
    Ou eu teria um servidor normal, sendo que a WAN, seria a saida do loadbalance ? exatamente isso
    faça o QoS no seu servidor mikrotik. deixa o PCC apenas com as regras de PCC

  16. #176

    Padrão

    Estou com o mesmo problema do rogeriodj. Depois que instalei o pcc não consigo acessar umas páginas internas para visualização dos clientes. O voip também não está funcionando. Alguém pode ajudar?



  17. #177

    Padrão

    Citação Postado originalmente por tiagomatias Ver Post
    1 - qual esta sendo a rota padrão ?
    2 - poste a regra de redirecionamento de portas para esse servidor web
    3 - poste a regra de accept tirando o servidor web do balanceamento
    Minha rota padrão é exatamente a qual tem o ip fixo que recebe as requisições externas.
    Minhas regras no MK Load
    Código :
    Parte do nat onde faço o redirecionamento para o MK onde se conecta o servidor web
    /ip firewall nat
    add action=masquerade chain=srcnat comment=MASCARA disabled=no out-interface=\
        NET-1
    add action=masquerade chain=srcnat comment="" disabled=no out-interface=NET-2
    add action=masquerade chain=srcnat comment="" disabled=no out-interface=NET-3
    add action=dst-nat chain=dstnat comment=Redirect_Site disabled=no dst-port=80 \
        in-interface=NET-1 protocol=tcp to-addresses=172.168.0.2 to-ports=80


    Código :
    Mangle . [B]OBS. no address-list eu coloquei o ip da interface, como o MK esta discando, o ip real esta no MK[/B]
    /ip firewall mangle
        add action=accept chain=prerouting comment="IP Site passar fora do load" disabled=no src-address-list=\
        fora_load
    add action=mark-packet chain=prerouting comment="Paginas Dinamicas" disabled=\
        no dst-port=443 new-packet-mark=Paginas_Dinamicas passthrough=yes \
        protocol=tcp
    add action=mark-packet chain=prerouting comment="" disabled=no dst-port=1863 \
        new-packet-mark=Paginas_Dinamicas passthrough=yes protocol=tcp
    add action=mark-packet chain=prerouting comment="" disabled=no dst-port=25 \
        new-packet-mark=Paginas_Dinamicas passthrough=yes protocol=tcp
    add action=mark-packet chain=prerouting comment="" disabled=no dst-port=\
        6891-6901 new-packet-mark=Paginas_Dinamicas passthrough=yes protocol=tcp
    add action=mark-packet chain=prerouting comment="" disabled=no dst-port=\
        6891-6901 new-packet-mark=Paginas_Dinamicas passthrough=yes protocol=udp
    add action=mark-packet chain=prerouting comment="" disabled=no dst-port=5190 \
        new-packet-mark=Paginas_Dinamicas passthrough=yes protocol=udp
    add action=mark-packet chain=prerouting comment="" disabled=no dst-port=1503 \
        new-packet-mark=Paginas_Dinamicas passthrough=yes protocol=tcp
    add action=mark-packet chain=prerouting comment="" disabled=no dst-port=7001 \
        new-packet-mark=Paginas_Dinamicas passthrough=yes protocol=tcp
    add action=mark-packet chain=prerouting comment="" disabled=no dst-port=9 \
        new-packet-mark=Paginas_Dinamicas passthrough=yes protocol=udp
    add action=mark-packet chain=prerouting comment="" disabled=no dst-port=7001 \
        new-packet-mark=Paginas_Dinamicas passthrough=yes protocol=udp
    add action=mark-packet chain=prerouting comment="" disabled=no dst-port=1025 \
        new-packet-mark=Paginas_Dinamicas passthrough=yes protocol=udp
    add action=mark-routing chain=prerouting comment="" disabled=no \
        new-routing-mark=https packet-mark=Paginas_Dinamicas passthrough=no
    add action=mark-connection chain=input comment=LOAD-PCC connection-state=new \
        disabled=no in-interface=NET-1 new-connection-mark=ether1_conn \
        passthrough=yes
    add action=mark-connection chain=input comment="" connection-state=new \
        disabled=no in-interface=NET-2 new-connection-mark=ether2_conn \
        passthrough=yes
    add action=mark-connection chain=input comment="" connection-state=new \
        disabled=no in-interface=NET-3 new-connection-mark=ether3_conn \
        passthrough=yes
    add action=mark-routing chain=output comment="" connection-mark=ether1_conn \
        connection-state=new disabled=no new-routing-mark=to_ether1 passthrough=\
        no
    add action=mark-routing chain=output comment="" connection-mark=ether2_conn \
        connection-state=new disabled=no new-routing-mark=to_ether2 passthrough=\
        no
    add action=mark-routing chain=output comment="" connection-mark=ether3_conn \
        connection-state=new disabled=no new-routing-mark=to_ether3 passthrough=\
        no
    add action=mark-connection chain=prerouting comment="" disabled=no \
        dst-address-type=!local in-interface=OUT new-connection-mark=ether1_conn \
        passthrough=yes per-connection-classifier=both-addresses-and-ports:6/0
    add action=mark-connection chain=prerouting comment="" disabled=no \
        dst-address-type=!local in-interface=OUT new-connection-mark=ether3_conn \
        passthrough=yes per-connection-classifier=both-addresses-and-ports:6/1
    add action=mark-connection chain=prerouting comment="" disabled=no \
        dst-address-type=!local in-interface=OUT new-connection-mark=ether3_conn \
        passthrough=yes per-connection-classifier=both-addresses-and-ports:6/2
    add action=mark-connection chain=prerouting comment="" disabled=no \
        dst-address-type=!local in-interface=OUT new-connection-mark=ether2_conn \
        passthrough=yes per-connection-classifier=both-addresses-and-ports:6/3
    add action=mark-connection chain=prerouting comment="" disabled=no \
        dst-address-type=!local in-interface=OUT new-connection-mark=ether2_conn \
        passthrough=yes per-connection-classifier=both-addresses-and-ports:6/4
    add action=mark-connection chain=prerouting comment="" disabled=no \
        dst-address-type=!local in-interface=OUT new-connection-mark=ether2_conn \
        passthrough=yes per-connection-classifier=both-addresses-and-ports:6/5
    add action=mark-routing chain=prerouting comment="" connection-mark=\
        ether1_conn disabled=no in-interface=OUT new-routing-mark=to_ether1 \
        passthrough=no
    add action=mark-routing chain=prerouting comment="" connection-mark=\
        ether2_conn disabled=no in-interface=OUT new-routing-mark=to_ether2 \
        passthrough=no
    add action=mark-routing chain=prerouting comment="" connection-mark=\
        ether3_conn disabled=no in-interface=OUT new-routing-mark=to_ether3 \
        passthrough=no

    Regra que recebe a net do MK-Balance e passar pro servidor web

    Código :
    add action=masquerade chain=srcnat comment=Mascara disabled=no out-interface=\
        LINK
    add action=masquerade chain=srcnat comment=Mascara_Ubuntu disabled=yes \
        src-address=172.31.255.0/30
    add action=dst-nat chain=dstnat comment="Redirect_Site " disabled=no \
        dst-port=80 in-interface=LINK protocol=tcp to-addresses=172.31.255.2 \
        to-ports=80

  18. #178

    Padrão

    Faz o seguinte:

    coloca seu servidor web para usar a internet diretamente do loadbalaced pcc.

    vamos imagina o seguinte cenario:
    SERVIDOR_WEB IP: 10.1.1.2
    SERVIDOR_PCC IP: 10.1.1.1

    em /ip firewall mangle vamos forçar a seu servidor WEB a utilzar a internet apenas do seu link com IP VALIDO "dedicado", e não passar pelo loadbalced.
    Não esqueça de colocar esta regra do mangle acima de todas.
    regra:
    /ip fiewall mangle
    add action=mark-routing chain=prerouting comment="SERVIDOR WEB" disabled=no new-routing-mark=SERVIDOR_WEB passthrough=no src-address=10.1.1.2

    logo vamos utilzar esta marcação na tebale de roteamento.
    regra:
    /ip route
    add comment="SERVIDOR WEB" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=SEU_GW_DO_IP_VALIDO routing-mark=SERVIDOR_WEB scope=30 target-scope=10

    tinha esquecido de colocar o redirecionamento

    /ip firewall nat
    add action=dst-nat chain=dstnat comment="SERVIDOR WEB" disabled=no dst-address=SEU_IP_VALIDO dst-port=80 protocol=tcp to-addresses=\
    10.1.1.2 to-ports=80


    com isso, vc esta forçando seu servidor web a utilzar apenas o link dedicao, vc pode ir em queue simples e coloca um controle de banda neste servidor cajo queira.

    Teste e nos comunique como que ficou.

    abraços
    Última edição por tiagomatias; 02-10-2009 às 11:16.



  19. #179

    Padrão

    Citação Postado originalmente por tiagomatias Ver Post
    Faz o seguinte:

    coloca seu servidor web para usar a internet diretamente do loadbalaced pcc.

    vamos imagina o seguinte cenario:
    SERVIDOR_WEB IP: 10.1.1.2
    SERVIDOR_PCC IP: 10.1.1.1

    em /ip firewall mangle vamos forçar a seu servidor WEB a utilzar a internet apenas do seu link com IP VALIDO "dedicado", e não passar pelo loadbalced.
    Não esqueça de colocar esta regra do mangle acima de todas.
    regra:
    /ip fiewall mangle
    add action=mark-routing chain=prerouting comment="SERVIDOR WEB" disabled=no new-routing-mark=SERVIDOR_WEB passthrough=no src-address=10.1.1.2

    logo vamos utilzar esta marcação na tebale de roteamento.
    regra:
    /ip route
    add comment="SERVIDOR WEB" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=SEU_GW_DO_IP_VALIDO routing-mark=SERVIDOR_WEB scope=30 target-scope=10

    tinha esquecido de colocar o redirecionamento

    /ip firewall nat
    add action=dst-nat chain=dstnat comment="SERVIDOR WEB" disabled=no dst-address=SEU_IP_VALIDO dst-port=80 protocol=tcp to-addresses=\
    10.1.1.2 to-ports=80


    com isso, vc esta forçando seu servidor web a utilzar apenas o link dedicao, vc pode ir em queue simples e coloca um controle de banda neste servidor cajo queira.

    Teste e nos comunique como que ficou.

    abraços
    Como faço esse roteamento, pois tenho o MK-Load e MK-Controlador onde o servidor web esta ligado.
    Ex. Load = ip 172.168.0.1 <--> ip 172.168.0.2 Controlador ip 172.31.255.1 <--> Servidor web + Cache = ip 172.31.255.2

  20. #180

    Padrão

    Citação Postado originalmente por rogeriodj Ver Post
    Como faço esse roteamento, pois tenho o MK-Load e MK-Controlador onde o servidor web esta ligado.
    Ex. Load = ip 172.168.0.1 <--> ip 172.168.0.2 Controlador ip 172.31.255.1 <--> Servidor web + Cache = ip 172.31.255.2
    Trie de traz do MK-Controlador e coloque ele a usar a internet do Mikrotik-Load

    existe varias formas de fazer isso, mas esta é a mais simples para vc resolver logo.
    Última edição por tiagomatias; 02-10-2009 às 12:44.