+ Responder ao Tópico



  1. #1

    Padrão Limitando tamanho de downloads

    Pessoal, sou novo em MK, portanto, gostaria da ajuda de vocês. Existe um cliente em minha rede que só vive fazendo download, a máquina do cara passa dias ligada. Queria saber se teria como limitar o tamanho dos downloads, por exemplo, uma cota de 500MB por dia, coisa assim, isso apenas pro down, mas que a navegação continuasse normal. Uso Mikrotik para gerenciar v3.24, e cliente conectado através de pppoe. Espero que possam me ajudar.

  2. #2
    xargs -n 1 kill -9 Avatar de sergio
    Ingresso
    Jan 2004
    Localização
    Capital do Triângulo
    Posts
    5.202
    Posts de Blog
    9

    Padrão

    Se não for pedir muito, faça uma pesquisa nos foruns que essa solução já foi postada anteriormente.



  3. #3

    Padrão

    Citação Postado originalmente por sergio Ver Post
    Se não for pedir muito, faça uma pesquisa nos foruns que essa solução já foi postada anteriormente.
    pesquisei sim, vi o post lo abaixo do amigo CATV, mas mesmo assim não consegui aplicar. Como cada caso é diferente, se não fosse pedir muito, por ser novato tem algumas coisas que não consigo entender.

  4. #4
    xargs -n 1 kill -9 Avatar de sergio
    Ingresso
    Jan 2004
    Localização
    Capital do Triângulo
    Posts
    5.202
    Posts de Blog
    9

    Padrão

    Agora sim, estamos começando a nos entender... disse que já pesquisou e viu o referido post. Para completar só falta detalhar suas configurações e dizer as tentativas utilizadas, usando como exemplo o post o David e ficará mais simples ainda.



  5. #5

    Padrão

    Estou utilizando mikotik v3.24 com autenticação dos clientes via pppoe.
    Utilizei o seguinte exemplo:

    /ip firewall filter
    add chain=forward protocol=tcp dst-port=80 connection-bytes=0-500000 \
    action=accept comment="" disabled=no

  6. #6
    xargs -n 1 kill -9 Avatar de sergio
    Ingresso
    Jan 2004
    Localização
    Capital do Triângulo
    Posts
    5.202
    Posts de Blog
    9

    Padrão

    existe algum bridge?



  7. #7

    Padrão

    Citação Postado originalmente por sergio Ver Post
    existe algum bridge?
    Não. Desculpa é q sou meio leigo no assunto ainda.

  8. #8
    xargs -n 1 kill -9 Avatar de sergio
    Ingresso
    Jan 2004
    Localização
    Capital do Triângulo
    Posts
    5.202
    Posts de Blog
    9

    Padrão

    Veja no tópico do catv novamente. Notará que existe um DROP e não accept.

    Limitando o tamanho de download (dropando ou aceitando) - CATVBRASIL



  9. #9

    Padrão

    Obrigado Sérgio, irei dar uma olhada mais atentamente, talvez tenha feito ou visto alguma coisa que não devia.

  10. #10
    xargs -n 1 kill -9 Avatar de sergio
    Ingresso
    Jan 2004
    Localização
    Capital do Triângulo
    Posts
    5.202
    Posts de Blog
    9

    Padrão

    veja

    Citação Postado originalmente por catv
    Funciona assim:

    0 (zero no início) = apartir de (0-500000 = apartir de 0k até 500k)
    0 (zero no final) = infinito (500000-0 = apartir de 500k para cima)

    Vamos supor que desejamos aceitar conexões com no máximo 500k, ficaria assim:

    /ip firewall filter
    add chain=forward protocol=tcp dst-port=80 connection-bytes=0-500000 \
    action=accept comment="" disabled=no

    Vamos supor que desejamos rejeitar todas as outras conexões acima de 500k, ficaria assim:

    /ip firewall filter
    add chain=forward protocol=tcp dst-port=80 content="" \
    connection-bytes=50000-0 src-address-list=no_download \
    action=drop comment="" disabled=no