Página 2 de 3 PrimeiroPrimeiro 123 ÚltimoÚltimo
+ Responder ao Tópico



  1. #21

    Padrão Resposta de cache

    Não amigo!
    O Mikrotik só faz a parte de controle de banda e apenas joga tudo para o Debian que só apenas faz a função de obedecer o Mikrotik nas diretrizes de cachear...
    t++++

  2. #22

    Padrão

    Muito boa sua contribuição Thiago,

    Eu atualmente estou usando o proxy do mikrotik mesmo, porq uso pc ap, porém estou precisando urgente montar um proxy em pararelo, estou pensando em testar a sua contribuição, porém pretendo também colocar um servidor web na maquina linux com ispconfig, gostaria de saber se é possivel isso ??

    Estou mais aconstumado com o linux CentOS, será que muda muito a config se fosse pra fazer esse proxy pararelo com CentOS ??



  3. #23

    Padrão res:

    Amigo não muito, ja que é so pra proxy paralelo vc não precisa fazer firewall, se faz no Mikrotik.
    Basta adaptar as regras aí para o teu OS e tudo vai dar certo.
    ahhhh lembrando a questão do server de web, eu não acho uma boa idéia não amigo, é mais interessante tu fazer em paralelo aos SERVERS aí.

  4. #24

    Padrão

    Citação Postado originalmente por gleitao Ver Post
    Thiago, tb é feito cache no Mikrotik ou só no Debian?
    caso nos dois seria sempre bom limpar o cache do Mk?

    Caso eu desabilite o web-proxy do MK e deixe apenas no Debian, tem algum problema?

    eu percebi que o MK está consumindo memoria!



  5. #25

    Padrão resposta

    não amigo, más no squid do Debian tem que ta abilitado o tranparente proxy e criar uma rota no MK e fazer marcação da porta 80 para ela. E outra esquece de cache full...

  6. #26

    Padrão

    Ei pow Thiagão, tu vai endoidar o povão aqui heim!!!!



  7. #27

    Padrão Pergunta Tiagoooooo

    Caro Tiago estou com uma dúvida???

    Montei como vc ensinou no tutorial que por sinal funcionou perfeitamente.

    Segui ao pé da letra e foi 10.

    Mas minha dúvida é a seguinte:

    Se eu der uma tracert em um endereço ele me mostra a rota do link, mas se eu entrar em um site para me mostrar como o www.meuip.com.br ele me mostra a rota da adsl no caso utilizando a porta 80 do redirecionamento do servidor de cache que sai pela adsl.

    Como fazer alguns domínios ou destinos sairem pelo link mesmo utilizando o redirecionamento da porta 80 para o cache.



    Ivan Galves

  8. #28

    Padrão tracert

    Não tem como redirecionar amigo, por conta do tracert ser um comando que permite descobrir o caminho feito pelos pacotes desde a sua origem até o seu destino que usa a porta 33434UDP, e não um "serviço".
    Sempre vai disparar para a rota default ja que o comando parte do cliente.
    t++++++++++++++
    Última edição por thiagogenesis; 28-10-2009 às 14:17.



  9. #29

    Padrão Pergunta

    Thiago, na configuração vc colocou um modem em bridge... só que no meu caso vou ter que add outro velox... e tenho um load balance da d-link para isso, como faço para usar o debian com esse roteador no lugar do modem em bridge?

    desde já agradeço a força... e sei que to te enchendo o saco! rsrsrs

  10. #30

    Padrão LB da d-link res:

    Simples, la no script do firewall tu deleta as duas ultimas linhas, que serve para deletar uma rota e add uma nova, trocando por essa (route add default gw ip-do-d-link-LB). E não instala o pacote ppp e pppoeconf. t++++++++++



  11. #31

    Padrão

    Thiago fiz como vc colocou ai, quando rodo o script

    ele apresenta SIOCADDRT A rede está fora de alcance

    o meu lb604 esta com o servidor dhcp ativo.


    tem uma varivél que vc criou no inicio do script = WAN_NIC=ppp0


    cara, to enrrolado.

  12. #32

    Padrão WAN_NIC=ppp0

    Então amigo!
    Em WAN_NIC=ppp0 a sigla ppp0 significa a interface do link que no teu caso seria: eth0/eth1 ou eth2...
    Bom troque só isso aí e manda bala.



  13. #33

    Padrão

    Citação Postado originalmente por thiagogenesis Ver Post
    Então amigo!
    Em WAN_NIC=ppp0 a sigla ppp0 significa a interface do link que no teu caso seria: eth0/eth1 ou eth2...
    Bom troque só isso aí e manda bala.

    Valeu Thiago, ta funcionando legal.

    Muito obg.

  14. #34

    Padrão

    thiagogenesis

    Blz Amigo

    Meu provedor tenho um AP-PC funcionando com um controle P2P, Limite de Conexões e Hotspot com uma adsl de 1MB e 30 clientes ate ai esta otimo.

    Mais estou pensando em melhor e se post é muito interessante.
    Tenho um Debian instalado Numa intel Dg31+ core2duo 7400 com 2ram

    Gostaria apenas de uma orientação na substituição do link dedicado por adsl de preferencia em bridge se preciso fazer alguma alteração nesta linhas da nat na configuração do adsl:
    /ip firewall nat

    add action=accept chain=dstnat comment="passa fora do proxy CONECTIVA" disabled=no dst-address=200.201.160.0/24
    add action=accept chain=dstnat comment="" disabled=no dst-address=200.201.173.0/24
    add action=accept chain=dstnat comment="" disabled=no dst-address=200.201.166.0/24
    add action=accept chain=dstnat comment="" disabled=no dst-address=200.201.174.0/24
    add action=accept chain=dstnat comment="passa fora do proxy RADIO-UOL" disabled=no dst-address=200.221.8.0/24
    add action=masquerade chain=srcnat comment="Nat Full" disabled=no
    add action=redirect chain=dstnat comment="redirecionamento para o proxy" disabled=no dst-port=80 protocol=tcp src-address=\
    192.168.0.0/24 to-ports=8080

    e no DNS do eth0 do Debian

    dns-nameservers 200.175.182.139
    dns-search 200.175.5.139

    estas linhas tenho que colocor as da operadora daqui de neste caso seria 200.165.132.154/200.165.132.148

    desde ja obrigado.




  15. #35

    Padrão Troca do link dedicado por adsl

    Não amigo no máximo você vai trocar apenas o dns e cria um discador pppoe para o modem.
    É muito interessante você seta o DNS de tua operadora.
    Bom é isso aí, boa sorte...

  16. #36

    Padrão

    Tiago

    Fiz como você orientou mais não funfou

    eu acredito que o erro foi no Debian
    eu add o comando

    mcedit /etc/init.d/bootmisc.sh
    e coloquei na primeira linha
    ifconfig eth1 180.33.1.1 netmask 255.255.255.0 up

    mais quando digitei no terminal ifconfig não tem o endereço atribuido no eth1

    tentei editar manualmente, mais o MK não conversou com o debian

    se poder dar uma luz, agradeço... meu msn é [email protected]
    Última edição por ferreiraa; 26-12-2009 às 03:41.



  17. #37

    Padrão placa de rede

    é amigo pelo que você ta me dizendo, pode ser a placa de rede que não foi reconhecida pelo Debian.
    Rode o comando lsmod, os módulos de placas rede ethernet comuns são 8139too, via-rhine, sis900 e rtl8139. Se não aparecerem na saída do lsmod aí em cima, podem ter sido carregados como drivers <*> junto com o kernel, ou podem não estar disponíveis os módulos corretos.
    Rode os comandos lspci, lsmod e ifconfig, e tenha certeza que a placa foi reconhecida.
    t+++++++

  18. #38

    Exclamation

    Homem não sei o que pode estar acontecendo

    lspci
    01:00.0 Ethernet controller: Attansic Technology Corp. L2 100 Mbit Ethernet Adapter (rev a0)
    02:01.0 Ethernet controller: Winbond Electronics Corp W89C840

    Comando executado:

    mcedit /etc/init.d/bootmisc.sh

    na primeira linha

    ifconfig eth1 180.33.1.1 netmask 255.255.255.0 up

    mais ainda não atribuiu. help

    fui via terminal e add direto implantei as regras no mk, mais não funcionou.
    naveguei mais apenas pelo link do MK


    Miniaturas de Anexos Miniaturas de Anexos Clique na imagem para uma versão maior

Nome:	         Captura_da_tela.png
Visualizações:	117
Tamanho: 	152,5 KB
ID:      	6391  
    Última edição por ferreiraa; 01-01-2010 às 13:25.



  19. #39

    Padrão

    Thiago oi

    Eu preciso que o servidor debian com squid, também instalado o Thundercache3.
    É possível fazer isso, você deve alterar as linhas no tutorial que você escreveu?
    O Thundercache foi configurado com um script desenhado por Luciano Rapanelli.

    Espero a vossa ajuda, obrigado

    OSVALDO
    ARGENTINA
    * Traduzido com o google tradutor

  20. #40

    Padrão

    caro amigo insanet,
    apenas muda as config do teu arquivo "squid.conf"...
    Aqui vai um exemplo:

    http_port 177.1.1.2:5128 transparent
    cache_mem 400 MB
    cache_swap_low 80
    cache_swap_high 85
    maximum_object_size 80 MB
    maximum_object_size_in_memory 256 KB
    cache_dir ufs /var/spool/squid 30000 16 256
    access_log /var/log/squid/access.log squid
    acl all src all
    acl manager proto cache_object
    acl localhost src 127.0.0.1/32
    acl to_localhost dst 127.0.0.0/8
    acl localnet src 10.0.0.0/8 # RFC1918 possible internal network
    acl localnet src 172.16.0.0/12 # RFC1918 possible internal network
    acl localnet src 177.1.1.0/24 # RFC1918 possible internal network
    acl SSL_ports port 443 # https
    acl SSL_ports port 563 # snews
    acl SSL_ports port 873 # rsync
    acl Safe_ports port 80 # http
    acl Safe_ports port 21 # ftp
    acl Safe_ports port 443 # https
    acl Safe_ports port 70 # gopher
    acl Safe_ports port 210 # wais
    acl Safe_ports port 1025-65535 # unregistered ports
    acl Safe_ports port 280 # http-mgmt
    acl Safe_ports port 488 # gss-http
    acl Safe_ports port 591 # filemaker
    acl Safe_ports port 777 # multiling http
    acl Safe_ports port 631 # cups
    acl Safe_ports port 873 # rsync
    acl Safe_ports port 901 # SWAT
    acl purge method PURGE
    acl CONNECT method CONNECT
    http_access allow manager localhost
    http_access deny manager
    http_access allow purge localhost
    http_access deny purge
    http_access deny !Safe_ports
    http_access deny CONNECT !SSL_ports
    http_access allow localnet
    http_access deny all
    icp_access allow localnet
    icp_access deny all
    #hierarchy_stoplist cgi-bin ?
    access_log /var/log/squid/access.log squid
    refresh_pattern ^ftp: 1440 20% 10080
    refresh_pattern ^gopher: 1440 0% 1440
    refresh_pattern -i (/cgi-bin/|\?) 0 0% 0
    refresh_pattern (Release|Package(.gz)*)$ 0 20% 2880
    refresh_pattern . 0 20% 4320
    acl shoutcast rep_header X-HTTP09-First-Line ^ICY\s[0-9]
    upgrade_http0.9 deny shoutcast
    acl apache rep_header Server ^Apache
    broken_vary_encoding allow apache
    extension_methods REPORT MERGE MKACTIVITY CHECKOUT
    hosts_file /etc/hosts
    coredump_dir /var/spool/squid

    # regras para redirecionar para o thunder
    acl thunder_lst url_regex -i "/etc/thunder/thunder.lst"
    cache deny thunder_lst
    cache_peer 177.1.1.2 parent 8080 0 proxy-only no-digest
    dead_peer_timeout 2 seconds
    cache_peer_access 177.1.1.2 allow thunder_lst
    cache_peer_access 177.1.1.2 deny all

    ## Bloquear o cache local
    acl servercache dstdomain 177.1.1.2
    acl sites_sem_cache dstdomain -i "/etc/thunder/thunder.lst"
    always_direct allow sites_sem_cache
    cache deny sites_sem_cache
    cache deny servercache
    server_persistent_connections off


    Pronto agora so mudar as faixa de redes, e seta para trabalhar com as tuas aí.
    Lembrando eu uso o squid não o squid3 por questão de configurações mesmo e não por estabilidade...
    GoooooooooooooD Luuuuuuuuuuck