+ Responder ao Tópico



  1. #1

    Padrão Clientes em Débito??? Veja aqui uma forma de Bloquea-los!!!

    Bora la galera!

    Quem é que em seu provedor não tem aqueles clientes que desde que assinou a internet só paga a mesma quando é suspenso os serviços?
    Seria muito simples você ir la e desabilitar a autenticação dele! Só que quando o folgado for navegar ira ser exibida "Página não encontrada" ai o mesmo ira lhe procurar/ligar dizendo que a internet "CAIU"!!!

    "Dai-nos paciência"

    Cenário testado:

    Autenticação: PPPoE
    Versão: 3.13 e 3.22
    Servidor Web: Apache (Instalado no proxy Debian/Ubuntu)

    Vamos ao que interessa...

    /ip firewall filter

    add action=accept chain=forward comment="Bloqueio de usuarios por falta de pagamento.Suspensao" disabled=no dst-port=81 protocol=tcp src-address-list=\
    Bloqueio-Debito-Suspensao
    add action=accept chain=forward comment="" disabled=no dst-port=53 protocol=udp src-address-list=Bloqueio-Debito-Suspensao
    add action=drop chain=forward comment="" disabled=no src-address-list=Bloqueio-Debito-Suspensao

    /ip firewall nat

    add action=masquerade chain=srcnat comment="Redirecionamento para pagina de aviso" disabled=no src-address=192.160.1.0/24
    add action=same chain=dstnat comment="Controle de clientes por falta de pagamento.Debito 15 dias de atraso" disabled=no dst-port=80 protocol=tcp \
    same-not-by-dst=no src-address-list=Bloqueio-Debito to-addresses=192.168.10.2 to-ports=81

    - Onde esta em verde:
    Faixa de ip da sua rede

    - Onde esta em vermelho:
    Ip da maquina onde esta hospedada a página (Nesse caso,em nosso proxy)

    Obs.: As regras de nat,procure deixa-las logo abaixo da regra de nat da internet.

    /ip firewall address-list

    Name: Bloqueio-Debito-Suspensao (Nome atribuido no src-address-list)
    Address: 000.000.000.000 (Ip do cliente que será bloqueado)

    Explicando...

    Em seu proxy faça o seguinte:

    Va até /etc/apache2/ports.conf
    Abra e sera exibida as seguintes linhas:

    # If you just change the port or add more ports here, you will likely also
    # have to change the VirtualHost statement in
    # /etc/apache2/sites-enabled/000-default
    # This is also true if you have upgraded from before 2.2.9-3 (i.e. from
    # Debian etch). See /usr/share/doc/apache2.2-common/NEWS.Debian.gz and
    # README.Debian.gz
    NameVirtualHost *:80
    Listen 80
    <IfModule mod_ssl.c>
    # SSL name based virtual hosts are not yet supported, therefore no
    # NameVirtualHost statement here
    Listen 443
    </IfModule>
    Listen 81 # Esse Listen 81 sera adicionado por você!

    Salve e feche...

    Obs.: Para quem instalou o proxy + thunder através do script,não será necessário esse procedimento!Pois ja vai estar feito...

    Próxima etapa:

    Va até /etc/apache2/apache2.conf
    Abra e la no final acresente a seguinte linha:

    ServerName teste.com (nome do seu provedor ou como preferir)

    Obs.: Para quem instalou o proxy + thunder através do script,será necessário alterar a linha "ServerName conprove" para "ServerName teste.com"

    Próximo passo:

    Va até /etc/apache2/sites-enabled/000-default
    Abra e sera exibida as seguintes linhas:

    <VirtualHost *:80>
    ServerAdmin [email protected]
    DocumentRoot /var/www/
    <Directory />
    Options FollowSymLinks
    AllowOverride None
    </Directory>
    <Directory /var/www/>
    Options Indexes FollowSymLinks MultiViews
    AllowOverride None
    Order allow,deny
    allow from all
    </Directory>
    ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
    <Directory "/usr/lib/cgi-bin">
    AllowOverride None
    Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
    Order allow,deny
    Allow from all
    </Directory>
    ErrorLog /var/log/apache2/error.log
    # Possible values include: debug, info, notice, warn, error, crit,
    # alert, emerg.
    LogLevel warn
    CustomLog /var/log/apache2/access.log combined
    Alias /doc/ "/usr/share/doc/"
    <Directory "/usr/share/doc/">
    Options Indexes MultiViews FollowSymLinks
    AllowOverride None
    Order deny,allow
    Deny from all
    Allow from 127.0.0.0/255.0.0.0 ::1/128
    </Directory>
    </VirtualHost>
    <VirtualHost 192.168.10.2:81> # Aqui é o ip do seu proxy e a porta onde estara a página.
    ServerName aviso.teste.com # Aqui é seu sub-dominio.
    DocumentRoot /var/www/teste/aviso/ # Aqui é sua pasta onde colocara a página.
    </VirtualHost>

    Obs.: Para quem instalou o proxy + thunder através do script,será necessário alterar:
    O endereço de ip,caso necessite.
    O nome do sub-dominio,caso necessite.
    O none/caminho da pasta do diretório,caso necessite.

    Continuando...

    Agora vá em /var/www e crie a pasta/diretório com o caminho de acordo que esta no DocumentRoot.

    Ficará assim: /var/www/teste/aviso , dentro desta pasta "aviso" você pôe sua página que sera mostrada aos clientes que estiverem bloqueados no /ip firewall address-list.
    Última edição por BillGates; 15-09-2009 às 09:53.

  2. #2

    Padrão show

    pow cara responsa mesmo vou testar logo embreve,na minha rede tem uma porção de inadiplentes,mais no meu caso eu trabalho com amarração de mac,ip,não trabalho com hotspot,nem com proxy cache,vou tentar á sorte e montar já que está tudo aí só não faz quem não quer mesmo vwl!



  3. #3

  4. #4

    Padrão

    Citação Postado originalmente por BillGates Ver Post
    Bora la galera!

    Quem é que em seu provedor não tem aqueles clientes que desde que assinou a internet só paga a mesma quando é suspenso os serviços?
    Seria muito simples você ir la e desabilitar a autenticação dele! Só que quando o folgado for navegar ira ser exibida "Página não encontrada" ai o mesmo ira lhe procurar/ligar dizendo que a internet "CAIU"!!!

    "Dai-nos paciência"

    Cenário testado:

    Autenticação: PPPoE
    Versão: 3.13 e 3.22
    Servidor Web: Apache (Instalado no proxy Debian/Ubuntu)

    Vamos ao que interessa...

    /ip firewall filter

    add action=accept chain=forward comment="Bloqueio de usuarios por falta de pagamento.Suspensao" disabled=no dst-port=81 protocol=tcp src-address-list=\
    Bloqueio-Debito-Suspensao
    add action=accept chain=forward comment="" disabled=no dst-port=53 protocol=udp src-address-list=Bloqueio-Debito-Suspensao
    add action=drop chain=forward comment="" disabled=no src-address-list=Bloqueio-Debito-Suspensao

    /ip firewall nat

    add action=masquerade chain=srcnat comment="Redirecionamento para pagina de aviso" disabled=no src-address=192.160.1.0/24
    add action=same chain=dstnat comment="Controle de clientes por falta de pagamento.Debito 15 dias de atraso" disabled=no dst-port=80 protocol=tcp \
    same-not-by-dst=no src-address-list=Bloqueio-Debito to-addresses=192.168.10.2 to-ports=81

    - Onde esta em verde:
    Faixa de ip da sua rede

    - Onde esta em vermelho:
    Ip da maquina onde esta hospedada a página (Nesse caso,em nosso proxy)

    Obs.: As regras de nat,procure deixa-las logo abaixo da regra de nat da internet.

    /ip firewall address-list

    Name: Bloqueio-Debito-Suspensao (Nome atribuido no src-address-list)
    Address: 000.000.000.000 (Ip do cliente que será bloqueado)

    Explicando...

    Em seu proxy faça o seguinte:

    Va até /etc/apache2/ports.conf
    Abra e sera exibida as seguintes linhas:

    # If you just change the port or add more ports here, you will likely also
    # have to change the VirtualHost statement in
    # /etc/apache2/sites-enabled/000-default
    # This is also true if you have upgraded from before 2.2.9-3 (i.e. from
    # Debian etch). See /usr/share/doc/apache2.2-common/NEWS.Debian.gz and
    # README.Debian.gz
    NameVirtualHost *:80
    Listen 80
    <IfModule mod_ssl.c>
    # SSL name based virtual hosts are not yet supported, therefore no
    # NameVirtualHost statement here
    Listen 443
    </IfModule>
    Listen 81 # Esse Listen 81 sera adicionado por você!

    Salve e feche...

    Obs.: Para quem instalou o proxy + thunder através do script,não será necessário esse procedimento!Pois ja vai estar feito...

    Próxima etapa:

    Va até /etc/apache2/apache2.conf
    Abra e la no final acresente a seguinte linha:

    ServerName teste.com (nome do seu provedor ou como preferir)

    Obs.: Para quem instalou o proxy + thunder através do script,será necessário alterar a linha "ServerName conprove" para "ServerName teste.com"

    Próximo passo:

    Va até /etc/apache2/sites-enabled/000-default
    Abra e sera exibida as seguintes linhas:

    <VirtualHost *:80>
    ServerAdmin [email protected]
    DocumentRoot /var/www/
    <Directory />
    Options FollowSymLinks
    AllowOverride None
    </Directory>
    <Directory /var/www/>
    Options Indexes FollowSymLinks MultiViews
    AllowOverride None
    Order allow,deny
    allow from all
    </Directory>
    ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
    <Directory "/usr/lib/cgi-bin">
    AllowOverride None
    Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
    Order allow,deny
    Allow from all
    </Directory>
    ErrorLog /var/log/apache2/error.log
    # Possible values include: debug, info, notice, warn, error, crit,
    # alert, emerg.
    LogLevel warn
    CustomLog /var/log/apache2/access.log combined
    Alias /doc/ "/usr/share/doc/"
    <Directory "/usr/share/doc/">
    Options Indexes MultiViews FollowSymLinks
    AllowOverride None
    Order deny,allow
    Deny from all
    Allow from 127.0.0.0/255.0.0.0 ::1/128
    </Directory>
    </VirtualHost>
    <VirtualHost 192.168.10.2:81> # Aqui é o ip do seu proxy e a porta onde estara a página.
    ServerName aviso.teste.com # Aqui é seu sub-dominio.
    DocumentRoot /var/www/teste/aviso/ # Aqui é sua pasta onde colocara a página.
    </VirtualHost>

    Obs.: Para quem instalou o proxy + thunder através do script,será necessário alterar:
    O endereço de ip,caso necessite.
    O nome do sub-dominio,caso necessite.
    O none/caminho da pasta do diretório,caso necessite.

    Continuando...

    Agora vá em /var/www e crie a pasta/diretório com o caminho de acordo que esta no DocumentRoot.

    Ficará assim: /var/www/teste/aviso , dentro desta pasta "aviso" você pôe sua página que sera mostrada aos clientes que estiverem bloqueados no /ip firewall address-list.




    Boa Noite Amigo, gostaria de saber se funcionaria no seguinte Cenário:

    Meu mk ta como ap-brideg faço tudo no debian (dhcp+proxy+cbq+firewall). o mk só distribui

    obrigado!



  5. #5

    Padrão

    parabéns...tá show cara....
    tá faltando agora um tuto de como gerar relatórios de uso dos clientes...ex: webmin, etc...
    lembrem-se q é algo importante já q todo provedor deve possuir um arquivo mês a mês....

  6. #6

    Padrão

    Citação Postado originalmente por allan3000 Ver Post
    Boa Noite Amigo, gostaria de saber se funcionaria no seguinte Cenário:

    Meu mk ta como ap-brideg faço tudo no debian (dhcp+proxy+cbq+firewall). o mk só distribui

    obrigado!
    Numca testei dessa forma colega,então passo a bola para os colegas que souberem te dizer...



  7. #7

    Padrão

    Citação Postado originalmente por ceusbar Ver Post
    parabéns...tá show cara....
    tá faltando agora um tuto de como gerar relatórios de uso dos clientes...ex: webmin, etc...
    lembrem-se q é algo importante já q todo provedor deve possuir um arquivo mês a mês....
    rs, é verdade... um dos meus proximos passos sera esse,ja tenho algo aqui em testes... quando estiver 100% testado,vem pro under ...

  8. #8

    Padrão

    precisar de ajudas Bill, estamos ae.Tenho um cenario interessante para podermos testar.Abraços.



  9. #9

    Padrão

    em ip>firewall>nat............essa regra não funciona, fica zerada e não ocorre o direcionamento no bloqueio. Já alterei os respectivos ips.
    mas qdo digito no browser ip : porta onde está a página hospedada vai tranquilo...

    add action=same chain=dstnat comment="Controle de clientes por falta de pagamento.Debito 15 dias de atraso" disabled=no dst-port=80 protocol=tcp \
    same-not-by-dst=no src-address-list=Bloqueio-Debito to-addresses=192.168.10.2 to-ports=81

  10. #10

    Padrão

    eu to bloqueando assim-> add chain=dstnat src-address=192.168.110.212 protocol=tcp action=dst-nat to-addresses=192.168.110.99 to-ports=0-65535 comment="BLOQUEIO - Maria Ferreira" disabled=no
    a situaçõaaqui eh servidor-mkt amarrando mac ao ip + queue....

    Mas da um certo trabalho na hora de digamos bloquearou desbloquear 50 clientes.....

    Tem como fazer apenas uma vez e depois ir soh adcionando ou retirando os ips de um arquivo tipo txt ?

    Ah outra coisaso ip que todirecionando eh pruma maquininha fuleira(configurada como um cliente normal mesmo) com o sambar server instalado... ta soh com a index do bloqueio mesmo, e ta funcionando. ...rs



  11. #11
    Avatar de Oldayr
    Ingresso
    Mar 2009
    Localização
    Rio de Janeiro, Rio de Janeiro, Brazil
    Posts
    300

    Padrão

    Citação Postado originalmente por BillGates Ver Post
    Bora la galera!

    Quem é que em seu provedor não tem aqueles clientes que desde que assinou a internet só paga a mesma quando é suspenso os serviços?
    Seria muito simples você ir la e desabilitar a autenticação dele! Só que quando o folgado for navegar ira ser exibida "Página não encontrada" ai o mesmo ira lhe procurar/ligar dizendo que a internet "CAIU"!!!

    "Dai-nos paciência"

    Cenário testado:

    Autenticação: PPPoE
    Versão: 3.13 e 3.22
    Servidor Web: Apache (Instalado no proxy Debian/Ubuntu)

    Vamos ao que interessa...

    /ip firewall filter

    add action=accept chain=forward comment="Bloqueio de usuarios por falta de pagamento.Suspensao" disabled=no dst-port=81 protocol=tcp src-address-list=\
    Bloqueio-Debito-Suspensao
    add action=accept chain=forward comment="" disabled=no dst-port=53 protocol=udp src-address-list=Bloqueio-Debito-Suspensao
    add action=drop chain=forward comment="" disabled=no src-address-list=Bloqueio-Debito-Suspensao

    /ip firewall nat

    add action=masquerade chain=srcnat comment="Redirecionamento para pagina de aviso" disabled=no src-address=192.160.1.0/24
    add action=same chain=dstnat comment="Controle de clientes por falta de pagamento.Debito 15 dias de atraso" disabled=no dst-port=80 protocol=tcp \
    same-not-by-dst=no src-address-list=Bloqueio-Debito to-addresses=192.168.10.2 to-ports=81

    - Onde esta em verde:
    Faixa de ip da sua rede

    - Onde esta em vermelho:
    Ip da maquina onde esta hospedada a página (Nesse caso,em nosso proxy)

    Obs.: As regras de nat,procure deixa-las logo abaixo da regra de nat da internet.

    /ip firewall address-list

    Name: Bloqueio-Debito-Suspensao (Nome atribuido no src-address-list)
    Address: 000.000.000.000 (Ip do cliente que será bloqueado)

    Explicando...

    Em seu proxy faça o seguinte:

    Va até /etc/apache2/ports.conf
    Abra e sera exibida as seguintes linhas:

    # If you just change the port or add more ports here, you will likely also
    # have to change the VirtualHost statement in
    # /etc/apache2/sites-enabled/000-default
    # This is also true if you have upgraded from before 2.2.9-3 (i.e. from
    # Debian etch). See /usr/share/doc/apache2.2-common/NEWS.Debian.gz and
    # README.Debian.gz
    NameVirtualHost *:80
    Listen 80
    <IfModule mod_ssl.c>
    # SSL name based virtual hosts are not yet supported, therefore no
    # NameVirtualHost statement here
    Listen 443
    </IfModule>
    Listen 81 # Esse Listen 81 sera adicionado por você!

    Salve e feche...

    Obs.: Para quem instalou o proxy + thunder através do script,não será necessário esse procedimento!Pois ja vai estar feito...

    Próxima etapa:

    Va até /etc/apache2/apache2.conf
    Abra e la no final acresente a seguinte linha:

    ServerName teste.com (nome do seu provedor ou como preferir)

    Obs.: Para quem instalou o proxy + thunder através do script,será necessário alterar a linha "ServerName conprove" para "ServerName teste.com"

    Próximo passo:

    Va até /etc/apache2/sites-enabled/000-default
    Abra e sera exibida as seguintes linhas:

    <VirtualHost *:80>
    ServerAdmin [email protected]
    DocumentRoot /var/www/
    <Directory />
    Options FollowSymLinks
    AllowOverride None
    </Directory>
    <Directory /var/www/>
    Options Indexes FollowSymLinks MultiViews
    AllowOverride None
    Order allow,deny
    allow from all
    </Directory>
    ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
    <Directory "/usr/lib/cgi-bin">
    AllowOverride None
    Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
    Order allow,deny
    Allow from all
    </Directory>
    ErrorLog /var/log/apache2/error.log
    # Possible values include: debug, info, notice, warn, error, crit,
    # alert, emerg.
    LogLevel warn
    CustomLog /var/log/apache2/access.log combined
    Alias /doc/ "/usr/share/doc/"
    <Directory "/usr/share/doc/">
    Options Indexes MultiViews FollowSymLinks
    AllowOverride None
    Order deny,allow
    Deny from all
    Allow from 127.0.0.0/255.0.0.0 ::1/128
    </Directory>
    </VirtualHost>
    <VirtualHost 192.168.10.2:81> # Aqui é o ip do seu proxy e a porta onde estara a página.
    ServerName aviso.teste.com # Aqui é seu sub-dominio.
    DocumentRoot /var/www/teste/aviso/ # Aqui é sua pasta onde colocara a página.
    </VirtualHost>

    Obs.: Para quem instalou o proxy + thunder através do script,será necessário alterar:
    O endereço de ip,caso necessite.
    O nome do sub-dominio,caso necessite.
    O none/caminho da pasta do diretório,caso necessite.

    Continuando...

    Agora vá em /var/www e crie a pasta/diretório com o caminho de acordo que esta no DocumentRoot.

    Ficará assim: /var/www/teste/aviso , dentro desta pasta "aviso" você pôe sua página que sera mostrada aos clientes que estiverem bloqueados no /ip firewall address-list.

    Muito maneiro!!!!!!!!!!

    Isto é uma maldição q nos persegue... "" A maldição dos Caloteiros""" e ainda fala mal da Internet para outros q só vive caindo, q é uma Net me***a, usa 30 dias e 23 horas e fala que já esta sem Net a 60 dias e não vai pagar, e ainda querem q vc tire vírus e formate de graça , pois foi problema da Net.

    Rsrsrsrsrsrsr!

    Billlll, valeu pela contribuição............ Parabénssssssssssss!

    Última edição por Oldayr; 13-09-2009 às 22:55.

  12. #12

    Padrão

    Citação Postado originalmente por Oldayr Ver Post
    Muito maneiro!!!!!!!!!!

    Isto é uma maldição q nos persegue... "" A maldição dos Caloteiros""" e ainda fala mal da Internet para outros q só vive caindo, q é uma Net me***a, usa 30 dias e 23 horas e fala que já esta sem Net a 60 dias e não vai pagar, e ainda querem q vc tire vírus e formate de graça , pois foi problema da Net.

    Rsrsrsrsrsrsr!

    Billlll, valeu pela contribuição............ Parabénssssssssssss!

    rsrs,é a vida!

    Atenção galera... não é necessário criar uma regra para cada cliente não... Basta no ir até address lists e add o ip do cliente... Simples assim



  13. #13

    Padrão

    "Em caso de dúvidas,mande um mp que venho responder... pois não é sempre que estou por esses lados..."


  14. #14

    Padrão

    Citação Postado originalmente por Oldayr Ver Post
    Muito maneiro!!!!!!!!!!

    Isto é uma maldição q nos persegue... "" A maldição dos Caloteiros""" e ainda fala mal da Internet para outros q só vive caindo, q é uma Net me***a, usa 30 dias e 23 horas e fala que já esta sem Net a 60 dias e não vai pagar, e ainda querem q vc tire vírus e formate de graça , pois foi problema da Net.

    Rsrsrsrsrsrsr!

    Billlll, valeu pela contribuição............ Parabénssssssssssss!


    puts!!!!CONCORDO plemanete com vc!!!!!!!!!!!!!!...........Tem hora q da vontade de explodir tudo issu aqui(inclusive e principalmente os clientes) e ir pra praia vender coco gelado soh de bermuda ........ rs



  15. #15

    Padrão Re: Clientes em Débito??? Veja aqui uma forma de Bloquea-los!!!

    Ola amigos preciso de uma ajuda urgente

    Meu provedor nao tem dhcp eu configuro manualmente o ip para cada cliente e amarro ao mac, quando o cliente estava suspenso por qq motivo e dava um de esperto e alterava o ip dele, logo aparecia esse novo ip na tabela ARP pedindo para ser cadastrado ou excluido, mas para isso nao acontecer eu fechava a entrada de IP´s, nao me lembro como se chamava acho que seria reply-only , mas eu clicava em firewall/filter rules e lá tinha uma opção de travar aentrada de ip´s.

    Td funcionava perfeito até que um raio caiu e consumiu tudo e para minha surpressa o bkp não funfou. estou com um novo mk funfando, mas nao sei fazer ele impedir a entrada de novos ips, hj qq cliente pode alterar seu ip para qq ip dentro da faixa q navega na internet.

    Como faço isso?

    Eu queria deixar o firewall fechado para impedir a entrada de novos ips e quando eu for instalar novos clientes esse novo clientes só navegará após a liberação do firewall, dai eu abro o firewall o cliente entra eu o cadastro e fecho novamente o firewall.