Página 2 de 3 PrimeiroPrimeiro 123 ÚltimoÚltimo
+ Responder ao Tópico



  1. #21

    Padrão Como faço o balanceamento de carga em ponte com o modem?

    [QUOTE = tskstar; 430775] Consegue vir antes e postar para vocês ....

    Segue código base para balanceamento utilizando com PCC 2 ADSLs da mesma ponte em Operadora

    Lembrem de Desmarcar a opção "adicionar rota padrão" Nas propriedades do pppoe-out

    Sistema utilizado: Mikrotik 3,28 X86

    Interfaces: Local (clientes pppoe-server)
    pppoe-OUT1 (ADSL1)
    pppoe-OUT2 (ADSL2)

    Mangle
    [CODE] / ip firewall mangle
    add action = aceitar chain = prerouting comment = "FORA DO LOADBALACED" disabled = no dst-address-list = loopback in-interface = Local
    add action = mark-connection chain = input comment = "Criar o pacote sai pela interface mesmo" connection-state = new disabled = no in-interface = pppoe-wan1 \
    ligação nova marca de wan1_conn = passthrough = yes
    add action = mark-connection chain = input comment = "" connection-state = new disabled = no in-interface = pppoe-WAN2 nova-connection-mark = wan2_conn passthrough = yes
    add action = mark-routing chain = output comment = "" connection-mark = ligação wan1_conn-state = new disabled = no new-routing-mark = to_wan1 passthrough = no
    add action = mark-routing chain = output comment = "" connection-mark = ligação wan2_conn-state = new disabled = no new-routing-mark = to_wan2 passthrough = no
    add action = aceitar chain = prerouting comment = "Atribuir o encaminhamento adequado da marca" disabled = yes dst-address = 10.111.0.0/24 in-interface = Local
    add action = aceitar chain = prerouting comment = "" disabled = yes dst-address = 10.112.0.0/24 in-interface = Local
    add action = mark-connection chain = prerouting comment = "PCC Balance" disabled = no dst-address-type =! local in-interface = Local new-connection-mark = wan1_conn \
    passthrough = no per-connection-classifier = dois endereços: 2 / 0
    add action = mark-connection chain = prerouting comment = "" disabled = no dst-address-type =! local in-interface = Local new-connection-mark = wan2_conn passthrough = yes \
    per-connection-classifier = dois endereços: 2 / 1
    add action = mark-routing chain = prerouting comment = "Marcar todos os pacotes" connection-mark = wan1_conn disabled = no in-interface = Local new-routing-mark = to_wan1 \
    passthrough = no
    add action = mark-routing chain = prerouting comment = "" connection-mark = wan2_conn disabled = no in-interface = Local new-routing-mark = to_wan2 passthrough = no
    [/ CODE]

    NAT
    [CODE] / ip firewall nat
    add action = masquerade chain = srcnat comment = "Masquerade Interfaces" disabled = no out-interface = pppoe-wan1
    add action = masquerade chain = srcnat comment = "" disabled = no out-interface = pppoe-WAN2
    [/ CODE]

    ROTAS
    [CODE] ip route /
    add comment = "" disabled = no distance = 1 dst-address = 0.0.0.0 / 0 gateway = Local
    add check-gateway = ping comment = "" disabled = no distance = 1 dst-address = 0.0.0.0 / 0 gateway = wan1-routing-mark = pppoe to_wan1
    add check-gateway = ping comment = "" disabled = no distance = 2 dst-address = 0.0.0.0 / 0 gateway = WAN2-pppoe
    add check-gateway = ping comment = "" disabled = no distance = 1 dst-address = 0.0.0.0 / 0 gateway = WAN2-routing-mark = pppoe to_wan2
    add check-gateway = ping comment = "" disabled = no distance = 1 dst-address = 0.0.0.0 / 0 gateway = wan1-pppoe
    [/ CODE]

    Espero que isso ajude ...

    Abração a todos! Precisando tamo ai! [/ QUOTE]


    Bom dia... ótimo exemplo está de parabéns.. porém tem duas duvidas já que vou implementar esse passo a passo hj.

    Quando vc disse isso logo no inicio " Interfaces: Local (clientes pppoe-server)"

    Eu trabalho em uma rede totamente cabeada eu preciso ter um ppoe-server instalado ? caso sim, como o faria ?

    outra coisa, essas regras abaixo são para ficar com disable=yes, mesmo ?

    add action = aceitar chain = prerouting comment = "Atribuir o encaminhamento adequado da marca" disabled = yes dst-address = 10.111.0.0/24 in-interface = Local
    add action = aceitar chain = prerouting comment = "" disabled = yes dst-address = 10.112.0.0/24 in-interface = Local

    antecipadamente agradeço,

    Carlos Gonzaga

  2. #22

    Padrão

    Citação Postado originalmente por fasseabra Ver Post
    É isso ai man, funcionou perfeitamente, só adaptei os nomes das interfaces pois ja tinha pcc seguindo a dica do amigo Tiago Matias. Valeu tskstar, continue assim.
    Muito obrigado pelos elogios..Tambem aprendi muito com o pessoal do forum que me ajudou a finalizar meu balanceamento sem problemas...Precisando estamos ai com oq precisar...abracao brother e boa sorte


    Citação Postado originalmente por cgonzaga Ver Post

    Bom dia... ótimo exemplo está de parabéns.. porém tem duas duvidas já que vou implementar esse passo a passo hj.

    Quando vc disse isso logo no inicio " Interfaces: Local (clientes pppoe-server)"

    Eu trabalho em uma rede totamente cabeada eu preciso ter um ppoe-server instalado ? caso sim, como o faria ?

    outra coisa, essas regras abaixo são para ficar com disable=yes, mesmo ?

    add action = aceitar chain = prerouting comment = "Atribuir o encaminhamento adequado da marca" disabled = yes dst-address = 10.111.0.0/24 in-interface = Local
    add action = aceitar chain = prerouting comment = "" disabled = yes dst-address = 10.112.0.0/24 in-interface = Local

    antecipadamente agradeço,

    Carlos Gonzaga
    Ola Carlos,

    Bem eu resolvi deixar essas regra desabilitadas pois elas seriam habilitadas caso o modem estivesse em modo roteador,como esta em bridge,pode deixar desabilitado mesmo...

    Com relacao a sua outra duvida sobre o pppoe-server,voce somente ira utilizar caso voce autentique seus clientes via pppoe,caso voce utilize somente liberacao por MAC/IP,hotspot ou algo no genero,sem ser pppoe voce substitui a saida "local" conforme o exemplo pela sua saida com os clientes,seja ela pppoe,hotspot,ipfixo ou oq voce quiser ok ?

    Caso voce queira utilziar pppoe-server e nao saiba como criar um servidor pppoe recomendo voce dar uma pesquisada aqui no forum que tem muitos topicos otimos ensinando como fazer passo a passo..inclusive na wiki do nosso colega "CATVBRASIL".

    Abracao!
    Última edição por tskstar; 28-08-2009 às 12:22.



  3. #23

    Padrão

    Citação Postado originalmente por williamterencio Ver Post
    se o amigo puder postar as regras será muito útil pra gente.

    obrigado!

    Cara o problema eh que o modem roteado não tem o processamento que um servidor tem ... por isso ele trava !

  4. #24

    Padrão

    bom pessoal eu fiz o load ficou muito bom .. o problema eh que eu nao to mais conseguindo usar o meu proxy do linux ...

    Meu proxy roda em uma interface separada .. funciiona tudo direitinhu no proxy mas o problema eh que ele nao tah funcionando no mikrotik !


    Segue a regra que redireciona o trafego pro proxy !

    add action=dst-nat chain=dstnat comment=Proxy disabled=no dst-port=80 \
    in-interface=Proxy protocol=tcp src-address=0.0.0.0/0 to-addresses=\
    192.168.0.180 to-ports=8180



  5. #25

    Padrão

    Citação Postado originalmente por admskill Ver Post
    bom pessoal eu fiz o load ficou muito bom .. o problema eh que eu nao to mais conseguindo usar o meu proxy do linux ...

    Meu proxy roda em uma interface separada .. funciiona tudo direitinhu no proxy mas o problema eh que ele nao tah funcionando no mikrotik !


    Segue a regra que redireciona o trafego pro proxy !

    add action=dst-nat chain=dstnat comment=Proxy disabled=no dst-port=80 \
    in-interface=Proxy protocol=tcp src-address=0.0.0.0/0 to-addresses=\
    192.168.0.180 to-ports=8180
    Ola admskill,

    Bem por mais que sabemos que o ideal eh rodar o LoadBalance em um outro mikrotik,nao o mesmo que faz o roteamento,pppoe-server etc...mas tambem da para implementar...

    Bem,somente confirmando voce utiliza uma interface separada para o proxy dentro do mikrotik para enviar para o seu squid ? Seria isso ?

    Caso positivo faca o seguinte,substitua a regra acima que voce fez por esta abaixo,modificando os campos em vermelho de acordo com a sua rede:

    add action=dst-nat chain=dstnat comment="Redirect HTTP Traffic to WebProxy" disabled=no dst-port=80 protocol=tcp src-address=FAIXA.IP.DOS.CLIENTES \
    to-addresses=ENDERECO.DO.SQUID to-ports=PORTA.DO.SQUID


    Abracos,

  6. #26
    Avatar de kyanbatera
    Ingresso
    Jun 2008
    Localização
    Vila Velha, Brazil, Brazil
    Posts
    132
    Posts de Blog
    1

    Padrão

    Amigos fiz o balanceamento está funcionando blz
    mais agora estou com problemas para acessar bancos quando usava NTH tinha umas regras aqui e funcionava agora não consigo entrar em conta de banco, tem um cliente reclamando que não entra na SKY nenhuma página HTTPS.



  7. #27

    Padrão

    Citação Postado originalmente por kyanbatera Ver Post
    Amigos fiz o balanceamento está funcionando blz
    mais agora estou com problemas para acessar bancos quando usava NTH tinha umas regras aqui e funcionava agora não consigo entrar em conta de banco, tem um cliente reclamando que não entra na SKY nenhuma página HTTPS.
    Boa noite amigo,

    Nao se esqueca de adicionar a regra "accept" na chain prerouting dentro do mangle com os enderecos dos sites que voce nao quer q entre no load e saia pelo gateway padrao..

    Simplesmente crie uma address-list com os IPs que voce quer dos sites ou faixas de enderecos e prontinho.Estara 100% contornado.

    Abracos

  8. #28
    Avatar de kyanbatera
    Ingresso
    Jun 2008
    Localização
    Vila Velha, Brazil, Brazil
    Posts
    132
    Posts de Blog
    1

    Padrão

    Citação Postado originalmente por tskstar Ver Post
    Boa noite amigo,

    Nao se esqueca de adicionar a regra "accept" na chain prerouting dentro do mangle com os enderecos dos sites que voce nao quer q entre no load e saia pelo gateway padrao..

    Simplesmente crie uma address-list com os IPs que voce quer dos sites ou faixas de enderecos e prontinho.Estara 100% contornado.

    Abracos
    Amigo você poderia me passar essas address-list???
    desde já agradecido!!!

    Forte Abraço!!!



  9. #29

    Padrão

    Citação Postado originalmente por kyanbatera Ver Post
    Amigo você poderia me passar essas address-list???
    desde já agradecido!!!

    Forte Abraço!!!
    Segue um exemplo de lista que utilizo aqui como,rapidshare,maegaupload,easyshare,bradesco e conectividade social da caixa,estao listados abaixo.
    Abracos,

    /ip firewall address-list
    add address=200.155.80.0-200.155.255.255 comment=BRADESCO disabled=no list=\
    loopback
    add address=200.220.186.0/24 comment=BRADESCO disabled=no list=loopback
    add address=200.220.178.0/24 comment=BRADESCO disabled=no list=loopback
    add address=64.38.29.0/24 comment=RapidShare disabled=no list=loopback
    add address=208.69.32.0/24 comment="" disabled=no list=loopback
    add address=208.67.217.0/24 comment="" disabled=no list=loopback
    add address=201.7.178.0/24 comment="" disabled=no list=loopback
    add address=201.7.176.0/24 comment="" disabled=no list=loopback

  10. #30

    Padrão

    Alguem ai tah usando esse load com proxy externo ??



  11. #31

    Padrão

    Citação Postado originalmente por admskill Ver Post
    Alguem ai tah usando esse load com proxy externo ??

    funciona perfeitamente,mas o ideal eh utilizar um mikrotik soh para o LB.Ai vc ja entrega a conexao pronta ao proxy e aos clientes...

  12. #32

    Padrão Como faço o balanceamento de carga em ponte com o modem?

    [QUOTE = tskstar; 431903] Muito obrigado pelos elogios .. Tambem aprendi muito com o pessoal do fórum que me ajudou um finalizar meu balanceamento sem problemas ... Precisando estamos ai com oq precisar ... abracao brother e boa sorte




    Ola Carlos,

    Bem eu resolvi deixar essas regra claire_jay pois elas seriam habilitadas caso o modem estivesse em modo roteador, ponte em como esta, pode deixar desabilitado mesmo ...

    Com relação a sua outra duvida sobre o pppoe-server, voce somente ira JAF caso voce autentique seus clientes via PPPoE, caso voce utilizar somente liberacao por MAC / IP, hotspot ou algo no gênero, sem ser pppoe voce substitui uma saida "local" conforme o exemplo pela sua saida com os clientes, seja ela pppoe hotspot, ipfixo ou oq voce quiser ok?

    Caso voce queira utilziar pppoe-server e nao saiba Como Criar um Servidor PPPoE recomendo voce dar uma pesquisada aqui no forum que tem muitos topicos otimos ensinando como fazer passo a passo .. wiki, inclusive na do nosso colega "CATVBRASIL".

    Abracao! [/ QUOTE]

    Olá,

    Fiz o procedimento sendo que inicialmente achei que estivesse 100%.. mas percebi que o 2º link adsl conectado está com pouco fluxo de tx e rx.. mas no nat tem referência de uso mas também pequeno fluxo, na conexão ppp os dois estão como conectados.. no Mangle também tem pequenas ocorrências.. Esse comportamento é normal ou posso ter errado em algo ?

    antecipadamente agradeço

    Carlos Gonzaga.
    Última edição por cgonzaga; 09-09-2009 às 22:44.



  13. #33

    Padrão

    Cara Aki eu uso o seguinte .. eu tenho um pc com MK instalado ele eh quem contrala td hj os clientes quem faz a discagem no modem. por enquanto ta com 1 link .
    Ai configurei um RB com esse Load Balance pra colcocar antes desse meu pc que faz o resto .. no caso a RB iria controlar as discagem e a fazer o balance ... configurei ela como esta aki ... mas pelo que vi ai nao sei se estou certo .. mas eh como se um link estivece de backup pro outro ...
    me explica como eh que vo redirecionar td da porta 80 pra 1 link e o resto pra outro ??
    O que este loadbalance esta fazendo na real .... desculpe a Ignorancia mas eh que nao entendi direito.... funcionou mas nao sei se da pra resolver meu problema... Obrigado

  14. #34

    Question ok boa iniativa

    Citação Postado originalmente por tskstar Ver Post
    Consegue vir antes e postar para vocês....

    Segue código base para balanceamento utilizando PCC com 2 ADSLs da mesma operadora em bridge

    Lembrem de desmarcar a opcao "add default route" nas propriedades do pppoe-out

    Sistema utilizado: Mikrotik 3.28 X86

    Interfaces:Local (clientes pppoe-server)
    pppoe-out1 (ADSL1)
    pppoe-out2 (ADSL2)

    Mangle
    Código :
    /ip firewall mangle
    add action=accept chain=prerouting comment="FORA DO LOADBALACED" disabled=no dst-address-list=loopback in-interface=Local
    add action=mark-connection chain=input comment="Make the packet leaves via same interface" connection-state=new disabled=no in-interface=wan1-pppoe \
        new-connection-mark=wan1_conn passthrough=yes
    add action=mark-connection chain=input comment="" connection-state=new disabled=no in-interface=wan2-pppoe new-connection-mark=wan2_conn passthrough=yes
    add action=mark-routing chain=output comment="" connection-mark=wan1_conn connection-state=new disabled=no new-routing-mark=to_wan1 passthrough=no
    add action=mark-routing chain=output comment="" connection-mark=wan2_conn connection-state=new disabled=no new-routing-mark=to_wan2 passthrough=no
    add action=accept chain=prerouting comment="Assigning the propper routing-mark" disabled=yes dst-address=10.111.0.0/24 in-interface=Local
    add action=accept chain=prerouting comment="" disabled=yes dst-address=10.112.0.0/24 in-interface=Local
    add action=mark-connection chain=prerouting comment="PCC Balance" disabled=no dst-address-type=!local in-interface=Local new-connection-mark=wan1_conn \
        passthrough=no per-connection-classifier=both-addresses:2/0
    add action=mark-connection chain=prerouting comment="" disabled=no dst-address-type=!local in-interface=Local new-connection-mark=wan2_conn passthrough=yes \
        per-connection-classifier=both-addresses:2/1
    add action=mark-routing chain=prerouting comment="Marking all the packets" connection-mark=wan1_conn disabled=no in-interface=Local new-routing-mark=to_wan1 \
        passthrough=no
    add action=mark-routing chain=prerouting comment="" connection-mark=wan2_conn disabled=no in-interface=Local new-routing-mark=to_wan2 passthrough=no
    NAT
    Código :
    /ip firewall nat
    add action=masquerade chain=srcnat comment="Masquerade Interfaces" disabled=no out-interface=wan1-pppoe
    add action=masquerade chain=srcnat comment="" disabled=no out-interface=wan2-pppoe
    ROUTES
    Código :
    /ip route
    add comment="" disabled=yes distance=1 dst-address=0.0.0.0/0 gateway=Local
    add check-gateway=ping comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=wan1-pppoe routing-mark=to_wan1
    add check-gateway=ping comment="" disabled=no distance=2 dst-address=0.0.0.0/0 gateway=wan2-pppoe
    add check-gateway=ping comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=wan2-pppoe routing-mark=to_wan2
    add check-gateway=ping comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=wan1-pppoe
    Espero que isso ajude...

    Abração a todos! Precisando tamo ai!
    mesmo,no meu caso como faço para fazer o balance usando hotspot com 3 planos de velo ... e uso web proxy
    Última edição por djjeantechno; 29-09-2009 às 03:17.



  15. #35

    Padrão Como faço load balance com o modem em bridge?

    [QUOTE = tskstar; 430775] Consegue vir antes e postar para vocês ....

    Segue código base para balanceamento utilizando com PCC 2 ADSLs da mesma ponte em Operadora

    Lembrem de Desmarcar a opção "adicionar rota padrão" Nas propriedades do pppoe-out

    Sistema utilizado: Mikrotik 3,28 X86

    Interfaces: Local (clientes pppoe-server)
    pppoe-OUT1 (ADSL1)
    pppoe-OUT2 (ADSL2)

    Mangle
    [CODE] / ip firewall mangle
    add action = aceitar chain = prerouting comment = "FORA DO LOADBALACED" disabled = no dst-address-list = loopback in-interface = Local
    add action = mark-connection chain = input comment = "Criar o pacote sai pela interface mesmo" connection-state = new disabled = no in-interface = pppoe-wan1 \
    ligação nova marca de wan1_conn = passthrough = yes
    add action = mark-connection chain = input comment = "" connection-state = new disabled = no in-interface = pppoe-WAN2 nova-connection-mark = wan2_conn passthrough = yes
    add action = mark-routing chain = output comment = "" connection-mark = ligação wan1_conn-state = new disabled = no new-routing-mark = to_wan1 passthrough = no
    add action = mark-routing chain = output comment = "" connection-mark = ligação wan2_conn-state = new disabled = no new-routing-mark = to_wan2 passthrough = no
    add action = aceitar chain = prerouting comment = "Atribuir o encaminhamento adequado da marca" disabled = yes dst-address = 10.111.0.0/24 in-interface = Local
    add action = aceitar chain = prerouting comment = "" disabled = yes dst-address = 10.112.0.0/24 in-interface = Local
    add action = mark-connection chain = prerouting comment = "PCC Balance" disabled = no dst-address-type =! local in-interface = Local new-connection-mark = wan1_conn \
    passthrough = no per-connection-classifier = dois endereços: 2 / 0
    add action = mark-connection chain = prerouting comment = "" disabled = no dst-address-type =! local in-interface = Local new-connection-mark = wan2_conn passthrough = yes \
    per-connection-classifier = dois endereços: 2 / 1
    add action = mark-routing chain = prerouting comment = "Marcar todos os pacotes" connection-mark = wan1_conn disabled = no in-interface = Local new-routing-mark = to_wan1 \
    passthrough = no
    add action = mark-routing chain = prerouting comment = "" connection-mark = wan2_conn disabled = no in-interface = Local new-routing-mark = to_wan2 passthrough = no
    [/ CODE]

    NAT
    [CODE] / ip firewall nat
    add action = masquerade chain = srcnat comment = "Masquerade Interfaces" disabled = no out-interface = pppoe-wan1
    add action = masquerade chain = srcnat comment = "" disabled = no out-interface = pppoe-WAN2
    [/ CODE]

    ROTAS
    [CODE] ip route /
    add comment = "" disabled = no distance = 1 dst-address = 0.0.0.0 / 0 gateway = Local
    add check-gateway = ping comment = "" disabled = no distance = 1 dst-address = 0.0.0.0 / 0 gateway = wan1-routing-mark = pppoe to_wan1
    add check-gateway = ping comment = "" disabled = no distance = 2 dst-address = 0.0.0.0 / 0 gateway = WAN2-pppoe
    add check-gateway = ping comment = "" disabled = no distance = 1 dst-address = 0.0.0.0 / 0 gateway = WAN2-routing-mark = pppoe to_wan2
    add check-gateway = ping comment = "" disabled = no distance = 1 dst-address = 0.0.0.0 / 0 gateway = wan1-pppoe
    [/ CODE]

    Espero que isso ajude ...

    Abração a todos! Precisando tamo ai! [/ QUOTE]

    Ótimo post!

    Venho aqui outra vez fazer tirar uma duvida.. no caso percebo que o 2º link que conecta na ordem do ppoe fica com taxa de uso bem menor do que o 1º link conectado.. e no caso do 1º cair o outro não funciona automaticamente tenho que desativar o nat e ativar outra vez, para voltar a internet...

    pergunto eh possivel deixar os links com o recurso do loadbalance via PCC e prover uma segurança em que uma cai e outro pelo menos assuma ? e sobre a velocidade do uso do pcc entre os links tem realmente alguma diferente ?

    Antecipadamente Agradeço,


    Carlos Gonzaga

  16. #36

    Padrão

    Bom pessoal aproveitando o tópico eu gostaria de saber se alguém pode me passar as regras do PCC fixo + bridge pppoe ... pq to torrando a cabeça aki nesse pcc com dois bridges to tentando adaptar mas não ficou 100% ... mais tarde quando chegar em casa vou postar as regras .... mas se puderem adiantar alguma coisa pra mim comparar eu agradeço !


    Abraços !



  17. #37

    Padrão

    Ola amigos o que eu vou pergunta esta fora total mento do tópico , estou com problema que e +- a sim o modem esta perfeito já ate troquei de modem usava um d-link 500b ai quando começou apresentar o problema mudei pra o modem speed 4200 mais permaneceu o problema, amigos da UNDER pergunto quando ele esta ligado funciona pelo menos umas 2 horas perfeitas mais com passa desse tempo ele começa a cai a velocidade, se o link e de 4Mb e faz Down de 450kbps por segundo começa a fazer uma espécie de contagem regressiva caindo a velocidade sucessivamente chegando a 0 de UPL e DOWN , quando chega a esse ponto eu desligo o modem e ligo novamente e volta a o normal sem problemas ai contasse mais 2 horas pra eu desliga o modem novamente e começa tudo de novo e uma obs: que os modems não estão rateados estão bridge ai gente já leguei pra telemar eles não dizem nada sobre o assunto e o rapaz já veio a que e verificou as linhas, poxa vida deve ter algo errado !!>?

  18. #38

    Padrão Re: Como faço load balance com o modem em bridge?

    olá amigo , nao estou conseguindo fazer o load balance , estou usando mk 3.x no caso tenho um modem em bridge , e o outro roteado , poderia me dar uma força.



  19. #39

    Padrão Re: Como faço load balance com o modem em bridge?

    Amigo , poderia me ajudar , com o load balance versao do mk 3.x estou com 2 placas para conexao com os modems em bridge e uma para rede local , e no caso uso hotspot e webproxy .

  20. #40

    Padrão Re: Como faço load balance com o modem em bridge?

    Amigo , tenho um mk 3.x com hotspot , e webproxy tenho que fazer em uma rb separa?? e isso