+ Responder ao Tópico



  1. #281
    Mikrotik inSide Avatar de luizbe
    Ingresso
    Sep 2005
    Localização
    Governador Valadares
    Posts
    1.212
    Posts de Blog
    1

    Padrão

    tmelooliveira,
    Rapaz , muito obrigado!
    usei o seu script, foi só colocar que rodou 100% , os links estão balanceados perfeitamente..
    eu nunca pensei que juntar links seria tão produtivo, a velocidade na rede aqui melhorou uns 70%.

    Agradeço, e digo o PCC concerteza é uma ferramenta incrivel.

  2. #282

    Padrão

    Citação Postado originalmente por luizbe Ver Post
    tmelooliveira,
    Rapaz , muito obrigado!
    usei o seu script, foi só colocar que rodou 100% , os links estão balanceados perfeitamente..
    eu nunca pensei que juntar links seria tão produtivo, a velocidade na rede aqui melhorou uns 70%.

    Agradeço, e digo o PCC concerteza é uma ferramenta incrivel.
    Tá vendo, é o que o tiago vive dizendo, se fizer direito vai funcionar, anotem todos ae e parabéns pelo seu sucesso.

    Grande abraço



  3. #283
    Mikrotik inSide Avatar de luizbe
    Ingresso
    Sep 2005
    Localização
    Governador Valadares
    Posts
    1.212
    Posts de Blog
    1

    Padrão

    alguem mais notou que quando altera both-adress para both-addres-and-ports, o balance fica melhor?

  4. #284

    Padrão

    Bom dia ! Luciano.

    Muito bom.. fiz o teste sendo que só percebi um problema ao acessar o site do banco bradesco e tentei fazer um pagamento on-line e ele e jogado para uma outra tela e diz que pegou outro IP e dando o erro impossibilitando essa função tem como resolver.

    Antecipadamente agradeço,

    Carlos Gonzaga



  5. #285

    Padrão

    Citação Postado originalmente por cgonzaga Ver Post
    Bom dia ! Luciano.

    Muito bom.. fiz o teste sendo que só percebi um problema ao acessar o site do banco bradesco e tentei fazer um pagamento on-line e ele e jogado para uma outra tela e diz que pegou outro IP e dando o erro impossibilitando essa função tem como resolver.

    Antecipadamente agradeço,

    Carlos Gonzaga
    se vc ler esse topico ou outro aqui sobre banco bradesco com pcc vai encontrar a regra que vai resolver seu problema

  6. #286
    Mikrotik inSide Avatar de luizbe
    Ingresso
    Sep 2005
    Localização
    Governador Valadares
    Posts
    1.212
    Posts de Blog
    1

    Padrão

    utilizei essas regras aqui , e pelo visto funcionou beleza.:

    no mangle:
    obs: troque o interface=EthClientes por interface e o nome da sua interface local.. que seja ether1 ou Local..
    /ip firewall mangle
    add action=accept chain=prerouting comment="LIBERAR SITES HTTPS" disabled=no dst-address-list=BB in-interface=EthClientes
    add action=accept chain=prerouting comment="" disabled=no dst-address-list=BRADESCO in-interface=EthClientes
    add action=accept chain=prerouting comment="" disabled=no dst-address-list=CEF in-interface=EthClientes
    add action=accept chain=prerouting comment="" disabled=no dst-address-list=HSBC in-interface=EthClientes
    add action=accept chain=prerouting comment="" disabled=no dst-address-list=ITAU in-interface=EthClientes
    add action=accept chain=prerouting comment="" disabled=no dst-address-list=NOSSACAIXA in-interface=EthClientes
    add action=accept chain=prerouting comment="" disabled=no dst-address-list=SANTANDER in-interface=EthClientes
    add action=accept chain=prerouting comment="" disabled=no dst-address-list=GLOBO1 in-interface=EthClientes
    add action=accept chain=prerouting comment="" disabled=no dst-address-list=GLOBO2 in-interface=EthClientes
    add action=accept chain=prerouting comment="" disabled=no dst-address-list=GLOBO3 in-interface=EthClientes
    add action=accept chain=prerouting comment="" disabled=no dst-address-list=TERRA in-interface=EthClientes
    no addres list:
    /ip firewall address-list
    add address=200.155.0.0/16 comment="" disabled=no list=BRADESCO
    add address=200.201.0.0/16 comment="" disabled=no list=CEF
    add address=170.66.0.0/24 comment="" disabled=no list=BB
    add address=200.220.0.0/16 comment="" disabled=no list=SANTANDER
    add address=200.196.0.0/16 comment="" disabled=no list=ITAU
    add address=189.56.0.0/16 comment="" disabled=no list=NOSSACAIXA
    add address=161.113.0.0/24 comment="" disabled=no list=HSBC
    add address=201.7.176.0/24 comment="" disabled=no list=GLOBO1
    add address=201.7.180.0/24 comment="" disabled=no list=GLOBO2
    add address=201.7.176.0/24 comment="" disabled=no list=GLOBO3
    add address=200.154.56.0/24 comment="" disabled=no list=TERRA
    add address=208.84.247.0/24 comment="" disabled=no list=TERRA

    espero que funcione pra você tambem..



  7. #287

    Padrão

    Olá pessoal,
    Parabéns ao autor do tópico.

    Se feito com cuidado e bom senso (de acordo com a realidade de cada um) o script funciona perfeitamente.


    Só estou com uma dúvida teórica:

    No começo do script é feito uma regra no Mangle onde os pacotes passam sem marcação (de acordo com uma lista de endereços).

    Seria essa regra:
    add action=accept chain=prerouting comment="SEM BALANCE" disabled=no dst-address-list=sem_balance in-interface=EthClientes

    O nosso amigo disse que com essa regra os sites da lista sem_balance saem pelo gateway padrão.
    Porém, como temos vários gateways, por onde exatamente sairá essas conexão não marcadas? pelo primeiro gateway com peso menor (distance) ?

    Agradeço a atenção.


    Abraços

  8. #288
    Mikrotik inSide Avatar de luizbe
    Ingresso
    Sep 2005
    Localização
    Governador Valadares
    Posts
    1.212
    Posts de Blog
    1

    Padrão

    Citação Postado originalmente por ajack Ver Post
    Olá pessoal,
    Parabéns ao autor do tópico.

    Se feito com cuidado e bom senso (de acordo com a realidade de cada um) o script funciona perfeitamente.


    Só estou com uma dúvida teórica:

    No começo do script é feito uma regra no Mangle onde os pacotes passam sem marcação (de acordo com uma lista de endereços).

    Seria essa regra:
    add action=accept chain=prerouting comment="SEM BALANCE" disabled=no dst-address-list=sem_balance in-interface=EthClientes

    O nosso amigo disse que com essa regra os sites da lista sem_balance saem pelo gateway padrão.
    Porém, como temos vários gateways, por onde exatamente sairá essas conexão não marcadas? pelo primeiro gateway com peso menor (distance) ?

    Agradeço a atenção.


    Abraços

    kra não intendi muito a regra, mas sei que funciona que uma beleza..
    alguns ips coloquei na lista sem_regras e outras eu usei um script que copiei aqui no under, mas porém..
    funcionou, Bradesco bb tudo ok.. alguns sites do governo, o ima tambem..
    ou seja..
    Funciona!



  9. #289

    Padrão

    Citação Postado originalmente por ajack Ver Post
    Olá pessoal,
    Parabéns ao autor do tópico.

    Se feito com cuidado e bom senso (de acordo com a realidade de cada um) o script funciona perfeitamente.


    Só estou com uma dúvida teórica:

    No começo do script é feito uma regra no Mangle onde os pacotes passam sem marcação (de acordo com uma lista de endereços).

    Seria essa regra:
    add action=accept chain=prerouting comment="SEM BALANCE" disabled=no dst-address-list=sem_balance in-interface=EthClientes

    O nosso amigo disse que com essa regra os sites da lista sem_balance saem pelo gateway padrão.
    Porém, como temos vários gateways, por onde exatamente sairá essas conexão não marcadas? pelo primeiro gateway com peso menor (distance) ?

    Agradeço a atenção.


    Abraços
    Exatamente amigo, ele vai sair pelo gw que tem a distancia menor

  10. #290

    Padrão

    Funciona com a versão 4.6?

    Obrigado.



  11. #291

    Padrão

    Citação Postado originalmente por luizbe Ver Post
    utilizei essas regras aqui , e pelo visto funcionou beleza.:

    no mangle:
    obs: troque o interface=EthClientes por interface e o nome da sua interface local.. que seja ether1 ou Local..


    no addres list:



    espero que funcione pra você tambem..
    havera alguma diferença se ao inves de

    add address=201.7.176.0/24 comment="" disabled=no list=GLOBO1
    add address=201.7.180.0/24 comment="" disabled=no list=GLOBO2
    add address=201.7.176.0/24 comment="" disabled=no list=GLOBO3

    eu colocar apenas 201.7.0.0/16? assim nao precisaria de 3 regras.

    teria alguma regra para redirecionar para a rota padrao os sites de video pelo seu conteudo? pois se eu for criar uma regra para cada site sera um processo muito moroso.

  12. #292

    Padrão

    Citação Postado originalmente por BraZuky Ver Post
    Funciona com a versão 4.6?

    Obrigado.
    acima da > 3.24 qualquer uma



  13. #293

    Padrão

    Fizemos o balanceamento e ficou muito bom.
    Fizemos numa rb só para o balanceamento.
    Só que agora não conseguimos entrar no servidor pelo ip fixo. Remotamente quando colocamos o IP fixo ele entra direto na RB do balanceamento.
    Só entra no servidor se estiver dentro da rede. Será que vou ter que apelar para o DynDns?

  14. #294

    Padrão

    Citação Postado originalmente por 1929 Ver Post
    Fizemos o balanceamento e ficou muito bom.
    Fizemos numa rb só para o balanceamento.
    Só que agora não conseguimos entrar no servidor pelo ip fixo. Remotamente quando colocamos o IP fixo ele entra direto na RB do balanceamento.
    Só entra no servidor se estiver dentro da rede. Será que vou ter que apelar para o DynDns?
    Bom dia, basta vc fazer o redirecionamento do IP ou PORTA que vc quer da RB para o SERVIDOR que esta atraz da BR, detalhe, coloque o IP ou PORTA dentro daquela regra SEM BALANCE, pronto, feito isso o redirecionamento funciona normal.

    abraços



  15. #295
    Avatar de dimensaonet
    Ingresso
    Feb 2010
    Localização
    São Francisco De Goiás, Goias, Brazil, Brazil
    Posts
    72

    Padrão

    ola amigos sou novo aqui e to precisando de uma ajudinha. tive olhando as regras do pcc postado pelo nosso amigo tmelooliveira e tantando montar um pcc aqui. meu caso é tenho 4 adsl 2 de 1mega e 2 de 1.5mega e queria fazer um balance pcc. mais eu nao sei quase nada ainda eu tenho uma rb 450 com o Mikrotik 3.31 alguem mim da um ajudinha?
    eu coloquei esse script postado pelo amigo tmelooliveira mais eu naõ sei se o pcc tem que gera ip se ele tem o dhcp ativo vou postas a regra e um printe. se alguem poder mim ajudar ficarei muito grato.

    4 X ADSL 2 DE 1MEGA E 2 DE 1.5 MEGA COM MODENS EM BRIDGE (Sendo discados pelo mikrotik)
    Balanceamento feito numa RB450G com Mikrotik 3.31 instalado

    Nome das interfaces

    1 R EthClientes (SAIDA DO LINK) POE
    2 R EthLinkA (MODEM 1)
    3 R EthLinkB (MODEM 2)
    4R EthLinkC (MODEM 3)

    5 R EthLinkC (MODEM 4)
    6 R pppoe-out1
    7 R pppoe-out2
    8 R pppoe-out3

    9 R pppoe-out3

    MARCAÇÃO DAS CONEXÕS, PACOTES...

    /ip firewall mangle
    add action=accept chain=prerouting comment="SEM BALANCE" disabled=no \
    dst-address-list=sem_balance in-interface=EthClientes
    add action=mark-connection chain=input comment="" connection-state=new \
    disabled=no in-interface=pppoe-out1 new-connection-mark=conn_na \
    passthrough=yes
    add action=mark-connection chain=input comment="" connection-state=new \
    disabled=no in-interface=pppoe-out2 new-connection-mark=conn_nb \
    passthrough=yes
    add action=mark-connection chain=input comment="" connection-state=new \
    disabled=no in-interface=pppoe-out3 new-connection-mark=conn_nc \
    passthrough=yes

    add action=mark-connection chain=input comment="" connection-state=new \
    disabled=no in-interface=pppoe-out3 new-connection-mark=conn_nd \
    passthrough=yes
    add action=mark-routing chain=output comment="" connection-mark=conn_na \
    disabled=no new-routing-mark=to_ra passthrough=no
    add action=mark-routing chain=output comment="" connection-mark=conn_nb \
    disabled=no new-routing-mark=to_rb passthrough=no
    add action=mark-routing chain=output comment="" connection-mark=conn_nc \
    disabled=no new-routing-mark=to_rc passthrough=no

    add action=mark-routing chain=output comment="" connection-mark=conn_nd \
    disabled=no new-routing-mark=to_rc passthrough=no
    add action=mark-connection chain=prerouting comment="" disabled=no \
    dst-address-type=!local in-interface=EthClientes new-connection-mark=\
    conn_ma0 passthrough=yes per-connection-classifier=both-addresses:3/0
    add action=mark-connection chain=prerouting comment="" disabled=no \
    dst-address-type=!local in-interface=EthClientes new-connection-mark=\
    conn_mb1 passthrough=yes per-connection-classifier=both-addresses:3/1
    add action=mark-connection chain=prerouting comment="" disabled=no \
    dst-address-type=!local in-interface=EthClientes new-connection-mark=\
    conn_mc2 passthrough=yes per-connection-classifier=both-addresses:3/2
    add action=mark-routing chain=prerouting comment="" connection-mark=conn_ma0 \
    disabled=no in-interface=EthClientes new-routing-mark=to_nra passthrough=\
    no
    add action=mark-routing chain=prerouting comment="" connection-mark=conn_mb1 \
    disabled=no in-interface=EthClientes new-routing-mark=to_nrb passthrough=\
    no
    add action=mark-routing chain=prerouting comment="" connection-mark=conn_mc2 \
    disabled=no in-interface=EthClientes new-routing-mark=to_nrc passthrough=\
    no

    MASCARAMENTO..

    /ip firewall nat
    add action=masquerade chain=srcnat comment="MASCARAMENTO PCC" disabled=no \
    out-interface=pppoe-out1
    add action=masquerade chain=srcnat comment="MASCARAMENTO PCC" disabled=no \
    out-interface=pppoe-out2
    add action=masquerade chain=srcnat comment="MASCARAMENTO PCC" disabled=no \
    out-interface=pppoe-out3

    add action=masquerade chain=srcnat comment="MASCARAMENTO PCC" disabled=no \
    out-interface=pppoe-out4

    ROTAS...

    /ip route
    add comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=pppoe-out1
    add comment="" disabled=no distance=2 dst-address=0.0.0.0/0 gateway=pppoe-out2
    add comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=pppoe-out1 \
    routing-mark=to_nra
    add comment="" disabled=no distance=3 dst-address=0.0.0.0/0 gateway=pppoe-out3
    add comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=pppoe-out3 \
    routing-mark=to_nrc
    add comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=pppoe-out2 \
    routing-mark=to_nrb




    Anexo 9818


  16. #296

    Padrão

    E ai amigo de cima.. tem uma interface com nome errado.. da uma olhada... tem duas pppoe-out3

    E essas regras não são para todos, cada caso é um caso, no seu por exemplo tem mais alterações..

    da uma olhada com calma.. se naum conseguir da um oi aqui que com tempo eu olho pra vc.. abraço
    Última edição por tmelooliveira; 14-03-2010 às 00:37.



  17. #297

    Padrão

    Amigo 1929, eu tbm me deparei com esse problema, mas dai fui ate as config da RB, mudei a porta http e winbox dela.. e redirecionei as portas do servidor,

    add action=dst-nat chain=dstnat comment="" disabled=no dst-port=PORTA QUE VAI SER ACESSADA \
    protocol=tcp to-addresses=IP DA REDE LOCAL DO SERVIDOR to-ports=PORTA NO SERVIDOR


    isso é bacana, porque vc pode colcoar portas diferentes em todas suas RBs, tendo assim acesso remoto a todas..

    Abraço Gauchão



  18. #298
    Avatar de dimensaonet
    Ingresso
    Feb 2010
    Localização
    São Francisco De Goiás, Goias, Brazil, Brazil
    Posts
    72

    Padrão

    ola amigo tmelooliveira obrigado pela ajuda eu consegui fazer o balanceamento pcc com 4 link e ficou muito bom.se alguem precisar do script ou de uma ajudinha pode pedir que posso tentar ajudar.
    eu Fiz numa rb 450g só para o balanceamento pcc dos 4 link pppoe discada pela rb.
    Só que agora não conseguimos entrar no servidor pelo ddns. Remotamente quando colocamos o ddns romoto q eu usava antes ele entra direto na RB do balanceamento que é a 450g.
    Só entra no servidor se estiver dentro da rede e colocolocar o ip do servidor no winbox. Será o que aconteceu? detalhes( o servidor agora só tem 2 placa de rede. cliente e link) se nao for pedir dimais ajuda eu nessa tambem? abraço



  19. #299

    Padrão

    Olá
    estou usando um servidor de balancer paralelo com o servidor principal
    o balancer é por pcc, até ai tudo bem ta funcionando normal
    mais uso o sistema de gerenciamento webmikrotik
    ele acessa por ssh para interagir com o mikrotik
    mais agora não acessa mais
    alguém sabe qual procedimento tenho que fazer para redirecionar a porta para o servidor principal?
    agradeço desde já
    obrigado

  20. #300

    Padrão

    A maioria das perguntas deste tópico é por falta de conhecimentos de rede.

    PS. Muito bom o script M4D3, funfou legal.