Página 3 de 85 PrimeiroPrimeiro 12345678 ... ÚltimoÚltimo
+ Responder ao Tópico



  1. #13

    Padrão

    Passou despercebido na hora da publicação, removido o 'ports' ficando apenas o address na marcação, tiagom e aprinou é um prazer tê-los por aqui, demais participantes também, na medida do possível vamos respondendo as dúvidas que forem surgindo enquanto for possível pelo primeiro post. Com relação a troca de ips não tive o problema, não posso falar pelos outros, com relação a uso em bridge fica perfeito também.

    Abraço a todos.

  2. #14

    Padrão

    olá, implemente este exemplo de balanço com dois ADSL e parece que esta trabalhando bem, minha pergunta agora é como se pode fazer o fail over com PCC utilizando os modems adsl em modo ruteador

    saludos



  3. #15
    vmh0909
    Visitante

    Padrão

    Ola M4D3, Parabéns pelo tutorial, muito bom mesmo, me ajudou a entender o funcionamento do PCC.
    Mas estou com um probleminha e quem sabe os universitarios podem me ajudar.

    implantei o PCC com hotspot em dois links de 10Mb um da NetVirtua e um da gvt, com um roteador na ponta de cada link antes do MK funciona muito bem com hotspot, porem ao eliminar estes roteadores e deixando os modens em bridge não tem jeito de fazer funcionar.

    vou detalhar bem como eu fiz para ver se podem me ajudar.

    RB 450G com MK 3.28

    Link1 - netvirtua = ether1
    Link2 - GVT bridge = ether2
    Clientes - hotspot = ether4

    /ip dhcp-client
    add add-default-route=yes comment="" default-route-distance=0 disabled=no \
    interface=ether1 use-peer-dns=yes use-peer-ntp=yes
    add add-default-route=yes comment="" default-route-distance=0 disabled=no \
    interface=ether2 use-peer-dns=yes use-peer-ntp=yes

    /ip dns
    set allow-remote-requests=no cache-max-ttl=1w cache-size=2048KiB \
    max-udp-packet-size=512 primary-dns=189.38.95.95 secondary-dns=\
    189.4.64.17

    /ip firewall mangle
    add action=accept chain=prerouting comment="SEM BALANCE" disabled=no \
    dst-address-list=sem_balance in-interface=ether4
    add action=mark-connection chain=input comment="" connection-state=new \
    disabled=no in-interface=ether1 new-connection-mark=conn_na passthrough=\
    yes
    add action=mark-connection chain=input comment="" connection-state=new \
    disabled=no in-interface=ether2 new-connection-mark=conn_nb passthrough=\
    yes
    add action=mark-routing chain=output comment="" connection-mark=conn_na \
    disabled=no new-routing-mark=to_ra passthrough=no
    add action=mark-routing chain=output comment="" connection-mark=conn_nb \
    disabled=no new-routing-mark=to_rb passthrough=no
    add action=mark-connection chain=prerouting comment="" disabled=no \
    dst-address-type=!local in-interface=ether4 new-connection-mark=conn_ma0 \
    passthrough=yes per-connection-classifier=both-addresses:2/0
    add action=mark-connection chain=prerouting comment="" disabled=no \
    dst-address-type=!local in-interface=ether4 new-connection-mark=conn_mb1 \
    passthrough=yes per-connection-classifier=both-addresses:2/1
    add action=mark-routing chain=prerouting comment="" connection-mark=conn_ma0 \
    disabled=no in-interface=ether4 new-routing-mark=to_nra passthrough=no
    add action=mark-routing chain=prerouting comment="" connection-mark=conn_mb1 \
    disabled=no in-interface=ether4 new-routing-mark=to_nrb passthrough=no

    /ip route
    add comment="" disabled=no distance=3 dst-address=0.0.0.0/0 gateway=ether2
    add comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=ether1 \
    routing-mark=to_nra
    add comment="" disabled=no distance=2 dst-address=0.0.0.0/0 gateway=ether1
    add comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=ether2 \
    routing-mark=to_nrb

    /ip firewall nat
    add action=masquerade chain=srcnat comment=HOTSPOT disabled=no src-address=\
    10.5.50.0/16

    bem é isso, não vou adicionar as regras do hotspot pois eu configuro ele padrão seguindo o winbox.

    se alguem puder me ajudar eu agradeço muito, pois ja estou quebrando a cabeça fazem algumas semanas e não consegui resolver.

    um Grande abraço a todos.

  4. #16

    Padrão erro /ip route

    Bom dia amigo, ja tive o mesmo problema e vou te explicar o que acontece: Não podemos colocar como gateway-interface uma interface ethernet (ether1, ether2). Colocar o gateway como interface, só funciona para interfaces ponto-a-ponto (ppp-client, pppoe-client, etc). No caso as interfaces ethernet sao interfaces broadcast portanto nao funciona colocando as mesmas como gateway diretamente.
    No caso do Virtua, nao tem oq fazer... só um roteador na frente mesmo, no caso do GVT é só colocar o modem em bridge, criar um pppoe-client no mikrotik, e no /ip route , colocar a interface como sendo esse pppoe-client. Faça como no exemplo abaixo (ja testado em outras ocasioes e funcionando muito bem), supondo que 192.168.0.1 seja o ip do roteador que recebe o virtua, e o virtua seja a rota padrao do sistema:

    # RB 450G com MK 3.28

    # Link1 - netvirtua = ether1
    # Link2 - GVT bridge = pppoe-out1
    # Clientes - hotspot = ether4
    # Substitua o user e password do pppoe-client conforme as nescessidades

    /interface pppoe-client
    add ac-name="" add-default-route=no allow=pap,chap,mschap1,mschap2 comment="" dial-on-demand=no disabled=no interface=\
    ether2 max-mru=1480 max-mtu=1480 mrru=disabled name=pppoe-out1 password=12345678 profile=default service-name="" \
    use-peer-dns=no [email protected]

    /ip address
    add address=192.168.0.2/24 broadcast=192.168.0.255 comment="" disabled=no interface=ether1 network=192.168.0.0

    /ip dns
    set allow-remote-requests=yes cache-max-ttl=1w cache-size=4096KiB \
    max-udp-packet-size=512 primary-dns=189.38.95.95 secondary-dns=\
    189.38.95.96

    /ip firewall mangle
    add action=accept chain=prerouting comment="SEM BALANCE" disabled=no \
    dst-address-list=sem_balance in-interface=ether4
    add action=mark-connection chain=input comment="" connection-state=new \
    disabled=no in-interface=ether1 new-connection-mark=conn_na passthrough=\
    yes
    add action=mark-connection chain=input comment="" connection-state=new \
    disabled=no in-interface=ether2 new-connection-mark=conn_nb passthrough=\
    yes
    add action=mark-routing chain=output comment="" connection-mark=conn_na \
    disabled=no new-routing-mark=to_ra passthrough=no
    add action=mark-routing chain=output comment="" connection-mark=conn_nb \
    disabled=no new-routing-mark=to_rb passthrough=no
    add action=mark-connection chain=prerouting comment="" disabled=no \
    dst-address-type=!local in-interface=ether4 connection-state=new new-connection-mark=conn_ma0 \
    passthrough=yes per-connection-classifier=both-addresses:2/0
    add action=mark-connection chain=prerouting comment="" disabled=no \
    dst-address-type=!local in-interface=ether4 connection-state=new new-connection-mark=conn_mb1 \
    passthrough=yes per-connection-classifier=both-addresses:2/1
    add action=mark-routing chain=prerouting comment="" connection-mark=conn_ma0 \
    disabled=no in-interface=ether4 new-routing-mark=to_ra passthrough=no
    add action=mark-routing chain=prerouting comment="" connection-mark=conn_mb1 \
    disabled=no in-interface=ether4 new-routing-mark=to_rb passthrough=no

    /ip firewall nat
    add action=masquerade chain=srcnat out-interface=ether1 comment="NAT" disabled=no
    add action=masquerade chain=srcnat out-interface=pppoe-out1 disabled=no

    /ip route
    add comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=192.168.0.1
    add comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=192.168.0.1 \
    routing-mark=to_ra
    add comment="" disabled=no distance=2 dst-address=0.0.0.0/0 gateway=pppoe-out1
    add comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=pppoe-out1 \
    routing-mark=to_rb



  5. #17

    Padrão

    Ótimo post, show de bola, esse vai pros meus Favoritos!

    Abraços!

  6. #18

    Padrão

    Fiz a configuração, porem, notei que os links não "somam".
    Cenario:

    Link dedicado 2MB.
    ADSL ip valido e fixo 6MB.

    Após essas configurações (modifiquei de acordo com minha necessidade), qdo eu adicionei as 2 rotas, uma delas ficou em azul (segunda rota, do link adsl, é normal?
    Qdo executo um download, o mesmo não passa dos 2mb, ou seja, velocidade do primeiro link.
    No momento do donwload, eu verifico na interface da ADSL, que a mesma continua com pouquissimo trafego.
    Disparei entao 2 downloads e o mm também não passaram de 2mb juntos.