+ Responder ao Tópico



  1. #161

    Padrão

    Citação Postado originalmente por tiagomatias Ver Post
    sim, faça a marcação com mark-routing do IP deste cliente e faça ele sair pelo link default
    Tem como dar um exemplo na pratica?

  2. #162

    Padrão

    Citação Postado originalmente por m4d3 Ver Post
    O tiago já respondeu essa no tópico PCC, procure por "loopback" esta bem explicadinho, use a busca aqui do fórum que vai encontrar na primeira.
    Eu encontrei o topico que vc citou, mais meu problema é outro, ates de implantar o PCC, eu acessava meu site que é hospedado localmente de qualquer parte do brasil, e acho que ate fora dele tbm, agora não consigo mais, so vou ate o MK que faz o balanceamento, nõ paço dele de forma alguma, nem meus Mks que estão depois do MK-Balanceador eu não consigo acessar.
    Ex. meu ip fixo 123.321.52.1, é por ele que acessava toda minha rede quando estava em outro local fora dela. Tenho o dominio meganetonline.com.br , onde redireciona pro meu ipfixo, se eu pegar meu dominio e colocar no winbox eu acesso o Mk-Balanceador, mais so ate ele, não passo pros mks que estão depois dele, se eu libero meu ipfixo pra sair do load, o load para, se eu libero o ip do Mk-Controlador, o load tbm para, pois todas as requisições passam pelo ip fixo. O servidor local que hospeda a minha pagina tbm é a mesma que faço cache é ligadado no MK-Controlador, ja tentei tudo que eu imaginei, mais não vai tbm, os outro MKs estão em portas diferentes da padrão, dei um acept no mangle pra essas portas e tbm não passa ate marca alguma coisa, mais o load não deixa passar, se eu desativo o load funciona.

    Como eu resolvo esse problema, ou não tem solução mesmo?



  3. #163

    Padrão

    Citação Postado originalmente por thiagotgc Ver Post
    Tem como dar um exemplo na pratica?
    veja esse tópico que explico em outra situação como se faz.

    link >>> https://under-linux.org/f128610-pcc-18#post438571

  4. #164

    Padrão

    Citação Postado originalmente por rogeriodj Ver Post
    Eu encontrei o topico que vc citou, mais meu problema é outro, ates de implantar o PCC, eu acessava meu site que é hospedado localmente de qualquer parte do brasil, e acho que ate fora dele tbm, agora não consigo mais, so vou ate o MK que faz o balanceamento, nõ paço dele de forma alguma, nem meus Mks que estão depois do MK-Balanceador eu não consigo acessar.
    Ex. meu ip fixo 123.321.52.1, é por ele que acessava toda minha rede quando estava em outro local fora dela. Tenho o dominio meganetonline.com.br , onde redireciona pro meu ipfixo, se eu pegar meu dominio e colocar no winbox eu acesso o Mk-Balanceador, mais so ate ele, não passo pros mks que estão depois dele, se eu libero meu ipfixo pra sair do load, o load para, se eu libero o ip do Mk-Controlador, o load tbm para, pois todas as requisições passam pelo ip fixo. O servidor local que hospeda a minha pagina tbm é a mesma que faço cache é ligadado no MK-Controlador, ja tentei tudo que eu imaginei, mais não vai tbm, os outro MKs estão em portas diferentes da padrão, dei um acept no mangle pra essas portas e tbm não passa ate marca alguma coisa, mais o load não deixa passar, se eu desativo o load funciona.

    Como eu resolvo esse problema, ou não tem solução mesmo?
    Eu já respondi essa sua pergunta em outro topico, e tenho certeza q vc conseguirá se conseguir seguir ele. Tenho um exemplo parecido com o seu e funciona como o exemplo que te disse.

    link >>>>> https://under-linux.org/f128610-pcc-18#post438571



  5. #165

    Padrão

    Citação Postado originalmente por tiagomatias Ver Post
    Eu já respondi essa sua pergunta em outro topico, e tenho certeza q vc conseguirá se conseguir seguir ele. Tenho um exemplo parecido com o seu e funciona como o exemplo que te disse.

    link >>>>> https://under-linux.org/f128610-pcc-18#post438571
    Sim Tiago, do seu modo funciona a pagina, mais mesmo assim não terei acesso ao meu outros Mks da rede, perderei meu servidor radius( MK-Auth e a pagina que eu uso é do MK-Auth tbm) e tbm perderei meu proxy. Não teria outra solução, mesmo que seja mais complicada?

  6. #166

    Padrão

    Citação Postado originalmente por tiagomatias Ver Post
    sim, faça a marcação com mark-routing do IP deste cliente e faça ele sair pelo link default
    amigo, como fasso isso, tem como vc me passar um exemplo? outra coisa, preciso acessar meu mk de controle de fora, como fasso pra redirecionar um ip valido pro meu mk de controle?

    se preciso eu pago por essas informacoes ok

    vlw



  7. #167

    Padrão

    Citação Postado originalmente por tiagomatias Ver Post
    veja esse tópico que explico em outra situação como se faz.

    link >>> https://under-linux.org/f128610-pcc-18#post438571
    Entao Tiago, mas ali voce usa o Roteamento para forçar...

    Eu nao quero mexer nisso, quero apenas por marcação, sem roteamento junto.. tem como?

  8. #168

    Padrão

    Citação Postado originalmente por thiagotgc Ver Post
    Entao Tiago, mas ali voce usa o Roteamento para forçar...

    Eu nao quero mexer nisso, quero apenas por marcação, sem roteamento junto.. tem como?
    Que eu saiba não, mas se souber como fazer posta ai para nós.



  9. #169

    Padrão

    Depois do Pcc tbm estou tendo problemas para envio do backup de meus MKs por email tbm...
    Como resolver isso? Segue a imagem do erro!

    Pensei que era erro no MK-Balanceador, formatei e fiço todas as regras novamentes na mão, mai não funcionou mesmo...
    Miniaturas de Anexos Miniaturas de Anexos Clique na imagem para uma versão maior

Nome:	         erroemail.jpg
Visualizações:	134
Tamanho: 	246,4 KB
ID:      	5824  

  10. #170

    Padrão mk

    pode definir sai por uma unica rota esse endereço, pode acontecer essses erros pricipalmente com adls quando nao se defini uma rota fixa pra esse tipo de serviço, teste colocando o host do seu endereço de e-mail sair por um unico link so pra teste. J vi muito isso pra mandar msgs em exesso pra celulares etc



  11. #171

    Padrão

    Citação Postado originalmente por aprinou Ver Post
    pode definir sai por uma unica rota esse endereço, pode acontecer essses erros pricipalmente com adls quando nao se defini uma rota fixa pra esse tipo de serviço, teste colocando o host do seu endereço de e-mail sair por um unico link so pra teste. J vi muito isso pra mandar msgs em exesso pra celulares etc
    Teria como me mostrar como se faz o regra, pois ja coloquei uma regra de accept, antes do PCC, mesmo assim não funcionou, fiço uma outra marcando a rota e tbm não funcionou, mesmo desativando o PCC da esse erro...

  12. #172

    Padrão

    se da erro mesmo sem pcc ai nao é problema no balanceamento, mais pra definir cria uma regra que voce vai direcionar o host de seu e-mail pra sair por um unico link e coloque ele acima de todas no mangle. e cre a rota dele.



  13. #173

  14. #174

    Padrão

    Citação Postado originalmente por aprinou Ver Post
    se da erro mesmo sem pcc ai nao é problema no balanceamento, mais pra definir cria uma regra que voce vai direcionar o host de seu e-mail pra sair por um unico link e coloque ele acima de todas no mangle. e cre a rota dele.
    Eu não sei o que aconteceu mais agora ta funcionando normal, as vezes da timeout, as vezes ~da erro de autenticação, mais ta funcionando!

    O PCC é uma maravilha, se vc não precisar acessar sua rede extenamente, se vc tem uma pagina hospedada, por exemplo, na mesma maquina que vc faz o cache, ou se precisar acessar o seu mk-controlador, ai ja era. Nesses quesitos prefiro o PFsense, esse papel ele faz certinho, tem tbm o ZeroShell, esse ainda eu não mexi, eu realmente vou abandonar o PCC do Mikrotik, estou muito descepcionado, ele não deixa passar nada, ja tentei varias regras que meus colegas me passaram mais mesmo assim não vai...
    Fica ai meu desabafo, o PCC é otimo, se vc não precisar de acessar nada que venha depois dele!



  15. #175

    Padrão

    Citação Postado originalmente por rogeriodj Ver Post
    Eu não sei o que aconteceu mais agora ta funcionando normal, as vezes da timeout, as vezes ~da erro de autenticação, mais ta funcionando!

    O PCC é uma maravilha, se vc não precisar acessar sua rede extenamente, se vc tem uma pagina hospedada, por exemplo, na mesma maquina que vc faz o cache, ou se precisar acessar o seu mk-controlador, ai ja era. Nesses quesitos prefiro o PFsense, esse papel ele faz certinho, tem tbm o ZeroShell, esse ainda eu não mexi, eu realmente vou abandonar o PCC do Mikrotik, estou muito descepcionado, ele não deixa passar nada, ja tentei varias regras que meus colegas me passaram mais mesmo assim não vai...
    Fica ai meu desabafo, o PCC é otimo, se vc não precisar de acessar nada que venha depois dele!
    Kra... ta fogo mesmo....

    Fiz o PCC e depois dele fiz um TS para meus clientes... mas ninguem conecta de fora....

    Incrivel!!!! por que sera hein???

    Sem contar que deveria ter algum jeito de quando habilitar o PCC para "somar" os links, ele nao dar erros nas paginas.... sei la... algo do tipo...

    Vlwww

  16. #176

    Padrão

    Ola pessoal, implementei esse PCC balance na minha rb450g, e estou muito satisfeito!!
    Sou iniciante e gostaria de saber como tratar as portas do msn para sairem só por um link? No meu caso um adsl.
    Desde ja agradeço ao pessoal que sempre me ajudou aki no forum!



  17. #177

    Padrão PCC 3 Links e 3 Redes

    Caros colegas sou usuário do forum ha algum tempo mas na maioria das vezes para consultas apenas, mas chegou a minha hora de pedir HELP também.

    Minha necessidade é a seguinte

    Link 1 -----\ ______________/ ---- Rede 1 (192.168.0.0/24)
    Link 2 ------> MKT Controler< ----- Rede 2 (192.168.1.0/24)
    Link 3 -----/ ______________\ ---- Rede 3 (192.168.2.0/24)

    Sendo que cada link mencionado já se encontram roteado na mesma rede correspondente como ex:

    Link 1 (192.168.0.1 ) na Rede 1 (192.168.0.0/24)

    Em linhas gerais é o seguinte gostaria de usar a "facinante" solução PCC nos meus links mas disponibilizar todos para as 3 redes, seguindo os wiki e tutoriais situados aqui no forum e no da Mikrotik não alcancei de fazer as configurações necessarias para a minha necessidade.

    Conto com a compreensão de todos e apoio

    *** Obs: Estou usando Router OS 4.1 Level 5

    Alessandro Dias

  18. #178

    Padrão

    Citação Postado originalmente por mauricionofre Ver Post
    Ola pessoal, implementei esse PCC balance na minha rb450g, e estou muito satisfeito!!
    Sou iniciante e gostaria de saber como tratar as portas do msn para sairem só por um link? No meu caso um adsl.
    Desde ja agradeço ao pessoal que sempre me ajudou aki no forum!
    Amigo segue minha ajuda, apenas troque conforme sua necessidade, obs:

    Aonde esta "80" troque pela porta que voce quer
    Aonde esta 10.1.1.0/29 troque pela sua rede local
    Aonde esta xxx.xxx.xxx.xxx coloque seu gateway 1
    Aonde esta o yyy.yyy.yyy.yyy coloque seu gateway 2

    Qualquer duvida poste aqui


    /ip firewall mangle

    add action=mark-routing chain=prerouting comment="FORCAR SAIDA LINK1" disabled=no new-routing-mark=Forcar_Saida_Link1 passthrough=no protocol=tcp \
    src-address=10.1.1.0/29
    add action=mark-routing chain=prerouting comment="" disabled=no dst-port=80 new-routing-mark=Forcar_Saida_Link1 passthrough=no protocol=tcp src-address=\
    add action=mark-routing chain=prerouting comment="FORCAR SAIDA LINK2" disabled=no new-routing-mark=Forcar_Saida_Link2 passthrough=no protocol=tcp \
    src-address=10.1.1.0/29
    add action=mark-routing chain=prerouting comment="" disabled=no dst-port=21 new-routing-mark=Forcar_Saida_Link2 passthrough=no protocol=tcp src-address=\
    10.1.1.0/29
    /ip route

    add comment="FORCAR SAIDA LINK1" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=xxx.xxx.xxx.xxx routing-mark=Forcar_Saida_Link1 scope=30 target-scope=\
    10
    add comment="FORCAR SAIDA LINK1" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=yyy.yyy.yyy.yyy routing-mark=Forcar_Saida_Link2 scope=30 target-scope=10



  19. #179

    Padrão Balanceamento

    agora utilizando os classificadores (0,1,2 e portanto são 3) na interface de clientes criamos novas marcas de conexão (conn_ma0, conn_mb1, conn_mc2), notem que se tivessemos 4 links seria aquie que fariamos as alterações para (0,1,2,3 e portanto são 4) ficando 4/0, 4/1, 4/2, 4/3 ou ainda se tivessemos links assimétricos onde por exemplo:

    LinkX de 512k
    LinkY de 1024k
    LinkZ de 2048k

    somariamos todos os links e dividiriamos pelo valor do menor link então teriamos 3584k/512k=7 então teriamos 7 marcações de pcc indo de 7/0 até 7/6 das quais devemos direcionar a primeira pro link X, a segunda e terceira pro link Y e as quatro restantes para o link Z fazendo nosso sistema perfeitamente equilibrado, vale resaltar que sistemas do tipo ADSL não garantem a banda e portanto devemos fazer testes em cada um dos links para aferir as velocidades possíveis em cada um, já vi muitos casos onde um link desse tipo de 2Mb era melhor do que o de 4Mb da mesma operadora instalada no mesmo local, também se deve criar as marcações para input e output.




    Amigo vc poderia demostrar como faço pra colocar duas conexoes pra um link tres pra outro link e quatro pra outro link, nao leve a mau é pq tenho varios links q nao sao do mesmo valores ............

  20. #180

    Padrão

    Citação Postado originalmente por Binhos5 Ver Post
    Amigo vc poderia demostrar como faço pra colocar duas conexoes pra um link tres pra outro link e quatro pra outro link, nao leve a mau é pq tenho varios links q nao sao do mesmo valores ............
    Eu não entendo essa sua pergunta.