+ Responder ao Tópico



  1. #1

    Padrão Load Balance nth bancos e msn 100%

    Boa tarde galera do furum, ja recorri muitas veses a este forum para resolver meus problemas, mas não teve jeito de arrumar o load balance com nth fazendo com que os bancos e alguns sites que fazem verificação de ip e o msn funcionassem direito, até tinha troca de ld varias veses, mas nenhum é tão bom quanto o nth, então bati muito a cabeçae saiu um lb bacana e venho aqui compartilhar com vcs, espero que ajude alguem, como ta me ajudando.... vai as regras ai em baixo.....

    para fazer este load usei uma maquina só pra fazer o load, usei um pentiu 233 com 32 de ram, e 2 placas de rede, uma para entrar os links adsl e outra para mandar o link para o server que faz controle de banda

    interfaces

    / ip address
    add address=192.168.3.222/24 network=192.168.3.0 broadcast=192.168.3.255 \
    interface=Link comment="Link1" disabled=no
    add address=192.168.4.222/24 network=192.168.4.0 broadcast=192.168.4.255 \
    interface=Link comment="LINK2" disabled=no
    add address=172.20.254.254/16 network=172.20.0.0 broadcast=172.20.255.255 \
    interface=Saida comment="SAIDA PARA SERVER" disabled=no
    add address=192.168.2.222/24 network=192.168.2.0 broadcast=192.168.2.255 \
    interface=Link comment="Link3" disabled=no

    pulo do gato

    / ip firewall address-list
    add list=nobalance address=65.54.0.0/16 comment="MSN1" disabled=no
    add list=nobalance address=207.46.0.0/16 comment="MSN2" disabled=no
    add list=nobalance address=64.4.0.0/16 comment="MSN3" disabled=no

    coloque no address-list todos os ips dos sites de bancos msn, etc que vc não quer que passe pelo load

    mangle

    / ip firewall mangle
    add chain=prerouting in-interface=Saida connection-state=new nth=2,1,0 \
    src-address-list=!nobalance action=mark-connection new-connection-mark=odd \
    passthrough=yes comment="LB Odd" disabled=no
    add chain=prerouting in-interface=Saida connection-mark=odd \
    action=mark-routing new-routing-mark=odd passthrough=no comment="Odd LB" \
    disabled=no
    add chain=prerouting in-interface=Saida connection-state=new nth=2,1,1 \
    src-address-list=!nobalance action=mark-connection \
    new-connection-mark=even passthrough=yes comment="LB Even" disabled=no
    add chain=prerouting in-interface=Saida connection-mark=even \
    action=mark-routing new-routing-mark=even passthrough=no comment="Even LB" \
    disabled=no
    add chain=prerouting in-interface=Saida connection-state=new nth=2,1,2 \
    src-address-list=!nobalance action=mark-connection \
    new-connection-mark=odd1 passthrough=yes comment="LB Odd1" disabled=no
    add chain=prerouting in-interface=Saida connection-mark=odd1 \
    action=mark-routing new-routing-mark=odd1 passthrough=no comment="Odd LB1" \
    disabled=no

    nat

    / ip firewall nat
    add chain=srcnat out-interface=Link action=masquerade comment="Nat" \
    disabled=no
    add chain=srcnat connection-mark=odd action=src-nat to-addresses=192.168.4.222 \
    to-ports=0-65535 comment="LB Redirect Odd" disabled=no
    add chain=srcnat connection-mark=even action=src-nat \
    to-addresses=192.168.3.222 to-ports=0-65535 comment="LB Redirect Even" \
    disabled=no
    add chain=srcnat connection-mark=odd1 action=src-nat \
    to-addresses=192.168.2.222 to-ports=0-65535 comment="LB Redirect Odd1" \
    disabled=no

    ip route

    / ip route
    add dst-address=0.0.0.0/0 gateway=192.168.4.254 scope=255 target-scope=10 \
    routing-mark=even comment="LB Route Odd" disabled=no
    add dst-address=0.0.0.0/0 gateway=192.168.3.254 scope=255 target-scope=10 \
    routing-mark=odd comment="LB Route Odd" disabled=no
    add dst-address=0.0.0.0/0 gateway=192.168.4.254 scope=255 target-scope=10 \
    comment="LB Route Odd" disabled=no
    add dst-address=0.0.0.0/0 gateway=192.168.2.254 scope=255 target-scope=10 \
    routing-mark=odd1 comment="" disabled=no

    ta ai galera...o pulo do gato é o seguinte....adicionar os ips no / ip address-list isso fara com que eles não passem pelo lb e fica redondo....testem que vcs vão ver que funciona....

    Abraços.....

    Anderson Junior
    Última edição por scinfovirtual; 01-11-2009 às 21:02.

  2. #2

    Padrão OPa

    humm vai ajudar muita gente!

    eu uso load PCC aqui, mais como a muitos ainda usam Mikrotik V2.9 vai ajudar muitos!

    parabens!



  3. #3

    Padrão

    scinfovirtual show de bola esse load vou testar aki para ver como fica. scinfovirtual valeu.
    So ficou faltando colocar os modens em bridge.

  4. #4

    Padrão

    Boa tarde, aqui no meu caso, eu autentico os modens com access point antes de chegarem ao mk, assim resolvi o problema dos travamentos, tente ai autenticar os modens em access point, ai joga tudo em uma unica interface e rola blz....



  5. #5

    Padrão

    Boa tarde. Gostaria de algumas explicaçoes sou novato no mundo MK.

    1. eu autentico os modens com access point antes de chegarem ao mk, poderia me dar mais detalhes do funcionamento.
    2. ai joga tudo em uma unica interface e rola blz...., nao entendi como fucionaria nesse modo.
    3. add address=192.168.3.222/24 network=192.168.3.0 broadcast=192.168.3.255 \
    interface=Link comment="Link1" disabled=no, esse ip seria ips dos modens, se for poderia ser qualquer um.


    Detalhes do minha configuração....
    Tenho em funcionamento MK funcionando com Hotpost mais cache no proprio MK, e demais controles. Possuo 2 ADSl de 8 mega cada sendo usada somente uma para todos os clientes, o modem que esta em uso esta em bridge.
    Possuo um outro computador com um configuraçao basica e com 3 placas de redes.
    Gostaria de mais detalhes de como posso fazer esse load que funcione na minha rede.
    Desde ja agradeço pela sua atenção.

  6. #6

    Padrão

    autentico os modens em um access point porque normalmente se vc deixa-los roteados ele travam muito,ai vc manda com um ip qualquer para o seu server, vc pode adicionar varios ips na interface de entrada dos links não vai precizar de uma placa de rede pra cada link....sim...pode ser qualquer ip...sendo que o seu ap sejam faixas corretas, o balance é bom sempre fazer em uma maquina separada para que fique bem estavel....

    para de tar mais detalhes me passe suas divudas...no mais ta tudo nos scripts no primeiro post....qualquer coisa poste suas duvidas



  7. #7

    Padrão

    valeu, estou estudando aki para colcar em pratica na rede.

  8. #8



  9. #9

    Padrão

    Vou passar o pulo do gato que desenvolvi:
    / ip firewall mange
    add chain=prerouting in-interface=EthClientes protocol=tcp dst-port=443 \
    connection-state=new action=mark-connection \
    new-connection-mark=off-balance passthrough=yes comment="OFF_BALANCE" \
    disabled=no
    / ip firewall nat
    add chain=srcnat out-interface="Seu Link Default" connection-mark=off-balance \
    action=masquerade comment="" disabled=no

    Pronto....

  10. #10

    Padrão

    Vlw...obrigado por sua Contribuição....infelismente pra mim eu nunca concegui fazer esta regra funcionar, mas ja a vi varias veses ai no forum e muitos tiveram sucesso....uso a marcação daquela forma porque colocando no address list depois eu seto uma dos links pra fazer uma marcação a menos e assim deixo ele para os ips que não devem ser balanceados....tive mais aproveitamento desta forma. Mas vlw pela sua Contribuição!



  11. #11
    Não Registrado(s)
    Visitante

    Padrão

    precisa adicionar os ips dos clientes no adress list?

  12. #12

    Padrão

    o meu modem esta em bridge e não tou conseguindo entra no msn e nem no email da hotmail, alguem poderia me ajudar.



  13. #13

    Padrão

    Citação Postado originalmente por clecioe Ver Post
    o meu modem esta em bridge e não tou conseguindo entra no msn e nem no email da hotmail, alguem poderia me ajudar.

    Explique melhor a situação....

  14. #14

    Padrão

    tenho uma rb450g fazendo o balanceamento de carga todos 3 modem discando, usei o software do scan para fazer as configurações do meu modem que não tenho nada a reclamar, mas fiquei com um probleminha no site da hotmail e msn que não abre de jeito nenhum

    rb 3 link em bridge
    pc mikrotik recebendo do loadbalance e repassando para os clientes uso dns da operadora, mas o interessante é que tem uns clientes meus que abre o msn + hotmail e tem outros que não abre. ja fiz varias tentativas de ip address list colocar os ip e nada.

    configuração da rede;
    rb450g manda para pc mikrotik dentro do pc mikrotik eu fiz uma bridge dentro sera que essa bridge é que ta atrapalhando a passagem dos pacotes?



  15. #15

    Padrão

    Citação Postado originalmente por clecioe Ver Post
    tenho uma rb450g fazendo o balanceamento de carga todos 3 modem discando, usei o software do scan para fazer as configurações do meu modem que não tenho nada a reclamar, mas fiquei com um probleminha no site da hotmail e msn que não abre de jeito nenhum

    rb 3 link em bridge
    pc mikrotik recebendo do loadbalance e repassando para os clientes uso dns da operadora, mas o interessante é que tem uns clientes meus que abre o msn + hotmail e tem outros que não abre. ja fiz varias tentativas de ip address list colocar os ip e nada.

    configuração da rede;
    rb450g manda para pc mikrotik dentro do pc mikrotik eu fiz uma bridge dentro sera que essa bridge é que ta atrapalhando a passagem dos pacotes?

    Tenho quase certeza que o problema está nas rotas.

    pode passar as conf do seu load pra avaliar?

  16. #16

    Padrão

    se precisar de mais alguma coisa é só avisar ja estou ficando aperiado .

    /ip firewall nat print
    0 I chain=srcnat action=masquerade out-interface=wan1
    1 chain=srcnat action=masquerade out-interface=wan2adsl
    2 chain=srcnat action=masquerade out-interface=wan3adsl
    3 I chain=srcnat action=masquerade out-interface=wan4adsl

    /ip firewall mangle
    0 ;;; HTTPS FORA DO LOADBALACED
    chain=prerouting action=accept protocol=tcp in-interface=local
    dst-port=443
    1 ;;; FORA DO LOADBALACED
    chain=prerouting action=accept dst-address-list=loopback
    in-interface=local
    2 ;;; Filtro Tracert / Traceroute
    chain=forward action=change-ttl new-ttl=set:30 protocol=icmp
    3 I chain=prerouting action=mark-connection new-connection-mark=wan1_conn
    passthrough=yes in-interface=wan1
    4 chain=prerouting action=mark-connection new-connection-mark=wan2adsl_conn
    passthrough=yes in-interface=wan2adsl
    5 chain=prerouting action=mark-connection new-connection-mark=wan3adsl_conn
    passthrough=yes in-interface=wan3adsl
    6 I chain=prerouting action=mark-connection new-connection-mark=wan4adsl_conn
    passthrough=yes in-interface=wan4adsl

    /ip firewall mangle
    0 ;;; HTTPS FORA DO LOADBALACED
    chain=prerouting action=accept protocol=tcp in-interface=local
    dst-port=443
    1 ;;; FORA DO LOADBALACED
    chain=prerouting action=accept dst-address-list=loopback
    in-interface=local
    2 ;;; Filtro Tracert / Traceroute
    chain=forward action=change-ttl new-ttl=set:30 protocol=icmp
    3 I chain=prerouting action=mark-connection new-connection-mark=wan1_conn
    passthrough=yes in-interface=wan1
    4 chain=prerouting action=mark-connection new-connection-mark=wan2adsl_conn
    passthrough=yes in-interface=wan2adsl
    5 chain=prerouting action=mark-connection new-connection-mark=wan3adsl_conn
    passthrough=yes in-interface=wan3adsl

    6 I chain=prerouting action=mark-connection new-connection-mark=wan4adsl_conn
    passthrough=yes in-interface=wan4adsl

    /ip route
    0 S ;;; Link1
    0.0.0.0/0 unreachable 192.168.200.2 1
    1 A S ;;; Link3
    0.0.0.0/0 reachable wan3adsl 1 wan3adsl
    2 S ;;; Link1
    0.0.0.0/0 unreachable 192.168.200.2 1
    3 A S ;;; Link2
    0.0.0.0/0 reachable wan2adsl 1 wan2adsl
    4 S ;;; Link4
    0.0.0.0/0 unreachable wan4adsl 1
    5 A S ;;; Link2
    0.0.0.0/0 reachable wan2adsl 2 wan2adsl
    6 S ;;; Link3
    0.0.0.0/0 reachable wan3adsl 3 wan3adsl
    7 S ;;; Link4
    0.0.0.0/0 unreachable wan4adsl 4
    8 ADC 192.168.100.0/24 192.168.100.3 0 wan3
    9 ADC 192.168.110.0/24 192.168.110.3 0 wan2
    10 ADC 192.168.254.0/24 192.168.254.2 0 local
    11 ADC 200.217.89.32/32 187.40.222.210 0 wan2adsl
    12 DC 200.217.89.32/32 187.40.219.204 0 wan3adsl

    /ip address>
    192.168.254.2/24 192.168.254.0 192.168.254.255 local
    192.168.200.3/24 192.168.200.0 192.168.200.255 wan1
    2 192.168.100.3/24 192.168.100.0 192.168.100.255 wan3
    3 192.168.110.3/24 192.168.110.0 192.168.110.255 wan2
    4 D 187.40.222.210/32 200.217.89.32 0.0.0.0 wan2adsl
    5 D 187.40.219.204/32 200.217.89.32 0.0.0.0 wan3adsl



  17. #17

    Padrão Re: Load Balance nth bancos e msn 100%

    rps67 ....

    Ola tem dado certo seu Balance que soma as carga?