+ Responder ao Tópico



  1. Bom pessoal, já testei vários scripts e reparei que tem uns que funcionam e talz, o que acontece é que quando o DDNS atualiza com o Ip da minha interface 2 .. eu nao consigo conectar... vou esclarecer ...


    Tenho duas situações, uma com 2 Adsl e outra com 5 rodando em PCC balance com modens em Bridge, o que acontece é que o mikrotik só aceita conexões de fora no winbox pela wan1 ... pelas outras eu não consigo de jeito nenhum ... não sei mais o que fazer ... pois tenho duas redes e não consigo acessa-las de fora quando o ddns atualiza com o ip de outra wan ... o script que eu estou usando é este aki

    # Define User Variables
    :global ddnsuser "user"
    :global ddnspass "senha"
    :global ddnshost "host.changeip.org"

    # Define Global Variables
    :global ddnsip
    :global ddnslastip
    :if ([ :typeof $ddnslastip ] = nil ) do={ :global ddnslastip "0" }

    :global ddnsinterface
    :global ddnssystem ("mt-" . [/system package get system version] )

    # Define Local Variables
    :local int

    # Loop thru interfaces and look for ones containing
    # default gateways without routing-marks
    :foreach int in=[/ip route find dst-address=0.0.0.0/0 active=yes ] do={
    :if ([:typeof [/ip route get $int routing-mark ]] != str ) do={
    :global ddnsinterface [/ip route get $int interface]
    }
    }

    # Grab the current IP address on that interface.
    :global ddnsip [ /ip address get [/ip address find interface=$ddnsinterface ] address ]

    # Did we get an IP address to compare?
    :if ([ :typeof $ddnsip ] = nil ) do={
    :log info ("DDNS: No ip address present on " . $ddnsinterface . ", please check.")
    } else={

    :if ($ddnsip != $ddnslastip) do={

    :log info "DDNS: Sending UPDATE!"
    :log info [ ut [/tool dns-update name=$ddnshost address=[ick $ddnsip 0 [:find $ddnsip "/"] ] key-name=$ddnsuser key=$ddnspass ] ]
    :global ddnslastip $ddnsip

    } else={
    :log info "DDNS: No update required."
    }

    }

    # End of script
    Gostaria que se alguem já passou pela mesma coisa me ajudasse a solucionar o meu problema....


    Abraços !

  2. Ola amigo, tenta usar o script q deixei em anexo e posta o resultado.
    Arquivos Anexos Arquivos Anexos
    • Tipo de Arquivo: txt ddns.txt (2,5 KB, 162 visualizações)



  3. Amigo, implantei e talz ... vi lah no log que atualizou .. porém na verdade quando eu pingo o host o ip nao está atualizando ...

  4. isso acontece devido a voce ter somente a wan1 como link default. entao voce nao consegue mesmo acessar pelas outras interfaces.
    Voce teria que Ativar como Rota padrao a wan2, porem só entraria pela wan2 dai.

    uma sugestao cria 2 script, para o dns, um em cada interface, como nomes diferentes
    alamdiasnet1.changeip.net e alamdiasnet2.changeipl.net

    Porem voce precisa disso por que mesmo? tipo caso seu link1 caia? nao entendi a nescessidade de usar a wan2.






Tópicos Similares

  1. Respostas: 2
    Último Post: 06-07-2016, 21:46
  2. DDNS no PCC com Modem Bridge
    Por admskill no fórum Redes
    Respostas: 9
    Último Post: 23-06-2010, 11:36
  3. Modem bridge - MK Autenticando PPPoE
    Por efren no fórum Redes
    Respostas: 2
    Último Post: 01-07-2008, 22:24
  4. Modem roteado ou Modem bridge Mk discando (PPPOe) ?
    Por airtonveiga no fórum Redes
    Respostas: 5
    Último Post: 15-02-2008, 17:38
  5. Respostas: 12
    Último Post: 01-02-2008, 06:08

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L