+ Responder ao Tópico



  1. #1

    Padrão Mikrotik Cache full! Como saber se está funcionando ?

    KOew galera olha so eu tenho umas regra aqui na minha rede que se diz ser o cache full mas até agora eu não sei se funciona mesmo.
    queria sabe como eu estoo ela sem precisar ir na casa do clientee

    Segue a regra:
    /queue tree
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
    max-limit=10M name=Cache-Full packet-mark=proxyfull parent=global-total \
    priority=1 queue=default

    /ip firewall mangle
    add action=mark-connection chain=output comment="PROXY FULL - Prioridade 2" \
    disabled=no dscp=4 new-connection-mark=proxyfull passthrough=yes \
    protocol=tcp src-port=8080
    add action=mark-packet chain=output comment="" connection-mark=proxyfull \
    disabled=no new-packet-mark=proxyfull passthrough=yes
    add action=return chain=output comment="" connection-mark=proxyfull disabled=\
    no

    Quem puder me ajudar
    Gratto dez de Já..
    Última edição por Magal; 13-05-2010 às 00:39. Razão: Correção do título

  2. #2

    Padrão

    Qual a versão do seu RouterOS ? Para saber se está funcionando, baixa um arquivo de tamanho 1mb, ele baixara na velocidade determinada na queue, exemplo 300kbps, ele baixara esse arquivo em média a 30kbps. Após isso, limpe o cache do seu navegador, e baixe o mesmo arquivo novamente, se o cache estiver funcionando, ele baixará o arquivo em uma velocidade muito superior. Observe também se está havendo contagem de 'HITS' no web-proxy.

    Vejo nas suas regras que você limitou 10mb pra o cache-full, se sua rede for toda cabeada td bem, mais se usa wireless, na banda B o máximo que consegue é 4mb de tráfego, ou seja, com 10 mb você vai deixar sempre seu(s) rádio(s) no 'gargalo'. Aconselho a deixar em 2~3mb.

    Abraço



  3. #3

    Padrão

    minha rede e toda cabeada ..!no caso so estando na dentro da rede para ver se esta funcioando mesmo de fora nen tem como correto ?

  4. #4

    Padrão

    vc tem o cache full rodando aii ? Se tive compartilha regra pode ser !



  5. #5

    Padrão

    Você pode fazer o teste citado ai em cima na sua maquina que usa diariamente. Qual a versão do seu OS ? Tenho as regras aqui, mas preciso da versão

  6. #6

    Padrão

    meu mikrotik e 3.28.Meu servidor contem as seguintes peças 320 HD 2 Giga de memoria Processador Dual corel.
    a minha regra que eu tenho aquii nãoesta legal seilaa acho que esta funfadaa se puder me ajudar agradeço de mas.



  7. #7
    Não Registrado
    Visitante

    Padrão cache full

    Citação Postado originalmente por smooking Ver Post
    Você pode fazer o teste citado ai em cima na sua maquina que usa diariamente. Qual a versão do seu OS ? Tenho as regras aqui, mas preciso da versão
    Amigo tenho o mk 2.9 na minha empresa e nunca consegui fazer este cache full funcionar direito vc poderia me mandar as regras?
    Um abraço e desde ja agradeço.
    Alexandre

  8. #8

    Padrão

    Citação Postado originalmente por DeividMoika Ver Post
    vc tem o cache full rodando aii ? Se tive compartilha regra pode ser !

    segue:

    INICIO

    ip proxy>
    enabled: yes
    src-address: 0.0.0.0
    port: 3128
    parent-proxy: 0.0.0.0
    parent-proxy-port: 0
    cache-administrator: "webmaster"
    max-cache-size: 27570000KiB
    cache-on-disk: yes
    max-client-connections: 200
    max-server-connections: 200
    max-fresh-time: 3d
    serialize-connections: no
    always-from-cache: no
    cache-hit-dscp: 4
    cache-drive: primary-master

    FIM

    INICIO

    ip firewall magle>

    0 chain=output action=mark-connection new-connection-mark=conn_squid-up passthrough=yes protocol=tcp src-port=3128 content=X-Cache: HIT

    1
    chain=output action=mark-packet new-packet-mark=pacotes_squid-up passthrough=yes connection-mark=conn_squid-up

    2
    chain=prerouting action=mark-connection new-connection-mark=conn_squid-up passthrough=yes protocol=tcp dst-port=3128

    3 chain=prerouting action=mark-packet new-packet-mark=pacotes_squid-down passthrough=yes connection-mark=conn_squid-down

    FIM

    INICIO

    ip firewall nat>
    1 redireciona proxy
    chain=dstnat action=redirect to-ports=3128 protocol=tcp dst-port=80

    FIM

    ip Firewall filter>

    INICIO

    0 ;;; boqueia proxy externo
    chain=input action=drop protocol=tcp in-interface=pppoe-out1 dst-port=3128

    1 ;;; aceitar conexoes do proxy
    chain=input action=accept protocol=tcp dst-port=3128

    FIM

    INICIO
    queue tree> print

    0 name="CACHE-FULL - Download" parent=global-in packet-mark=pacotes_squid-down limit-at=0 queue=default priority=1 max-limit=0 burst-limit=0 burst-threshold=0 burst-time=0s

    1 name="CACHE-FULL - Upload" parent=global-out packet-mark=pacotes_squid-up limit-at=0 queue=default priority=1 max-limit=5000000 burst-limit=0 burst-threshold=0 burst-time=0s

    Fim

    Versao testada e funcionando 3.20!

    ate mais

    segue em anexo passos para verificar se esta funcionando note que esses valores mudam a todo momento qualquer movimentação dos valores o proxy vai estar funcionando!
    Última edição por cls7007; 01-12-2009 às 10:54.



  9. #9

    Padrão anexo!

    confira anexo
    Miniaturas de Anexos Miniaturas de Anexos Clique na imagem para uma versão maior

Nome:	         ver proxy.JPG
Visualizações:	659
Tamanho: 	72,9 KB
ID:      	6201  

  10. #10

    Padrão

    Nessa opão vc deixa desmarcado as duas opção e isso ?
    serialize-connections: no
    always-from-cache: no



  11. #11

    Padrão

    koew cara implantei as regras ja no meu servidor da uma olhada
    Segue as regras

    /queue tree
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
    max-limit=0 name="CACHE-FULL - Download" packet-mark=pacotes_squid-down \
    parent=global-in priority=1 queue=default
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
    max-limit=5M name="CACHE-FULL - Upload" packet-mark=pacotes_squid-up \
    parent=global-out priority=1 queue=default

    /ip firewall mangle
    add action=mark-connection chain=output comment="Cache Full" content=\
    "X-Cache: HIT" disabled=no new-connection-mark=conn_squid-up passthrough=\
    yes protocol=tcp src-port=3128
    add action=mark-packet chain=output comment="" connection-mark=conn_squid-up \
    disabled=no new-packet-mark=pacotes_squid-up passthrough=yes
    add action=mark-connection chain=prerouting comment="" disabled=no \
    new-connection-mark=conn_squid-up passthrough=yes protocol=tcp src-port=\
    3128
    add action=mark-packet chain=prerouting comment="" connection-mark=\
    conn_squid-down disabled=no new-packet-mark=pacotes_squid-down \
    passthrough=yes

    /ip firewall filter
    add action=drop chain=input comment="boqueia proxy externo" disabled=no \
    dst-port=3128 in-interface=Link protocol=tcp
    add action=accept chain=input comment="aceitar conexoes do proxy" disabled=no \
    dst-port=3128 protocol=tcp

    /ip firewall nat
    add action=redirect chain=dstnat comment="Web-Proxy + Cache Full" disabled=no \
    dst-port=80 protocol=tcp to-ports=3128

    /ip proxy
    set always-from-cache=yes cache-administrator="Deivid Moik\E1\E0 ( Suporte T\
    \E9cnico e Consultoria em Rede e Mikrotik ) Msn [email protected]" \
    cache-hit-dscp=4 cache-on-disk=yes enabled=yes max-cache-size=27570000KiB \
    max-client-connections=200 max-fresh-time=4w2d max-server-connections=200 \
    parent-proxy=0.0.0.0 parent-proxy-port=0 port=3128 serialize-connections=\
    yes src-address=0.0.0.0

    Fim..
    correto ?

  12. #12

    Padrão

    Citação Postado originalmente por DeividMoika Ver Post
    koew cara implantei as regras ja no meu servidor da uma olhada
    Segue as regras

    /queue tree
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
    max-limit=0 name="CACHE-FULL - Download" packet-mark=pacotes_squid-down \
    parent=global-in priority=1 queue=default
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
    max-limit=5M name="CACHE-FULL - Upload" packet-mark=pacotes_squid-up \
    parent=global-out priority=1 queue=default

    /ip firewall mangle
    add action=mark-connection chain=output comment="Cache Full" content=\
    "X-Cache: HIT" disabled=no new-connection-mark=conn_squid-up passthrough=\
    yes protocol=tcp src-port=3128
    add action=mark-packet chain=output comment="" connection-mark=conn_squid-up \
    disabled=no new-packet-mark=pacotes_squid-up passthrough=yes
    add action=mark-connection chain=prerouting comment="" disabled=no \
    new-connection-mark=conn_squid-up passthrough=yes protocol=tcp src-port=\
    3128
    add action=mark-packet chain=prerouting comment="" connection-mark=\
    conn_squid-down disabled=no new-packet-mark=pacotes_squid-down \
    passthrough=yes

    /ip firewall filter
    add action=drop chain=input comment="boqueia proxy externo" disabled=no \
    dst-port=3128 in-interface=Link protocol=tcp
    add action=accept chain=input comment="aceitar conexoes do proxy" disabled=no \
    dst-port=3128 protocol=tcp

    /ip firewall nat
    add action=redirect chain=dstnat comment="Web-Proxy + Cache Full" disabled=no \
    dst-port=80 protocol=tcp to-ports=3128

    /ip proxy
    set always-from-cache=yes cache-administrator="Deivid Moik\E1\E0 ( Suporte T\
    \E9cnico e Consultoria em Rede e Mikrotik ) Msn [email protected]" \
    cache-hit-dscp=4 cache-on-disk=yes enabled=yes max-cache-size=27570000KiB \
    max-client-connections=200 max-fresh-time=4w2d max-server-connections=200 \
    parent-proxy=0.0.0.0 parent-proxy-port=0 port=3128 serialize-connections=\
    yes src-address=0.0.0.0

    Fim..
    correto ?

    ctrl+c ctrl+v acho que vai funcionar, se a sua versão for a mesma da minha!!!

    se nao for me fala pra mim te passar pelo msn!

    abração!



  13. #13

    Padrão

    beleza o meu mk a versão e 3.28 eu coloqueii aqui amanha eu vou la na minha rede..
    e vou testar na casa de um clienteee.
    mas uma duvidaa viu oque eu te falei sobre ohh
    serialize-connections: no
    always-from-cache: no

    você deixa os dois desmarcados mesmo ?
    e me add no msn
    aii
    [email protected]

  14. #14

    Padrão

    Citação Postado originalmente por DeividMoika Ver Post
    beleza o meu mk a versão e 3.28 eu coloqueii aqui amanha eu vou la na minha rede..
    e vou testar na casa de um clienteee.
    mas uma duvidaa viu oque eu te falei sobre ohh
    serialize-connections: no
    always-from-cache: no

    você deixa os dois desmarcados mesmo ?
    e me add no msn
    aii
    [email protected]
    Sim.... estão desmarcado e funcionando perfeitamente!!!!



  15. #15

    Padrão

    Beleza vou deixar desmarcado aquii no meu tmbb.
    me manda o seu msn aii para podermos conversa melhor
    abraçoo.
    Gratoo pela sua ajuda !

  16. #16

    Padrão

    te falar uma coisa na webproxy na baia cache tenho que colocar alguma tipo de configuração espesifica.
    ?
    se tive passa a regraaa
    grattoo



  17. #17

    Lightbulb Re: Mikrotik Cache full ! Como saber se esta funicionando ?

    bom dia gostaria de uma ajuda estou fasendo testes aqui a nao estou consegindo faser o cahefull esterno ex: um mk com o proxy extermo as regras de marcasao de pacote q esta sento unsada nas esplicasoes q voces estao unsado eu nao consegi altera para um proxy esterno poderiao me dar uma ajuda nisto ?

  18. #18

    Padrão Re: Mikrotik Cache full! Como saber se está funcionando ?

    gente isso ai er Web Proxy ou cache full...ou er os dois juntos...tovendo ai uma misturahh...me explica isso aii to sem entender aindah...