Página 2 de 3 PrimeiroPrimeiro 123 ÚltimoÚltimo
+ Responder ao Tópico



  1. Citação Postado originalmente por anjunior Ver Post
    cara,

    nesse caso a solucao é fazer NAT 1:1. Muito simples e facil de implementar.

    segue abaixo a regra, é so colocar o IP e colar!

    /ip firewall nat
    add action=dst-nat chain=dstnat comment="" disabled=no dst-address=<ip publico> to-addresses=<ip privado>
    add action=src-nat chain=srcnat comment="" disabled=no src-address=<ip privado> to-addresses=<ip publico>
    usando essa regra, qual é o IP de saida do cliente, o do servidor ou o ip publico que está na regra?
    criei a regra, consegui navegar, mas continuei saindo com o ip do servidor. Eu instalei o apache na máquina pra tentar entrar, de outra máquina, nesta que está com o ip publico mas nao entrou, mesmo desativando todas as regras de firewall.

  2. Citação Postado originalmente por byosni Ver Post
    amigo acho que este link poderia te ajudar...

    Mikrotik Fácil.com: IP Válido no MikroTik e Repasse

    Até mais..
    Então, o pouco que eu consegui fazer foi em cima daquele artigo seu.

    Só que uma diferença q notei da sua rede pra minha é q meu primeiro IP já é o ip do gateway.
    Aí acontece o seguinte, se eu fizer do jeitinho q tá lá, qd eu coloco /30 no IP da WAN, o servidor perde contato com o roteador, então voltei a deixar do jeito q estava, /24.

    Aí volto ao problema inicial, não consigo sair pro roteador na máquina cliente.



  3. Citação Postado originalmente por lrmurad Ver Post
    usando essa regra, qual é o IP de saida do cliente, o do servidor ou o ip publico que está na regra?
    criei a regra, consegui navegar, mas continuei saindo com o ip do servidor. Eu instalei o apache na máquina pra tentar entrar, de outra máquina, nesta que está com o ip publico mas nao entrou, mesmo desativando todas as regras de firewall.
    O Ip de saida do cliente para a internet é o IP publico.
    Levanta esse IP que voce colocou na regra na sua interface, e testa novamente.
    Voce fazendo essa regra é como se o ip publico estivesse diretamente setado no cliente. Ele faz uma traducao completa.
    Por exemplo, se o cliente quiser acessar externamente a maquina dele, ele vai poder acessar normalmente pelo ip que vc redirecionou.

  4. vou postar as regras.

    Tentei de duas maneiras.
    1º TESTE
    ADDRESS
    # ADDRESS NETWORK BROADCAST INTERFACE
    0 192.168.100.1/24 192.168.100.0 192.168.100.255 Rede Local
    1 201.63.186.177/24 201.63.186.0 201.63.186.255 LinkTelefonica
    2 201.63.186.180/32 201.63.186.180 201.63.186.180 LinkTelefonica

    NAT
    0 ;;; NAT
    chain=srcnat action=masquerade src-address=192.168.100.0/24
    out-interface=LinkTelefonica
    1 ;;; TESTE
    chain=dstnat action=dst-nat to-addresses=192.168.100.250
    dst-address=201.63.186.180
    2 ;;; TESTE
    chain=srcnat action=src-nat to-addresses=201.63.186.180
    src-address=192.168.100.250
    3 ;;; REDIRECIONANDO PARA O PROXY
    chain=dstnat action=redirect to-ports=3128 protocol=tcp
    src-address=192.168.100.0/24 in-interface=Rede Local dst-port=80


    2º TESTE
    ADDRESS
    0 192.168.100.1/24 192.168.100.0 192.168.100.255 Rede Local
    1 201.63.186.177/24 201.63.186.0 201.63.186.255 LinkTelefonica
    2 201.63.186.181/30 201.63.186.180 201.63.186.183 LinkTelefonica
    NAT
    0 ;;; NAT
    chain=srcnat action=masquerade src-address=192.168.100.0/24
    out-interface=LinkTelefonica
    1 ;;; TESTE
    chain=dstnat action=dst-nat to-addresses=192.168.100.250
    to-ports=0-65535 protocol=tcp dst-address=201.63.186.181
    dst-port=0-65535
    2 ;;; TESTE
    chain=srcnat action=src-nat to-addresses=201.63.186.181 to-ports=0-65535
    protocol=tcp src-address=192.168.100.250 dst-port=0-65535
    3 ;;; REDIRECIONANDO PARA O PROXY
    chain=dstnat action=redirect to-ports=3128 protocol=tcp
    src-address=192.168.100.0/24 in-interface=Rede Local dst-port=80

    Sempre desativo todas as regras do Firewall, pra ter certeza q ele não está barrando.
    Tem alguma coisa errada ou faltando?



  5. Consegui, ufa. até que enfim.
    Fiz o Nat 1:1.
    Agradeço imensamente a ajuda que todos vcs me deram.

    Agora, o que estava ocorrendo mesmo, é q o firewall do cliente não estava deixando acessar a máquina dele, mesmo apache estando na lista de excecoes. E eu desativando o meu firewall !!!
    Última edição por lrmurad; 04-12-2009 às 16:29. Razão: pra completar






Tópicos Similares

  1. Ajuda com NAT - Help Simples
    Por testeteste no fórum Servidores de Rede
    Respostas: 4
    Último Post: 02-08-2006, 09:47
  2. ajuda com NAT
    Por leonardonaweb no fórum Servidores de Rede
    Respostas: 2
    Último Post: 25-07-2006, 12:44
  3. Respostas: 1
    Último Post: 26-06-2006, 10:38
  4. 2 Webservers com 1 IP valido
    Por biosterlinux no fórum Servidores de Rede
    Respostas: 5
    Último Post: 12-07-2005, 08:43
  5. Iptables com dois IPs válidos
    Por Atos no fórum Servidores de Rede
    Respostas: 2
    Último Post: 29-11-2004, 18:28

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L