Página 4 de 10 PrimeiroPrimeiro 123456789 ... ÚltimoÚltimo
+ Responder ao Tópico



  1. Citação Postado originalmente por Raniel Ver Post
    Veja, se há algo relacionado, saiba de onde foi o principio da coisa.
    Under-Linux.org - Mikrotik - Sistema de aviso - avisa que faltou Internet
    Raniel obrigado por sua ajuda no tópico, mas só te lembrando que já usava isso a "milianos"... Não vi seu video e nem sabia que você já tinha feito algo parecido...

    Já estava "namorando" uma solução assim desde o ano passado e contactei a Mikrotik para ver se tinham algo para resolver o problema. Eles informaram que era "impossível" aparecer a tela do login sem link, então depois de muitos dias, descobri que o hotspot consulta o dns e tendo resposta ele abre a tela do login (inclusive se o cliente tiver um endereço inválido no navegador a tela de login não aparece). Vi que o Mikrotik consulta antes a tabela de dns estática dele e só depois (caso não encontre), consulta externamente.

    O problema foi resolvido desta forma. No ano de 2007 eu tinha postado um tópico para o pessoal redirecionar clientes para um servidor de mensagens externos, então considero que esta solução partiu do original que eu já tinha postado.

    Segue tópico:

    https://under-linux.org/f94712-redir...ntes-via-pppoe


    PS: Eu particularmente gosto de criar soluções somente Mikrotik. Soluções com outros sistema, no meu ponto de vista, fogem do escopo e da facilidade que o Mikrotik (tudo em um) nos oferece. Como todos podem ver, a solução que desenvolvi usa apenas o Mikrotik e nada mais...
    Última edição por catvbrasil; 06-12-2009 às 16:16.

  2. Citação Postado originalmente por Raniel Ver Post
    Você pode usar apenas isto no dns para redirecionar:
    Ficando assim:
    Código :
    /tool netwatch add host=192.168.200.1 timeout=100 interval=5s down-script="/ip dns static add name=".*" address=192.168.2.2" up-script="/ip dns static remove [/ip dns static find dynamic=no]"

    Assim não vai precisar digitar todos os endereços.

    Esta sua soluão é show!

    Código :
    /tool netwatch add host=192.168.200.1 timeout=100 interval=5s down-script="/ip dns static add name=".*" address=192.168.2.2" up-script="/ip dns static remove [/ip dns static find dynamic=no]"

    Parabéns!



  3. Flw meu caro! Estamos no forum para ajudar e ser ajudado, como vejo você mesmo vem ajudando muito.

  4. Citação Postado originalmente por catvbrasil Ver Post
    ... No ano de 2007 eu tinha postado um tópico para o pessoal redirecionar clientes para um servidor de mensagens externos, então considero que esta solução partiu do original que eu já tinha postado...
    Minha solução foi desenvolvida a partir desta dúvida.
    https://under-linux.org/f119692-hots...nk-de-internet



  5. Citação Postado originalmente por Raniel Ver Post
    Você pode usar apenas isto no dns para redirecionar:
    Ficando assim:
    Código :
    /tool netwatch add host=192.168.200.1 timeout=100 interval=5s down-script="/ip dns static add name=".*" address=192.168.2.2" up-script="/ip dns static remove [/ip dns static find dynamic=no]"

    Assim não vai precisar digitar todos os endereços.

    Cara, não está dando para adicionar o .* no dns, o MK não aceita.

    [admin@hm_server] > /ip dns static add name=".*" address=192.168.0.2
    bad name
    [admin@hm_server] > /ip dns static add name=.* address=192.168.0.2
    bad name
    Ele aceita apenas
    ".*"
    ou então somente
    *
    e mesmo assim, não está redirecionando as páginas.

    minha versão do MK é a 2.9.27 (caso faça diferença)

    Edit: Vi no seu blog que um cara usou o .* e ainda tirou um print screen, como??? hehehe
    Última edição por pardz; 07-12-2009 às 08:52.






Tópicos Similares

  1. Palestras do MUM Brasil e Argentina 2011
    Por lfaria no fórum Redes
    Respostas: 6
    Último Post: 28-11-2011, 13:58
  2. Mum 2011 sp - palestra
    Por catvbrasil no fórum Redes
    Respostas: 20
    Último Post: 11-11-2011, 15:12
  3. Respostas: 8
    Último Post: 01-09-2011, 00:45
  4. Respostas: 124
    Último Post: 18-04-2011, 07:38
  5. Respostas: 7
    Último Post: 23-08-2008, 01:49

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L