+ Responder ao Tópico



  1. #1

    Padrão PCC e Problemas em Bancos

    Pessoal, implementei o balanceamento PCC em 2 links dedicados, um OI e um Embratel, e está funcionando bem, mas meus clientes estão tendo problemas com bancos, principalmente o Bradesco.

    Procurei e vi que já tem alguns tópicos falando da mesma coisa, mas em nenhum eu consegui identificar uma solução.

    Alguém que tenha isto funcionando poderia postar as regras para resolver este problema?

    Obrigado!

  2. #2



  3. #3

    Padrão

    vc setou a porta 443 (https) para abrir com apenas um dos links??

  4. #4

    Padrão BRADESCO NO PCC

    =oi
    montei pcc versão 4.2 e 4.3 fico nota 10,l.,,muito bom mesmo.;.;.show de bola,.,.
    =como eu tenho conta em varios banco notei que somente com bradesco dava pagina espirada ou sesão invalida,.
    = pra mim resolvi assim ( que peguei aqui mesmo no under) coloque no mangle o passar por fora do balance e no adress liste os ips que vc quer (bradesco e outros que vc tiver problema )e eu coloquei tambem minha rede interna porque não entra de minha casa no pcc e nem nas torres,,., ai resolveu,.,

    =na versão antiga tinha clientes com arp,queue,proxy ecache full tudo perfeito,.
    =nesta versão 4.2 ou 4.3 não resolvi ainda apesar de muitos teste é por clientes no arp no queue junto com web-proxy e com hotspot fazendo apenas pagina de pagamento em atrazo,.,.
    =vc iver um como ajudar te agradeço /;;

    =obs.pcc so para balance e pc serve em macnas separadas para clientes ,web-proxy e hotspot somente para bloqueio com nota de pagamento em atraso..

    aguardo a ajuda de algum amigo e espero ter ajudado com que passei que funciona pra mim;;



  5. #5

    Padrão SOLUÇÃO

    HTTPS só deve sair por 1 dos links

    Esse mesmo problema acontece com o Load Balance da D-LINK LB-604, a solução foi adicionar uma regra para que tudo que for HTTPS utilize apenas um dos links de saída. Provavelmente a solução do seu problema será a mesma.

  6. #6

    Padrão

    Alguém poderia me ajudar com a montagem dessa regra?

    Hoje minhas regras estão assim:

    Código :
     1   chain=input action=mark-connection new-connection-mark=conn_na passthrough=yes connection-state=new in-interface=Link1 
     2   chain=input action=mark-connection new-connection-mark=conn_nb passthrough=yes connection-state=new in-interface=Link2 
     3   chain=output action=mark-routing new-routing-mark=to_ra passthrough=no connection-mark=conn_na 
     4   chain=output action=mark-routing new-routing-mark=to_rb passthrough=no connection-mark=conn_nb 
     5   chain=prerouting action=mark-connection new-connection-mark=conn_ma0 passthrough=yes dst-address-type=!local in-interface=Clientes 
         per-connection-classifier=both-addresses:2/0 
     6   chain=prerouting action=mark-connection new-connection-mark=conn_mb1 passthrough=yes dst-address-type=!local in-interface=Clientes 
         per-connection-classifier=both-addresses:2/1 
     7   chain=prerouting action=mark-routing new-routing-mark=to_nra passthrough=no in-interface=Clientes connection-mark=conn_ma0 
     8   chain=prerouting action=mark-routing new-routing-mark=to_nrb passthrough=no in-interface=Clientes connection-mark=conn_mb1



  7. #7

    Padrão

    Por favor pessoal, alguém poderia me ajudar com essa regra para não ter mais problema com sites de bancos usando balanceamento com PCC?

    As regras que uso atualmente estão no post acima. Agradeço que puder contribuir.

  8. #8

    Padrão Load Balance PCC

    Fala Gustavo, blz
    Vou postar as minhas regras que utilizo aki, nao tenho problemas com bancos/sites seguros ... pelo menos nunca ninguem reclamou. Segue o exemplo para 2 links, adapte ai conforme suas nescessidades.
    Legenda:
    192.168.0.0/24 = rede clientes
    200.200.200.0/29 = faixa de IPs link 1
    201.201.201.0/29 = faixa de IPs link 2
    200.200.200.1 = gateway link 1
    201.201.201.1 = gateway link 2
    Lan1 = nome da interface que atende os clientes
    Wan1 = nome da interface que esta conectado o link1
    Wan2 = nome da interface que esta conectado o link 2


    Código :
    /ip firewall address-list
    add address=192.168.0.0/24 comment="" disabled=no list=local
    add address=200.200.200.0/29 comment="" disabled=no list=wans
    add address=201.201.201.0/29 comment="" disabled=no list=wans
     
    /ip firewall nat
    add action=masquerade chain=srcnat comment=NAT disabled=no out-interface=Wan1
    add action=masquerade chain=srcnat comment="" disabled=no out-interface=Wan2
     
    /ip firewall mangle
    add action=mark-connection chain=input comment="Mark Incoming (to router itself) connections so their reply packets get routed to the interface the connections came in" connection-state=new \
        disabled=no in-interface=Wan1 new-connection-mark=wan1_conn passthrough=yes
    add action=mark-connection chain=input comment="" connection-state=new disabled=no in-interface=Wan2 new-connection-mark=wan2_conn passthrough=yes
    add action=accept chain=output comment="Prevent Outgoing connections to clients' IP addresses from being mangled and routed by PCC" disabled=no dst-address-list=local
    add action=accept chain=output comment="Prevent proper to gateway connections from hitting the PCC mangles and being re-assigned to other gateway" connection-state=new disabled=no dst-address-list=\
        wans
    add action=mark-routing chain=output comment="Set Outgoing (from the router itself) routes" connection-mark=wan1_conn disabled=no new-routing-mark=to_wan1 passthrough=yes
    add action=mark-routing chain=output comment="" connection-mark=wan2_conn disabled=no new-routing-mark=to_wan2 passthrough=yes
    add action=accept chain=prerouting comment="Accept rules - Prevent local connections from being marked and sent to the Internet gateways where they would be dropped since the addresses wont match" \
        disabled=no dst-address-list=local src-address-list=local
    add action=accept chain=prerouting comment="" disabled=no dst-address-list=wans src-address-list=local
    add action=accept chain=prerouting comment="" disabled=no dst-address-list=local src-address-list=wans
    add action=mark-routing chain=prerouting comment="HTTPS fixed route (main routing table)" disabled=no dst-port=443 new-routing-mark=main \
        passthrough=no protocol=tcp src-address-list=local
    add action=mark-connection chain=prerouting comment="Mark connections from clients ip addresses w PCC balance before they get routed so they can be assigned routing rules later and get routed" \
        connection-state=new disabled=no dst-address-type=!local new-connection-mark=wan1_conn passthrough=yes per-connection-classifier=both-addresses:2/0 src-address-list=local
    add action=mark-connection chain=prerouting comment="" connection-state=new disabled=no dst-address-type=!local new-connection-mark=wan2_conn passthrough=yes per-connection-classifier=\
        both-addresses:2/1 src-address-list=local
    add action=mark-routing chain=prerouting comment="" connection-mark=wan1_conn disabled=no new-routing-mark=to_wan1 passthrough=yes src-address-list=local
    add action=mark-routing chain=prerouting comment="" connection-mark=wan2_conn disabled=no new-routing-mark=to_wan2 passthrough=yes src-address-list=local
     
    /ip route
    add comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=200.200.200.1
    add comment="" disabled=no distance=2 dst-address=0.0.0.0/0 gateway=201.201.201.1
    add comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=200.200.200.1 routing-mark=to_wan1
    add comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=201.201.201.1 routing-mark=to_wan2
    Espero ter colaborado
    ATT.
    Gabriel Siena
    Última edição por gsiena; 14-12-2009 às 15:46.



  9. #9
    Não Registrado
    Visitante

    Talking

    Amigo se você seguiu o tutorial do Luciano fica fácil, segue abaixo a solução para os seus problemas:

    /ip firewall address-list
    add address=200.155.80.0/20 comment="" disabled=no list=sem_balance

    Obs.: Este é o IP para o site do Bradesco, se você tiver problemas com outros sites é fácil copie a regra e mude o IP.

    Att.
    Alessandro - TI

  10. #10

    Talking

    Amigo se você seguiu o tutorial de configuração do Luciano é fácil, segue abaixo a solução para os seus problemas:

    /ip firewall address-list
    add address=200.155.80.0/20 comment="" disabled=no list=sem_balance

    Obs.: Esta regra está com o IP principal do Bradesco, o mesmo irá resolver os seus problema com relação ao site desse banco, e caso você tenha problemas com outras páginas é simples copie a regra e altere somente para o IP.

    Att.
    Alessandro - TI



  11. #11

    Padrão Só criar a address-list???

    Caro amigo certeza que é só criar a address-list com o ip que vc quer sair do balanceamento, não precisa criar mais nada, como o balanceamento vai indetificar que tem essa address-list??? e como ou MK vai saber que opa tem uma address-list com o ip tal e então o que eu faço como ele ???

    creio que tem que fazer mais algo né ???

    e o que seria ???



    Citação Postado originalmente por sandros2fabi Ver Post
    Amigo se você seguiu o tutorial de configuração do Luciano é fácil, segue abaixo a solução para os seus problemas:

    /ip firewall address-list
    add address=200.155.80.0/20 comment="" disabled=no list=sem_balance

    Obs.: Esta regra está com o IP principal do Bradesco, o mesmo irá resolver os seus problema com relação ao site desse banco, e caso você tenha problemas com outras páginas é simples copie a regra e altere somente para o IP.

    Att.
    Alessandro - TI

  12. #12

    Padrão bradesco fora de balanco

    meus problema era so com bradesco e foi resolvido de maneira simples é so por a regra que nosso amigo passo ;.

    ip firewall address-list
    add address=200.155.80.0/20 comment="" disabled=no list=sem_balance

    ((((Obs.: Esta regra está com o IP principal do Bradesco, o mesmo irá resolver os seus problema com relação ao site desse banco, e caso você tenha problemas com outras páginas é simples copie a regra e altere somente para o IP.))))
    e acrecenta esta no mangle e ta tudo pronto.,.


    /ip firewall address-list
    add address=192.168.4.0/24 comment="RED INTERNA" disabled=no list=\
    "SEM BALANCE"

    /ip firewall mangle
    add action=accept chain=prerouting comment="SEM BALANCE" disabled=no \
    dst-address-list="SEM BALANCE" in-interface=SAIDA,..,


    espero ter ajudado



  13. #13

    Padrão Re: PCC e Problemas em Bancos

    amigo VIE190 tira uma duvida minha no final da regra vc ponhe SAIDA qual saida vc se refere.. saida link internet wlan ou interface Local pro clientes??

  14. #14

    Padrão Re: PCC e Problemas em Bancos

    oi
    vc tera de ter esta regra para quando no adrees liste por site que saira fora do balanco ter esta opção,mais acredito vc esta em opção errado pq para sair forda do balaço não tem outrs opção alem da cadastrada,,caso queira configurar do principio tem aqui como gerar codigo pcc que da tudo pronto

    /ip firewall mangle
    add action=accept chain=prerouting comment="SEM BALANCE" disabled=no \
    dst-address-list="SEM BALANCE" in-interface=SAIDA,..,



  15. #15

    Padrão Re: PCC e Problemas em Bancos

    ok aqui pra mim funciona tranquilo antes esta com ip 200.155.0.0/16 estava otimo ai paro do nada fui e mudei para 200.155.80.0/20 na hora fico ok . obrigado abraço

  16. #16

    Padrão Re: PCC e Problemas em Bancos

    Oi Essfalcao tudo bem , Como posso fazer para Https sair por outro link tem como me dizer como fazer isso , preciso disso com urgencia.