+ Responder ao Tópico



  1. #1

    Padrão Problema com interfaces de rede

    Tenho um roteador (Debian Lenny) com duas interfaces de rede funcionando certinho. A configuração atual é a seguinte: eth0 conectada com a internet e a eth1 conectada com a rede local. Coloquei mais uma interface (eth2) para conectar um segundo link de internet e fazer redundância de links. O sistema reconheceu a terceira interface na boa e aparentemente está funcionando sem problema algum. Para testa-la conectei o cabo que fica na eth1 nela e a mesma recebeu um endereço da rede na boa via DHCP da rede local. O problema é que quando faço teste de ping com a mesma, ela não pinga para lugar algum, no máximo o ping só tem efeito sobre ela mesma. Fixei o IP da eth1 nessa nova interface (eth2) e repeti o teste de ping e ficou na mesma, ou seja, não pingou!. Agora se conecto o cabo a eth1 (192.168.1.2) e também conecto o cabo a eth2 (192.168.1.3) o ping funciona. O que pode está ocorrendo? Como posso resolver isso? Será problema de rota?

    Obrigado a todos e aguardo qualquer orientação.

    Abraço.

  2. #2

    Padrão

    Boa noite, amigo creio que seja problemas com rotas.
    Observe a tabela de roteamento abaixo.

    ns1:~# ip route show
    192.168.37.1 via 192.168.1.249 dev eth1
    192.168.1.0/24 dev eth1 proto kernel scope link src 192.168.1.3
    192.168.13.0/24 via 192.168.1.249 dev eth1
    192.168.254.0/24 dev eth0 proto kernel scope link src 192.168.254.162
    default via 192.168.254.254 dev eth0

    Dizendo pra onde vai cada pacote, pode ser que o ping esta enviando solicitações para uma interface que nao tem link. Adicione a rota para a interface e teste.

    creio que vc saiba usar o comando route ou ip route, da quase na mesma, caso precise esclarecer alguma duvida pode acessar aqui:

    Redes e Servidores Linux, 2ed.: Configurando manualmente no Linux

    Guia Foca GNU/Linux - Rede

    Abraços



  3. #3

    Padrão

    Citação Postado originalmente por robsonlula Ver Post
    Boa noite, amigo creio que seja problemas com rotas.
    Observe a tabela de roteamento abaixo.

    ns1:~# ip route show
    192.168.37.1 via 192.168.1.249 dev eth1
    192.168.1.0/24 dev eth1 proto kernel scope link src 192.168.1.3
    192.168.13.0/24 via 192.168.1.249 dev eth1
    192.168.254.0/24 dev eth0 proto kernel scope link src 192.168.254.162
    default via 192.168.254.254 dev eth0

    Dizendo pra onde vai cada pacote, pode ser que o ping esta enviando solicitações para uma interface que nao tem link. Adicione a rota para a interface e teste.

    creio que vc saiba usar o comando route ou ip route, da quase na mesma, caso precise esclarecer alguma duvida pode acessar aqui:

    Redes e Servidores Linux, 2ed.: Configurando manualmente no Linux

    Guia Foca GNU/Linux - Rede

    Abraços
    Estou postando minha configurações. Se você puder dar uma olhadinha lhe serei muito grato.

    Minha configurações:

    route:
    Tabela de Roteamento IP do Kernel
    Destino Roteador MáscaraGen. Opções Métrica Ref Uso Iface
    13.0.0.2 * 255.255.255.255 UH 0 0 0 tun2
    12.0.0.2 * 255.255.255.255 UH 0 0 0 tun1
    14.0.0.2 * 255.255.255.255 UH 0 0 0 tun3
    11.0.0.2 * 255.255.255.255 UH 0 0 0 tun0
    XXX.XX.XXX.96 * 255.255.255.248 U 0 0 0 eth0
    192.168.3.0 13.0.0.1 255.255.255.0 UG 0 0 0 tun2
    192.168.1.0 * 255.255.255.0 U 0 0 0 eth1
    192.168.0.0 12.0.0.1 255.255.255.0 UG 0 0 0 tun1
    default XXX.XX.XXX.97 0.0.0.0 UG 0 0 0 eth0

    ifconfig:

    eth0 Link encap:Ethernet Endereço de HW 00:21:97:95:49:79
    inet end.: XXX.XX.XXX.100 Bcast:XXX.XX.XXX.103 Masc:255.255.255.248
    endereço inet6: fe80::221:97ff:fe95:4979/64 Escopo:Link
    UP BROADCASTRUNNING MULTICAST MTU:1500 Métrica:1
    RX packets:1147514 errors:0 dropped:0 overruns:0 frame:0
    TX packets:1135370 errors:0 dropped:0 overruns:0 carrier:0
    colisões:0 txqueuelen:1000
    RX bytes:731196824 (697.3 MiB) TX bytes:329855640 (314.5 MiB)
    IRQ:221 Endereço de E/S:0xa000

    eth1 Link encap:Ethernet Endereço de HW 00:08:54:a7:29:39
    inet end.: 192.168.1.2 Bcast:192.168.1.255 Masc:255.255.255.0
    endereço inet6: fe80::208:54ff:fea7:2939/64 Escopo:Link
    UP BROADCASTRUNNING MULTICAST MTU:1500 Métrica:1
    RX packets:2178424 errors:0 dropped:0 overruns:0 frame:0
    TX packets:1396678 errors:0 dropped:0 overruns:0 carrier:0
    colisões:0 txqueuelen:1000
    RX bytes:1180687943 (1.0 GiB) TX bytes:893189369 (851.8 MiB)
    IRQ:18 Endereço de E/S:0xcc00

    eth2 Link encap:Ethernet Endereço de HW 00:08:a1:a3:50:dc
    UP BROADCASTMULTICAST MTU:1500 Métrica:1
    RX packets:0 errors:0 dropped:0 overruns:0 frame:0
    TX packets:6 errors:0 dropped:0 overruns:0 carrier:0
    colisões:0 txqueuelen:1000
    RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
    IRQ:19 Endereço de E/S:0xe400

    lo Link encap:Loopback Local
    inet end.: 127.0.0.1 Masc:255.0.0.0
    endereço inet6: ::1/128 Escopo:Máquina
    UP LOOPBACKRUNNING MTU:16436 Métrica:1
    RX packets:34 errors:0 dropped:0 overruns:0 frame:0
    TX packets:34 errors:0 dropped:0 overruns:0 carrier:0
    colisões:0 txqueuelen:0
    RX bytes:13561 (13.2 KiB) TX bytes:13561 (13.2 KiB)

    tun0 Link encap:Não Especificado Endereço de HW 00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00
    inet end.: 11.0.0.1 P-a-P:11.0.0.2 Masc:255.255.255.255
    UP POINTOPOINT RUNNING NOARP MULTICAST MTU:1500 Métrica:1
    RX packets:1113 errors:0 dropped:0 overruns:0 frame:0
    TX packets:781 errors:0 dropped:0 overruns:0 carrier:0
    colisões:0 txqueuelen:100
    RX bytes:90494 (88.3 KiB) TX bytes:99168 (96.8 KiB)

    tun1 Link encap:Não Especificado Endereço de HW 00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00
    inet end.: 12.0.0.1 P-a-P:12.0.0.2 Masc:255.255.255.255
    UP POINTOPOINT RUNNING NOARP MULTICAST MTU:1500 Métrica:1
    RX packets:72813 errors:0 dropped:0 overruns:0 frame:0
    TX packets:75022 errors:0 dropped:0 overruns:0 carrier:0
    colisões:0 txqueuelen:100
    RX bytes:18260914 (17.4 MiB) TX bytes:11574661 (11.0 MiB)

    tun2 Link encap:Não Especificado Endereço de HW 00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00
    inet end.: 13.0.0.1 P-a-P:13.0.0.2 Masc:255.255.255.255
    UP POINTOPOINT RUNNING NOARP MULTICAST MTU:1500 Métrica:1
    RX packets:44621 errors:0 dropped:0 overruns:0 frame:0
    TX packets:50381 errors:0 dropped:0 overruns:0 carrier:0
    colisões:0 txqueuelen:100
    RX bytes:3613798 (3.4 MiB) TX bytes:10295001 (9.8 MiB)

    tun3 Link encap:Não Especificado Endereço de HW 00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00
    inet end.: 14.0.0.1 P-a-P:14.0.0.2 Masc:255.255.255.255
    UP POINTOPOINT RUNNING NOARP MULTICAST MTU:1500 Métrica:1
    RX packets:2044 errors:0 dropped:0 overruns:0 frame:0
    TX packets:2477 errors:0 dropped:0 overruns:0 carrier:0
    colisões:0 txqueuelen:100
    RX bytes:187084 (182.6 KiB) TX bytes:268574 (262.2 KiB)

    A interface eth2 está sem endereçamento, pois tive que retirar o seu respectivo cabo rede.

    Obrigado pela atenção e aguardo retorno.

  4. #4

    Padrão

    Citação Postado originalmente por aprendiz_ce Ver Post
    Estou postando minha configurações. Se você puder dar uma olhadinha lhe serei muito grato.

    Minha configurações:

    route:
    Tabela de Roteamento IP do Kernel
    Destino Roteador MáscaraGen. Opções Métrica Ref Uso Iface
    13.0.0.2 * 255.255.255.255 UH 0 0 0 tun2
    12.0.0.2 * 255.255.255.255 UH 0 0 0 tun1
    14.0.0.2 * 255.255.255.255 UH 0 0 0 tun3
    11.0.0.2 * 255.255.255.255 UH 0 0 0 tun0
    XXX.XX.XXX.96 * 255.255.255.248 U 0 0 0 eth0
    192.168.3.0 13.0.0.1 255.255.255.0 UG 0 0 0 tun2
    192.168.1.0 * 255.255.255.0 U 0 0 0 eth1 <---- aqui
    192.168.0.0 12.0.0.1 255.255.255.0 UG 0 0 0 tun1
    default XXX.XX.XXX.97 0.0.0.0 UG 0 0 0 eth0


    ifconfig:

    eth0 Link encap:Ethernet Endereço de HW 00:21:97:95:49:79
    inet end.: XXX.XX.XXX.100 Bcast:XXX.XX.XXX.103 Masc:255.255.255.248
    endereço inet6: fe80::221:97ff:fe95:4979/64 Escopo:Link
    UP BROADCASTRUNNING MULTICAST MTU:1500 Métrica:1
    RX packets:1147514 errors:0 dropped:0 overruns:0 frame:0
    TX packets:1135370 errors:0 dropped:0 overruns:0 carrier:0
    colisões:0 txqueuelen:1000
    RX bytes:731196824 (697.3 MiB) TX bytes:329855640 (314.5 MiB)
    IRQ:221 Endereço de E/S:0xa000

    eth1 Link encap:Ethernet Endereço de HW 00:08:54:a7:29:39
    inet end.: 192.168.1.2 Bcast:192.168.1.255 Masc:255.255.255.0
    endereço inet6: fe80::208:54ff:fea7:2939/64 Escopo:Link
    UP BROADCASTRUNNING MULTICAST MTU:1500 Métrica:1
    RX packets:2178424 errors:0 dropped:0 overruns:0 frame:0
    TX packets:1396678 errors:0 dropped:0 overruns:0 carrier:0
    colisões:0 txqueuelen:1000
    RX bytes:1180687943 (1.0 GiB) TX bytes:893189369 (851.8 MiB)
    IRQ:18 Endereço de E/S:0xcc00

    eth2 Link encap:Ethernet Endereço de HW 00:08:a1:a3:50:dc
    UP BROADCASTMULTICAST MTU:1500 Métrica:1
    RX packets:0 errors:0 dropped:0 overruns:0 frame:0
    TX packets:6 errors:0 dropped:0 overruns:0 carrier:0
    colisões:0 txqueuelen:1000
    RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
    IRQ:19 Endereço de E/S:0xe400

    lo Link encap:Loopback Local
    inet end.: 127.0.0.1 Masc:255.0.0.0
    endereço inet6: ::1/128 Escopo:Máquina
    UP LOOPBACKRUNNING MTU:16436 Métrica:1
    RX packets:34 errors:0 dropped:0 overruns:0 frame:0
    TX packets:34 errors:0 dropped:0 overruns:0 carrier:0
    colisões:0 txqueuelen:0
    RX bytes:13561 (13.2 KiB) TX bytes:13561 (13.2 KiB)

    tun0 Link encap:Não Especificado Endereço de HW 00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00
    inet end.: 11.0.0.1 P-a-P:11.0.0.2 Masc:255.255.255.255
    UP POINTOPOINT RUNNING NOARP MULTICAST MTU:1500 Métrica:1
    RX packets:1113 errors:0 dropped:0 overruns:0 frame:0
    TX packets:781 errors:0 dropped:0 overruns:0 carrier:0
    colisões:0 txqueuelen:100
    RX bytes:90494 (88.3 KiB) TX bytes:99168 (96.8 KiB)

    tun1 Link encap:Não Especificado Endereço de HW 00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00
    inet end.: 12.0.0.1 P-a-P:12.0.0.2 Masc:255.255.255.255
    UP POINTOPOINT RUNNING NOARP MULTICAST MTU:1500 Métrica:1
    RX packets:72813 errors:0 dropped:0 overruns:0 frame:0
    TX packets:75022 errors:0 dropped:0 overruns:0 carrier:0
    colisões:0 txqueuelen:100
    RX bytes:18260914 (17.4 MiB) TX bytes:11574661 (11.0 MiB)

    tun2 Link encap:Não Especificado Endereço de HW 00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00
    inet end.: 13.0.0.1 P-a-P:13.0.0.2 Masc:255.255.255.255
    UP POINTOPOINT RUNNING NOARP MULTICAST MTU:1500 Métrica:1
    RX packets:44621 errors:0 dropped:0 overruns:0 frame:0
    TX packets:50381 errors:0 dropped:0 overruns:0 carrier:0
    colisões:0 txqueuelen:100
    RX bytes:3613798 (3.4 MiB) TX bytes:10295001 (9.8 MiB)

    tun3 Link encap:Não Especificado Endereço de HW 00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00
    inet end.: 14.0.0.1 P-a-P:14.0.0.2 Masc:255.255.255.255
    UP POINTOPOINT RUNNING NOARP MULTICAST MTU:1500 Métrica:1
    RX packets:2044 errors:0 dropped:0 overruns:0 frame:0
    TX packets:2477 errors:0 dropped:0 overruns:0 carrier:0
    colisões:0 txqueuelen:100
    RX bytes:187084 (182.6 KiB) TX bytes:268574 (262.2 KiB)

    A interface eth2 está sem endereçamento, pois tive que retirar o seu respectivo cabo rede.

    Obrigado pela atenção e aguardo retorno.


    Repare que na tabela de roteamento, o kernel manda os pacotes para eth1, obviamente pelo link estar nela, verifique a tabela de roteamento quando conectar o cabo na eth2, deve mudar, para teste você pode forçar com o comando.

    [email protected]:~#route add -net 192.168.1.0/24 dev eth2

    Lembre-se tudo que ele não encontra caminho definido vai pra default gateway, e se o kernel está entendendo que os pacotes da rede 192.168.1.0/24 devem sair pela eth1, ele vai mandar tudo pra ela, até que você defina o caminho correto.



    Confira também com o comando "mii-tool" se os links estão ok.

    Posta ai os resultados, abraços
    Última edição por robsonlula; 27-12-2009 às 12:01.



  5. #5

    Padrão

    Citação Postado originalmente por robsonlula Ver Post
    Repare que na tabela de roteamento, o kernel manda os pacotes para eth1, obviamente pelo link estar nela, verifique a tabela de roteamento quando conectar o cabo na eth2, deve mudar, para teste você pode forçar com o comando.

    [email protected]:~#route add -net 192.168.1.0/24 dev eth2

    Lembre-se tudo que ele não encontra caminho definido vai pra default gateway, e se o kernel está entendendo que os pacotes da rede 192.168.1.0/24 devem sair pela eth1, ele vai mandar tudo pra ela, até que você defina o caminho correto.



    Confira também com o comando "mii-tool" se os links estão ok.

    Posta ai os resultados, abraços
    Olá,

    O link (Internet) na realidade está é no eth0 e o eth1 está na rede local. Quero deixa o eth0 com o link primário, o eth1 com o link secundário e o eth2 para a rede local. O problema todo está com o eth2 que mesmo conectato não pinga para lugar algum. Deve ser a rota mesmo, né?

    Grato pela sua pronta atenção.

  6. #6

    Padrão

    Desculpe, quero te ajudar, mais não estou entendo direito, se possível, responda as perguntas abaixo na sequência.

    Antes de tudo, confira suas regras de firewall, se possível, desative no momento dos teste, deve estar já, mais caso não esteja, habilite o encaminhamento
    de pacotes entre as interfaces.


    Vamos por partes...

    "Para testa-la conectei o cabo que fica na eth1 nela e a mesma recebeu um endereço da rede na boa via DHCP da rede local"
    Quando você faz o teste de conectar o cabo da eth1 na eth2, ele deverá sair para a rede local, certo? Como fica a tabela de roteamento nessa condição?
    Repare que ela não pode ficar, dizendo pro kernel que tudo que for sair para a rede 192.168.1.0/24, terá como caminho a eth1, pois ela não terá mais cabo conectado, deverá sair pela eth2, a partir desse momento.
    Conferindo na tabela de roteamento, deverá ficar assim:

    Tabela de Roteamento IP do Kernel
    Destino Roteador MáscaraGen. Opções Métrica Ref Uso Iface
    XXX.XX.XXX.96 * 255.255.255.248 U 0 0 0 eth0
    192.168.1.0 * 255.255.255.0 U 0 0 0 eth2 <--- aqui
    default XXX.XX.XXX.97 0.0.0.0 UG 0 0 0 eth0

    Feito isso, faça o teste de ping para uma máquina que você tenha certeza que está conectada e aceite solicitações de ping.

    # ping 192.168.1.X -t

    Para sair para a internet, lembre de habilitar o nat
    # ping Google ou 208.67.220.220

    Se respondeu ao ping, está tudo certo, se não, troque a placa de rede, pode ser problema de hardware.

    Depois que tudo der certo, ai sim, você poderá passar para a configuração do segundo link.

    Att,



  7. #7

    Padrão

    Citação Postado originalmente por robsonlula Ver Post
    Desculpe, quero te ajudar, mais não estou entendo direito, se possível, responda as perguntas abaixo na sequência.

    Antes de tudo, confira suas regras de firewall, se possível, desative no momento dos teste, deve estar já, mais caso não esteja, habilite o encaminhamento
    de pacotes entre as interfaces.


    Vamos por partes...

    "Para testa-la conectei o cabo que fica na eth1 nela e a mesma recebeu um endereço da rede na boa via DHCP da rede local"
    Quando você faz o teste de conectar o cabo da eth1 na eth2, ele deverá sair para a rede local, certo? Como fica a tabela de roteamento nessa condição?
    Repare que ela não pode ficar, dizendo pro kernel que tudo que for sair para a rede 192.168.1.0/24, terá como caminho a eth1, pois ela não terá mais cabo conectado, deverá sair pela eth2, a partir desse momento.
    Conferindo na tabela de roteamento, deverá ficar assim:

    Tabela de Roteamento IP do Kernel
    Destino Roteador MáscaraGen. Opções Métrica Ref Uso Iface
    XXX.XX.XXX.96 * 255.255.255.248 U 0 0 0 eth0
    192.168.1.0 * 255.255.255.0 U 0 0 0 eth2 <--- aqui
    default XXX.XX.XXX.97 0.0.0.0 UG 0 0 0 eth0

    Feito isso, faça o teste de ping para uma máquina que você tenha certeza que está conectada e aceite solicitações de ping.

    # ping 192.168.1.X -t

    Para sair para a internet, lembre de habilitar o nat
    # ping Google ou 208.67.220.220

    Se respondeu ao ping, está tudo certo, se não, troque a placa de rede, pode ser problema de hardware.

    Depois que tudo der certo, ai sim, você poderá passar para a configuração do segundo link.

    Att,
    Estou fazendo exatamente o que você recomenda. Mas como o eth2 não pinga para lugar algum... Creio que seja rota mesmo. Não parei e nem lembrei de ver a rota após o cabo ficar conectado na eth2, mas estarei fazendo isso já já... Dúvida: Caso o problema seja rota para o eth2, terei que fixar essa rota em um script, não é?!? Ou simplesmente após executar o comando "route add..." o mesmo deixará a nova rota fixa???

    Obrigado mais uma vez pela sua pronta atenção.

    Abraço.

  8. #8

    Padrão

    Boa noite,

    Então, confere esse problema das rotas, na minha visão do que você passou, creio que seja rotas mesmo, faz os teste e posta aqui. Se der posta a tabela de roteamento nas duas condições.

    Sobre a dúvida, eu havia pensado em um script mesmo, cheguei até ver um agora a pouco falando sobre isso, mais tem soluções mais profissionais para isso, vou te passar alguns links que achei interessante sobre HA de links.


    Esse é link do script
    Slackware-Brasil

    Soluções mais profissionais

    UCARP
    Linux: Alta disponibilidade com IP compartilhado - UCARP [Artigo]

    VRRP
    Linux: Firewalls redundantes utilizando VRRP [Artigo]

    Obs: Uma sugestão, resolve primeiro esse problema de saída ai, depois parte pra essa configuração.

    Abraços



  9. #9

    Padrão

    modem bridge + mikrotik autenticando = manda sinal sem necessidade de autenticar?



    Ola pessoal, sou novo no forum. To tentando configurar uma mikrotik, porém n to conseguindo.

    O que eu quero....mandar sinal wireless para 5 clientes. quero mandar o sinal pros clientes ja autenticado. Sem a necessidade de eles conectar. Quero acessar a placa, no caso eu sendo cliente da Routerboard rb/433AH com 1 cartão. meu modem está configurado com o ip 10.1.1.1 dns primário 10.1.1.1 e secundário 10.1.1.2 e gatway 10.1.1.1.


    como os equipamentos estão conectados: modem está conectado em ether1, e quero mandar sinal wireless por wlan1, não preciso de controle de banda, nem MAC. Só quero fazer mandar sinal wireless. Quero mandar tanfo para placa de rede wireless, como pra ap, sendo q o ap repetirá o sinal wireless para notebook.


    Por favor, me ajudem. Eu estou há 2 semanas fazendo pesquisas no google, nos forums. mas eu n consegui. pq eles ensinam, mas geralmente n ensinam rede interna, ou o que eu n quero.

    Desde ja agradeço a quem me ajudar.....................


    favor passar por e-mail a resposta
    [email protected]