+ Responder ao Tópico



  1. #1

    Padrão Juntar 2 link diferentes (Velox + NET) em um mesmo microtik - Balaceamento

    Eu tenho configurado no meu mikrotik o link da Velox, porém eu gostaria de acrescentar o link da NET também, so q a velox usa ppp (usuario e senha), e a net usa ip dinamico (automatico).
    Como eu poderia fazer um balanceamento dos 2 links, numa merma rede tipo 192.168.0.1.
    Eu gostaria q fosse numa merma rede, para que se cair um link de internet o outro link segurava!
    Grato pela atenção!

  2. #2

    Padrão

    Tem o PCC pode fazer balanceamento tem esse dois topicos sobre assunto https://under-linux.org/f227/pcc-128610/
    https://under-linux.org/f227/pcc-bal...r-m4d3-131343/ so que vai ter que usar uma Rb so para o balanceamento.



  3. #3

    Padrão

    mais essa ferramenta funciona para a versão 2.9??

  4. #4

    Padrão

    se não me engano funciona apartir da versão 3.23. pode usar uma rb450.



  5. #5

    Padrão

    Citação Postado originalmente por jrgiva Ver Post
    Eu tenho configurado no meu mikrotik o link da Velox, porém eu gostaria de acrescentar o link da NET também, so q a velox usa ppp (usuario e senha), e a net usa ip dinamico (automatico).
    Como eu poderia fazer um balanceamento dos 2 links, numa merma rede tipo 192.168.0.1.
    Eu gostaria q fosse numa merma rede, para que se cair um link de internet o outro link segurava!
    Grato pela atenção!

    Meu amigo, eu estou com o mesmo problema que vc e ainda nao encontrei nenhuma solução, ninguém me passou nada para ajudar...

    Vc conseguiu algo???

  6. #6
    Marlon Bolzan Avatar de marlon
    Ingresso
    Dec 2009
    Localização
    Ecoporanga-ES
    Posts
    265

    Padrão

    Procura por PCC no forun tem uns tópicos muito bom amigo!

    Procure antes de Postar!

    Se te foi util não esqueça de agradeçer!



  7. #7

    Padrão

    jrgiva,

    Dá pra fazer o que você quer sim, sem problema. Você vai precisar de uma RB 750, que é bem baratinha, com versão 3.23 ou superior. Recomendo que use a versão 4.6. Vamos lá.

    Primeiro você vai criar duas conexões. A primeira do velox. Menu PPP -> PPPoE Client e nomeie ela pra: pppoe-VELOX. Adiciona lá os dados direitinho e "DESMARCA" a opção "Add Default Route". Segundo, crie a da NET. Menu IP -> DHCP Client e nomeie ela pra dhcp-NET. Adiciona a interface que você conectou o NET e "DESMARCA" a opção "Add Default Route". Esse detalhe é muito importante. Diante disto você estará com os 2 links prontos. Agora falta fazer o balanceamento. Siga como vou por abaixo:

    ## Coloque um IP e nomeie sua interface de rede local que chegará o trafego de seus clientes. ##
    /ip address
    add address=192.168.0.1/24 network=192.168.0.0 broadcast=192.168.0.255 interface=Rede_Local

    ## Efetue a marcação das conexões para fazer o balanceamento ##
    /ip firewall mangle
    add chain=input in-interface=pppoe-VELOX action=mark-connection new-connection-mark=velox_conn
    add chain=input in-interface=dhcp-NET action=mark-connection new-connection-mark=net_conn

    add chain=prerouting dst-address-type=!local in-interface=Rede_Local per-connection-classifier=both-addresses:2/0 action=mark-connection new-connection-mark=velox_conn passthrough=yes
    add chain=prerouting dst-address-type=!local in-interface=Rede_Local per-connection-classifier=both-addresses:2/1 action=mark-connection new-connection-mark=net_conn passthrough=yes

    add chain=prerouting connection-mark=velox_conn in-interface=Local action=mark-routing new-routing-mark=VELOX
    add chain=prerouting connection-mark=net_conn in-interface=Local action=mark-routing new-routing-mark=NET

    ## Crie as rotas a partir das marcações e garanta o "fail over"
    /ip route
    add dst-address=0.0.0.0/0 gateway=pppoe-VELOX routing-mark=VELOX check-gateway=arp
    add dst-address=0.0.0.0/0 gateway=dhcp-NET routing-mark=NET check-gateway=arp
    add dst-address=0.0.0.0/0 gateway=ppoe-VELOX distance=1 check-gateway=arp
    add dst-address=0.0.0.0/0 gateway=NET distance=2 check-gateway=arp

    ## Faça o nateamento das conexões
    /ip firewall nat
    add chain=srcnat out-interface=pppoe-VELOX action=masquerade
    add chain=srcnat out-interface=dhcp-NET action=masquerade

    Seja feliz e não compre esses produtos prontos que são relativamente caros e não tem a qualidade de gerência que o MK tem.

    Abs.
    Última edição por guilhermeramires; 22-04-2010 às 09:30.

  8. #8

    Padrão Re: Juntar 2 link diferentes (Velox + NET) em um mesmo microtik - Balaceamento

    Citação Postado originalmente por guilhermeramires Ver Post
    jrgiva,

    Dá pra fazer o que você quer sim, sem problema. Você vai precisar de uma RB 750, que é bem baratinha, com versão 3.23 ou superior. Recomendo que use a versão 4.6. Vamos lá.

    Primeiro você vai criar duas conexões. A primeira do velox. Menu PPP -> PPPoE Client e nomeie ela pra: pppoe-VELOX. Adiciona lá os dados direitinho e "DESMARCA" a opção "Add Default Route". Segundo, crie a da NET. Menu IP -> DHCP Client e nomeie ela pra dhcp-NET. Adiciona a interface que você conectou o NET e "DESMARCA" a opção "Add Default Route". Esse detalhe é muito importante. Diante disto você estará com os 2 links prontos. Agora falta fazer o balanceamento. Siga como vou por abaixo:

    ## Coloque um IP e nomeie sua interface de rede local que chegará o trafego de seus clientes. ##
    /ip address
    add address=192.168.0.1/24 network=192.168.0.0 broadcast=192.168.0.255 interface=Rede_Local

    ## Efetue a marcação das conexões para fazer o balanceamento ##
    /ip firewall mangle
    add chain=input in-interface=pppoe-VELOX action=mark-connection new-connection-mark=velox_conn
    add chain=input in-interface=dhcp-NET action=mark-connection new-connection-mark=net_conn

    add chain=prerouting dst-address-type=!local in-interface=Rede_Local per-connection-classifier=both-addresses:2/0 action=mark-connection new-connection-mark=velox_conn passthrough=yes
    add chain=prerouting dst-address-type=!local in-interface=Rede_Local per-connection-classifier=both-addresses:2/1 action=mark-connection new-connection-mark=net_conn passthrough=yes

    add chain=prerouting connection-mark=velox_conn in-interface=Local action=mark-routing new-routing-mark=VELOX
    add chain=prerouting connection-mark=net_conn in-interface=Local action=mark-routing new-routing-mark=NET

    ## Crie as rotas a partir das marcações e garanta o "fail over"
    /ip route
    add dst-address=0.0.0.0/0 gateway=pppoe-VELOX routing-mark=VELOX check-gateway=arp
    add dst-address=0.0.0.0/0 gateway=dhcp-NET routing-mark=NET check-gateway=arp
    add dst-address=0.0.0.0/0 gateway=ppoe-VELOX distance=1 check-gateway=arp
    add dst-address=0.0.0.0/0 gateway=NET distance=2 check-gateway=arp

    ## Faça o nateamento das conexões
    /ip firewall nat
    add chain=srcnat out-interface=pppoe-VELOX action=masquerade
    add chain=srcnat out-interface=dhcp-NET action=masquerade

    Seja feliz e não compre esses produtos prontos que são relativamente caros e não tem a qualidade de gerência que o MK tem.

    Abs.
    Boa noite meu amigo Guilherme, me tire uma dúvida: Essa configuração que postou, eu faço no balancer ou no meu servidor MK que controla meus clientes? Ainda estou com essa pequena dúvida em relação ao Balacer. Podrria me ajudar também a faze-lo em uma RB entrando 1 Link dedicado e um ADSL?
    Obrigado pela ajuda.

    Wilson Jr.



  9. #9

    Padrão Re: Juntar 2 link diferentes (Velox + NET) em um mesmo microtik - Balaceamento

    mp3fm, você tem que ter um mikrotik separado somente para loadbalance e outro somente para controle de clientes,

    t+

  10. #10

    Padrão Re: Juntar 2 link diferentes (Velox + NET) em um mesmo microtik - Balaceamento

    Citação Postado originalmente por mp3fm Ver Post
    Boa noite meu amigo Guilherme, me tire uma dúvida: Essa configuração que postou, eu faço no balancer ou no meu servidor MK que controla meus clientes? Ainda estou com essa pequena dúvida em relação ao Balacer. Podrria me ajudar também a faze-lo em uma RB entrando 1 Link dedicado e um ADSL?
    Obrigado pela ajuda.

    Wilson Jr.
    Wilson,

    Isso vai depender se sua rede é roteada ou nateada. Se for nateada precisa ser onde os clientes logam. Se for roteada precisa ser onde está o link de bordar. Essa regra que passei você pode usar pra 1 link dedicado e um ADSL. Precisa mudar pouca coisa. Basta você seguir a lógica. Tenta ai e fala qual foi o resultado. Se você não conseguir, explica qual a dificuldade que você tá tendo, ok?

    Abs.



  11. #11

    Padrão Re: Juntar 2 link diferentes (Velox + NET) em um mesmo microtik - Balaceamento

    Aproveitando o topico criado, estou querendo somar 4 links, eu disse somar, 1mb+6mb+6mb+6mb=19mb em um unico gateway pra entrar em um servidor de cache, seguindo novamente pra um outro MK que gerencie os clientes.

    Tem como eu fazer esta soma em um unico gateway?

    Abraços
    Última edição por ricnecro; 10-05-2010 às 15:11.

  12. #12

    Padrão Re: Juntar 2 link diferentes (Velox + NET) em um mesmo microtik - Balaceamento

    Amigo somar não tem como so se for todos dedicado, ai sei que tem um esquema que você faz com a operadora que pega o dedicado que eles juntar, mais mesmo assim eles não soma, não tem como somar, se tiver quero saber tambem. O que você pode fazer é o PCC vai ficar muito bom com essa quantia de link. t+



  13. #13

    Padrão Re: Juntar 2 link diferentes (Velox + NET) em um mesmo microtik - Balaceamento

    Esse 4 links você poderia juntar eles em uma RB 750 que é bem baratinha. Eu aconselharia que você desconsiderasse o link de 1MB para um melhor balanceamento. Se você incluir esse link no balanceamento você vai precisar fazer 19 regras só pro PCC. Se você tirar ele só vai precisar de 3 regras. Além de ter um sistema bem mais estável, ok?

    Abs.

  14. #14

    Padrão Re: Juntar 2 link diferentes (Velox + NET) em um mesmo microtik - Balaceamento

    Eu montei o meu pcc em uma rb450g só que ela so tem 5 porta ethernet, ja a 750 citada pelo guilherme eu acho que possui mais portas, abaixo segue o link do tutorial do pcram para fazer o loadbalance:

    https://under-linux.org/f227/pcc-bal...r-m4d3-131343/

    t+



  15. #15

    Padrão Re: Juntar 2 link diferentes (Velox + NET) em um mesmo microtik - Balaceamento

    A única dificuldade que estou tendo é essa......POR ONDE COMEÇAR. Sei que o Balance é feito a parte, em uma outra RB. Cá tenho uma 450G.
    Só queria saber onde coloco a configuração que descreveu acima.....no controle dos clientes ou na RB.

    Meus clientes estão conctados com IP fixo, controlo acesso por MAC e simple qeuee.
    Sinto que se eu pegar o principio fecho com chave de ouro.

    Grato pelo retorno e aguardo socorro, heheheh

    Wilson Jr.

  16. #16

    Padrão Re: Juntar 2 link diferentes (Velox + NET) em um mesmo microtik - Balaceamento

    Não amigo o load balance as configurações você coloca na RB, quando você estiver fazendo o loadbalance pode esquecer que você tem cliente hehehehe... brincadeiras a parte, você começa a configurar a rb como o tutu do pc ram, que postei ou do nosso amigo guilherme fica a sua escolha, qualquer coisa add no msn que do uma força para você, msn ta na assinatura. t+



  17. #17

    Padrão Re: Juntar 2 link diferentes (Velox + NET) em um mesmo microtik - Balaceamento

    Citação Postado originalmente por mktguaruja Ver Post
    Não amigo o load balance as configurações você coloca na RB, quando você estiver fazendo o loadbalance pode esquecer que você tem cliente hehehehe... brincadeiras a parte, você começa a configurar a rb como o tutu do pc ram, que postei ou do nosso amigo guilherme fica a sua escolha, qualquer coisa add no msn que do uma força para você, msn ta na assinatura. t+
    oK AMIGÃO, vou te add no msn...também possuo Nextel
    14*142

    Um Abraço

    Wilson Jr.

  18. #18

    Padrão Re: Juntar 2 link diferentes (Velox + NET) em um mesmo microtik - Balaceamento

    Opa wilson add mesmo vo ter um prazer em te ajuda, eu tbm tive dificuldade mais um amigo me ajudo bastante e vo passar o que ele me passo. add e me chama e fala que você é aqui no under que te ajuderei t+



  19. #19

    Padrão Re: Juntar 2 link diferentes (Velox + NET) em um mesmo microtik - Balaceamento

    amigo tem condição de juntar 2 links tipo tenho 2 links de 10MB e sair 20 MB?