Página 2 de 3 PrimeiroPrimeiro 123 ÚltimoÚltimo
+ Responder ao Tópico



  1. https://under-linux.org/f116/falecim...-mr-rg-138845/

    Citação Postado originalmente por unibraz Ver Post
    vc tem pelomenos um script que da para ver se estam clonando o MAC e IP de algum cliente na rede, fico no aguardo, se puder postar fico grato.

  2. Lamento mesmo pela morte do Daniel. Tive um irmão que também morreu de acidente de moto. Bom deixando as coisas triste, eu peguei um script no Forum do MK internacional, se alguém poder testar agradeço:
    Código :
     
    :local hosts [:toarray "comp1,comp2"]
    :local host;
    :local ipnum;
    :local unum;
    :local usr;
    :local i;
     
    :foreach host in=$hosts do={
       :foreach i in= [/ip dhcp-server lease find host-name=$host] do={
          :set ipnum [/ip dhcp-server lease get $i address];
          :set unum [/ip hotspot active find address=$ipnum];
          :set usr [/ip hotspot active get $unum user];
          :log warning ($host . " " . $ipnum . " " . $usr);
          /ip hotspot active remove $unum
          /ip dhcp-server lease remove [/ip dhcp-server lease find host-name=$host]
       }
    }



  3. Falto o outro script, são dois. Um monta a lista e o outro compara de x em x segundos conforme programado, deem uma pesquisada que iram encontrar

  4. Citação Postado originalmente por int21 Ver Post
    Falto o outro script, são dois. Um monta a lista e o outro compara de x em x segundos conforme programado, deem uma pesquisada que iram encontrar

    POsta ai pra gente amigo, não custa nada. Nos ajude



  5. Set up a schedule to run this script every few minutes
    Code:
    :local hosts [/ip dhcp-server lease find]
    :local pcname ""
    :local pcnum 0
    :global hacklist ""
    # To log the value of $hacklist each hour, make debug 1 (if $hacklist is blank, nothing will be logged)
    :local debug 1

    :foreach h1 in=$hosts do={
    :local host [/ip dhcp-server lease get $h1 host-name]
    :if ([:len $host] >0) do {
    :set pcname ($pcname . "," . $host)
    :set pcnum ($pcnum + 1)
    }
    }

    :local pcnameArr [:toarray $pcname];

    :foreach h2 in=$pcnameArr do={
    :local hh 0
    :if (!([:find $hacklist $h2]>=0)) do={
    :foreach k in=$pcnameArr do={ :if ($k=$h2) do={:set hh ($hh + 1) } }
    :if ($hh>2) do={
    :if ([:len $hacklist] >0) do {:set hacklist ($hacklist . "," . $h2)} else={:set hacklist $h2}
    }
    }
    }

    # monitor results in logfile once an hour
    :local timer [ick [/system clock get time] 3 5]
    :if (($debug > 0) || ($timer >= "58")) do={
    :if ([:len $hacklist] >0) do={
    :log warning ("New Hacklist: " . $hacklist)
    }
    }



    Set up a schedule to run this every 20 seconds. (Which is the period of time a hacker will be able to remain active before they get kicked off, therefore this value can be increased if you want to reduce CPU utilisation or you are not worried that the hacker stays connected for longer. Your decision! Do not reduce time below 15 seconds, otherwise script could still be running when it gets called again by scheduler.)

    Code:
    :local host
    :local ipnum
    :local unum
    :local usr
    :local i
    :global hacklist

    :foreach host in=$hacklist do={
    :foreach i in= [/ip dhcp-server lease find host-name=$host] do={
    :set ipnum [/ip dhcp-server lease get $i address]
    :set unum [/ip hotspot active find address=$ipnum]
    :if ([:len $unum] >0) do {
    :set usr [/ip hotspot active get $unum user]
    :log warning ($host . " " . $ipnum . " " . $usr)
    /ip hotspot active remove $unum
    }
    }
    }
    Última edição por int21; 06-08-2010 às 22:16.






Tópicos Similares

  1. Respostas: 14
    Último Post: 01-06-2016, 00:16
  2. Problema com conflito de IP
    Por lflisboa no fórum Redes
    Respostas: 7
    Último Post: 01-06-2009, 23:07
  3. Respostas: 13
    Último Post: 22-04-2009, 11:21
  4. Invasão Mikrotik clonagem de ip e mac
    Por dionatanvc no fórum Redes
    Respostas: 32
    Último Post: 07-03-2009, 17:48
  5. Problemas com atribuiçao de ip
    Por francispaulinely no fórum Redes
    Respostas: 3
    Último Post: 10-02-2008, 22:10

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L