+ Responder ao Tópico

  1. Citação Postado originalmente por combatnet Ver Post
    otimo progama amigo scan sou usuario leigo e fiz de primeira com 2 links , se não for ofença esta aberto a doaçoes
    Eu também consegui fazer de primeira com 3 link, já tem duas semanas que está funcionando perfeitamente...
    Scan, só tenho a te agradecer pelo programa q foi de grande ajuda para mim e para muito aq do forum...
    Eu fiquei meio sem jeito de perguntar, mas já que o amigo combatnet já perguntou eu repito a pergunta dele... Você está aberto a doações, ou mesmo gostaria de uma doação para um projeto que você participa ou apoia?!... Isso seria uma forma de agradecimento e incentivo ao seu trabalho que nos foi tão útil.
    Obg ...

  2. Bom dia!

    Não é nescessário doações, pois este programa free foi feito para agradeçer a todos do forum que me ajudaram de uma forma ou de outra, pois aqui é um lugar de tirar dúvidas e passar conhecimentos. A melhor forma que achei para contribuir para o forum foi a criação do Programa - PCC para facilitar a vida de muitos e evitar erros na hora da configuração que a medida que há varios links aumenta e muito a configuração.

    Att.: Scan




  3. Bom noite Scan,
    Infelismente não tive sorte com o programa infelismente pra mim não quer dar certo.
    Simplesmente quando ativo os dos links adsl a navegação para nos dois links.

    Uso dois adsl com modem em bridge. segue minhas regras para vc dar uma analisada e ver se tem algo de errado.

    # ip address --------------------------
    /ip address add address=10.1.1.1/24 interface=Link-Vai
    # interface pppoe-client ---------------
    /interface pppoe-client add ac-name="" add-default-route=no allow=pap,chap,mschap1,mschap2 dial-on-demand=no disabled=no interface=Modem-OI-2 max-mru=1480 max-mtu=1480 mrru=disabled name=adsl_Modem-OI-2 password=6536631918 profile=default service-name="" use-peer-dns=no user=MTOS89884103
    /interface pppoe-client add ac-name="" add-default-route=no allow=pap,chap,mschap1,mschap2 dial-on-demand=no disabled=no interface=Modem-GVT-3 max-mru=1480 max-mtu=1480 mrru=disabled name=adsl_Modem-GVT-3 password=gvt25 profile=default service-name="" use-peer-dns=no [email protected]
    # ip dns --------------------------------
    /ip dns set allow-remote-requests=yes

    # ip firewall Filter------------------------
    /ip firewall filter add action=drop chain=forward comment="BLOQUEIO DE DNS REVERSO" content=velox.user.com.br disabled=no
    /ip firewall filter add action=drop chain=forward comment="BLOQUEIO DE DNS REVERSO" content=speed.user.com.br disabled=no
    # ip firewall nat--------------------------
    /ip firewall nat add action=masquerade chain=srcnat disabled=no out-interface=adsl_Modem-OI-2
    /ip firewall nat add action=masquerade chain=srcnat disabled=no out-interface=adsl_Modem-GVT-3
    # ip firewall mangle------------------------
    # LoopBack por link-------------------------
    / ip firewall mangle add action=mark-connection chain=prerouting comment="" connection-state=new disabled=no dst-address-list=LINK0 in-interface=Link-Vai new-connection-mark=Sites0 passthrough=yes
    / ip firewall mangle add action=mark-routing chain=prerouting comment="" connection-mark=Sites0 disabled=no in-interface=Link-Vai new-routing-mark=Rota0 passthrough=no
    / ip route add gateway=adsl_Modem-OI-2 routing-mark=Rota0
    / ip firewall mangle add action=mark-connection chain=prerouting comment="" connection-state=new disabled=no dst-address-list=LINK1 in-interface=Link-Vai new-connection-mark=Sites1 passthrough=yes
    / ip firewall mangle add action=mark-routing chain=prerouting comment="" connection-mark=Sites1 disabled=no in-interface=Link-Vai new-routing-mark=Rota1 passthrough=no
    / ip route add gateway=adsl_Modem-GVT-3 routing-mark=Rota1
    /ip firewall address-list add address=201.7.176.0/20 comment="Vídeos - Globo" disabled=no list=LINK0
    /ip firewall address-list add address=208.84.247.0/24 comment="Vídeos - terratv" disabled=no list=LINK0
    /ip firewall address-list add address=200.154.56.0/24 comment="Vídeos - terratv" disabled=no list=LINK0
    /ip firewall address-list add address=201.7.176.0/24 comment="" disabled=no list=LINK1
    /ip firewall address-list add address=201.7.178.0/24 comment="" disabled=no list=LINK1
    /ip firewall address-list add address=208.67.217.0/24 comment="" disabled=no list=LINK1
    /ip firewall address-list add address=208.69.32.0/24 comment="" disabled=no list=LINK1
    /ip firewall address-list add address=64.38.29.0/24 comment="RapidShare" disabled=no list=LINK1
    # Fim LoopBack por link----------------------
    /ip firewall mangle add action=accept chain=prerouting comment="HTTPS FORA DO LOADBALACED" disabled=no protocol=tcp dst-port=443 in-interface=Link-Vai
    /ip firewall mangle add action=accept chain=prerouting comment="FORA DO LOADBALACED" disabled=no dst-address-list=loopback in-interface=Link-Vai
    /ip firewall mangle add action=change-ttl chain=forward comment="Filtro Tracert / Traceroute" disabled=no new-ttl=set:30 protocol=icmp
    /ip firewall mangle add action=mark-connection connection-state=new chain=prerouting disabled=no in-interface=adsl_Modem-OI-2 new-connection-mark=adsl_Modem-OI-2_conn passthrough=yes
    /ip firewall mangle add action=mark-connection connection-state=new chain=prerouting disabled=no in-interface=adsl_Modem-GVT-3 new-connection-mark=adsl_Modem-GVT-3_conn passthrough=yes
    /ip firewall mangle add action=mark-routing chain=output connection-mark=adsl_Modem-OI-2_conn disabled=no new-routing-mark=to_adsl_Modem-OI-2 passthrough=yes
    /ip firewall mangle add action=mark-routing chain=output connection-mark=adsl_Modem-GVT-3_conn disabled=no new-routing-mark=to_adsl_Modem-GVT-3 passthrough=yes
    /ip firewall mangle add action=mark-connection connection-state=new chain=prerouting disabled=no dst-address-type=!local in-interface=Link-Vai new-connection-mark=adsl_Modem-OI-2_conn passthrough=yes per-connection-classifier=both-addresses-and-ports:6/0
    /ip firewall mangle add action=mark-connection connection-state=new chain=prerouting disabled=no dst-address-type=!local in-interface=Link-Vai new-connection-mark=adsl_Modem-GVT-3_conn passthrough=yes per-connection-classifier=both-addresses-and-ports:6/1
    /ip firewall mangle add action=mark-connection connection-state=new chain=prerouting disabled=no dst-address-type=!local in-interface=Link-Vai new-connection-mark=adsl_Modem-GVT-3_conn passthrough=yes per-connection-classifier=both-addresses-and-ports:6/2
    /ip firewall mangle add action=mark-connection connection-state=new chain=prerouting disabled=no dst-address-type=!local in-interface=Link-Vai new-connection-mark=adsl_Modem-GVT-3_conn passthrough=yes per-connection-classifier=both-addresses-and-ports:6/3
    /ip firewall mangle add action=mark-connection connection-state=new chain=prerouting disabled=no dst-address-type=!local in-interface=Link-Vai new-connection-mark=adsl_Modem-GVT-3_conn passthrough=yes per-connection-classifier=both-addresses-and-ports:6/4
    /ip firewall mangle add action=mark-connection connection-state=new chain=prerouting disabled=no dst-address-type=!local in-interface=Link-Vai new-connection-mark=adsl_Modem-GVT-3_conn passthrough=yes per-connection-classifier=both-addresses-and-ports:6/5
    /ip firewall mangle add action=mark-routing chain=prerouting connection-mark=adsl_Modem-OI-2_conn disabled=no in-interface=Link-Vai new-routing-mark=to_adsl_Modem-OI-2 passthrough=yes
    /ip firewall mangle add action=mark-routing chain=prerouting connection-mark=adsl_Modem-GVT-3_conn disabled=no in-interface=Link-Vai new-routing-mark=to_adsl_Modem-GVT-3 passthrough=yes

  4. # ip route----------------------------------
    /ip route add disabled=no distance=1 dst-address=0.0.0.0/0 gateway=adsl_Modem-OI-2 routing-mark=to_adsl_Modem-OI-2 comment="Link0"
    /ip route add disabled=no distance=1 dst-address=0.0.0.0/0 gateway=adsl_Modem-GVT-3 routing-mark=to_adsl_Modem-GVT-3 comment="Link1"
    /ip route add comment="Link0" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=adsl_Modem-OI-2 scope=30 target-scope=10
    /ip route add comment="Link1" disabled=no distance=2 dst-address=0.0.0.0/0 gateway=adsl_Modem-GVT-3 scope=30 target-scope=10
    # ip firewall address-list-----------------------------
    /ip firewall address-list add address=200.155.80.0-200.155.255.255 comment=BRADESCO disabled=no list=loopback
    /ip firewall address-list add address=200.220.186.0/24 comment=BRADESCO disabled=no list=loopback
    /ip firewall address-list add address=200.220.178.0/24 comment=BRADESCO disabled=no list=loopback
    /ip firewall address-list add address=64.38.29.0/24 comment=RapidShare disabled=no list=loopback
    /ip firewall address-list add address=208.69.32.0/24 comment="" disabled=no list=loopback
    /ip firewall address-list add address=208.67.217.0/24 comment="" disabled=no list=loopback
    /ip firewall address-list add address=201.7.178.0/24 comment="" disabled=no list=loopback
    /ip firewall address-list add address=201.7.176.0/24 comment="" disabled=no list=loopback
    /ip firewall address-list add address=200.159.128.0/24 comment=BRADESCO disabled=no list=loopback
    /ip firewall address-list add address=201.7.176.0/20 comment="Vídeos - Globo" disabled=no list=loopback
    /ip firewall address-list add address=208.84.247.0/24 comment="Vídeos - terratv" disabled=no list=loopback
    /ip firewall address-list add address=200.154.56.0/24 comment="Vídeos - terratv" disabled=no list=loopback
    /ip firewall address-list add address=200.201.160.0/24 comment="Caixa Economica Federal" disabled=no list=loopback
    /ip firewall address-list add address=200.201.166.0/24 comment="" disabled=no list=loopback
    /ip firewall address-list add address=200.201.173.0/24 comment="" disabled=no list=loopback
    /ip firewall address-list add address=200.201.174.0/24 comment="" disabled=no list=loopback
    /ip firewall address-list add address=200.141.207.3 comment=Detran disabled=no list=loopback
    # /system script--------------------------------------
    /system script add name=Link0Dow policy=\ ftp,reboot,read,write,policy,test,winbox,password,sniff,sensitive source="\ /ip firewall filter set [find comment=\"Link0\"] disabled=yes;\r\ \n/ip firewall nat set [find comment=\"Link0\"] disabled=yes;\r\ \n/ip firewall mangle set [find comment=\"Link0\"] disabled=yes;\r\ \n/ip route set [find comment=\"Link0\"] disabled=yes;"
    /system script add name=Link1Dow policy=\ ftp,reboot,read,write,policy,test,winbox,password,sniff,sensitive source="\ /ip firewall filter set [find comment=\"Link1\"] disabled=yes;\r\ \n/ip firewall nat set [find comment=\"Link1\"] disabled=yes;\r\ \n/ip firewall mangle set [find comment=\"Link1\"] disabled=yes;\r\ \n/ip route set [find comment=\"Link1\"] disabled=yes;"
    /system script add name=Link0Up policy=\ ftp,reboot,read,write,policy,test,winbox,password,sniff,sensitive source="\ /ip firewall filter set [find comment=\"Link0\"] disabled=no;\r\ \n/ip firewall nat set [find comment=\"Link0\"] disabled=no;\r\ \n/ip firewall mangle set [find comment=\"Link0\"] disabled=no;\r\ \n/ip route set [find comment=\"Link0\"] disabled=no;"
    /system script add name=Link1Up policy=\ ftp,reboot,read,write,policy,test,winbox,password,sniff,sensitive source="\ /ip firewall filter set [find comment=\"Link1\"] disabled=no;\r\ \n/ip firewall nat set [find comment=\"Link1\"] disabled=no;\r\ \n/ip firewall mangle set [find comment=\"Link1\"] disabled=no;\r\ \n/ip route set [find comment=\"Link1\"] disabled=no;"



    No aguardo.
    Obrigado.

  5. bom dia!

    Analisando o código, aparentemente está ok, pode ser outro fator, por exemplo: a porta que está conectado o link oi está erra e sim conectada na porta lan do outro adsl e vise versa... tipo, qual dns vc está usando pois pode ocorrer o problema de um requisição ir por um adsl sendo que a requisição dns vai pelo dns do outro link, aqui uso dns do google 8.8.8.8 e 8.8.4.4, tem vários outros.... como eu falei, aparentemente não erros no código, mas para desencargo de conciencia, reset sua rb e não renomeie as interfaces e depois faça uma nova config usando só o básico das configuraçoes do pcc, sem usar o loop back direcionado por link "por que isso, o loop back direcionado foi o ultimo recurso colocado no programa no qual nao testei, foi código disponibilizado por colaboradores", resumindo, o negocio é procurar "conserteza é algum detalhe que possa ter passado despercebido".

    Att.: Scan







Tópicos Similares

  1. Respostas: 24
    Último Post: 25-03-2014, 07:52
  2. script para gerar tabelas dos logs???
    Por tomelin no fórum Linguagens de Programação
    Respostas: 1
    Último Post: 26-06-2006, 09:25
  3. programa para testar segurança do firewall
    Por johnny no fórum Servidores de Rede
    Respostas: 9
    Último Post: 01-11-2005, 13:48
  4. problemas para gerar modulo do tomcat
    Por mcclaudio no fórum Servidores de Rede
    Respostas: 2
    Último Post: 03-09-2004, 10:07
  5. Programa para gerenciar configuração!!!
    Por Algoritmo_PB no fórum Servidores de Rede
    Respostas: 2
    Último Post: 24-07-2004, 15:10

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L