+ Responder ao Tópico

  1. dimix, a aba comment eh apenas para comentarios, e nao tem problema nenhum vc remove-la, entao estao tudo OK sim.

    agora, uma coisa q eu nao entendo, o PCC nao precisa de DNS, pois ele soh balanceia os links, nao precisa ta navegando na router do PCC, entao eu nao entendo pq o Scan usa o DNS primario e secudario no PCC.

    em relacao a router, nao tem problema a licenca, pois tanto na nivel 4 ja da pra funcionar o PCC, e vc nao faz cadastro de usuario no mkt, vc tem q imaginar q o mkt vai virar um ROTEADOR, estilo um cisco balanceador, a diferenca eh q um balanceador da cisco custa mais de mil reais.

    tem gente q usa o PCC junto com hotspot, porem nao eh aconselhado.

    aqui eu uso em uma RB750G, antes do meu servidor de autenticacao q eh em linux, funciona td ok, soh q eu nao cadastro DNS no meu pcc, muito menos esse dns estatico!!

    eu usei esse tutorial, aqui msm do under:
    http://under-linux.org/f227/pcc-bala...r-m4d3-131343/

    percebe-se q o m4d3 nem toca no assunto de DNS no tutorial dele, e funciona 100%.
    eu acho q a unica vantagem q se tem, de setar um DNS no PCC seria para um acesso externo ao PCC, porem acho q nao tem necessidade!! me corrija se estiver errado!!

    abracos......

  2. NKS, Agradeço seu esclarecimento quanto à minha pergunta, mas apaguei a mesma (pelo jeito, no momento que estava respondendo) para acrescentar mais uma dúvida e assim não criar várias perguntas distribuidas... Mais uma vez obrigado pelo esclarecimento... Agora tenho uma pergunta à mais (junto com a primeira), sobre uma regra no Firewall Filter, se poder me ajudar novamente, agradeço.

    Pessoal... FELIZ 2011 à todos... Que seja um ano com muita paz, sucesso e conquistas para todos!!!

    Só uma coisa quanto a geração do código na parte do DNS Estático, isso já na versão 1.3 do programa (o qual estou começando a usar):
    O código gerado é:

    # ip dns statico------------------------
    /ip dns static add address=172.16.0.1 comment="" disabled=no name=172.16.0.1.e-compti.com.br ttl=1d

    Só que quando colo todo o código no terminal, ele mostra erro na parte do "comment", e quando fui no MK pelo Winbox, ví que não tem o campo "comment" no "DNS Estático", então só apaguei o comment="", que quando colei de novo o código no terminal não apresentou nenhum erro e criou o "DNS Estático" normal no MK, ficando assim o código:

    # ip dns statico------------------------
    /ip dns static add address=172.16.0.1 disabled=no name=172.16.0.1.e-compti.com.br ttl=1d

    Somente apagando a referência ao comment=""

    **Nova Pergunta**

    Outra coisa que notei, foi no código:

    # ip firewall Filter------------------------
    /ip firewall filter add action=drop chain=forward comment="BLOQUEIO DE DNS REVERSO" content=dsl.telesp.net.br disabled=no
    /ip firewall filter add action=accept chain=input disabled=no in-interface=!ether2 src-address=172.16.0.1/24

    Ele está criando o bloqueio do DNS REVERSO, mas na próxima regra, é necessário especificar a "interface=!ether2"? Depois quando acesso pelo Winbox, no Firewall - Filter Rules, aparece no Src. Address o ip: 172.16.0.0/24, e não o 172.16.0.1/24, igual no código acima que foi gerado pelo programa PCC.
    E mesmo se for necessário especificar a interface, no meu caso, a que se comunica com o Servidor MK que faz o controle dos clientes é a "ether1", e não a "ether2" que é a interface do meu link Dedicado. Posso deixar "ether2", ou mudo para "ether1"?
    Eu tenho um Balance PCC aqui rodando normalmente, mas paguei para fazerem prá mim na época, então não sei como que funciona exatamente, estou aprendendo agora com esse novo balance que estou fazendo com a ajuda de vcoês e quero aproveitar e adicionar mais link.
    Aqui no meu balance atual (que eu paguei para fazerem), no campo "Src. Address", está 172.16.0.0/24 também, igual ficou no Balance novo (através do programa PCC)como foi criado pelo seu código, isso quando acesso pelo Winbox (mesmo ele mostrando 172.16.0.1/24 no código criado através do programa PCC), mas não especifica nenhuma "interface", ficando em branco, já através do programa PCC, especifica a "ether2". Estou mandando uma imagem de como ficou esse campo aqui. É assim mesmo, ou preciso mudar algo?

    É isso mesmo Scan e demais membros que manjam?
    Só mais uma dúvida, sobre o mikrotik, tem diferença de ser Level 4 para Level 6 pela quantidade de clientes conectados simultaneamente? Ou por somente se conectar ao link, isso não tem importância? Porque minha licença é Level 4.
    Mais uma vez Obrigado NKS e demais membros do Fórum...
    Valeu pessoal... FELIZ 2011 A TODOS!!!!!

    Imagem abaixo:
    Miniaturas de Anexos Miniaturas de Anexos Clique na imagem para uma versão maior

Nome:	         firewall - filter.jpg
Visualizações:	80
Tamanho: 	44,6 KB
ID:      	18212  
    Última edição por dimix; 01-01-2011 às 22:07.



  3. a primeira vez que eu tentei gerar a config, ele gerou, mas ficou igual à config padrão que tava no txt inicialmente. A segunda vez que eu tentei, deu um erro, mas não tinha descrição do que aconteceu de errado.

    Alguem pode me gerar uma config e colar o código aqui? São 3 links dsl, e 1 interface de saída (IP mesmo, rede /24). Depois eu corrijo os ips, nomes de interfaces e tudo mais.

    Infelizmente eu não tenho links sobrando aqui pra poder ficar fazendo teste até descobrir como funciona esse load balance, só posso mexer nos links durante a madrugada, coloco um link de backup pros clientes e começo a fazer lab com os outros.

    Grato, abraço!
    Última edição por Gosulator; 03-01-2011 às 09:20.

  4. Olá Gosulator....
    Eu fiz o código para você baseando em 3 links DSL de 2048 mb cada. Qualquer coisa quanto a isso, me passa a velocidade real dos seus links que eu refaço o código aqui para você.
    Quanto ao código, quando colo o mesmo no MK 3.30 (versão que testei no início) ele cria todas as regras normais, mas quando faço no MK 4.6 (que é a versão que tenho no meu balance), ele não cria somente os DNS, sendo que depois eu acesso o MK através do Winbox e coloco os DNS manualmente, do resto vai tudo normal.
    Qualquer coisa é só falar que estamos aqui a disposição.
    O código vai dividido em 2 partes:

    # ip address --------------------------
    /ip address add address=172.16.0.1/24 interface=saida

    # interface pppoe-client ---------------
    /interface pppoe-client add ac-name="" add-default-route=no allow=pap,chap,mschap1,mschap2 dial-on-demand=no disabled=no interface=adsl_01 max-mru=1480 max-mtu=1480 mrru=disabled name=adsl_adsl_01 password=user1 profile=default service-name="" use-peer-dns=no user=user1@user1.com.br
    /interface pppoe-client add ac-name="" add-default-route=no allow=pap,chap,mschap1,mschap2 dial-on-demand=no disabled=no interface=adsl_02 max-mru=1480 max-mtu=1480 mrru=disabled name=adsl_adsl_02 password=user2 profile=default service-name="" use-peer-dns=no user=user2@user2.com.br
    /interface pppoe-client add ac-name="" add-default-route=no allow=pap,chap,mschap1,mschap2 dial-on-demand=no disabled=no interface=adsl_03 max-mru=1480 max-mtu=1480 mrru=disabled name=adsl_adsl_03 password=user3 profile=default service-name="" use-peer-dns=no user=user3@user3.com.br

    # ip dns --------------------------------
    /ip dns set primary-dns=200.204.0.10
    /ip dns set secondary-dns=200.204.0.138
    /ip dns set allow-remote-requests=yes

    # ip dns statico------------------------
    /ip dns static add address=172.16.0.1 disabled=no name=172.16.0.1.provedor.com.br ttl=1d

    # ip firewall Filter------------------------
    /ip firewall filter add action=drop chain=forward comment="BLOQUEIO DE DNS REVERSO" content=dsl.telesp.net.br disabled=no

    # ip firewall nat--------------------------
    /ip firewall nat add action=masquerade chain=srcnat disabled=no out-interface=adsl_adsl_01
    /ip firewall nat add action=masquerade chain=srcnat disabled=no out-interface=adsl_adsl_02
    /ip firewall nat add action=masquerade chain=srcnat disabled=no out-interface=adsl_adsl_03

    # ip firewall mangle------------------------

    # LoopBack por link-------------------------
    / ip firewall mangle add action=mark-connection chain=prerouting comment="" connection-state=new disabled=no dst-address-list=LINK1 in-interface=saida new-connection-mark=Sites1 passthrough=yes
    / ip firewall mangle add action=mark-routing chain=prerouting comment="" connection-mark=Sites1 disabled=no in-interface=saida new-routing-mark=Rota1 passthrough=no
    / ip route add gateway=adsl_adsl_02 routing-mark=Rota1

    /ip firewall address-list add address=201.7.176.0/24 comment="" disabled=no list=LINK1
    /ip firewall address-list add address=201.7.178.0/24 comment="" disabled=no list=LINK1
    /ip firewall address-list add address=208.67.217.0/24 comment="" disabled=no list=LINK1
    /ip firewall address-list add address=208.69.32.0/24 comment="" disabled=no list=LINK1
    /ip firewall address-list add address=64.38.29.0/24 comment="RapidShare" disabled=no list=LINK1
    # Fim LoopBack por link----------------------

    /ip firewall mangle add action=accept chain=prerouting comment="HTTPS FORA DO LOADBALACED" disabled=no protocol=tcp dst-port=443 in-interface=saida
    /ip firewall mangle add action=accept chain=prerouting comment="FORA DO LOADBALACED" disabled=no dst-address-list=loopback in-interface=saida
    /ip firewall mangle add action=change-ttl chain=forward comment="Filtro Tracert / Traceroute" disabled=no new-ttl=set:30 protocol=icmp
    /ip firewall mangle add action=mark-connection connection-state=new chain=prerouting disabled=no in-interface=adsl_adsl_01 new-connection-mark=adsl_adsl_01_conn passthrough=yes
    /ip firewall mangle add action=mark-connection connection-state=new chain=prerouting disabled=no in-interface=adsl_adsl_02 new-connection-mark=adsl_adsl_02_conn passthrough=yes
    /ip firewall mangle add action=mark-connection connection-state=new chain=prerouting disabled=no in-interface=adsl_adsl_03 new-connection-mark=adsl_adsl_03_conn passthrough=yes
    /ip firewall mangle add action=mark-routing chain=output connection-mark=adsl_adsl_01_conn disabled=no new-routing-mark=to_adsl_adsl_01 passthrough=yes
    /ip firewall mangle add action=mark-routing chain=output connection-mark=adsl_adsl_02_conn disabled=no new-routing-mark=to_adsl_adsl_02 passthrough=yes
    /ip firewall mangle add action=mark-routing chain=output connection-mark=adsl_adsl_03_conn disabled=no new-routing-mark=to_adsl_adsl_03 passthrough=yes
    /ip firewall mangle add action=mark-connection connection-state=new chain=prerouting disabled=no dst-address-type=!local in-interface=saida new-connection-mark=adsl_adsl_01_conn passthrough=yes per-connection-classifier=both-addresses:3/0
    /ip firewall mangle add action=mark-connection connection-state=new chain=prerouting disabled=no dst-address-type=!local in-interface=saida new-connection-mark=adsl_adsl_02_conn passthrough=yes per-connection-classifier=both-addresses:3/1
    /ip firewall mangle add action=mark-connection connection-state=new chain=prerouting disabled=no dst-address-type=!local in-interface=saida new-connection-mark=adsl_adsl_03_conn passthrough=yes per-connection-classifier=both-addresses:3/2
    /ip firewall mangle add action=mark-routing chain=prerouting connection-mark=adsl_adsl_01_conn disabled=no in-interface=saida new-routing-mark=to_adsl_adsl_01 passthrough=yes
    /ip firewall mangle add action=mark-routing chain=prerouting connection-mark=adsl_adsl_02_conn disabled=no in-interface=saida new-routing-mark=to_adsl_adsl_02 passthrough=yes
    /ip firewall mangle add action=mark-routing chain=prerouting connection-mark=adsl_adsl_03_conn disabled=no in-interface=saida new-routing-mark=to_adsl_adsl_03 passthrough=yes
    Última edição por dimix; 03-01-2011 às 16:04.

  5. Continuação:

    # ip route----------------------------------
    /ip route add disabled=no distance=1 dst-address=0.0.0.0/0 gateway=adsl_adsl_01 routing-mark=to_adsl_adsl_01 comment="Link0"
    /ip route add disabled=no distance=1 dst-address=0.0.0.0/0 gateway=adsl_adsl_02 routing-mark=to_adsl_adsl_02 comment="Link1"
    /ip route add disabled=no distance=1 dst-address=0.0.0.0/0 gateway=adsl_adsl_03 routing-mark=to_adsl_adsl_03 comment="Link2"
    /ip route add comment="Link0" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=adsl_adsl_01 scope=30 target-scope=10
    /ip route add comment="Link1" disabled=no distance=2 dst-address=0.0.0.0/0 gateway=adsl_adsl_02 scope=30 target-scope=10
    /ip route add comment="Link2" disabled=no distance=3 dst-address=0.0.0.0/0 gateway=adsl_adsl_03 scope=30 target-scope=10

    # ip firewall address-list-----------------------------
    /ip firewall address-list add address=200.155.80.0-200.155.255.255 comment=BRADESCO disabled=no list=loopback
    /ip firewall address-list add address=200.220.186.0/24 comment=BRADESCO disabled=no list=loopback
    /ip firewall address-list add address=200.220.178.0/24 comment=BRADESCO disabled=no list=loopback
    /ip firewall address-list add address=64.38.29.0/24 comment=RapidShare disabled=no list=loopback
    /ip firewall address-list add address=208.69.32.0/24 comment="" disabled=no list=loopback
    /ip firewall address-list add address=208.67.217.0/24 comment="" disabled=no list=loopback
    /ip firewall address-list add address=201.7.178.0/24 comment="" disabled=no list=loopback
    /ip firewall address-list add address=201.7.176.0/24 comment="" disabled=no list=loopback
    /ip firewall address-list add address=200.159.128.0/24 comment=BRADESCO disabled=no list=loopback
    /ip firewall address-list add address=201.7.176.0/20 comment="Vídeos - Globo" disabled=no list=loopback
    /ip firewall address-list add address=208.84.247.0/24 comment="Vídeos - terratv" disabled=no list=loopback
    /ip firewall address-list add address=200.154.56.0/24 comment="Vídeos - terratv" disabled=no list=loopback
    /ip firewall address-list add address=200.201.160.0/24 comment="Caixa Economica Federal" disabled=no list=loopback
    /ip firewall address-list add address=200.201.166.0/24 comment="" disabled=no list=loopback
    /ip firewall address-list add address=200.201.173.0/24 comment="" disabled=no list=loopback
    /ip firewall address-list add address=200.201.174.0/24 comment="" disabled=no list=loopback
    /ip firewall address-list add address=200.141.207.3 comment=Detran disabled=no list=loopback

    # /system script--------------------------------------
    /system script add name=Link0Dow policy=\ ftp,reboot,read,write,policy,test,winbox,password,sniff,sensitive source="\ /ip firewall filter set [find comment=\"Link0\"] disabled=yes;\r\ \n/ip firewall nat set [find comment=\"Link0\"] disabled=yes;\r\ \n/ip firewall mangle set [find comment=\"Link0\"] disabled=yes;\r\ \n/ip route set [find comment=\"Link0\"] disabled=yes;"
    /system script add name=Link1Dow policy=\ ftp,reboot,read,write,policy,test,winbox,password,sniff,sensitive source="\ /ip firewall filter set [find comment=\"Link1\"] disabled=yes;\r\ \n/ip firewall nat set [find comment=\"Link1\"] disabled=yes;\r\ \n/ip firewall mangle set [find comment=\"Link1\"] disabled=yes;\r\ \n/ip route set [find comment=\"Link1\"] disabled=yes;"
    /system script add name=Link2Dow policy=\ ftp,reboot,read,write,policy,test,winbox,password,sniff,sensitive source="\ /ip firewall filter set [find comment=\"Link2\"] disabled=yes;\r\ \n/ip firewall nat set [find comment=\"Link2\"] disabled=yes;\r\ \n/ip firewall mangle set [find comment=\"Link2\"] disabled=yes;\r\ \n/ip route set [find comment=\"Link2\"] disabled=yes;"
    /system script add name=Link0Up policy=\ ftp,reboot,read,write,policy,test,winbox,password,sniff,sensitive source="\ /ip firewall filter set [find comment=\"Link0\"] disabled=no;\r\ \n/ip firewall nat set [find comment=\"Link0\"] disabled=no;\r\ \n/ip firewall mangle set [find comment=\"Link0\"] disabled=no;\r\ \n/ip route set [find comment=\"Link0\"] disabled=no;"
    /system script add name=Link1Up policy=\ ftp,reboot,read,write,policy,test,winbox,password,sniff,sensitive source="\ /ip firewall filter set [find comment=\"Link1\"] disabled=no;\r\ \n/ip firewall nat set [find comment=\"Link1\"] disabled=no;\r\ \n/ip firewall mangle set [find comment=\"Link1\"] disabled=no;\r\ \n/ip route set [find comment=\"Link1\"] disabled=no;"
    /system script add name=Link2Up policy=\ ftp,reboot,read,write,policy,test,winbox,password,sniff,sensitive source="\ /ip firewall filter set [find comment=\"Link2\"] disabled=no;\r\ \n/ip firewall nat set [find comment=\"Link2\"] disabled=no;\r\ \n/ip firewall mangle set [find comment=\"Link2\"] disabled=no;\r\ \n/ip route set [find comment=\"Link2\"] disabled=no;"






Visite: BR-Linux ·  VivaOLinux ·  Dicas-L