+ Responder ao Tópico



  1. bom dia gsiena!

    As observações 1,2,3,4,6 foram todas implementadas e só estou a fazer uns testes básicos aqui e logo posta a versão nova do programa....

    t++ e obrigado pela colaboração...

  2. bom dia!

    Baseado nas observação do colega gsiena, segue abaixo nova versão do programa.

    Versão 0.9
    http://www.saocarlosnet.com.br/PCC_ver_0.9.zip
    http://www.saocarlosnet.com.br/log.txt



  3. Citação Postado originalmente por scan Ver Post
    bom dia!

    Baseado nas observação do colega gsiena, segue abaixo nova versão do programa.

    Versão 0.9
    http://www.saocarlosnet.com.br/PCC_ver_0.9.zip
    http://www.saocarlosnet.com.br/log.txt
    Estou usando aqui a versão com script gerado apartir da versão 0.8 em duas ADSL Bridge, ambas estão operando normalmente numa RB450. Durante a madrugada vou fazer o update, mas gostaria de saber se é realmente necessário ou não, uma vez que nenhum assinante reclamou de nada até agora!

  4. Everton, se esta tudo funcionando 100%, nao é nescessário o update. o Codigo gerado é praticamente o mesmo, exceto os comments. Estou aperfeiçoando umas coisas no script gerado, logo posto aqui mais algumas dicas/ideias. Eu uso esse balanceamento pcc praticamente desde quando foi lançado e tenho uma boa experiencia com ele, tenho cerca de 10 clientes meus (provedores) com esse balanceamento em produçao, alguns tem 8 links e mais de 400 clientes ativos nos horarios de pico, sem nenhum problema de navegaçao.
    Qualquer duvida posta ae...abraço
    Gabriel



  5. Citação Postado originalmente por gsiena Ver Post
    Sugestoes/Correçoes
    Caro scan , sugiro algumas modificaçoes/correçoes no programa, que alias é muito bom:

    1 - Opçao para escolher qual dos links será a rota padrão (distance=1 e sem routing-mark)
    2 - em /interface pppoe-client , setar como no as opçoes add-default-route e use-peer-dns , pois as mesmas interferem nas rotas e dns setados pelo codigo gerado.
    3 - Criar uma regra pra direcionar o trafego https (porta tcp 443) para a rota principal (esta regra deve ficar antes das regras do balanceamento PCC)
    (/ip firewall mangle add action=accept chain=prerouting comment="HTTPS FORA DO LOADBALACED" disabled=no protocol=tcp dst-port=443 in-interface=ether1)
    4 - Mudar a politica de balanceamento de=both-address para=both-address-and-ports , acho que esta ultima divide o trafego mais uniformemente.

    O resto ta excelente, o programa faz muito bem o que promete. Parabens pela iniciativa
    Gsiena, tenho o pcc funcionando e agora vejo sua dica para deixar as opçoes add-default-route e use-peer-dns como desmarcadas?! é isso mesmo ou essa dica é apenas para o programa do nosso amigo scan?

  6. Boa noite!

    Esta observação do Gsiena já foi implementada na ultima versão do sistema e pode ser utilizada por todos, a modificação visa a melhor ainda mais o desempenho do balanceador, neste caso, pode ser o caso de vc salvar suas configurações e testar a configuração com as modificações e confirmar ou não a melhora de desempenho.

    OBS:
    o add-default-route, prejudicava a marcação de rotas.
    o use-peer-dns, prejudicava o dns que vc tinha definido, ou seja, independente de vc ter ou não configurado um dns, esta opção alterava seu dns pela da operadora de um dos links adsl.

    t++



  7. Boa noite!

    na versão 1.0, eu quero modificar a interface mais uma vez e adicionar a possibilidade de modificar configurações já feitas, evitando assim por algum erro ter que fechar o programa e começar tudo novamente. Irei centralizar mais as funções na tela e deixar algumas opções opcionais tais como "qual per-connection usar, configurar dns, gerar ou não script para para alguma rota, etc.", vai demorar um pouco pois as primeiras versões deste programa éra programação estruturada, e da versão 6 adiante é orientado a objeto o que me deu a oportunidade de altualizar o programa com mais rapidez, mas eu quero refazer a estrutura do programa para que eu possa adicionar as funções novas e permitir colocar mais funções com mais facilidades.

    t++

  8. Citação Postado originalmente por scan Ver Post
    Boa noite!

    Esta observação do Gsiena já foi implementada na ultima versão do sistema e pode ser utilizada por todos, a modificação visa a melhor ainda mais o desempenho do balanceador, neste caso, pode ser o caso de vc salvar suas configurações e testar a configuração com as modificações e confirmar ou não a melhora de desempenho.

    OBS:
    o add-default-route, prejudicava a marcação de rotas.
    o use-peer-dns, prejudicava o dns que vc tinha definido, ou seja, independente de vc ter ou não configurado um dns, esta opção alterava seu dns pela da operadora de um dos links adsl.

    t++
    Obrigado por responder. Certamente voce esclareu para muitos de nós o significado e aplicaçao dessas opçoes.
    Fiz as mudanças -e mudei tambem de both-address para both-address-and-ports- e aparentemente melhorou.

    Obrigado
    Última edição por Juniin; 06-04-2010 às 22:54.



  9. Os sites Microsoft Corporation e www.avast.com não estam abrindo a solução vai ser adicionar ele em firewall > address list os ip dos sites para eu poder ter acesso a eles só ta faltando isso agora.

  10. Bom dia pessoal
    Mais algumas alterações para melhorar ainda mais o programa:

    # Alterações no codigo gerado:
    1 - Nas regras /ip firewall mangle, onde action=mark-connection , adicionado a opção connection-state=new , isto corrige possives falhas na navegacão e ainda permite redirecionamento de portas para todos os links.
    /ip firewall mangle add action=mark-connection chain=prerouting disabled=no in-interface=link1 connection-state=new new-connection-mark=ether2_conn passthrough=yes
    /ip firewall mangle add action=mark-connection chain=prerouting disabled=no dst-address-type=!local in-interface=ether1 connection-state=new new-connection-mark=ether2_conn passthrough=yes per-connection-classifier=both-addresses-and-ports:2/0

    2 - Nos scripts, corrigido erro, onde estava disable=yes o correto é disabled=yes
    /system script add name=Link1Dow policy=\ ftp,reboot,read,write,policy,test,winbox,password,sniff,sensitive source="\ /ip firewall filter set [find comment=\"Link1\"] disabled=yes;\r\ \n/ip firewall nat set [find comment=\"Link1\"] disabled=yes;\r\ \n/ip firewall mangle set [find comment=\"Link1\"] disabled=yes;\r\ \n/ip route set [find comment=\"Link1\"] disabled=yes;"

    3 - Recomendado utilizar a versão 4.x do Mikrotik para um excelente rendimento do balanceamento PCC, de preferencia a versão estável mais recente possível. A versão 4.x teve o pacote routing atualizado, com algumas melhorias.
    Última edição por gsiena; 08-04-2010 às 07:22.



  11. Cada dia esse programa ta mais show, valeu amigo...

  12. ainda não testei, mas parece que ta ficando cada vez mais show mesmo, estou sempre acompanhadno aqui



  13. bom dia!

    gsiena, irei fazer as atualizações o quanto antes possivel, mas estas vai demorar um pouco pois quero adicionar as funcionalidades que comentei em post anterior, mas ao terminar o sistema vai estar de cara nova e com as funcionalidades novas "as citadas acima e as citadas em post anterior".

    t++

  14. estou tendo problemas com o site da Microsoft Corporation, www.avast.com e o site da Sign In e o msn não abre de jeito nenhum, data e horas estão atualizados no servidor e nos computadores da rede e ainda continua com o mesmo problema.

  15. pode ser dns, aqui eu uso opendns...

    OBS: o código gerado pelo programa não esta setando o dns em versão 4.x do MK, pode ter acontecido isso com vc, basta ir em ip dns e setar o dns...

    na proxima versão este erro vai estar corrigido.

    t++

  16. eu estou usando os dns da minha operadora quando coloco opendns tambem fica do mesmo jeito, estou usando os script da sua ultima versão 0.9 que vc desenvolveu ... mas o resto ta show de bola, parabéns e sucessos.
    a briga agora ta feia loadbalance vs microsoft, avast e msn.

  17. uma duvida que apareceu agora no tutorial do amigo catvbrasil ele diz para marca duas opções: Na aba DIAL OUT, configure os campos:
    Deixar marcado as opções:
    *ADD DEFAULT ROUTER
    *USER PEER DNS
    fui dar uma olhada no meu loadbalance essas duas opções não esta marcada eu devo marca ou deixo do jeito que tá. porque ele marcou e no seu script não teve a necessidade de marca essas opções.

  18. Citação Postado originalmente por clecioe Ver Post
    uma duvida que apareceu agora no tutorial do amigo catvbrasil ele diz para marca duas opções: Na aba DIAL OUT, configure os campos:
    Deixar marcado as opções:
    *ADD DEFAULT ROUTER
    *USER PEER DNS
    fui dar uma olhada no meu loadbalance essas duas opções não esta marcada eu devo marca ou deixo do jeito que tá. porque ele marcou e no seu script não teve a necessidade de marca essas opções.
    amigo , dá uma olhada na pagina anterior que tem a explicaçao para essa sua pergunta

  19. em ip firewall address lists tem uma loopback que são os endereços que vc não quer que passe pelo balanceador e sim na rota principal...

    pode ser uma boa adicionar o bloco de ips dos serviços que estão com problemas até encontrar o problema "a solução".

    t++

  20. na opção ip firewall address lists eu adicionei o site www.hotmail.com.br mas continuo do mesmo jeito, o interessante é que em uns computador ele conseguer abrir e em outros não e queria fazer uma forma de todos os usuarios da rede passar somente por um gateway para ver se o site da hotmail abria e o msn, pois quando o modem ta roteador ele passar somento por um gateway.






Tópicos Similares

  1. Respostas: 24
    Último Post: 25-03-2014, 06:52
  2. script para gerar tabelas dos logs???
    Por tomelin no fórum Linguagens de Programação
    Respostas: 1
    Último Post: 26-06-2006, 08:25
  3. programa para testar segurança do firewall
    Por johnny no fórum Servidores de Rede
    Respostas: 9
    Último Post: 01-11-2005, 12:48
  4. problemas para gerar modulo do tomcat
    Por mcclaudio no fórum Servidores de Rede
    Respostas: 2
    Último Post: 03-09-2004, 09:07
  5. Programa para gerenciar configuração!!!
    Por Algoritmo_PB no fórum Servidores de Rede
    Respostas: 2
    Último Post: 24-07-2004, 14:10

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L