+ Responder ao Tópico



  1. #1

    Question squid cache.log comm_select: time out?

    ola a todos,estou tendo esse log no meu cache.log, e estou achando um pouco extranho "comm_select: time out" gostaria de saber se seus cache.log tem o mesmo ou se isso é algum problema, digo porque meu proxy é autenticado, e quando o usuario autentica log após, intermitentemente a primeira pagina na abre, tendo que aperta F5 diversas vezes para ele trazer a pagina. alguém pode dar um help?

    2010/01/26 19:16:00| storeAufsDirMaintain: /var/spool/squid3 removed 0/10 f=0.000 max_scan=100
    2010/01/26 19:16:00| storeMaintainSwapSpace: f=0.000000, max_scan=100, max_remove=10
    2010/01/26 19:16:00| cbdataFree: 0x9a50370
    2010/01/26 19:16:00| cbdataFree: Freeing 0x9a50370
    2010/01/26 19:16:00| storeAufsDirMaintain: /var/spool/squid4 removed 0/10 f=0.000 max_scan=100
    2010/01/26 19:16:00| eventAdd: Adding 'MaintainSwapSpace', in 1.000000 seconds
    2010/01/26 19:16:00| comm_select: timeout 1000
    2010/01/26 19:16:01| comm_select: time out
    2010/01/26 19:16:01| comm_select: timeout 8
    2010/01/26 19:16:01| comm_select: time out

    2010/01/26 19:16:01| eventRun: RUN ID 1592
    2010/01/26 19:16:01| eventRun: Running 'MaintainSwapSpace', id 1591
    2010/01/26 19:16:01| storeMaintainSwapSpace: f=0.000000, max_scan=100, max_remove=10
    2010/01/26 19:16:01| cbdataFree: 0x9a50370
    2010/01/26 19:16:01| cbdataFree: Freeing 0x9a50370
    2010/01/26 19:16:01| storeAufsDirMaintain: /var/spool/squid removed 0/10 f=0.000 max_scan=100
    2010/01/26 19:16:01| storeMaintainSwapSpace: f=0.000000, max_scan=100, max_remove=10

  2. #2

    Padrão

    ja fiz proxy autenticado e nao, nenhum deles tem que apertar F5 para atualizar, e esse erro nao e normal nao, sua rede e grandfe ou pequena, se for grande, as vezes tem que aumentar uma opcao no squid, mas nao sei se e seu caso, tipo, se tiver uns 500 clientes, assim precisa, se nao nao.



  3. #3

    Padrão

    Citação Postado originalmente por wppitp Ver Post
    ja fiz proxy autenticado e nao, nenhum deles tem que apertar F5 para atualizar, e esse erro nao e normal nao, sua rede e grandfe ou pequena, se for grande, as vezes tem que aumentar uma opcao no squid, mas nao sei se e seu caso, tipo, se tiver uns 500 clientes, assim precisa, se nao nao.
    a rede tem 150 maquinas, poderia passar essa opção do squid para eu poder testa-la aqui? agradeço.

  4. #4

    Padrão

    Boa tarde, comigo nunca aconteceu isso, andei verificando todos os logs do meu squid. Tente os passos a seguir, caso não de certo um tente o outro.

    1 - Chame o squid em modo debug, e vá verificando todas as mensagens, qualquer coisa posta aqui, se eu puder te ajudar, estarei a disposição.

    # squid -d10

    2 - A respeito da autenticação, como está sendo feita? Se é AD, o host está ao alcance do squid, no firewall não tem nenhuma regra que pode estar bloqueando algum retorno ou mesmo saída de pedidos.

    3 - Pode ser algum problema na compilação do squid, faça um backup e remova todo seu squid, e restos de instalações, e recompile ele novamente. Volte o backup e faça o teste, se possível faça os testes em VMs, depois que tiver tudo ok, coloca em produção.

    Abraço, t+



  5. #5

    Padrão

    Citação Postado originalmente por robsonlula Ver Post
    Boa tarde, comigo nunca aconteceu isso, andei verificando todos os logs do meu squid. Tente os passos a seguir, caso não de certo um tente o outro.

    1 - Chame o squid em modo debug, e vá verificando todas as mensagens, qualquer coisa posta aqui, se eu puder te ajudar, estarei a disposição.

    # squid -d10

    2 - A respeito da autenticação, como está sendo feita? Se é AD, o host está ao alcance do squid, no firewall não tem nenhuma regra que pode estar bloqueando algum retorno ou mesmo saída de pedidos.

    3 - Pode ser algum problema na compilação do squid, faça um backup e remova todo seu squid, e restos de instalações, e recompile ele novamente. Volte o backup e faça o teste, se possível faça os testes em VMs, depois que tiver tudo ok, coloca em produção.

    Abraço, t+
    1 - ja fiz isso diversas vezes em diversos teste e a unica coisa que eu verifiquei de extranho foi as linha postadas abaixo, realmente nao tem mais nada de diferente:

    2010/01/26 19:16:00| comm_select: timeout 1000
    2010/01/26 19:16:01| comm_select: time out
    2010/01/26 19:16:01| comm_select: timeout 8
    2010/01/26 19:16:01| comm_select: time out

    2 - a autenticação é feita pelo pam, veja abaixo as linha configuradas aqui.

    auth_param basic program /usr/lib/squid/pam_auth

    auth_param basic children 5
    auth_param basic realm Proxy Server
    auth_param basic credentialsttl 2 hours
    auth_param basic casesensitive off
    authenticate_cache_garbage_interval 10 minutes
    authenticate_ttl 10 minutes
    authenticate_ip_ttl 0 seconds

    3 - eu uso o centos 5.4 e o squid instalado foi a ultima versão desta distro, que é extamene essa squid-2.6.STABLE21-3.el5.i386.rpm


    só quero salientar esse problema somente acontece com o windows xp, tenho estações ltsp e não acontece roda normal sem problema, já verifiquei possivel virus mas também não identifiquei nada, eu suspeito de atualização da microsoft, mas somente suspeito.

  6. #6

    Padrão

    Bom dia,

    Pode ser alguma coisa no windows mesmo, acontece em qualquer windows que tenta? Você testou com quais navegadores? Se possível teste com Firefox também e em máquinas diferentes. Verifique se não há atualizações para o pacote do squid ou pam no Cent OS, se de tudo não der certo, compile ele na mão, pegando a ultima versão 2.7.. no site do squid.

    squid : Optimising Web Delivery

    t+