+ Responder ao Tópico



  1. #1

    Padrão Roteamento do OpenWRT em MetaRouter

    PessoALL,

    Estou precisando da ajuda de vcs. Instalei o OpenWRT numa MetaRouter em uma RB433.
    Porém, não consigo fazer o OpenWRT ter acesso a internet. Só consigo faze-la acessar os
    IPs que estão na RB host.
    Eu coloquei na interface virtual criado pelo MetaRouter (vif1) o IP 192.168.30.1/24 e nas configurações da lan no OpenWRT o IP 192.168.30.2/24 tendo o outro IP como gateway. As "maquinas" se enxergam "numa nice".
    A saida pra rede externa desta RB é por uma classe 10.2.0.0/24 configurada na WLAN1, em WDS, funcionando perfeitamente.
    Infelizmente não posso colocar as interfaces em bridge, pois rodo PPPoE nesta RB para meus clientes na WLAN2.
    Já tentei fazer NAT pra esta classe e nada.

    Alguém poderia me ajudar?

  2. #2

    Padrão

    acredito q vc precisa criar uma bridge.. com a interface que voce precisa..



  3. #3
    xargs -n 1 kill -9 Avatar de sergio
    Ingresso
    Jan 2004
    Localização
    Capital do Triângulo
    Posts
    5.202
    Posts de Blog
    9

    Padrão

    Veja minha apresentação do MUM 2009. Explica como fazer isso que precisa.

    http://mum.mikrotik.com/presentation...terOpenWRT.pdf

  4. #4

    Padrão

    Caro Sergio,

    Foi baseado na sua apresentação mesmo que consegui criar a vm no MetaRouter. Obrigado.
    Mas a questão é que não consigo fazer o OpenWRT acessar a internet, pois questões da minha rede mesmo, pois não posso criar uma bridge com as WLANs, pois assim que crio, o serviço PPPoE pára de funcionar e meus clientes caem.
    Obrigado pela ajuda.



  5. #5
    xargs -n 1 kill -9 Avatar de sergio
    Ingresso
    Jan 2004
    Localização
    Capital do Triângulo
    Posts
    5.202
    Posts de Blog
    9

    Padrão

    uai... mas porque precisa de bridge para wlan???

    Crie uma nova bridge e adiciona apenas a interface VIF1 e uma interface ethernet, e boa.


    Citação Postado originalmente por ArilsonWestLink Ver Post
    Caro Sergio,

    Foi baseado na sua apresentação mesmo que consegui criar a vm no MetaRouter. Obrigado.
    Mas a questão é que não consigo fazer o OpenWRT acessar a internet, pois questões da minha rede mesmo, pois não posso criar uma bridge com as WLANs, pois assim que crio, o serviço PPPoE pára de funcionar e meus clientes caem.
    Obrigado pela ajuda.