Página 4 de 4 PrimeiroPrimeiro 1234
+ Responder ao Tópico



  1. Citação Postado originalmente por agnaldo52 Ver Post
    Se alguem precisar para versão 4.x , segue o script contando que já tenha uma conta no changeip.og.

    /tool dns-update name=seu server.changeip.org address=127.0.0.255 key-name=seu usuario key="sua senha"
    [/tool dns-update ]

    Nota que só houve apenas uma alteração que está destacado em vermelho em relação ao script anterior.

    Espero ter ajudado

    ------------------------------------------------------------------------------------------------------------

    Pessoal, tem alguem que esta com problemas nesse script do changeip? desde sempre eu usei esse script, agora o site changeip fez uma atualizaçao e meus MK nao funcionam (nao atualiza os ips). alguem esta com esse problema?

    blz valeu galera.
    Última edição por pedrobrother; 14-01-2013 às 10:53.

  2. Citação Postado originalmente por pedrobrother Ver Post
    ------------------------------------------------------------------------------------------------------------

    Pessoal, tem alguem que esta com problemas nesse script do changeip? desde sempre eu usei esse script, agora o site changeip fez uma atualizaçao e meus MK nao funcionam (nao atualiza os ips). alguem esta com esse problema?

    blz valeu galera.
    Me deparei com este problema também, aqui uso este:

    Código :
    # Dynamic DNS Update / Simple Edition
    # Written by Sam Norris, ChangeIP.com
    # Copyright ChangeIP.com 2009-2010
    # For support send mail to Support@ChangeIP.com
    #
    # 2009-06-22 RouterOS 3.25 Tested
    # 2009-10-05 RouterOS 4.01rc1 Tested
    #
    # OVERVIEW:         %
    #  This script will update a ChangeIP.com dynamic dns hostname
    #  with an ip address located directly on an interface.
    #                   %
    # NOTES:            %
    #  IF THIS SCRIPT DOES NOT PRODUCE ANY OUTPUT PLEASE COPY AND PASTE IT
    #  AGAIN.  THERE PROBABLY IS A LINE BREAK IN THE WRONG PLACE! Once you
    #  have created this script and tested that it works by running it
    #  manually you can schedule it to run every few minutes.
    #                   %
    # CONFIGURATION FIELD DEFINITIONS:
    #  ddnsuser:  Enter your ChangeIP.com user id.
    #  ddnspass:  Enter your ChangeIP.com password.
    #  ddnshost:  Enter the hostname (www.example.com) to update.
    #  ddnsinterface:  Enter an interface name - case sensative.
    #                   %
    #                   %
    #                   %
    #                   %
    #               %   %   %
    #                %  %  %
    #                 % % %
    #                   %
    # ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    # EDIT YOUR DETAILS / CONFIGURATION HERE
    # ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    :global ddnsuser "xxxxxxxxx"
    :global ddnspass "xxxxxxxxx"
    :global ddnshost "xxxxxx.ddns.info"
    :global ddnsinterface "pppoe-out1"
    # ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    # END OF USER DEFINED CONFIGURATION
    # ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
     
    :global ddnssystem ("mt-" . [/system package get [/system package find name=system] version] )
    :global ddnsip [ /ip address get [/ip address find interface=$ddnsinterface] address ]
    :global ddnslastip
     
    :if ([:len [/interface find name=$ddnsinterface]] = 0 ) do={ :log info "DDNS: No interface named $ddnsinterface, please check configuration." }
     
    :if ([ :typeof $ddnslastip ] = "nothing" ) do={ :global ddnslastip 0.0.0.0/0 }
     
    :if ([ :typeof $ddnsip ] = "nothing" ) do={
     
    :log info ("DDNS: No ip address present on " . $ddnsinterface . ", please check.")
     
    } else={
     
      :if ($ddnsip != $ddnslastip) do={
     
        :log info "DDNS: Sending UPDATE!"
        :log info [ :put [/tool dns-update name=$ddnshost address=[:pick $ddnsip 0 [:find $ddnsip "/"] ] key-name=$ddnsuser key=$ddnspass ] ]
        :global ddnslastip $ddnsip
     
      }
     
    }
     
    # END OF SCRIPT
    Log do Mikrotik => ddns error => timeout



  3. Aqui estou fazendo o seguinte

    Em System/ scripts

    Name: DDNS


    /tool dns-update name=seuendereco.changeip.net address=127.0.0.255 key-name=usuario key=senha



    Depois só copiar e colar no terminal:

    /system scheduler
    add comment="" disabled=no interval=10m name=DDNS on-event=DDNS policy=\
    read,write,policy,test,sniff,sensitive start-time=startup


    Obs. Ele está configurado para atualizar a cada 10min, se caso queira mudar o tempo é só alterar o 10m para o tempo desejado...

    Este foi o unico jeito que consegui fazer funcionar com o changeIp





    Citação Postado originalmente por silviola Ver Post
    Me deparei com este problema também, aqui uso este:

    Código :
    # Dynamic DNS Update / Simple Edition
    # Written by Sam Norris, ChangeIP.com
    # Copyright ChangeIP.com 2009-2010
    # For support send mail to Support@ChangeIP.com
    #
    # 2009-06-22 RouterOS 3.25 Tested
    # 2009-10-05 RouterOS 4.01rc1 Tested
    #
    # OVERVIEW:         %
    #  This script will update a ChangeIP.com dynamic dns hostname
    #  with an ip address located directly on an interface.
    #                   %
    # NOTES:            %
    #  IF THIS SCRIPT DOES NOT PRODUCE ANY OUTPUT PLEASE COPY AND PASTE IT
    #  AGAIN.  THERE PROBABLY IS A LINE BREAK IN THE WRONG PLACE! Once you
    #  have created this script and tested that it works by running it
    #  manually you can schedule it to run every few minutes.
    #                   %
    # CONFIGURATION FIELD DEFINITIONS:
    #  ddnsuser:  Enter your ChangeIP.com user id.
    #  ddnspass:  Enter your ChangeIP.com password.
    #  ddnshost:  Enter the hostname (www.example.com) to update.
    #  ddnsinterface:  Enter an interface name - case sensative.
    #                   %
    #                   %
    #                   %
    #                   %
    #               %   %   %
    #                %  %  %
    #                 % % %
    #                   %
    # ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    # EDIT YOUR DETAILS / CONFIGURATION HERE
    # ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    :global ddnsuser "xxxxxxxxx"
    :global ddnspass "xxxxxxxxx"
    :global ddnshost "xxxxxx.ddns.info"
    :global ddnsinterface "pppoe-out1"
    # ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    # END OF USER DEFINED CONFIGURATION
    # ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
     
    :global ddnssystem ("mt-" . [/system package get [/system package find name=system] version] )
    :global ddnsip [ /ip address get [/ip address find interface=$ddnsinterface] address ]
    :global ddnslastip
     
    :if ([:len [/interface find name=$ddnsinterface]] = 0 ) do={ :log info "DDNS: No interface named $ddnsinterface, please check configuration." }
     
    :if ([ :typeof $ddnslastip ] = "nothing" ) do={ :global ddnslastip 0.0.0.0/0 }
     
    :if ([ :typeof $ddnsip ] = "nothing" ) do={
     
    :log info ("DDNS: No ip address present on " . $ddnsinterface . ", please check.")
     
    } else={
     
      :if ($ddnsip != $ddnslastip) do={
     
        :log info "DDNS: Sending UPDATE!"
        :log info [ :put [/tool dns-update name=$ddnshost address=[:pick $ddnsip 0 [:find $ddnsip "/"] ] key-name=$ddnsuser key=$ddnspass ] ]
        :global ddnslastip $ddnsip
     
      }
     
    }
     
    # END OF SCRIPT
    Log do Mikrotik => ddns error => timeout

  4. Amigo Eduardi

    esse script serve na distribuição Mikrotik OS x86 5.20?????






Tópicos Similares

  1. Respostas: 9
    Último Post: 08-12-2008, 15:47
  2. Configuração do dns para rede interna
    Por Wal no fórum Servidores de Rede
    Respostas: 9
    Último Post: 12-01-2005, 21:43
  3. Servidor DNS para rede Windows 2000
    Por lopespio no fórum Servidores de Rede
    Respostas: 0
    Último Post: 28-02-2004, 09:58
  4. Direcionando servidor DNS para Provedor
    Por Elvis no fórum Servidores de Rede
    Respostas: 4
    Último Post: 04-07-2003, 11:02
  5. Direcionando servidor DNS para Provedor
    Por Elvis no fórum Servidores de Rede
    Respostas: 5
    Último Post: 14-05-2003, 12:29

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L