Página 7 de 12 PrimeiroPrimeiro ... 234567891011 ... ÚltimoÚltimo
+ Responder ao Tópico



  1. #31
    djcleyton
    Muito Obrigado apenas tive que mudar o ip do server para : 74.125.140.108
    Obs: testei na versão 5.20 X86.

    Citação Postado originalmente por Claudineibj Ver Post
    Server:173.194.77.108
    Port:587
    fromode ser um email hotmail
    user:seulogin@gmail.com
    Password:...........



    Script

    enviar-log
    :log info message="enviando log por email"
    :global data [/system clock get date]
    :global hora [/system clock get time]
    :global nome [/system identity get name]
    /tool e-mail send to="seulogin@hotmail.com" subject="log-mikrotik-$nome $data $hora" file=log-mikrotik.txt tls=yes


    fazer-e-enviar-backup-seu nome
    /system backup save name=backup-mikrotik.backup
    :log info message="enviando backup para seunome"
    :global data [/system clock get date]
    :global hora [/system clock get time]
    :global nome [/system identity get name]
    /tool e-mail send to="seulogin@hotmail.com" subject="backup-mikrotik-$nome $data $hora" file=backup-mikrotik.backup tls=yes


    salvar-log

    /log print file=log-mikrotik.txt



    scheduler

    enviar-log-automatico
    Jan/01/1970
    00:00:00
    12:00:00
    enviar-log

    fazer-e-enviar-backup-seunome
    Jan/01/1970
    00:00:00
    12:00:00
    fazer-e-enviar-backup-seunome


    salvar-log-automatico
    Jan/01/1970
    00:00:00
    12:00:00
    salvar-log

    Todos 1° é name depois é o script

    O script acima eu estou dizendo para o mikrotik enviar do gmail para meu email hotmail

  2. Depois de queimar alguns neuronios consegui colocar para funcionar em meus 2 servidores, tive que criar um e-mail no gmail, pois no meu servidor "kinghost" não consigo enviar, mas agora estou me deparando com um problema: nas rbs que funcionam como ap´s, como enviar o backup automatico se elas estão em bridge?

    Fiz a mesma configuiraçãomas não funciona.



  3. Citação Postado originalmente por rinaldovaz Ver Post
    escrevi esse artigo pois já vi muitos casos em que equipamentos sofreram defeitos e tiveram logs / backups perdidos por estarem guardados no próprio equipamento. O título não sugere que este guia sirva apenas para versão 4.6 do routeros, apenas que as regras foram testadas em bancada e estão funcionado bem nessa versão.


    Sugestões para melhorar ou mesmo consertar serão muito bem vindas.


    Configurando o envio de emails:


    No winbox:

    Menu

    /tool>email>

    server: Smtp.gmail.com
    port: 587
    from: seu_email_no_gmail@gmail.com
    user: seu_email_no_gmail@gmail.com
    password: ********** (sua senha no gmail=)

    clique no botao "apply" e imediatamente a url smtp.gmail.com é resolvida trocada para o ip certo.

    Escrevendo um script para gerar o arquivo log-mikrotik.txt
    no winbox

    menu

    /system>scripts

    adicione um script chamado "salvar-log"

    name: Salvar-log

    source: (código fonte)

    /log print file=log-mikrotik.txt


    _______________________________________

    escrevendo um script para gerar o arquivo backup-mikrotik.backup

    do mesmo jeito com o seguinte código fonte:

    Name: Salvar-backup

    source:

    /system backup save name=backup-mikrotik.backup


    _______________________________________


    agora é preciso criar mais 2 scripts, um para enviar o log e outro para enviar o backup por email



    name: Enviar-log

    source:

    :log info message="enviando log por email"
    :global data [/system clock get date]
    :global hora [/system clock get time]
    /tool e-mail send to="email_de_destino01@dominio.com" subject="log-mikrotik $data $hora" file=log-mikrotik.txt tls=yes


    _______________________________________

    name: Enviar-backup

    source:

    :log info message="enviando backup por email"
    :global data [/system clock get date]
    :global hora [/system clock get time]
    /tool e-mail send to="email_de_destino01@dominio.com" subject="backup-mikrotik $data $hora" file=backup-mikrotik.backup tls=yes



    _______________________________________


    configurando o envio automático dos logs/backups

    no winbox

    /system>scheduler

    agora é só agendar os 4 scripts de acordo com a necessidade, geralmente uso backup a cada 24 horas e logs a cada 6 horas como nas regras abaixo:

    /system scheduler add comment="" disabled=no interval=1d name=enviar-backup-automatico \
    on-event=enviar-backup policy=\
    reboot,read,write,policy,test,password,sniff,sensitive start-date=\
    jan/01/1970 start-time=23:10:00
    /system scheduler add comment="" disabled=no interval=1d name=salvar-backup-automatico \
    on-event=salvar-backup policy=\
    reboot,read,write,policy,test,password,sniff,sensitive start-date=\
    jan/01/1970 start-time=23:00:00
    /system scheduler add comment="" disabled=no interval=6h name=salvar-log-automatico on-event=\
    salvar-log policy=reboot,read,write,policy,test,password,sniff,sensitive \
    start-date=jan/01/1970 start-time=00:00:00
    /system scheduler add comment="" disabled=no interval=6h name=enviar-log-automatico on-event=\
    enviar-log policy=reboot,read,write,policy,test,password,sniff,sensitive \
    start-date=jan/01/1970 start-time=00:10:00




    escolhi o gmail porque tem muito espaço de caixa de entrada e um recurso próprio que facilida a visualização dos logs sem a necessidade de baixar anexos. Isso faz muita diferença pois infelizmente o arquivo ".txt" que o routeros gera é no padrão unix, é muito complicado de visualizar no bloco de notas do windows.




    ao tentar configurar em tools = e-mail= smtp.gmail.com
    aparece um erro dizendo error in server! Ip address or ipv6 address expectd!!

    O que faço agora?

  4. depois de atualizar mikrotik para versao 6.2 parou de funcionar backups e envios de email, alguem sabe o que mudou se foi o script ou a configuração de email,
    Agradeço!



  5. Descobri o que mudou!

    /system backup save name=backup-mikrotik.backup
    :log info message="enviando backup por email"
    :global data [/system clock get date]
    :global hora [/system clock get time]
    /tool e-mail send to="email" subject="backup-mikrotik-PopRouter1 $data $hora" file=backup-mikrotik.backup start-tls=yes

    antes tls=yes
    depois start-tls=yes

    Se fui útil agradeça!






Tópicos Similares

  1. Salvar Log Mikrotik e enviar por e-mail
    Por hizunspire no fórum Redes
    Respostas: 13
    Último Post: 07-07-2012, 00:28
  2. Erro ao Enviar Backup automático por e-mail
    Por tonflatland no fórum Redes
    Respostas: 4
    Último Post: 30-08-2010, 22:13
  3. Enviar Backup por e-mail
    Por fabianojean no fórum Redes
    Respostas: 1
    Último Post: 28-02-2006, 09:57
  4. Enviar backup por e-mail
    Por -thiago- no fórum Servidores de Rede
    Respostas: 2
    Último Post: 09-12-2005, 20:08
  5. Mandar log de backup por email
    Por Bolinhazin no fórum Servidores de Rede
    Respostas: 3
    Último Post: 12-06-2005, 15:17

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L