+ Responder ao Tópico



  1. bom cara o cache esta funcionando pinga pra host na internet normal, mas não configurei no proxy para o mk ser gateway dele, pois não sabia dessa configuração... o ip do thundercache é 192.168.2.1 o ip do mikrotik esta na faixa 192.168.0.0/24 o mikrotik pinga pra o thundercache normal, e vice-versa já tentei todas as regras validas de redirecionamento sobre o assunto as vezes a regra funciona a internet mais o thundercache cai, não entra as vezes o thundercache funciona mais a internet cai, quando configuro o proxy direto no navegador funciona perfeitamente. como faço pra fazer essa configuração no proxy ? sendo que o ip do mk esta na faixa 192.168.0.0/24 e o proxy esta em 192.168.2.1 ? obrigado pela ajuda.
    Última edição por thefox; 16-04-2010 às 22:59.

  2. Entao Faz o seguinte, na placa de rede do mk que esta ligado o linux coloca o ip do mk em 192.168.2.253/24, no linux você vai deixar o ip em:
    ip="192.168.2.1"
    mask=255.255.255.0
    network=192.168.2.0
    broadcast=192.168.2.255
    gateway=192.168.2.253

    No mk vai fazer uma nat pro linux :
    ip firewall nat
    add chain=srcnat src-address=192.168.2.1 protocol=tcp action=masquerade \comment="THUNDER" disabled=no

    add chain=dstnat src-address=192.168.1.0/24 dst-address=!192.168.2.1 \
    protocol=tcp dst-port=80 action=dst-nat to-addresses=192.168.2.1 \
    to-ports=3128 comment="" disabled=no

    Onde esta em vermelho é a faixa de rede dos seus clientes.
    Lembrando que essa regra vale pra quando o mk esta como gateway da rede ok

    Testa e diga se funcionou.

    Abraços e boa sorte



  3. ok... irei testa, quanto o ip do ubuntu server? eu terei que troca na config do squid e do thunder?

    mudando o ip terei que edita tudo no squid/thunder? correto?

    sudo nano /etc/network/interfaces

    Troque o texto abaixo....
    auto eth0
    iface eth0 inet dhcp
    .... pelo texto
    auto eth0
    iface eth0 inet static
    address 192.168.1.10
    netmask 255.255.255.0
    network 192.168.1.0
    broadcast 192.168.1.255
    gateway 192.168.1.1

    sudo nano /etc/resolv.conf

    search virtua.com.br casa.lan
    nameserver 192.168.1.10
    nameserver 201.6.0.112
    nameserver 201.6.0.108
    Última edição por thefox; 17-04-2010 às 12:49.

  4. Citação Postado originalmente por thefox Ver Post
    ok... irei testa, quanto o ip do ubuntu server? eu terei que troca na config do squid e do thunder?

    mudando o ip terei que edita tudo no squid/thunder? correto?

    sudo nano /etc/network/interfaces

    Troque o texto abaixo....
    auto eth0
    iface eth0 inet dhcp
    .... pelo texto
    auto eth0
    iface eth0 inet static
    address 192.168.1.10
    netmask 255.255.255.0
    network 192.168.1.0
    broadcast 192.168.1.255
    gateway 192.168.1.1

    sudo nano /etc/resolv.conf

    search virtua.com.br casa.lan
    nameserver 192.168.1.10
    nameserver 201.6.0.112
    nameserver 201.6.0.108
    Acho que nao fui claro o suficiente.

    auto eth0
    iface eth0 inet static
    address 192.168.2.1
    netmask 255.255.255.0
    network 192.168.2.0
    broadcast 192.168.2.255
    gateway 192.168.2.253

    sudo nano /etc/resolv.conf

    search virtua.com.br casa.lan
    nameserver 192.168.2.253
    nameserver 201.6.0.112
    nameserver 201.6.0.108
    Isso ai vai ficar no linuz(UBUNTU) OK.

    No mikrotik 192.168.2.253/24 na placa exclusiva pro Linux(UBUNTU)

    Ainda no Mikrotik
    ip firewall nat
    add chain=srcnat src-address=192.168.2.1 protocol=tcp action=masquerade \comment="THUNDER" disabled=no

    Ainda no Mikrotik
    ip firewall nat
    add chain=dstnat src-address=192.168.1.0/24 dst-address=!192.168.2.1 \
    protocol=tcp dst-port=80 action=dst-nat to-addresses=192.168.2.1 \
    to-ports=3128 comment="" disabled=no

    Onde esta em vermelho é a faixa de rede dos seus clientes.

    Espero ter sido mais claro agora.

    Lembrando que no squid e nas conf do thunder tem que ser o ip do Linux(UBUNTU)
    192.168.2.1 oks

    Qualquer coisa posta ai
    Última edição por edcomrocha; 17-04-2010 às 13:25.



  5. ok,obrigado.

    \comment="THUNDER" disabled=no

    não entendi "disabled=no", seria um comentario?






Tópicos Similares

  1. Roteador 812 3Com e porta 3128
    Por crazy4tech no fórum Servidores de Rede
    Respostas: 2
    Último Post: 10-08-2005, 11:39
  2. porta 3128 não levanta nem com viagra!!!
    Por tianguapontocom no fórum Servidores de Rede
    Respostas: 4
    Último Post: 08-08-2005, 12:45
  3. Squid nao abre a porta 3128
    Por ifc0nfig no fórum Servidores de Rede
    Respostas: 8
    Último Post: 03-08-2005, 09:48
  4. Acesso na internet somente pela porta 3128
    Por no fórum Servidores de Rede
    Respostas: 3
    Último Post: 03-11-2003, 15:16
  5. Porta 3128 - Problema de conexão
    Por ATNunes no fórum Servidores de Rede
    Respostas: 5
    Último Post: 19-11-2002, 11:35

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L