+ Responder ao Tópico



  1. #1

    Padrão Problema no msn depois do pcc

    Tenho uma rb1000 e depois que estou fazendo o balanceamento de dois links os meus clientes nao conseguem entrar no msn na maioria das vezes, como posso resolver...

  2. #2

    Padrão Re: Problema no msn depois do pcc

    E quando desativa o balanceamento, normaliza?



  3. #3

    Padrão Re: Problema no msn depois do pcc

    adamaral,

    Qual critério você usou como forma de balancear pelo pcc? Tá com cara que você usou a opção: "both address and port". Se for essa realmente não vai funcionar. Principalmente os sites dos bancos. Se foi essa é só você mudar pra opção: "both address".
    Verifica isso ai, ok?

    Abs.

  4. #4

    Padrão Re: Problema no msn depois do pcc

    Acompanhando...



  5. #5

    Padrão Re: Problema no msn depois do pcc

    Cara era isso mensmo muito obrigado pela ajuda......valew

  6. #6

    Padrão Re: Problema no msn depois do pcc

    Tranquilo.
    Você vai notar que o balanceamento não vai ficar tão igual como antes, mas dessa forma você terá um bom balanceamento e sem problemas, ok?

    Abs.



  7. #7

    Red face Re: Problema no msn depois do pcc

    aproveitando o tópico e a ajuda do amigo Guilherme, tenho aqui 3 links: 2 de 1,5mb e 1 de 1mb. para q a carga fosse bem dividida a melhor opção seria dividir por 5? (5/0, 5/1, 5/2, 5/3 e 5/4) jogando 2x em cada link de 1,5 e 1x no link de 1mb?... pq dividi aqui por 3 mais notei q ficou lenta em horário de pico. segue as regras usadas.

    add action=mark-connection chain=prerouting comment="" disabled=no \
    in-interface=ether1adsl new-connection-mark=ether1adsl_conn passthrough=\
    yes
    add action=mark-connection chain=prerouting comment="" disabled=no \
    in-interface=ether2adsl new-connection-mark=ether2adsl_conn passthrough=\
    yes
    add action=mark-connection chain=prerouting comment="" disabled=no \
    in-interface=ether3adsl new-connection-mark=ether3adsl_conn passthrough=\
    yes
    add action=mark-routing chain=output comment="" connection-mark=\
    ether1adsl_conn disabled=no new-routing-mark=to_ether1adsl passthrough=\
    yes
    add action=mark-routing chain=output comment="" connection-mark=\
    ether2adsl_conn disabled=no new-routing-mark=to_ether2adsl passthrough=\
    yes
    add action=mark-routing chain=output comment="" connection-mark=\
    ether3adsl_conn disabled=no new-routing-mark=to_ether3adsl passthrough=\
    yes
    add action=mark-connection chain=prerouting comment="" disabled=no \
    dst-address-type=!local in-interface=ether4 new-connection-mark=\
    ether1adsl_conn passthrough=yes per-connection-classifier=\
    both-addresses-and-ports:5/0
    add action=mark-connection chain=prerouting comment="" disabled=no \
    dst-address-type=!local in-interface=ether4 new-connection-mark=\
    ether2adsl_conn passthrough=yes per-connection-classifier=\
    both-addresses-and-ports:5/1
    add action=mark-connection chain=prerouting comment="" disabled=no \
    dst-address-type=!local in-interface=ether4 new-connection-mark=\
    ether1adsl_conn passthrough=yes per-connection-classifier=\
    both-addresses-and-ports:5/2
    add action=mark-connection chain=prerouting comment="" disabled=no \
    dst-address-type=!local in-interface=ether4 new-connection-mark=\
    ether2adsl_conn passthrough=yes per-connection-classifier=\
    both-addresses-and-ports:5/3
    add action=mark-connection chain=prerouting comment="" disabled=no \
    dst-address-type=!local in-interface=ether4 new-connection-mark=\
    ether3adsl_conn passthrough=yes per-connection-classifier=\
    both-addresses-and-ports:5/4
    add action=mark-routing chain=prerouting comment="" connection-mark=\
    ether1adsl_conn disabled=no in-interface=ether4 new-routing-mark=\
    to_ether1adsl passthrough=yes
    add action=mark-routing chain=prerouting comment="" connection-mark=\
    ether2adsl_conn disabled=no in-interface=ether4 new-routing-mark=\
    to_ether2adsl passthrough=yes
    add action=mark-routing chain=prerouting comment="" connection-mark=\
    ether3adsl_conn disabled=no in-interface=ether4 new-routing-mark=\
    to_ether3adsl passthrough=yes

    aos mais experientes, poderia ver se elas estão corretas?
    Agradeço desde já a ajuda.
    Última edição por bodoquenanet; 28-04-2010 às 15:03.

  8. #8

    Padrão Re: Problema no msn depois do pcc

    Amigo,

    O interessante é você achar um denominador comun. Logo você tem um link total de 4 MB. O denominador comun para sua equação é 0.5 MB. Logo a melhor opção seria o número 8. Seriam:

    3 x 0.5 = 1.5 MB para o link 1 de 1.5 MB
    3 x 0.5 = 1.5 MB para o link 2 de 1.5 MB
    2 x 0.5 = 1.0 MB para o link 3 de 1.0 MB

    Ou seja: 3+3+2 = 8

    ok?

    Abs.



  9. #9

    Padrão Re: Problema no msn depois do pcc

    valeu mesmo a atenção Guilherme, vou alterar aqui. E qto a alterar "both address and port" para "both address", melhora o desempenho do balance?

  10. #10

    Padrão Re: Problema no msn depois do pcc

    Na verdade esse balanceamento "both address and port" é o mesmo ECMP que o mikrotik usa pra rotas de mesmo destinos com mesmo custo. Se você tiver 2 links redundantes dentro da sua rede você pode usar sem problema. Mas quando se trata de saida de link pra internet não se usa "both address and ports" porque dá muito problema. A pra saida internet a opção "both address" é a mais indicada. Como falei anteriormente, ela não é tão eficiente como a "both address and port" porém ela é muito boa e não dá problema. Aqui na minha rede eu uso "both address" e tenho 15 links de 2MB. Eu consigo uma performance de 28 MB de uso em hora de pico.

    Abs.



  11. #11

    Padrão Re: Problema no msn depois do pcc

    oi guilhermeramires
    pesso sua ajuda
    a um ano tenho pcc em rb 750 g,,ta beleza funciona bem,porem webcam no msn , pate papo no ig e jogos online para pse somente futebol ........não consegui resolver,,
    vc poderia dar uma ajuda de como resolveu ,caso teve o mesmo problema ?/
    desde ja agradeço pela ajuda

  12. #12

    Padrão Re: Problema no msn depois do pcc

    Qual foi o classificador que você usou no balance? Tá parecendo que você optou pela opção "both address and ports". Muda pra "both address" que vai resolver, ok?

    Abs.



  13. #13

    Padrão Re: Problema no msn depois do pcc

    oi
    obrigado por responder.
    esta em both address
    ja tentei outras tambem da mesmo erro,,demais site ta normal e consumo do link esta dividido por igual tambem,.,.
    so resta resolver estes que te passei.,
    não sei se resolveria tirar porta de jogo e camera do balanco.,
    mais não tentei ,pois nunca usei esta forma.,
    caso saiba oq pode ser ,por favor me oriente.,
    esto ate vendo projeto para link da ctbc ,pois atualmente compro telefonica e não tem como pagar mais , e se der certo com ctbc para com balanco pois não resolvi estes q te passei.,
    tenho 300 clinete
    aguardo

  14. #14

    Padrão Re: Problema no msn depois do pcc

    Coloca o mangle do seu pcc em um arquivo e posta aqui pra eu analisar ele.



  15. #15

    Padrão Re: Problema no msn depois do pcc

    oi
    obrigado por responder
    ai esta minha configuração do mangle,.,

    /ip firewall mangle
    add action=accept chain=prerouting comment="HTTPS FORA DO LOADBALACED" \
    disabled=no dst-port=443 in-interface=SAIDA protocol=tcp
    add action=accept chain=prerouting comment="FORA DO LOADBALACED" disabled=no \
    dst-address-list=loopback in-interface=SAIDA
    add action=change-ttl chain=forward comment="Filtro Tracert / Traceroute" \
    disabled=no new-ttl=set:30 protocol=icmp
    add action=mark-connection chain=prerouting disabled=no in-interface=LINKLP \
    new-connection-mark=ether2_conn passthrough=yes
    add action=mark-connection chain=prerouting disabled=no in-interface=LINKFX \
    new-connection-mark=ether3_conn passthrough=yes
    add action=mark-connection chain=prerouting disabled=no in-interface=\
    ether4adsl new-connection-mark=ether4adsl_conn passthrough=yes
    add action=mark-routing chain=output connection-mark=ether2_conn disabled=no \
    new-routing-mark=to_ether2 passthrough=yes
    add action=mark-routing chain=output connection-mark=ether3_conn disabled=no \
    new-routing-mark=to_ether3 passthrough=yes
    add action=mark-routing chain=output connection-mark=ether4adsl_conn \
    disabled=no new-routing-mark=to_ether4adsl passthrough=yes
    add action=accept chain=prerouting disabled=no dst-address=187.51.72.0/24 \
    in-interface=SAIDA
    add action=accept chain=prerouting disabled=no dst-address=189.111.157.0/24 \
    in-interface=SAIDA
    add action=mark-connection chain=prerouting comment=CLLP disabled=no \
    dst-address-type=!local in-interface=SAIDA new-connection-mark=\
    ether2_conn passthrough=yes per-connection-classifier=both-addresses:4/0
    add action=mark-connection chain=prerouting comment=CLFX disabled=no \
    dst-address-type=!local in-interface=SAIDA new-connection-mark=\
    ether3_conn passthrough=yes per-connection-classifier=both-addresses:4/1
    add action=mark-connection chain=prerouting comment=CLFX disabled=no \
    dst-address-type=!local in-interface=SAIDA new-connection-mark=\
    ether4adsl_conn passthrough=yes per-connection-classifier=\
    both-addresses:4/2
    add action=mark-connection chain=prerouting comment=CLSP disabled=no \
    dst-address-type=!local in-interface=SAIDA new-connection-mark=\
    ether4adsl_conn passthrough=yes per-connection-classifier=\
    both-addresses:4/3
    add action=mark-routing chain=prerouting connection-mark=ether2_conn \
    disabled=no in-interface=SAIDA new-routing-mark=to_ether2 passthrough=yes
    add action=mark-routing chain=prerouting connection-mark=ether3_conn \
    disabled=no in-interface=SAIDA new-routing-mark=to_ether3 passthrough=yes
    add action=mark-routing chain=prerouting connection-mark=ether4adsl_conn \
    disabled=no in-interface=SAIDA new-routing-mark=to_ether4adsl \
    passthrough=yes

  16. #16

    Padrão Re: Problema no msn depois do pcc

    to tendo problema com meu msn, e orkut, minhas regras estão para marcar como "both address" ja nivelei o mtu, e nada, o interessante é que bancos e demis serviços ate agora nao deram problemas, em 3 dias de funcionamento. so msn e orkut



  17. #17

    Padrão Re: Problema no msn depois do pcc

    mesmo problema com a webcam no msn... vou acompanhar...

  18. #18

    Padrão Re: Problema no msn depois do pcc

    muito sinistro este problema, mas continuo pesquisando na net e em materiais que tenho aqui, mas nada de resolver o po.



  19. #19

    Padrão Re: Problema no msn depois do pcc

    tbm to com problema de msn de vez em quando..