+ Responder ao Tópico



  1. #1

    Padrão Hotspot - Aumentar velocidade sem perder Qos

    Bom dia Galera.

    Estou tendo um problema aki!
    Fiz um hotspot meio fresco com um flash e talz ficou um pouco pessado intao
    tive a ideia de liberar a banda dentro do hotspot. Ate ai tudo bem
    colokei as seguitnes regras:

    IP - Firewal - Mangle
    add action=mark-connection chain=postrouting comment="PRIORIZA SERVIDOR WEB PARA REDE" disabled=no dst-address=\
    192.168.254.0/24 new-connection-mark="conex\E3o_servidorlivre" passthrough=yes
    add action=mark-packet chain=postrouting comment="" connection-mark="conex\E3o_servidorlivre" disabled=no \
    new-packet-mark=QoS_ServidorLivre passthrough=yes

    Depois criei no queue tree
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=10000000 name="QoS SERVIDOR WEB" \
    packet-mark=QoS_ServidorLivre parent=global-out priority=8 queue=default

    Funcionou perfeitamente so que meu controle de banda foi pro espaço!
    Gostaria saber como faço pra isso funcionar juntamente com meu controle de banda

    Vlww

  2. #2

    Padrão Re: Hotspot - Aumentar velocidade sem perder Qos

    Meio louca essa regra sua, tenta essa:

    / ip firewall mangle
    add action=mark-connection chain=output comment="HOTSPOT FULL" disabled=no new-connection-mark=hotspot-out out-interface=local passthrough=yes protocol=udp src-port=64872
    add action=mark-connection chain=output comment="" disabled=no new-connection-mark=hotspot-out out-interface=local passthrough=yes protocol=tcp src-port=64872
    add action=mark-connection chain=output comment="" disabled=no new-connection-mark=hotspot-out out-interface=local passthrough=yes protocol=tcp src-port=64873
    add action=mark-connection chain=output comment="" disabled=no new-connection-mark=hotspot-out out-interface=local passthrough=yes protocol=tcp src-port=64874
    add action=mark-connection chain=output comment="" disabled=no new-connection-mark=hotspot-out out-interface=local passthrough=yes protocol=tcp src-port=64875

    /queue tree
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=100M name="HOTSPOT FULL" packet-mark=hotspot-output parent=global-out priority=8 queue=default

    Mude o nome da interface de "local" para o nome da sua interface de rede de saída para os clientes.

    Uso aqui 100% funcional.
    Última edição por emsfalcao; 30-04-2010 às 16:32.



  3. #3

    Padrão Re: Hotspot - Aumentar velocidade sem perder Qos

    Muito Obrigado pela dica!
    O unico problema e que criei essas regras que voce me mandou e a contagem delas nao sai do 0
    isso nao e normal ne?
    Mais mesmo assim obrigado ! Quero mt arumar isso

  4. #4
    André Andrade*MikrotikRio Avatar de interhome
    Ingresso
    Oct 2008
    Localização
    Brasil.
    Posts
    1.094
    Posts de Blog
    15

    Padrão Re: Hotspot - Aumentar velocidade sem perder Qos

    Suba com as regras no seu mangle. Para melhor orientacao é necessario postar o seu mangle completo.



  5. #5

    Padrão Re: Hotspot - Aumentar velocidade sem perder Qos

    Obrigado pela dica de todos
    Mias acho que me expressei errado!
    o que eu quero e que mesmo apos o cliente logar-se na pagina do hotspot ele continue sem controle de banda dentro dakela pagina !
    Queria q a pagina do hotspot ficasse livre do controle de banda!

    Eu fiz como nosso amigo falou subi as regras no mangle e agora elas começaram a contar mais nao funcionou o que preciso!
    Se alguem tiver alguma sugestao

  6. #6

    Padrão Re: Hotspot - Aumentar velocidade sem perder Qos

    Citação Postado originalmente por kakavga Ver Post
    Obrigado pela dica de todos
    Mias acho que me expressei errado!
    o que eu quero e que mesmo apos o cliente logar-se na pagina do hotspot ele continue sem controle de banda dentro dakela pagina !
    Queria q a pagina do hotspot ficasse livre do controle de banda!

    Eu fiz como nosso amigo falou subi as regras no mangle e agora elas começaram a contar mais nao funcionou o que preciso!
    Se alguem tiver alguma sugestao
    É exatamente isso que a regra faz... Marca os pacotes e conexões das portas pertinentes ao hotspot e a regra de queue tree libera a velocidade, não importa se o cliente está ou não logado, o hotspot fica sempre com a banda liberada ou setada a 100mb como expressa na regra que passei.

    Observe se suas regras estão com a prioridade necessária, ou seja, que elas estejam acima das demais regras no Mangle.

    Se vc estiver usando o hotspot e não estiver marcando nada, tem coisa errada sim, reveja as regras, analise com calma.

    Vc mudou o nome da interface dos clientes?

    Aqui eu uso, consegui essas regras aqui mesmo no under, fiz as adaptações necessárias e estão sempre 100% funcionais.

    Uma pergunta importante, vc já tem as regras que liberam o acesso às paginas do hotspot após o cliente ter logado? Ou seja, vc já tem acesso a página de hotspot depois de logado?
    Última edição por emsfalcao; 01-05-2010 às 23:57.



  7. #7

    Padrão Re: Hotspot - Aumentar velocidade sem perder Qos

    Tenho um outro MK aki zerado vou fazer testes nele aki e posto os resultados!
    Desde Ja mt Obrigado!,
    Vou Criar as regras novamente e Posto aki pra voces qual foi meu resultado!
    Estou precisando mt disso por isso quero resolver o mais rapido possivel!
    Obs: Tenho acesso sim a pagina mesmo apos logado! meu hotspot tem 5 paginas ( como se fosse um site) consigo acessa-las depois de logar porem com a velocidade setada no profile!

  8. #8
    André Andrade*MikrotikRio Avatar de interhome
    Ingresso
    Oct 2008
    Localização
    Brasil.
    Posts
    1.094
    Posts de Blog
    15

    Padrão Re: Hotspot - Aumentar velocidade sem perder Qos

    Citação Postado originalmente por emsfalcao Ver Post
    Meio louca essa regra sua, tenta essa:

    / ip firewall mangle
    add action=mark-connection chain=output comment="HOTSPOT FULL" disabled=no new-connection-mark=hotspot-out out-interface=local passthrough=yes protocol=udp src-port=64872
    add action=mark-connection chain=output comment="" disabled=no new-connection-mark=hotspot-out out-interface=local passthrough=yes protocol=tcp src-port=64872
    add action=mark-connection chain=output comment="" disabled=no new-connection-mark=hotspot-out out-interface=local passthrough=yes protocol=tcp src-port=64873
    add action=mark-connection chain=output comment="" disabled=no new-connection-mark=hotspot-out out-interface=local passthrough=yes protocol=tcp src-port=64874
    add action=mark-connection chain=output comment="" disabled=no new-connection-mark=hotspot-out out-interface=local passthrough=yes protocol=tcp src-port=64875

    /queue tree
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=100M name="HOTSPOT FULL" packet-mark=hotspot-output parent=global-out priority=8 queue=default

    Mude o nome da interface de "local" para o nome da sua interface de rede de saída para os clientes.

    Uso aqui 100% funcional.
    Importante, 100 M de velocidade é muita coisa, pode arrebentar uma rede wireless. O certo seria ou não ter limite de velocidade ou algum valor perto de 2M. Provavelmente serão arquivos grandes que deve estar querendo disponibilizar para downloads no servidor. Pense que isso irá passar e consumir o seu throughput.



  9. #9

    Padrão Re: Hotspot - Aumentar velocidade sem perder Qos

    Citação Postado originalmente por interhome Ver Post
    Importante, 100 M de velocidade é muita coisa, pode arrebentar uma rede wireless. O certo seria ou não ter limite de velocidade ou algum valor perto de 2M. Provavelmente serão arquivos grandes que deve estar querendo disponibilizar para downloads no servidor. Pense que isso irá passar e consumir o seu throughput.

    Eu citei 100MB porque se prestarmos atenção ele pediu para "liberar" a banda do hotspot, no meu caso uso 10MB, até porque além de downloads que meus clientes tem acesso pela página do hotspot, tem os acessos para login, e são vários simultâneos e caso não tenha banda suficiente, a abertura da página de login fica lenta.

    Mas vc frisou bem interhome.

  10. #10

    Padrão Re: Hotspot - Aumentar velocidade sem perder Qos

    Bom implementei as regras
    Mais mesmo assim nao funcionou!
    as do mangle colokei elas em primeiro na lista de regras e eles estao contando normal
    porem a regra do quee tree nao sai do 0
    nao conta nada
    o q pode ser
    ?
    lembrando trokei o nome das interfaces e a banda tb colokei 5mb
    Última edição por kakavga; 02-05-2010 às 20:36.



  11. #11
    André Andrade*MikrotikRio Avatar de interhome
    Ingresso
    Oct 2008
    Localização
    Brasil.
    Posts
    1.094
    Posts de Blog
    15

    Padrão Re: Hotspot - Aumentar velocidade sem perder Qos

    Citação Postado originalmente por emsfalcao Ver Post
    Eu citei 100MB porque se prestarmos atenção ele pediu para "liberar" a banda do hotspot, no meu caso uso 10MB, até porque além de downloads que meus clientes tem acesso pela página do hotspot, tem os acessos para login, e são vários simultâneos e caso não tenha banda suficiente, a abertura da página de login fica lenta.

    Mas vc frisou bem interhome.
    Obrigado, vc tbm. Abraço.