+ Responder ao Tópico



  1. #1

    Padrão Dividir bloco de IPs de forma transparente no MK

    Prezados,

    Já li bastante no fórum mas ainda me resta essa dúvida:

    Estou ativando um novo link e vou receber uma faixa /26. Meu fornecedor utiliza layer2 até são paulo, eu não vou ter roteador nenhum aqui comigo, só a ponta do rj45 mesmo. Então vou dividir os IPs e o link no MK.

    REDE = 201.12.130.64
    MASCARA =
    /26
    Vou revender uma parte desse link e gostaria de saber como quebrar corretamente esse bloco em 4x /28 no MK.

    No caso nas interfaces do meu MK eu iria colocar assim??
    ether1 LINK 201.12.130.66/26, mascara 255.255.255.192 gateway 201.12.130.65
    ether2 201.12.130.81/28, mascara 255.255.255.240
    ether2 201.12.130.97/28, mascara 255.255.255.240
    ether2 201.12.130.13/28, mascara 255.255.255.240

    E nos servidores dos clientes:

    cliente1 201.12.130.82/28 até .94/28, mascara 255.255.255.240 e gateway 201.12.130.81
    cliente2 201.12.130.98/28 até .110/28, mascara 255.255.255.240 e gateway 201.12.130.97
    cliente3 201.12.130.114/28 até .126/28, mascara 255.255.255.240 e gateway 201.12.130.113

    Está certo ou estou viajando na maionese?

    E como faço o roteamento de saída desses blocos /28 para o bloco /26 (ether1)?

    Agradeço a ajuda de todos,

    Abraços


    P.S. as faixas de IPs citadas acima são fictícias/aleatórias apenas para exemplificar e ser mais didático o exemplo, não me pertencem.


  2. #2

    Padrão Re: Dividir bloco de IPs de forma transparente no MK

    alguém?

    :P



  3. #3
    Patrocinador Avatar de edcomrocha
    Ingresso
    Aug 2007
    Localização
    São Paulo, Brazil, Brazil
    Posts
    840

    Padrão Re: Dividir bloco de IPs de forma transparente no MK

    Opa ressucitando esse topico...

    Você conseguiu fazer? Estou na mesma duvida até a a quantidade de ips são os mesmos.

    Se você conseguiu ou alguem puder ajudar será de grande valia


    Obrigado


    Abraços a todos.

  4. #4

    Padrão Re: Dividir bloco de IPs de forma transparente no MK

    Amigo,
    não sei se entendi direito, posso estar errado. Vamos supor que vc quer revender um bloco de ip por exemplo um bloco mais simples assim:

    200.200.200.200/30

    vc faz assim:

    o cliente que quer este bloco esta dentro da sua rede no ip 192.168.2.10 ai vc faz assim: o bloco que chega na interface com a internet no seu mikrotik é 200.200.200.200/26
    vc pega e quebra este bloco mandando ele para o cliente que vc quer desta maneira:

    vai em ip route
    em destination vc coloca o bloco que vc quer, queremos vender o bloco 200.200.200.200/30 para o ip 192.168.2.10, entao em destination vc coloca o bloco e em gateway o ip 192.168.2.10 que representa o cliente que esta dentro da sua rede.

    ai apartir de agora na interface LAN do rádio 192.168.2.10 este bloco estará disponivel.

    É isto que vc quer?

    Até mais...

    Osni

    Citação Postado originalmente por edcomrocha Ver Post
    Opa ressucitando esse topico...

    Você conseguiu fazer? Estou na mesma duvida até a a quantidade de ips são os mesmos.

    Se você conseguiu ou alguem puder ajudar será de grande valia


    Obrigado


    Abraços a todos.



  5. #5
    Patrocinador Avatar de edcomrocha
    Ingresso
    Aug 2007
    Localização
    São Paulo, Brazil, Brazil
    Posts
    840

    Padrão Re: Dividir bloco de IPs de forma transparente no MK

    Citação Postado originalmente por byosni Ver Post
    Amigo,
    não sei se entendi direito, posso estar errado. Vamos supor que vc quer revender um bloco de ip por exemplo um bloco mais simples assim:

    200.200.200.200/30

    vc faz assim:

    o cliente que quer este bloco esta dentro da sua rede no ip 192.168.2.10 ai vc faz assim: o bloco que chega na interface com a internet no seu mikrotik é 200.200.200.200/26
    vc pega e quebra este bloco mandando ele para o cliente que vc quer desta maneira:

    vai em ip route
    em destination vc coloca o bloco que vc quer, queremos vender o bloco 200.200.200.200/30 para o ip 192.168.2.10, entao em destination vc coloca o bloco e em gateway o ip 192.168.2.10 que representa o cliente que esta dentro da sua rede.

    ai apartir de agora na interface LAN do rádio 192.168.2.10 este bloco estará disponivel.

    É isto que vc quer?

    Até mais...

    Osni
    Eantao Osni, é mais ou menos isso mesmo que quero fazer, so que no cliente quero setar o ip publico mesmo entendeu, nao quero colocar ip privado, vi em seu blog sobre dividir os ips so que la vcoê usa proxy-arp na interface do link, ate usei aqui uma vez, so que começou a ficar lenta a rede e dar um pau de hora navegar hora nao navegar

    Obrigado pela resposta.

    Abraços

  6. #6

    Padrão Re: Dividir bloco de IPs de forma transparente no MK

    a forma correta não e usando proxy-arp, no seu caso seria quebrando sua rede em 04 blocos /30 e 03 blocos /28 a config ficaria assim no seu server

    ether2 201.12.130.65/30
    ether2 201.12.130.69/30
    ether2 201.12.130.73/30
    ether2 201.12.130.77/30

    routes

    destination=201.12.130.80/28 gateway= 201.12.130.66
    destination=201.12.130.96/28 gateway= 201.12.130.70
    destination=201.12.130.112/28 gateway= 201.12.130.74


    nos clientes

    clientes 01
    ether1 201.12.130.66/30
    ether2 201.12.130.81/28
    route
    destination 0.0.0.0/0 gateway=201.12.130.65

    clientes 02
    ether1 201.12.130.70/30
    ether2 201.12.130.97/28
    route
    destination 0.0.0.0/0 gateway=201.12.130.69

    clientes 03
    ether1 201.12.130.74/30
    ether2 201.12.130.113/28
    route
    destination 0.0.0.0/0 gateway=201.12.130.73
    simples assim.
    Última edição por binhorp; 27-08-2010 às 15:26.



  7. #7

    Padrão Re: Dividir bloco de IPs de forma transparente no MK

    boa noite!

    Sua lógica não esta errada, aqui é um pouco diferente pois tenho o ip do roteador e depois um bloco onde eu divido em dois e o segundo bloco da divisão eu disponibilizo para meus clientes.

    no seu caso, como vc vai receber direto no seu servidor "algo como um roteador assincrono", tente usar da seguinte forma abaixo, pois a mesma uso em servidores teste tipo e funciona corretamente.

    ##Informações do bloco
    Address: 201.12.130.64
    Netmask: 255.255.255.192 = 26
    Wildcard: 0.0.0.63
    Network: 201.12.130.64
    Broadcast: 201.12.130.127
    HostMin: 201.12.130.65
    HostMax: 201.12.130.126
    Hosts/Net: 62

    #bloco
    bloco 201.12.130.64/26
    #configuração no Mk
    IP Wan MK 201.12.130.65/26
    IP Lan MK 201.12.130.66/26
    ip DNS MK 201.12.130.67/26
    #configuração nos Clientes
    ip 201.12.130.68
    masc 255.255.255.192
    gat 201.12.130.66
    dns 201.12.130.67
    #regras para adicionar no mk
    /ip firewall action=accept src-address=201.12.130.64/26
    /ip firewall action=accept src-address=201.12.130.64/26

    OBS: lembrando que no /ip dns vc deve ativar a opção request dns para que o mesmo possa resolver usando o gateway ou outro ip do servidor, caso esqueça ou tenha dúvidas uso o dns da operadora e nos clientes tambem.

    o ip dns 201.12.130.67 é somente para ser criado em ip address e não adicionado em ip dns.

    att.: Scan
    Última edição por scan; 27-08-2010 às 20:47.

  8. #8
    Patrocinador Avatar de edcomrocha
    Ingresso
    Aug 2007
    Localização
    São Paulo, Brazil, Brazil
    Posts
    840

    Padrão Re: Dividir bloco de IPs de forma transparente no MK

    Citação Postado originalmente por scan Ver Post
    boa noite!

    Sua lógica não esta errada, aqui é um pouco diferente pois tenho o ip do roteador e depois um bloco onde eu divido em dois e o segundo bloco da divisão eu disponibilizo para meus clientes.

    no seu caso, como vc vai receber direto no seu servidor "algo como um roteador assincrono", tente usar da seguinte forma abaixo, pois a mesma uso em servidores teste tipo e funciona corretamente.

    ##Informações do bloco
    Address: 201.12.130.64
    Netmask: 255.255.255.192 = 26
    Wildcard: 0.0.0.63
    Network: 201.12.130.64
    Broadcast: 201.12.130.127
    HostMin: 201.12.130.65
    HostMax: 201.12.130.126
    Hosts/Net: 62

    #bloco
    bloco 201.12.130.64/26
    #configuração no Mk
    IP Wan MK 201.12.130.65/26
    IP Lan MK 201.12.130.66/26
    ip DNS MK 201.12.130.67/26
    #configuração nos Clientes
    ip 201.12.130.68
    masc 255.255.255.192
    gat 201.12.130.66
    dns 201.12.130.67
    #regras para adicionar no mk
    /ip firewall action=accept src-address=201.12.130.64/26
    /ip firewall action=accept src-address=201.12.130.64/26

    OBS: lembrando que no /ip dns vc deve ativar a opção request dns para que o mesmo possa resolver usando o gateway ou outro ip do servidor, caso esqueça ou tenha dúvidas uso o dns da operadora e nos clientes tambem.

    o ip dns 201.12.130.67 é somente para ser criado em ip address e não adicionado em ip dns.

    att.: Scan
    Scan me desculpe se eu entendi mal.
    MAis ai no caso que você colocu a rede nao esta sendo dividida neh (Digo os Ips)

    E a regra do firewall é em que lugar, ip firewall nat ou onde ?

    ABraços valew pela ajuda



  9. #9

    Padrão Re: Dividir bloco de IPs de forma transparente no MK

    bom dia!

    da forma citada acima vc vai poder pegar praticamente todos os ips disponiveis "+ ou - 59"

    use a configuração abaixo que deve resolver o problema:
    /ip address
    add address=201.12.130.66/26 interface=ether2
    add address=201.12.130.67/26 interface=ether1
    /ip dns
    set allow-remote-requests=yes cache-max-ttl=1w cache-size=2048KiB \
    max-udp-packet-size=512 servers=4.2.2.1,4.2.2.2
    /ip firewall filter
    add action=accept chain=forward comment="" disabled=no src-address=\
    201.12.130.64/26
    /ip firewall nat
    add action=accept chain=srcnat comment="" disabled=no src-address=\
    201.12.130.64/26
    /ip route
    add check-gateway=ping comment="" disabled=no distance=1 dst-address=\
    0.0.0.0/0 gateway=201.12.130.65 scope=255 target-scope=10
    #clientes
    Ip = 201.12.130.68
    masc = 255.255.255.192
    gatway = 201.12.130.67
    dns = 201.12.130.67
    Ip = 201.12.130.69
    masc = 255.255.255.192
    gatway = 201.12.130.67
    dns = 201.12.130.67
    Ip = 201.12.130.70
    masc = 255.255.255.192
    gatway = 201.12.130.67
    dns = 201.12.130.67
    Ip = 201.12.130.71
    masc = 255.255.255.192
    gatway = 201.12.130.67
    dns = 201.12.130.67


    att.: Scan
    Última edição por scan; 28-08-2010 às 08:12.

  10. #10
    Patrocinador Avatar de edcomrocha
    Ingresso
    Aug 2007
    Localização
    São Paulo, Brazil, Brazil
    Posts
    840

    Padrão Re: Dividir bloco de IPs de forma transparente no MK

    Citação Postado originalmente por scan Ver Post
    bom dia!

    da forma citada acima vc vai poder pegar praticamente todos os ips disponiveis "+ ou - 59"

    use a configuração abaixo que deve resolver o problema:
    /ip address
    add address=201.12.130.66/26 interface=ether2
    add address=201.12.130.67/26 interface=ether1
    /ip dns
    set allow-remote-requests=yes cache-max-ttl=1w cache-size=2048KiB \
    max-udp-packet-size=512 servers=4.2.2.1,4.2.2.2
    /ip firewall filter
    add action=accept chain=forward comment="" disabled=no src-address=\
    201.12.130.64/26
    /ip firewall nat
    add action=accept chain=srcnat comment="" disabled=no src-address=\
    201.12.130.64/26
    /ip route
    add check-gateway=ping comment="" disabled=no distance=1 dst-address=\
    0.0.0.0/0 gateway=201.12.130.65 scope=255 target-scope=10
    #clientes
    Ip = 201.12.130.68
    masc = 255.255.255.192
    gatway = 201.12.130.67
    dns = 201.12.130.67
    Ip = 201.12.130.69
    masc = 255.255.255.192
    gatway = 201.12.130.67
    dns = 201.12.130.67
    Ip = 201.12.130.70
    masc = 255.255.255.192
    gatway = 201.12.130.67
    dns = 201.12.130.67
    Ip = 201.12.130.71
    masc = 255.255.255.192
    gatway = 201.12.130.67
    dns = 201.12.130.67


    att.: Scan
    Tentei fazer aqui dessa forma mais ainda sem sucesso.

    Vou ter que ligar na operadora mesmo e ver se ele me mandam uma faixa /30 separada, pra eu pegar essa outra faixa /26 e dividir aqui, creio que sera mais facil


    Agradeço a todos pela força


    Abraços a todos



  11. #11

    Padrão Re: Dividir bloco de IPs de forma transparente no MK

    OLA MEUS AMIGO
    FAÇO ISSO DIFERENTE
    O MEU FUNCIONA ASSIM ...
    MEU LINK CHEGA EM UM CISCO 2600
    NO MIKROTIK CRIO UMA BRIDGE EM E COLOCO DUA INTERFACES NELA
    E APLICO AS REGRAS EM BRIDGE/FILTER
    OBS. COLOCO IP PUBLICO NO CLIENTE E APLICO QoS, FIREWALL, QQ COISA USO ASSIM POR MAIS DE 5 ANOS
    FICA PERFEITO.
    QQ COISA ESTOU ESTAREI A DISPOSIÇÃO ...VLW.
    Miniaturas de Anexos Miniaturas de Anexos Clique na imagem para uma versão maior

Nome:	         Bridge MK.jpg
Visualizações:	215
Tamanho: 	136,2 KB
ID:      	47491  
    Última edição por rivaldo; 15-08-2013 às 07:56.