+ Responder ao Tópico



  1. Citação Postado originalmente por fablinuxer Ver Post
    Resolvi da seguinte maneira, tirei thunder na mão mesmo, e rodei o script novamente, com as alteraçoes que já comentei a cima Agora to pelejando com uma outra coisa, no cache full, esta configurado um limite de 10M mas, na hora de baixar novamente um down, ele ta dando no maximo 50kbps de down para cliente com 128/128, acho q é alguma treta no zhp, pois pelo que vi ele marca com 0, e tenho visto artigos na net com 12 naum sei bem oq significa aquelas siglas no squid.conf ex: zph_local 0x30 e outras tbm, mas de qq forma mexi tudo, até mesmo comentei essa linhas e ainda sim continua marcando com 0. Alguém tem alguma ideia? Posta ai.
    Isso te ajudaria?
    ToS to DSCP mappig, ToS to DSCP conversion, convert ToS to DSCP | Networking Blog

  2. Citação Postado originalmente por minelli Ver Post
    Nao é o correto mas teste:
    Código :
    http.*\.youtube\.com.*
    Se funcionar e o Thunder.lst, se não funcionar e outra coisa.
    Testei mas tb não funcionou. realmente passou a aparecer mais FIRST_UP_PARENT, mas justo os videos naum. da uma olhada:
    286308044.861 247 192.168.10.1 TCP_MISS/204 333 GET http://www.youtube.com/get_video? - DIRECT/209.85.157.136 text/html
    1286308059.281 1026 192.168.10.1 TCP_MISS/200 986 GET YouTube Toolbar - DIRECT/208.93.140.60 text/html
    1286308073.355 1127 192.168.10.1 TCP_MISS/200 1431 GET http://www.youtube.com/v/INDFC85jKYs - FIRST_UP_PARENT/192.168.10.2 application/x-shockwave-flash
    1286308091.366 4899 192.168.10.1 TCP_MISS/200 20028 GET http://www.youtube.com/watch? - DIRECT/209.85.157.190 text/html
    1286308092.459 304 192.168.10.1 TCP_MISS/204 333 GET http://www.youtube.com/get_video? - DIRECT/209.85.157.190 text/html
    1286308093.141 1019 192.168.10.1 TCP_MISS/204 221 GET http://v8.lscache7.c.youtube.com/generate_204? - DIRECT/173.194.18.175 text/html
    1286308093.171 1047 192.168.10.1 TCP_MISS/302 629 GET http://v8.lscache7.c.youtube.com/videoplayback? - DIRECT/173.194.18.175 -
    1286308095.200 825 192.168.10.1 TCP_MISS/302 774 GET http://tc.v8.cache7.c.youtube.com/videoplayback? - DIRECT/208.117.241.165 text/html
    1286308096.971 866 192.168.10.1 TCP_MISS/200 1431 GET http://www.youtube.com/v/INDFC85jKYs - FIRST_UP_PARENT/192.168.10.2 application/x-shockwave-flash
    1286308104.020 429 192.168.10.1 TCP_MISS/200 1463 GET http://www.youtube.com/v/0D0SSnCRduA - FIRST_UP_PARENT/192.168.10.2 application/x-shockwave-flash
    1286308104.783 1186 192.168.10.1 TCP_MISS/200 1467 GET http://www.youtube.com/v/VNTyvhRdZns - FIRST_UP_PARENT/192.168.10.2 application/x-shockwave-flash
    1286308105.784 677 192.168.10.1 TCP_MISS/200 383 GET http://www.youtube.com/set_awesome? - DIRECT/209.85.157.190 text/xml
    1286308108.697 754 192.168.10.1 TCP_MISS/204 340 GET http://www.youtube.com/player_204? - DIRECT/209.85.157.190 text/html
    1286308128.915 83795 192.168.10.1 TCP_MISS/200 6773858 GET http://tc.v9.cache2.c.youtube.com/videoplayback? - DIRECT/195.27.182.17 video/x-flv
    1286308132.561 876 192.168.10.1 TCP_MISS/200 6178 GET http://www.youtube.com/xlb/watch/strings-pt_BR.xlb - FIRST_UP_PARENT/192.168.10.2 text/plain
    pode ser alguma config do squid (lusca), e por isso ele não consegue desviar para o parent? pq pra desviar só depende do squid, naum é?

    grato pela atenção!



  3. Minelli ajudou bastante, porém se eu falar ninguem acdredita..... coloco a marcaçao 0x30 no squid.config o q objetivamente seria 12(dcsp), mas quando tento marcar no mk com 12 nao marca de jeito nenhum é sou eu trocar pra 0 que a contagem começa estou usando squid 2.7 STABLE, postando a regra:
    add action=mark-connection chain=forward comment="PROXYFULL-MARCACAO FABRICIO -- REGRA SENTIDO PROXY > CLIENTES 64" \
    disabled=no in-interface=ether4 new-connection-mark=CONNSAINDOPROCLIENTE-64 passthrough=yes protocol=tcp \
    src-address=2.0.0.2 src-port=5128
    add action=mark-packet chain=forward comment="" connection-mark=CONNSAINDOPROCLIENTE-64 disabled=no in-interface=ether4 \
    new-packet-mark=PCTVINDOSDOPROXYINDOPRACLI64 passthrough=yes protocol=tcp src-address=2.0.0.2 src-port=5128.
    Dai crio na queue tree a regra pra full, na regra naum tem o 0 do dcsp, a marcaçao acontece com ou sem o 0, e eu naum sei por que o objeto naum vem na velocidade que ta marcado na queue tree mesmo estando sozinho na rede. vai entender. Seá que pode ser a versao do mk ak usa um rb1000 v4.3

  4. Citação Postado originalmente por fablinuxer Ver Post
    Minelli ajudou bastante, porém se eu falar ninguem acdredita..... coloco a marcaçao 0x30 no squid.config o q objetivamente seria 12(dcsp), mas quando tento marcar no mk com 12 nao marca de jeito nenhum é sou eu trocar pra 0 que a contagem começa estou usando squid 2.7 STABLE, postando a regra:
    add action=mark-connection chain=forward comment="PROXYFULL-MARCACAO FABRICIO -- REGRA SENTIDO PROXY > CLIENTES 64" \
    disabled=no in-interface=ether4 new-connection-mark=CONNSAINDOPROCLIENTE-64 passthrough=yes protocol=tcp \
    src-address=2.0.0.2 src-port=5128
    add action=mark-packet chain=forward comment="" connection-mark=CONNSAINDOPROCLIENTE-64 disabled=no in-interface=ether4 \
    new-packet-mark=PCTVINDOSDOPROXYINDOPRACLI64 passthrough=yes protocol=tcp src-address=2.0.0.2 src-port=5128.
    Dai crio na queue tree a regra pra full, na regra naum tem o 0 do dcsp, a marcaçao acontece com ou sem o 0, e eu naum sei por que o objeto naum vem na velocidade que ta marcado na queue tree mesmo estando sozinho na rede. vai entender. Seá que pode ser a versao do mk ak usa um rb1000 v4.3
    Está errado não esta? Não seria CHAIN = "POSROUTING" ????



  5. Quanto a erros no script não sei pois aqui funcionou bem,
    Eu particularmente estou testando agora o tc5 (versão paga), alias tentando fazer funcionar, Pois até agora não funcionou direito, kkkkkkk
    Quanto ao script creio que ainda esteja on em alguns foruns, mais recomendo usar um que tem no forum Mk-auth que é bem mais completo do que o que eu fiz, esse foi criado pelo Alisson Jonas da Silva o link é...
    Squid + Thundercache 3.1 + Cache DNS (Receita Pronta) - MK-AUTH

    Abraços a todos.






Tópicos Similares

  1. Script para desabilitar e habilitar instances do OSPF
    Por carlinhotocabrabo no fórum Redes
    Respostas: 7
    Último Post: 03-08-2016, 08:09
  2. Respostas: 6
    Último Post: 15-03-2016, 14:19
  3. Respostas: 6
    Último Post: 04-08-2012, 14:26
  4. Respostas: 6
    Último Post: 25-01-2011, 21:33
  5. Script para compactar arquivos de log do squid
    Por sandroreis no fórum Servidores de Rede
    Respostas: 2
    Último Post: 30-11-2005, 14:34

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L