Olá galera.
Valeu pela força. O soloneto conseguiu resolver.

O problema estava no mascaramento da rede pelo nat.
eu criava um "masquerade" apenas para as interfaces dos clientes. Ai foi criado um masquerade para toda rede.
O script ficou assim:

Código :
/ip firewall nat
 
add action=masquerade chain=srcnat comment="" disabled=no
add action=dst-nat chain=dstnat comment="" disabled=no dst-port=7070(PORTA EXTERNA) in-interface=pppoe-out5 protocol=tcp to-addresses=192.168.10.111 to-ports=1000(PORTA INTERNA)