Página 4 de 10 PrimeiroPrimeiro 123456789 ... ÚltimoÚltimo
+ Responder ao Tópico



  1. pelo que esta mostrando na imagem seu modem com link de 1Mb esta desconectado na RJ45, quando vc tirar outra Screen tire com os logs aparecendo.

  2. como eu disse antes,seus links nao sao simétricos,entao a marcação de pesos esta errada.
    tem que ser 8 pro link de 8M e 1 pro link de 1M,daforma que esta acima esta mandando 1pro link 8M e 1 pro link de 1M, ocasionando o estouro de banda do link de 1M.



  3. Citação Postado originalmente por sostenes Ver Post
    como eu disse antes,seus links nao sao simétricos,entao a marcação de pesos esta errada.
    tem que ser 8 pro link de 8M e 1 pro link de 1M,daforma que esta acima esta mandando 1pro link 8M e 1 pro link de 1M, ocasionando o estouro de banda do link de 1M.
    o sostenes tem razao quanto ao peso, mas a imagem dele fala tudo o link de 1 que entra na interface LINK 1MB nao esta conectado.
    Clique na imagem para uma versão maior

Nome:	         screen.jpg
Visualizações:	61
Tamanho: 	113,9 KB
ID:      	13818

    aos pesos vc deve por da seguinte forma:

    Código :
    add action=mark-connection chain=input comment="Load Balance////////////////////////////////////////////////////////////////////////////////////////////////\
        //////////////////////////////////////////////////////////////////////////////////////////////////////" connection-state=new disabled=no in-interface=\
        EthLinkA new-connection-mark=conn_na passthrough=yes
    add action=mark-connection chain=input comment="" connection-state=new disabled=no in-interface=EthLinkB new-connection-mark=conn_nb passthrough=yes
    add action=mark-routing chain=output comment="Marcando Rotas" connection-mark=conn_na disabled=no new-routing-mark=to_ra passthrough=no
    add action=mark-routing chain=output comment="" connection-mark=conn_nb disabled=no new-routing-mark=to_rb passthrough=no
    [COLOR="red"]#(Se baseando que a conn_ma0 é o link de 1Mb)[/COLOR]
    add action=mark-connection chain=prerouting comment=Balanceando disabled=no dst-address-type=!local in-interface=EthClientes new-connection-mark=conn_ma0 \
        passthrough=yes per-connection-classifier=both-addresses:8/0
    [COLOR="red"]#(E o link de 8Mb é a conn_mb1)[/COLOR]
    add action=mark-connection chain=prerouting comment="" disabled=no dst-address-type=!local in-interface=EthClientes new-connection-mark=conn_mb1 \
        passthrough=yes per-connection-classifier=both-addresses:8/1
    add action=mark-connection chain=prerouting comment="" disabled=no dst-address-type=!local in-interface=EthClientes new-connection-mark=conn_mb1 \
        passthrough=yes per-connection-classifier=both-addresses:8/2
    add action=mark-connection chain=prerouting comment="" disabled=no dst-address-type=!local in-interface=EthClientes new-connection-mark=conn_mb1 \
        passthrough=yes per-connection-classifier=both-addresses:8/3
    add action=mark-connection chain=prerouting comment="" disabled=no dst-address-type=!local in-interface=EthClientes new-connection-mark=conn_mb1 \
        passthrough=yes per-connection-classifier=both-addresses:8/4
    add action=mark-connection chain=prerouting comment="" dis8bled=no dst-address-type=!local in-interface=EthClientes new-connection-mark=conn_mb1 \
        passthrough=yes per-connection-classifier=both-addresses:8/5
    add action=mark-connection chain=prerouting comment="" disabled=no dst-address-type=!local in-interface=EthClientes new-connection-mark=conn_mb1 \
        passthrough=yes per-connection-classifier=both-addresses:8/6
    add action=mark-connection chain=prerouting comment="" disabled=no dst-address-type=!local in-interface=EthClientes new-connection-mark=conn_mb1 \
        passthrough=yes per-connection-classifier=both-addresses:8/7
    add action=mark-routing chain=prerouting comment="Marca Rotas de Saida" connection-mark=conn_ma0 disabled=no in-interface=EthClientes new-routing-mark=\
        to_nra passthrough=no
    add action=mark-routing chain=prerouting comment="" connection-mark=conn_mb1 disabled=no in-interface=EthClientes new-routing-mark=to_nrb passthrough=no

    é so fazer as alterações no script anterior ^^.

  4. para se balancear corretamente soma-se os links 8M+1M=9M ai se divide pelo valor menor que é 1M=9 marcações de rota,

    /ip firewall mangle add action=mark-connection chain=prerouting comment="Link1" disabled=no dst-address-type=!local in-interface= new-connection-mark=link1adsl_conn passthrough=yes per-connection-classifier=both-addresses-and-ports:9/0
    /ip firewall mangle add action=mark-connection chain=prerouting comment="Link1" disabled=no dst-address-type=!local in-interface= new-connection-mark=link1adsl_conn passthrough=yes per-connection-classifier=both-addresses-and-ports:9/1
    /ip firewall mangle add action=mark-connection chain=prerouting comment="Link1" disabled=no dst-address-type=!local in-interface= new-connection-mark=link1adsl_conn passthrough=yes per-connection-classifier=both-addresses-and-ports:9/2
    /ip firewall mangle add action=mark-connection chain=prerouting comment="Link1" disabled=no dst-address-type=!local in-interface= new-connection-mark=link1adsl_conn passthrough=yes per-connection-classifier=both-addresses-and-ports:9/3
    /ip firewall mangle add action=mark-connection chain=prerouting comment="Link1" disabled=no dst-address-type=!local in-interface= new-connection-mark=link1adsl_conn passthrough=yes per-connection-classifier=both-addresses-and-ports:9/4
    /ip firewall mangle add action=mark-connection chain=prerouting comment="Link1" disabled=no dst-address-type=!local in-interface= new-connection-mark=link1adsl_conn passthrough=yes per-connection-classifier=both-addresses-and-ports:9/5
    /ip firewall mangle add action=mark-connection chain=prerouting comment="Link1" disabled=no dst-address-type=!local in-interface= new-connection-mark=link1adsl_conn passthrough=yes per-connection-classifier=both-addresses-and-ports:9/6
    /ip firewall mangle add action=mark-connection chain=prerouting comment="Link1" disabled=no dst-address-type=!local in-interface= new-connection-mark=link1adsl_conn passthrough=yes per-connection-classifier=both-addresses-and-ports:9/7
    /ip firewall mangle add action=mark-connection chain=prerouting comment="Link2" disabled=no dst-address-type=!local in-interface= new-connection-mark=link2adsl_conn passthrough=yes per-connection-classifier=both-addresses-and-ports:9/8



  5. eu sei que tua lógica esta certo mas fazendo assim, por experiência própria ele quase nao vai usar o link de 1 Mb a não ser q ele seja a rota de distancia 1






Tópicos Similares

  1. Respostas: 35
    Último Post: 01-07-2016, 12:22
  2. balanceamento de 2 links adsl com modem em bridge
    Por eudesamarelo no fórum Redes
    Respostas: 6
    Último Post: 02-05-2013, 16:04
  3. Respostas: 7
    Último Post: 16-09-2012, 17:31
  4. Respostas: 0
    Último Post: 25-01-2011, 18:10
  5. Respostas: 11
    Último Post: 07-04-2010, 20:36

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L