+ Responder ao Tópico



  1. #21
    Luiz Paulo
    Visitante

    Cool Re: PÁGINA DE MANUTENÇÃO NO MIKROTIK SEM USAR SERVIDOR EXTERNO

    Para o RFJonas....

    Parabens meu caro.... muito boa esse seu tuto..

    consegui colocar pra funcionar... porem "nao sei porque" tive que retirar a ultima regra do script DOWN-LINK e a ultima do script LINK-UP, pois com as mesmas nao funfava..... e a pagina com o aviso só aparece quando o cliente é derrubado,.... ou seja tive que por aquela regra no script DOWN-LINK ai sim...apareceu... fora isso, ta tudo varendo... meus parabens.

    Att.

    Luiz paulo

  2. #22

    Padrão Re: PÁGINA DE MANUTENÇÃO NO MIKROTIK SEM USAR SERVIDOR EXTERNO

    RFJonas, obrigado pela ajuda mais ainda não consigui fazer funcionar, fiz tudo que voce falou e nada, continua aparecendo a pagina de status do hotspot, mais notei que o script DOWN-LINK nao ta trocando o profile no hotspot serve, se coloco manualmente o profile manutençao ai sim aparece a pagina de manutenção.... alguem que conseguiu fazer usa o mikrotik 3.30.
    a ja ia esquecendo RFJonas no mikrotik 3.30 no policy no script nao tem a opção ftp.



  3. #23

    Padrão Re: PÁGINA DE MANUTENÇÃO NO MIKROTIK SEM USAR SERVIDOR EXTERNO

    Citação Postado originalmente por Luiz Paulo Ver Post
    Para o RFJonas....

    Parabens meu caro.... muito boa esse seu tuto..

    consegui colocar pra funcionar... porem "nao sei porque" tive que retirar a ultima regra do script DOWN-LINK e a ultima do script LINK-UP, pois com as mesmas nao funfava..... e a pagina com o aviso só aparece quando o cliente é derrubado,.... ou seja tive que por aquela regra no script DOWN-LINK ai sim...apareceu... fora isso, ta tudo varendo... meus parabens.

    Att.

    Luiz paulo
    Obrigado Luiz Paulo!
    vou disponibilizar os print screen com o passo a passo para amenizar as duvidas! as regras que você retirou são esenciais para o funcionamento perfeito do sistema, ela muda seu dns-name: x para .* que vai resolver toas as requisições pela porta 80 ( dns-name= .* ou seja qualquer site digitado na hora que estiver sem link "em manutenção" ele vai encontrar sua pagina de manutenção) sem isso pode dar erro pagina não encontrada... no script eu deixei assim dns-name=provedor.com.br altere para o seu.
    qualquer coisa estamos ai para ajudar!

  4. #24

    Padrão Re: PÁGINA DE MANUTENÇÃO NO MIKROTIK SEM USAR SERVIDOR EXTERNO

    Citação Postado originalmente por tizedosal Ver Post
    RFJonas, obrigado pela ajuda mais ainda não consigui fazer funcionar, fiz tudo que voce falou e nada, continua aparecendo a pagina de status do hotspot, mais notei que o script DOWN-LINK nao ta trocando o profile no hotspot serve, se coloco manualmente o profile manutençao ai sim aparece a pagina de manutenção.... alguem que conseguiu fazer usa o mikrotik 3.30.
    a ja ia esquecendo RFJonas no mikrotik 3.30 no policy no script nao tem a opção ftp.
    tizedosal, testei com outras versões do mk até a "2.9.27" e funcionou perfeitamente! não entendi "no mikrotik 3.30 no policy no script nao tem a opção ftp."! vou tirar print screen aqui e vou postar, acho que ajuda mais! aguarde ai.



  5. #25
    Luiz Paulo
    Visitante

    Padrão Re: PÁGINA DE MANUTENÇÃO NO MIKROTIK SEM USAR SERVIDOR EXTERNO

    ok...estou no aguardo... das screenshot

    uma duvida..... pra quem nao usa pagina de login (login e senha)..... utiliza o metodo de login por mac (cliente loga automatico) como ficaria ?

    Agradeço desde ja.

    Abraços

  6. #26

    Padrão Re: PÁGINA DE MANUTENÇÃO NO MIKROTIK SEM USAR SERVIDOR EXTERNO

    RFJonas, mais uma vez obrigado vou aguarda os print screen.....



  7. #27

    Padrão Re: PÁGINA DE MANUTENÇÃO NO MIKROTIK SEM USAR SERVIDOR EXTERNO

    olá pessoal!
    Estou dispondo em anexo todo o tutorial em pdf com as imagens, os scripts em .txt, outra página de manutenção, para aqueles que não tem conhecimento, uma dica onde vão alterar o código HTML para os dados do seu provedor! Há! Vamos clicar na estrelinha ai né!!! Um abraço a todos!
    Arquivos Anexos Arquivos Anexos
    Última edição por RFjonas; 23-09-2011 às 12:05. Razão: correção

  8. #28

    Padrão Re: PÁGINA DE MANUTENÇÃO NO MIKROTIK SEM USAR SERVIDOR EXTERNO

    Citação Postado originalmente por RFjonas Ver Post
    olá pessoal!
    Estou dispondo em anexo todo o tutorial em pdf com as imagens, os scripts em .txt, outra página de manutenção, para aqueles que não tem conhecimento, uma dica onde vão alterar o código HTML para os dados do seu provedor! Há! Vamos clicar na estrelinha ai né!!! Um abraço a todos!
    amigão vou testar aqui no meu servidor mais ja agradeço por ter postado o tuto...



  9. #29

    Padrão Re: PÁGINA DE MANUTENÇÃO NO MIKROTIK SEM USAR SERVIDOR EXTERNO

    Poxa, aqui quando o link cai que tento abrir qualquer outra página ta direcionando pra página de status.

  10. #30
    Luiz Paulo
    Visitante

    Padrão Re: PÁGINA DE MANUTENÇÃO NO MIKROTIK SEM USAR SERVIDOR EXTERNO

    Então..RFJonas.....

    com esse script nao funfou nao... uso a 3.30....Velox....

    Consegui com essas alterações aqui óóóó...

    /ip dns static
    add address=IP DO MK disabled=no name=MEU DNS ttl=5s


    /system script
    add name=DOWN-LINK policy=ftp,read,write,winbox source="/ip firewall nat enabl\
    e [find comment=\"MANUTENCAO\"]\r\
    \n/ip hotspot profile set default html-directory=manutencao\r\
    \n/ip hotspot active remove [/ip hotspot active find]\r\
    \n/ip hotspot cookie remove [/ip hotspot cookie find]\r\
    \n/ip hotspot host remove [/ip hotspot host find]\r\
    \n\r\
    \n"
    add name=LINK-UP policy=ftp,read,write,winbox source="/ip firewall nat disable\
    \_[find comment=\"MANUTENCAO\"]\r\
    \n/ip hotspot profile set default html-directory=hotspot\r\
    \n"
    add name=REMOVER-DNS-DINAMICO policy=ftp,read,write,winbox source="/ip dns sta\
    tic remove [/ip dns static find dynamic=yes]\r\
    \n/system script run LINK-UP\r\
    \n/system scheduler disable [/system scheduler find name=remover_dns_dinam\
    ico]"


    /system scheduler
    add comment="" disabled=yes interval=5s name=remover_dns_dinamico on-event=\
    REMOVER-DNS-DINAMICO policy=\
    reboot,read,write,policy,test,password,sniff,sensitive start-date=\
    jan/01/1970 start-time=00:00:00


    /tool netwatch
    add comment="MONITORAR LINK" disabled=no down-script=\
    "/ system script run DOWN-LINK\r\
    \n" host=8.8.8.8 interval=5s timeout=1s up-script="/system scheduler enabl\
    e [/system scheduler find name=remover_dns_dinamico]\r\
    \n/ system script run LINK-UP\r\
    \n"

    com esse ficou 100% AQUI NO MEU server... (com clientes que usam login e senha)

    mais ainda estou com uma duvida... para clientes que estao configurados para logar automaticamente (AUTENTICAÇÃO POR MAC) não funciona... acredito eu.... que seja pelo fato desse tipo de autenticão nao ser redirecionado para pagina de login..... se eu estiver errado por favor me digam...

    então fica a pergunta....

    Tem como redirecionar esses tipos de clientes tambem...para essa pagina de manutenção quando solicitarem a pagina e nao houver link ?

    Aguardo e desde ja agradeço.....

    Abralos..



  11. #31

    Padrão Re: PÁGINA DE MANUTENÇÃO NO MIKROTIK SEM USAR SERVIDOR EXTERNO

    Citação Postado originalmente por amilton Ver Post
    Poxa, aqui quando o link cai que tento abrir qualquer outra página ta direcionando pra página de status.
    Poxa! eu achei que com o tutorial em pdf anexado iria eliminar todas as duvidas! mais vamos lá,
    Amilton você importou a pasta manutencao para files em seu mikrotik?
    se tiver feito tudo como mostrei, é pra funfar. qualquer coisa estamos ai!

  12. #32

    Padrão Re: PÁGINA DE MANUTENÇÃO NO MIKROTIK SEM USAR SERVIDOR EXTERNO

    Então, usei um cliente ftp pra upar a pasta manutencao pro mk, percebi que ao ocorrer a queda do link, não esta havendo a troca de diretórios. Coloquei a pasta manutencao fora da pasta hotspot, ou seja na raiz. Agora será que tem algo a ver com o uso do webproxy? Pensei que seria simples, mas estou tomando um baile kkkk.



  13. #33

    Padrão Re: PÁGINA DE MANUTENÇÃO NO MIKROTIK SEM USAR SERVIDOR EXTERNO

    Citação Postado originalmente por amilton Ver Post
    Então, usei um cliente ftp pra upar a pasta manutencao pro mk, percebi que ao ocorrer a queda do link, não esta havendo a troca de diretórios. Coloquei a pasta manutencao fora da pasta hotspot, ou seja na raiz. Agora será que tem algo a ver com o uso do webproxy? Pensei que seria simples, mas estou tomando um baile kkkk.
    Em hotspot/ user profiles transparent proxy está marcado? confere e diz!

  14. #34

    Padrão Re: PÁGINA DE MANUTENÇÃO NO MIKROTIK SEM USAR SERVIDOR EXTERNO

    Esta marcado, mas fiz testes com ele desmarcado e deu no mesmo.



  15. #35

    Padrão Re: PÁGINA DE MANUTENÇÃO NO MIKROTIK SEM USAR SERVIDOR EXTERNO

    Citação Postado originalmente por amilton Ver Post
    Esta marcado, mas fiz testes com ele desmarcado e deu no mesmo.
    post ai como esta seu nat! se ja tem um dstnat para seu proxy o outro da manutençao não vai funfar. tem que organizar as regra do nat ok!

  16. #36

    Padrão Re: PÁGINA DE MANUTENÇÃO NO MIKROTIK SEM USAR SERVIDOR EXTERNO

    Pior que ta uma bagunça mesmo, dá só uma olhada:

    /ip firewall nat
    add action=passthrough chain=unused-hs-chain comment=\
    "place hotspot rules here" disabled=yes
    add action=redirect chain=dstnat comment=\
    "Air Force One WEB PROXY redirecionamento porta 80 para webproxy 3128" \
    disabled=no dst-port=80 protocol=tcp src-address=192.168.0.0/24 to-ports=\
    3128
    add action=masquerade chain=srcnat comment="masquerade hotspot network" \
    disabled=no src-address=192.168.0.0/24
    add action=masquerade chain=srcnat comment="Added by webbox" disabled=no \
    out-interface="LINK SPEEDY"
    add action=masquerade chain=srcnat comment="masquerade hotspot network" \
    disabled=no src-address=192.168.0.0/24
    add action=masquerade chain=srcnat comment="masquerade hotspot network" \
    disabled=no src-address=192.168.0.0/24
    add action=masquerade chain=srcnat comment="masquerade hotspot network" \
    disabled=no src-address=192.168.0.0/24
    add action=masquerade chain=srcnat comment="masquerade hotspot network" \
    disabled=no src-address=192.168.0.0/24
    add action=masquerade chain=srcnat comment="masquerade hotspot network" \
    disabled=no src-address=192.168.0.0/24
    add action=redirect chain=pre-hotspot comment="" disabled=yes dst-port=80 \
    hotspot=auth in-interface=CLIENTES protocol=tcp src-address=\
    192.168.0.0/24 to-ports=3128
    add action=dst-nat chain=dstnat comment=MANUTENCAO disabled=yes dst-port=80 \
    protocol=tcp to-addresses=192.168.0.1 to-ports=64873
    add action=redirect chain=dstnat comment=MANUTENCAO disabled=yes dst-port=80 \
    protocol=tcp to-ports=64873

    Tem como ajudar?
    Última edição por amilton; 17-10-2010 às 21:12.



  17. #37

    Padrão Re: PÁGINA DE MANUTENÇÃO NO MIKROTIK SEM USAR SERVIDOR EXTERNO

    RFjonas, aqui tambem ainda não consegui, eu tenho o dstnat para proxy, estou colocando o nat da manutençao depois do masquerade do hotspot e antes do nat do proxy, mais so aparece a tela do status do hotspot, notei tambem que não muda o profile la no server....

  18. #38

    Padrão Re: PÁGINA DE MANUTENÇÃO NO MIKROTIK SEM USAR SERVIDOR EXTERNO

    Citação Postado originalmente por tizedosal Ver Post
    RFjonas, aqui tambem ainda não consegui, eu tenho o dstnat para proxy, estou colocando o nat da manutençao depois do masquerade do hotspot e antes do nat do proxy, mais so aparece a tela do status do hotspot, notei tambem que não muda o profile la no server....
    ok! faça um teste ai dessa forma, não é o profile que vai mudar e sim o diretorio html, faça manualmente, em ip/hotspot/server profile em html directory mude para o diretorio manutencao e teste ai, há! post ai como esta o seu hotspot, eu testei com web proxy aqui e funfou redondinho! vamos colocar esse negocio p funfar!!!!rsrsrs
    /ip hotspot export
    Última edição por RFjonas; 18-10-2010 às 00:33.



  19. #39

    Padrão Re: PÁGINA DE MANUTENÇÃO NO MIKROTIK SEM USAR SERVIDOR EXTERNO

    Citação Postado originalmente por amilton Ver Post
    Pior que ta uma bagunça mesmo, dá só uma olhada:

    /ip firewall nat
    add action=passthrough chain=unused-hs-chain comment=\
    "place hotspot rules here" disabled=yes
    add action=redirect chain=dstnat comment=\
    "Air Force One WEB PROXY redirecionamento porta 80 para webproxy 3128" \
    disabled=no dst-port=80 protocol=tcp src-address=192.168.0.0/24 to-ports=\
    3128
    add action=masquerade chain=srcnat comment="masquerade hotspot network" \
    disabled=no src-address=192.168.0.0/24
    add action=masquerade chain=srcnat comment="Added by webbox" disabled=no \
    out-interface="LINK SPEEDY"
    add action=masquerade chain=srcnat comment="masquerade hotspot network" \
    disabled=no src-address=192.168.0.0/24
    add action=masquerade chain=srcnat comment="masquerade hotspot network" \
    disabled=no src-address=192.168.0.0/24
    add action=masquerade chain=srcnat comment="masquerade hotspot network" \
    disabled=no src-address=192.168.0.0/24
    add action=masquerade chain=srcnat comment="masquerade hotspot network" \
    disabled=no src-address=192.168.0.0/24
    add action=masquerade chain=srcnat comment="masquerade hotspot network" \
    disabled=no src-address=192.168.0.0/24
    add action=redirect chain=pre-hotspot comment="" disabled=yes dst-port=80 \
    hotspot=auth in-interface=CLIENTES protocol=tcp src-address=\
    192.168.0.0/24 to-ports=3128
    add action=dst-nat chain=dstnat comment=MANUTENCAO disabled=yes dst-port=80 \
    protocol=tcp to-addresses=192.168.0.1 to-ports=64873
    add action=redirect chain=dstnat comment=MANUTENCAO disabled=yes dst-port=80 \
    protocol=tcp to-ports=64873

    Tem como ajudar?
    Amilton esse seu nat está um pouco desorganizado cara ! pelo que eu entendi aqui você so precisa disso:

    /ip firewall nat
    add action=redirect chain=dstnat comment="MANUTENCAO" disabled=yes dst-port=80 \
    protocol=tcp to-ports=64873
    add action=masquerade chain=srcnat comment="masquerade hotspot network" \
    disabled=no src-address=192.168.0.0/24
    add action=redirect chain=dstnat comment=\
    "Air Force One WEB PROXY redirecionamento porta 80 para webproxy 3128" \
    disabled=no dst-port=80 protocol=tcp src-address=192.168.0.0/24 to-ports=\
    3128

    Outra coisa! veja como está ip/hotspot/servers em name tem que esta = hotspot1
    e em profile = hsprof1 como manda o script do tuto...
    verifica ai e diz depois!
    Última edição por RFjonas; 18-10-2010 às 02:27.

  20. #40

    Padrão Re: PÁGINA DE MANUTENÇÃO NO MIKROTIK SEM USAR SERVIDOR EXTERNO

    Valeu cara otimo tópico, vou colocar em teste assim que possivel rsrs...

    Parabéns!!!