+ Responder ao Tópico



  1. Uma pequena contribuição...

    Fiz uma pequena modificação no código para que o mesmo pudesse funcionar.

    Eis o meu cenário de teste, PC-MK 3.22 - Hotspot testado com e sem cookies

    No seguinte trecho do codigo em vermelho: Deverá ser removida as barras invertidas, deixando somente entre os Parenteses
    /system script
    add name=DOWN-LINK policy=ftp,read,write,winbox source="/ip firewall nat enabl\
    e [find comment=\"MANUTENCAO\"]\r\
    \n/ip hotspot profile set hsprof1 html-directory=manutencao\r\
    \n/ip dns static set [/ip dns static find name=hotspot.seuhotspot.com] address=8.8.8.8\
    comment=\"\" disabled=no name=.* ttl=5s"
    Faça o mesmo em DOWN-LNIK E LINK-UP no Diretório SYSTEM > SCRIPTS > SCRIPT LIST

    Com esse procedimento a regra do Nat abaixo especificada funcionara a contento.
    /ip firewall nat
    add action=redirect chain=dstnat comment=manutencao disabled=yes dst-port=80 protocol=tcp to-ports=64873
    Boa sorte!

  2. Citação Postado originalmente por RFjonas Ver Post
    Tizedosal, eu já estava preocupado com as configurações do seu hotspot! graças a DEUS funfou!

    ATENÇÃO A TODOS!
    o que acontece é que se você não ler o script com atenção antes de colocar em seu MK, não vai perceber uma coisa básica!
    quando você criar o hotspot no MK pela 1ª vez, ele é nomeado em servers como "hotspot1" e em server profiles como "hsprof1"
    -assim como esta no script!
    se você criar o hotspot pela 2ª vez e não excluiu o primeiro completamente antes, oque acontece?
    ele vai ser nomeado em servers como "hotspot2" e em server profiles "hsprof2" e assim sucessivamente,
    agora me diga, porque o script não funciona com o servers "hotspot2"?

    resp: porque o script está procurando o servers "hotspot1" e server profiles "hsprof1"
    o jeito é ou editar o script para seu hotspot ou o seu hotspot para o script!

    espero que assim resolva as duvidas dos demais amigos!
    Tive de ler uma porção de vezes para entender tudo, mais agora está 100%



  3. Citação Postado originalmente por RFjonas Ver Post
    olá pessoal!
    Estou dispondo em anexo todo o tutorial em pdf com as imagens, os scripts em .txt, outra página de manutenção, para aqueles que não tem conhecimento, uma dica onde vão alterar o código HTML para os dados do seu provedor! Há! Vamos clicar na estrelinha ai né!!! Um abraço a todos!
    Há muito tempo não conseguia colocar para funcionar isso. Agora foi.

    O meu erro:

    Não tinham todas as páginas dentro da pasta manutenção, tinha deixado a login.html, assim não funciona, tem que ter todas as outras, alogin.html, redirect.html, etc....

    Valeu,

    Hayttle

  4. Aqui funcionou 1x só e parou!!!



  5. Citação Postado originalmente por peritinaicos Ver Post
    Aqui funcionou 1x só e parou!!!
    Aqui tb funciona 1 vez e parou
    Deve ser algum detalhe minimo






Tópicos Similares

  1. Respostas: 19
    Último Post: 28-01-2016, 03:18
  2. Respostas: 0
    Último Post: 24-11-2014, 18:21
  3. Personalizar pagina de login no mikrotik
    Por Bizinho no fórum Redes
    Respostas: 5
    Último Post: 18-07-2010, 00:26
  4. Página de Aviso no Mikrotik
    Por JRNET no fórum Redes
    Respostas: 2
    Último Post: 16-08-2008, 15:19
  5. página de redirecinamento no mikrotik
    Por alamilly no fórum Redes
    Respostas: 5
    Último Post: 06-08-2007, 18:55

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L