+ Responder ao Tópico



  1. #1

    Padrão Mais um que nao consegue fazer cache full

    caros amigos achei bastante conteúdo aqui no forum sobre web proxy e cache full, porem cansei de tentar colocar as regras e adapta-las e nao funciona, meu conhecimento em Mk eh pequeno porem faço tudo certinho e nao funciona, o fato de eu usar HOTSPOT e uma versão 3.30, piora a cituação, se nao fosse por isso creio q ja estava funcionando a muito tempo, bom copiei algumas regras minhas e gostaria que alguem pudesse analizar e ver se descobre oq esta errado q nao funciona, segue as regras:



    #
    /ip firewall connection tracking
    set enabled=yes generic-timeout=10m icmp-timeout=10s tcp-close-timeout=10s \
    tcp-close-wait-timeout=10s tcp-established-timeout=1d \
    tcp-fin-wait-timeout=10s tcp-last-ack-timeout=10s \
    tcp-syn-received-timeout=5s tcp-syn-sent-timeout=5s tcp-syncookie=no \
    tcp-time-wait-timeout=10s udp-stream-timeout=3m udp-timeout=10s
    /ip firewall filter
    add action=drop chain=input comment="BARRA BRUTAL FOR\C7A" disabled=no \
    dst-port=22 protocol=tcp src-address-list=!black_list
    add action=drop chain=input comment="BLOQUEIO DO PROXY EXTERNO" disabled=no \
    dst-port=8080 protocol=tcp
    add action=accept chain=input comment="CHACHE FULL - ACEITAR CONEXOES PROXY" \
    disabled=no dscp=0 dst-port=8080 in-interface=CLIENTES protocol=tcp \
    src-address=192.168.2.0/24
    add action=passthrough chain=unused-hs-chain comment=\
    "place hotspot rules here" disabled=yes
    /ip firewall mangle
    add action=accept chain=output comment="qcept proxy" disabled=no dscp=4
    add action=mark-connection chain=output comment=Cache-squid content=\
    "X-Cache: HIT" disabled=no new-connection-mark=squid-connection-HIT \
    passthrough=yes protocol=tcp src-port=3128
    add action=mark-packet chain=output comment="" connection-mark=\
    squid-connection-HIT disabled=no new-packet-mark=squid-packet-HIT \
    passthrough=no
    add action=add-dst-to-address-list address-list=youtube address-list-timeout=\
    4w2d chain=prerouting comment=Youtube content=youtube.com disabled=no \
    dst-port=80 in-interface=CLIENTES protocol=tcp
    add action=add-dst-to-address-list address-list=4shared address-list-timeout=\
    4w2d chain=prerouting comment=4Shared content=4shared.com disabled=no \
    dst-port=80 in-interface=CLIENTES protocol=tcp
    add action=add-dst-to-address-list address-list=megaupload \
    address-list-timeout=4w2d chain=prerouting comment=Mega content=\
    megaupload.com disabled=no dst-port=80 in-interface=CLIENTES protocol=tcp
    add action=add-dst-to-address-list address-list=rapidshare \
    address-list-timeout=4w2d chain=prerouting comment=Rapid content=\
    rapidshare.com disabled=no dst-port=80 in-interface=CLIENTES protocol=tcp
    add action=add-dst-to-address-list address-list=orkut address-list-timeout=\
    4w2d chain=prerouting comment=Orkut content=orkut.com.br disabled=no \
    dst-port=80 in-interface=CLIENTES protocol=tcp
    add action=mark-connection chain=output comment="Hotspot - Full" disabled=no \
    new-connection-mark=hotspot-out out-interface=CLIENTES passthrough=yes \
    protocol=udp src-port=64872
    add action=mark-connection chain=output comment="" disabled=no \
    new-connection-mark=hotspot-out out-interface=CLIENTES passthrough=yes \
    protocol=tcp src-port=64872
    add action=mark-connection chain=output comment="" disabled=no \
    new-connection-mark=hotspot-out out-interface=CLIENTES passthrough=yes \
    protocol=tcp src-port=64873
    add action=mark-connection chain=output comment="" disabled=no \
    new-connection-mark=hotspot-out out-interface=CLIENTES passthrough=yes \
    protocol=tcp src-port=64874
    add action=mark-connection chain=output comment="" disabled=no \
    new-connection-mark=hotspot-out out-interface=CLIENTES passthrough=yes \
    protocol=tcp src-port=64875
    add action=mark-connection chain=prerouting comment="QoS - MSN" disabled=no \
    dst-port=1863 new-connection-mark=Messenger-Conexao passthrough=yes \
    protocol=tcp
    add action=mark-connection chain=prerouting comment="" disabled=no dst-port=\
    1863 new-connection-mark=Messenger-Conexao passthrough=yes protocol=udp
    add action=mark-connection chain=prerouting comment="" disabled=no dst-port=\
    6891-6901 new-connection-mark=Messenger-Conexao passthrough=yes protocol=\
    tcp
    add action=mark-connection chain=prerouting comment="" disabled=no dst-port=\
    6891-6901 new-connection-mark=Messenger-Conexao passthrough=yes protocol=\
    udp
    add action=mark-connection chain=prerouting comment="" disabled=no dst-port=\
    5190 new-connection-mark=Messenger-Conexao passthrough=yes protocol=udp
    add action=mark-packet chain=prerouting comment="" connection-mark=\
    Messenger-Conexao disabled=no new-packet-mark=Messenger-Pacotes \
    passthrough=no
    add action=mark-connection chain=prerouting comment=YOU disabled=no \
    new-connection-mark=you_conn passthrough=yes src-address-list=youtube
    add action=mark-packet chain=prerouting comment="" connection-mark=you_conn \
    disabled=no new-packet-mark=you_packet passthrough=yes
    add action=mark-connection chain=prerouting comment=4SH disabled=no \
    new-connection-mark=4sh_conn passthrough=yes src-address-list=4shared
    add action=mark-packet chain=prerouting comment="" connection-mark=4sh_conn \
    disabled=no new-packet-mark=4sh_packet passthrough=yes
    add action=mark-connection chain=prerouting comment=MEGA disabled=no \
    new-connection-mark=mega_conn passthrough=yes src-address-list=megaupload
    add action=mark-packet chain=prerouting comment="" connection-mark=mega_conn \
    disabled=no new-packet-mark=mega_packet passthrough=yes
    add action=mark-connection chain=prerouting comment=RAPID disabled=no \
    new-connection-mark=rapid_conn passthrough=yes src-address-list=\
    rapidshare
    add action=mark-packet chain=prerouting comment="" connection-mark=rapid_conn \
    disabled=no new-packet-mark=rapid_packet passthrough=yes
    add action=mark-connection chain=output comment=ORK content=orkut.com \
    disabled=no new-connection-mark=ork_conn passthrough=yes
    add action=mark-packet chain=output comment="" connection-mark=ork_conn \
    disabled=no new-packet-mark=ork_packet passthrough=yes
    add action=mark-packet chain=output comment=";;; HIT TRAFFIC FROM PROXY " \
    disabled=no dscp=!4 new-packet-mark=proxy-hit out-interface=CLIENTES \
    passthrough=no
    add action=mark-packet chain=prerouting comment=";;; UP TRAFFIC" disabled=no \
    in-interface=CLIENTES new-packet-mark=proxy-up passthrough=no \
    src-address=192.168.2.0/24
    add action=mark-connection chain=forward comment=";;; CONN-MARK" disabled=no \
    new-connection-mark=proxy-conn passthrough=yes src-address=192.168.2.0/24
    add action=mark-packet chain=forward comment=";;; DOWN-DIRECT CONNECTION" \
    connection-mark=proxy-conn disabled=no in-interface=LINK new-packet-mark=\
    proxy-down passthrough=no
    add action=mark-packet chain=output comment=";;; DOWN-VIA PROXY" disabled=no \
    new-packet-mark=proxy-down out-interface=CLIENTES passthrough=no \
    src-address=192.168.2.0/24
    add action=mark-connection chain=prerouting comment="Controle P2P" disabled=\
    no new-connection-mark=p2p_conn p2p=all-p2p passthrough=yes
    add action=mark-packet chain=prerouting comment="" connection-mark=p2p_conn \
    disabled=no new-packet-mark=p2p passthrough=yes
    add action=change-mss chain=forward comment="Alterar MSS do MSN para 1440" \
    disabled=no dst-port=1863 new-mss=1440 protocol=tcp tcp-flags=syn \
    tcp-mss=1441-65535
    /ip firewall nat
    add action=passthrough chain=unused-hs-chain comment=\
    "place hotspot rules here" disabled=yes
    add action=masquerade chain=srcnat comment="masquerade hotspot network" \
    disabled=no src-address=192.168.2.0/24
    add action=redirect chain=dstnat comment=\
    "redirecionamento porta 80 para webproxy 3128" disabled=no dst-port=80 \
    in-interface=CLIENTES protocol=tcp src-address=192.168.2.0/24 to-ports=\
    3128
    /ip firewall service-port
    set ftp disabled=no ports=21
    set tftp disabled=no ports=69
    set irc disabled=no ports=6667,3128
    set h323 disabled=no
    set sip disabled=no ports=5060,5061
    set pptp disabled=no



    ja nao aguento mais tentar seguir algum tutorial que nunca da certo,
    desde já agradeço a qualquer ajuda, abraços

  2. #2

    Padrão Re: Mais um que nao consegue fazer cache full

    tambem nunca consegui fazer nada que prestasse neste sentido, uma vez ate fiz um que fazia lentidao na rede.. kkk



  3. #3

    Padrão Re: Mais um que nao consegue fazer cache full

    é porque ctrl+c e ctrl+v nao funciona !!

    voces precisam entender a LOGICA que o firewall segue.. e saber a ordem EXATA para colocar as regras...

    ainda mais quando se tem hotspot.

    não é o cache-full que não funciona..


    alem do mais, o seu proxy precisa estar configurado para fazer cache, muita gente configura proxy com receita de bolo.. e a maioria não sabe nem o que se trata !!!


    Clique na imagem para uma versão maior

Nome:	         full.jpg
Visualizações:	148
Tamanho: 	69,8 KB
ID:      	16075


    acabei de fazer o teste, baixei (usando o firefox) o skype antes.. e veio a 2Mbit/s (meu plano de acesso aqui da minha casa)..

    e depois, pelo internet explorer (para evitar cache local do browser), baixei novamente.. e veio na velocidade full .. a repetidora que estou conectado é 5.8ghz .. entao deu essa velocidade aqui..


  4. #4

    Padrão Re: Mais um que nao consegue fazer cache full

    Com muita dificuldade consegui fazer com que tudo fique gravado no cache, só que apenas os downloads saõ buscados do cache e saiem di la na velocidade full, mas as paginas não apenas são armazenadas, o que poderia esta errado?



  5. #5
    técnico em Telecom Avatar de laurence669
    Ingresso
    Oct 2009
    Localização
    minas gerais
    Posts
    1.000
    Posts de Blog
    1

    Padrão Re: Mais um que nao consegue fazer cache full

    eu geralmente não uso cache full não pois os minis pci 2.4ghz estoura ....
    e causa lentidão nos aps ....

  6. #6

    Padrão Re: Mais um que nao consegue fazer cache full

    Pelo amor de DEUS gente... será que não existe ninguém nesse mundo , q pode ensinar a fazer essa "PRAGA" desse cache full na versão 3.30 eu já li de tudo já tentei fazer de todas as formas e a unica coisa que consigo é depois de 1 hora uma internet lentissima, pow "Alexandre Correia" vc é considerado o Gandalf aqui do forum, vc tem mais respeito aqui doque o Osama Bin Laden na AlQaeda, seu conhecimento faz o Albert Einstein parecer um menino de 5 anos no jardim da infancia, faz um mini tutorial ae passo-a-passo e deixa como fixo no forum... vc ia salvar mais gente do que a cruz vermelha, grato pela força....

    "É nóis que gira Zangief"



  7. #7

    Padrão Re: Mais um que nao consegue fazer cache full

    Citação Postado originalmente por alexandrecorrea Ver Post
    é porque ctrl+c e ctrl+v nao funciona !!

    voces precisam entender a LOGICA que o firewall segue.. e saber a ordem EXATA para colocar as regras...

    porem cansei de tentar colocar as regras e adapta-las.... eu nao disse que apenas copiava e colava, disse q tentava adpta-las mais sem exito!
    Citação Postado originalmente por alexandrecorrea Ver Post
    ainda mais quando se tem hotspot.
    não é o cache-full que não funciona..

    alem do mais, o seu proxy precisa estar configurado para fazer cache, muita gente configura proxy com receita de bolo.. e a maioria não sabe nem o que se trata !!!
    eu nao disse q o cache nao funciona, disse que eu nao consegui fazer funcionar e no meu servidor nao esta funcionando, alem do mais nunca vi nenhum tópico que explicasse cada configuração o q significa, para eu poder saber adaptar no meu server, só vejo tutorial tipo receita de bolo, onde nem a voz de quem fez a gente escuta, apenas uma musica de fundo, isso quando eh em video, inclusive os seus, vc tem algum tutorial que explique como se faz e explique cada configuração, para nao ficar tipo receita de bolo?


    Citação Postado originalmente por alexandrecorrea Ver Post
    acabei de fazer o teste, baixei (usando o firefox) o skype antes.. e veio a 2Mbit/s (meu plano de acesso aqui da minha casa)..
    e depois, pelo internet explorer (para evitar cache local do browser), baixei novamente.. e veio na velocidade full .. a repetidora que estou conectado é 5.8ghz .. entao deu essa velocidade aqui..
    sei que aki nao é um curso de MK onde se explica tudo, cada configuração, mais nao consigo entender, pq colocam tutoriais que sem explicaçoes nao irá funcionar?

  8. #8

    Padrão Re: Mais um que nao consegue fazer cache full

    o video do cache-full explica passo-a-passo !! nao tem como fazer mais detalhado :P



  9. #9

    Padrão Re: Mais um que nao consegue fazer cache full

    Amigo Jeferson eu vi seu post e o desespero do nosso amigo LoboMaL, ele chegou a elogiar o Alexandre correia dizendo que ele era o Gandalf aqui do forum... eu criei esse tutorial agora pouco, e garanto que esta funcionando, pois eu utilizo a versão 3.30 e aqui ficou bacana mesmo espero que te ajude, com sinceridade não sei te explicar todas as regras mas te garanto que funciona o cache sim... ele vai a full ou na velocidade determinada por você segue abaixo o link espero que te ajude, um forte abraço

    https://under-linux.org/f211/tutoria...3-30-a-142823/

  10. #10

    Padrão Re: Mais um que nao consegue fazer cache full

    Citação Postado originalmente por wanderley85 Ver Post
    Amigo Jeferson eu vi seu post e o desespero do nosso amigo LoboMaL, ele chegou a elogiar o Alexandre correia dizendo que ele era o Gandalf aqui do forum... eu criei esse tutorial agora pouco, e garanto que esta funcionando, pois eu utilizo a versão 3.30 e aqui ficou bacana mesmo espero que te ajude, com sinceridade não sei te explicar todas as regras mas te garanto que funciona o cache sim... ele vai a full ou na velocidade determinada por você segue abaixo o link espero que te ajude, um forte abraço

    https://under-linux.org/f211/tutoria...3-30-a-142823/
    caro amigo, muito obrigado, vou testar hj e logo posto o resultado.



  11. #11

    Padrão Re: Mais um que nao consegue fazer cache full

    Citação Postado originalmente por wanderley85 Ver Post
    Amigo Jeferson eu vi seu post e o desespero do nosso amigo LoboMaL, ele chegou a elogiar o Alexandre correia dizendo que ele era o Gandalf aqui do forum... eu criei esse tutorial agora pouco, e garanto que esta funcionando, pois eu utilizo a versão 3.30 e aqui ficou bacana mesmo espero que te ajude, com sinceridade não sei te explicar todas as regras mas te garanto que funciona o cache sim... ele vai a full ou na velocidade determinada por você segue abaixo o link espero que te ajude, um forte abraço

    https://under-linux.org/f211/tutoria...3-30-a-142823/
    caro amigo, ate consegui fazer as regras com elas marcando os pacotes, baixando um arquivo de 15MB ele ficou salvo no cache entao presumo q ate ai fico tudo blz, mais na hr de baixar a realidade eh outra, tava baixando com velocidade baixa, ou com a propria limitação do profile utilizado, ta parecendo que vc nao usa hotspot certo? a grande dificuldade esta ai, fazer o cliente baixar rapido um arquivo usando sua conexão limitada do hotspot, de quaquer forma muito obrigado pelas regras, dicas e pela boa vontade em ajudar.

  12. #12

    Padrão Re: Mais um que nao consegue fazer cache full

    Citação Postado originalmente por alexandrecorrea Ver Post
    o video do cache-full explica passo-a-passo !! nao tem como fazer mais detalhado :P
    esse video é do cache full em mk 3.x com hotspot? se for me mande o link por favor.



  13. #13

    Padrão Re: Mais um que nao consegue fazer cache full

    Putz amigão sinto muito mas eu não uso hotspot, desculpa mesmo, como sou 100% novato em MikroTik e ainda venho Migrando do BrazilFW, só tentei ajudar... alias eu nem sabia que se eu usar o Hotspot bagunça tudo...

    aaaaa o link que nosso amigo moderador estava te falando é esse aqui mas creio que não vai te ajudar em nada afinal... é da versão 2.x nas se vc tiver paciencia e conseguir migrar para o 3.x, boa sorte e um forte abraço

    https://under-linux.org/f211/cache-f...emplos-102203/

  14. #14

    Padrão Re: Mais um que nao consegue fazer cache full

    Citação Postado originalmente por wanderley85 Ver Post
    Putz amigão sinto muito mas eu não uso hotspot, desculpa mesmo, como sou 100% novato em MikroTik e ainda venho Migrando do BrazilFW, só tentei ajudar... alias eu nem sabia que se eu usar o Hotspot bagunça tudo...

    aaaaa o link que nosso amigo moderador estava te falando é esse aqui mas creio que não vai te ajudar em nada afinal... é da versão 2.x nas se vc tiver paciencia e conseguir migrar para o 3.x, boa sorte e um forte abraço

    https://under-linux.org/f211/cache-f...emplos-102203/

    sem problema, muito obrigado por tentar me ajudar, acho q tem alguns caras que sabem fazer essa configuração, mais nao explicam aki no forum, eles devem querer cobrar para tal serviço, to desistindo de cache em 3.x com hotspot, acho q vou monter um servidor separado só para cache, de qualquer forma agradeço muito pela ajuda, abraços



  15. #15

    Padrão Re: Mais um que nao consegue fazer cache full

    Olha ai o bolo já pronto:


    So seguir o tutorial que vai dar certo!