+ Responder ao Tópico



  1. #1

    Padrão Problema com hotspot no mikrotik 3.30 rb 433

    Boa tarde !!

    Pessoal,

    Estou tendo problema em relação a resolução de nomes no mk 3.30,a tela de autenticação não aparece quando eu abro o navegador,no entanto se eu digitar o endereço ip do servidor a tela aparece.Alguém poderia me ajudar ?
    Agradeço desde já.

    Segue abaixo as configurações do hotspot

    /ip hotspot profile
    set default dns-name="" hotspot-address=0.0.0.0 html-directory=hotspot \
    http-cookie-lifetime=3d http-proxy=0.0.0.0:0 login-by=cookie,http-chap \
    name=default rate-limit="" smtp-server=0.0.0.0 split-user-domain=no \
    use-radius=no
    add dns-name=www.linkconnection.com.br hotspot-address=10.1.1.1 \
    html-directory=hotspot http-proxy=0.0.0.0:0 login-by=\
    http-chap,https,http-pap name=hsprof1 rate-limit="" smtp-server=0.0.0.0 \
    split-user-domain=no ssl-certificate=none use-radius=no
    /ip hotspot
    add address-pool=dhcp_cliente addresses-per-mac=1 disabled=no idle-timeout=5m \
    interface=Rede_Cliente keepalive-timeout=none name=hotspot1 profile=\
    hsprof1
    /ip hotspot user profile
    set default idle-timeout=none keepalive-timeout=2m name=default shared-users=\
    1 status-autorefresh=1m transparent-proxy=no
    /ip hotspot service-port
    set ftp disabled=no ports=21
    /ip hotspot user
    add comment="" disabled=no name=Gerson password=geu1985 profile=default

  2. #2

    Padrão Re: Problema com hotspot no mikrotik 3.30 rb 433

    add dns-name=www.linkconnection.com.br

    Sugestão: add dns-name=linkconnection.com.br



  3. #3

    Padrão Re: Problema com hotspot no mikrotik 3.30 rb 433

    O Correto e fazer como o amigo acima sugeriu.
    Veja se da certo e poste aqui....

  4. #4

    Padrão Re: Problema com hotspot no mikrotik 3.30 rb 433

    Bom dia !

    Roberto,
    Fiz a alteração comforme você mencionou,no entanto o problema pesiste.



  5. #5

    Padrão Re: Problema com hotspot no mikrotik 3.30 rb 433

    Seguinte então, me diga como está sua configuração de DNS.
    Vá na Aba DNS e faça assim:
    1 - Clique no "+" E na janela New DNS Static Entry digite:
    Name: linkconnection.com.br
    Adress: o IP do seu MK (aki uso assim)
    TTL: deixe como está e dê OK.

    2 - Na janela DNS clique em SETTINGS:
    Primary DNS e Secondary DNS: digite servidores DNS válidos: 8.8.8.8 por exemplo, isso vc vê com o seu provedor de Link.
    Marque a opção Allow Remote Requests
    (creio eu que seja apenas essa opção faltando)
    O restante deixe como está.

    Feito isso seu DNS tem que funcionar amigo.

    Qualquer coisa avise por aki.

  6. #6

    Padrão Re: Problema com hotspot no mikrotik 3.30 rb 433

    Bom dia !
    Roberto,

    As minhas configurações de dns estavam dessa forma,mesmo assim eu refiz e infelizmente o problema pesistiu

    Segue abaixo as configurações atuais do dns

    /ip dns
    set allow-remote-requests=yes cache-max-ttl=lw cache-size= 2048kib \
    max-udp-packet-size=512 primary-dns= 200.165.132.155 secondary-dns=200.149.55.142
    /ip dns static
    add address=10.1.1.1 disabled=no name=linkconnection.com.br ttl=1d



  7. #7

    Padrão Re: Problema com hotspot no mikrotik 3.30 rb 433

    Roberto,

    Depois q eu realizei as configurações referente ao dns conforme você postou, eu consigo acessar a página de autenticação do hotspot se eu digitar o endereço ip do mikrotik no navegador ou digitando o nome da url associada (http://linkconnection.com.br),no entanto a tela de autenticação não aparece automaticamente ao abrir o navegador.

  8. #8

    Padrão Re: Problema com hotspot no mikrotik 3.30 rb 433

    Então falta alguma coisa no hotspot, dê cois cliques no seu hotspot, na aba SERVERS, e veja lá em baixo se aparece em Ip of DNS name, o ip do seu MK.



  9. #9

    Padrão Re: Problema com hotspot no mikrotik 3.30 rb 433

    O endereço ip do mikrotik tá na aba server do hotspot,conforme a configuração exportada no tópico,já refiz a configuração toda......o pppoe client conecta,a bridgge funcionando,consigo pingar em endereços externos,mais só consigo acessar a tela de autenticação do hotspot se eu digitar o ip do mikrotik ou o endereço no navegador

  10. #10

    Padrão Re: Problema com hotspot no mikrotik 3.30 rb 433

    add dns-name=www.linkconnection.com.br ainda tá assim?



  11. #11

    Padrão Re: Problema com hotspot no mikrotik 3.30 rb 433

    Boa noite !

    Roberto,

    Mudei conforme sua sugestão. add dns-name=linkconnection.com.br,no entanto o problema pesiste.Só consigo acessar a tela de autenticação do hotspot se digitar o ip do mikrotik ou o endereço dns name na barra de endereço do navegador.

    Agradeço desde já a sua atenção

  12. #12

    Padrão Re: Problema com hotspot no mikrotik 3.30 rb 433

    Tá estranho isso, pq aki uso o 3.25 e não tenho problemas, você consegue pingar para algum site usando o terminal?



  13. #13

    Padrão Re: Problema com hotspot no mikrotik 3.30 rb 433

    Amigo, faça o seguinte teste.

    Se vc ja estiver autenticado, remova da tabela hosts, cookies o usuario.

    Depois tente abrir a pagina da internet, se ele não abrir vá em IP>Address e desative o IP referente a este usuario e ative-o novamente.

    veja se desta forma ele consegue carregar a pagina de autenticação.

  14. #14

    Padrão Re: Problema com hotspot no mikrotik 3.30 rb 433

    Se vc estiver utilizando algum hotspot personalizado, tenta habilitar a opção "http-pap" no profile que vc esta usando.

    Ficando as duas: "http-chap" e "http-pap".

    Caso contrario, deixa só: "http-chap"

    Desabilita o "HTTPS".
    Última edição por soloneto; 14-02-2011 às 11:46. Razão: Incluir informação



  15. #15

    Padrão Re: Problema com hotspot no mikrotik 3.30 rb 433

    Bom dia !

    Roberto,

    Sim.A conexão pppoe client funciona normalmente e eu consigo pingar em site externos.O único problema e a tela de autenticação do hotspot que não aparece ao automaticamente ao abrir o navegador

  16. #16

    Padrão Re: Problema com hotspot no mikrotik 3.30 rb 433

    Sobre o "add dns-name=www.linkconnection.com.br", tenho uma rb433ah configurada dessa forma e funciona normal com o www na frente.



  17. #17

    Padrão Re: Problema com hotspot no mikrotik 3.30 rb 433

    Citação Postado originalmente por soloneto Ver Post
    Sobre o "add dns-name=www.linkconnection.com.br", tenho uma rb433ah configurada dessa forma e funciona normal com o www na frente.
    Funcionar funciona, mais caso você coloque um endereço válido como o site da sua empresa, seus clientes podem ter problema ao tentar acessar essa pagina, por ela estar apontando para o endereço do seu hotspot.

    coloque login.seusite.com.br que não tem erro.

  18. #18

    Padrão Re: Problema com hotspot no mikrotik 3.30 rb 433

    Bom dia !

    Soloneto,

    Fiz as modificações conforme propostoo,no entanto o problema pesiste.Você teria alguma outra sujestão ?



  19. #19

    Padrão Re: Problema com hotspot no mikrotik 3.30 rb 433

    Bom dia !

    Gustavinho,

    Realizei os testes conforme foi proposto no tópico acima,no entantao o problema pesiste.Você teria alguma outra sujestão ?

    Agradeço desde já a sua atenção.

  20. #20

    Padrão Re: Problema com hotspot no mikrotik 3.30 rb 433

    Citação Postado originalmente por gerson25 Ver Post
    Bom dia !

    Gustavinho,

    Realizei os testes conforme foi proposto no tópico acima,no entantao o problema pesiste.Você teria alguma outra sujestão ?

    Agradeço desde já a sua atenção.
    Tente trocar o IP deste usuario para um outro que ainda não tenha registrado no sistema e veja se funciona.