+ Responder ao Tópico



  1. #1

    Padrão VPN para unir duas Redes Matriz Filial!

    Olá galera Under, estou com um problema alguns dias e não estou conseguindo resolver, sobre VPN não sei se este e a melhor opção mais é o que estou tentando, tenho duas redes e quero que os computadores dá mesmas se comuniquem como se estivesse em uma intranet. vou explicar melhor!
    tenho Intenet ADSL na Cidade 1 Filial.
    modem bridge RB sai com hotspot para os clientes 192.168.1.1/24

    preciso que os computadores da cidade B com modem Roteado ligado em uma rb que distribui ips via DHCP 192.168.2.1/24 se comuniquem com a rede 1 ma matriz

    é o seguinte quero todos os computadores da filial se comuniquem com os da matriz somente sem precisar senha nada só para trocar informações msm exemplo; eu tenho um servidor de controle de estoque quero que as duas utilizem o msm servidor eu tbm tenho 2 ATAs quer liga-los para não pagar interurbano no VPN uma vez que meus ips não são fixo. como mostra a imagem abaixo.
    Clique na imagem para uma versão maior

Nome:	         VPN.jpg
Visualizações:	411
Tamanho: 	31,2 KB
ID:      	20161

  2. #2

    Padrão Re: VPN para unir duas Redes Matriz Filial!

    Amigo caso tenha como utilizar duas RB´s uma na matriz e outra na filial poderá configurar com facilidade um tunelamento EOIP, como não sou expert nisso não saberei informar a configuração, mas ví um video tutorial do MUM que fizeram e não demorou 3 minutos para fechar o tunel, além de ser nativo do mikrotik e poder compartilhar o enlace com outro serviço até....



  3. #3

    Padrão Re: VPN para unir duas Redes Matriz Filial!

    vlw pela dica amtigo

  4. #4

    Padrão Re: VPN para unir duas Redes Matriz Filial!

    Necessariamente não precisa ser EOIP...

    Me corrige se eu estiver errado. A rede1 é 192.168.1.0/24, sendo que o gateway é o Mikrotik como 192.168.1.1... Já a rede 2 192.168.2.0/24, Mikrotik 192.168.2.1.

    Ambos estes Mikrotiks tem IPs públicos e se falam apenas pela Internet?



  5. #5

    Padrão Re: VPN para unir duas Redes Matriz Filial!

    Citação Postado originalmente por mtrojahn Ver Post
    Necessariamente não precisa ser EOIP...

    Me corrige se eu estiver errado. A rede1 é 192.168.1.0/24, sendo que o gateway é o Mikrotik como 192.168.1.1... Já a rede 2 192.168.2.0/24, Mikrotik 192.168.2.1.

    Ambos estes Mikrotiks tem IPs públicos e se falam apenas pela Internet?
    perfeitamente, só se comunicam pela Internet por isso que quero criar uma espécie de túnel para que eles façam parte da msm rede porem pela internet

  6. #6

    Padrão Re: VPN para unir duas Redes Matriz Filial!

    eu pretendo ligar todos os computadores como se estivessem em uma Intranet lembrando que meu ip não é fixo disponho de 2 ADSL!



  7. #7

    Padrão Re: VPN para unir duas Redes Matriz Filial!

    Você vai querer utilizar compartilhamentos Windows? Pergunto porque as redes estão em classes distintas no seu desenho.

    O protocolo utilizado vai muito do uso final... Se você precisa de compartilhamento de arquivos windows, realmente EOIP e L2TP são mais indicados... L2TP seria minha escolha pela facilidade de se criptografar a comunicação e deixar tudo mais seguro.

    Eu faria tudo roteado. Evitando tráfego desnecessário. Usaria PPTP.

    Eu posso te dar exemplos 2 dois casos... Tenho coisas aqui funcionando das 2 formas (L2TP e PPTP)... Me diz ai o que tu precisa que eu posso dar um export rápido aqui na configuração para vc dar uma olhada.

  8. #8

    Padrão Re: VPN para unir duas Redes Matriz Filial!

    blz eu preciso pra troca de informações windows e principalmente fazer com que dois ATA´s se falem como em uma intranet pra que eu não precise pagar interurbano de uma cidade pra outra. gostaria sim dos seus exemplos



  9. #9

    Padrão Re: VPN para unir duas Redes Matriz Filial!

    Ok... L2TP.

    A idéia do L2TP é ligar 2 bridges através da Internet. Então o que você vai precisar, pra iniciar, é que a interface interna de ambos os Mikrotiks seja uma bridge. Se os IPs 192.168.x.x dos Mikrotiks estiverem em uma interface comum, crie uma bridge em ambos, coloque apenas estas interfaces na bridge e mude o IP para a bridge.

    Servidor:
    Código :
    # cria um profile que vai adicionar a conexao l2tp a bridge (assume o nome da bridge bridge1)
    /ppp profile add bridge=bridge1 local-address=172.16.10.1 name=profile-l2tp
    # cria o servidor l2tp
    /interface l2tp-server set authentication=mschap2 default-profile=profile-l2tp enabled=yes max-mru=1440 max-mtu=1440 mrru=1700
    # cria um usuario
    /ppp secret add name=teste password=123abc profile=profile-l2tp service=l2tp remote-address=172.16.0.2

    Cliente
    Código :
    # cria o profile que adiciona a conexao na bridge
    /ppp profile add bridge=bridge1 name=profile-l2tp
    # cria o cliente l2tp
    /interface l2tp-client allow=mschap2 connect-to=IP-PUBLICO-DO-SERVIDOR max-mru=1460 max-mtu=1460 mrru=1700 name=l2tp-out1 password=abc123 profile=profile-l2tp user=teste

    Se tudo ocorrer certo, o que você vai ver são 2 interfaces virtuais que são criadas nos 2 Mikrotiks quando o L2TP está conectado... Estas interfaces são automaticamente adicionadas nas bridges internas de ambos os Mikrotiks e isto "liga" as bridges dos dois locais tornando possível uma máquina de um lado "pingar" e outra diretamente, sem roteamento necessário...

    Claro que pra isto funcionar, ambos os lados deveriam estar com na mesma rede e máscara...

    Não se esqueça também que com esta configuração as redes estão literalmente ligadas... Ou seja, o tráfego de uma vaza pra outra... Seu DHCP server, por exemplo, vai começar a fornecer IPs para o outro lado também
    Última edição por mtrojahn; 28-02-2011 às 16:56. Razão: mais informacoes.

  10. #10

    Padrão Re: VPN para unir duas Redes Matriz Filial!

    Citação Postado originalmente por mtrojahn Ver Post
    Ok... L2TP.

    A idéia do L2TP é ligar 2 bridges através da Internet. Então o que você vai precisar, pra iniciar, é que a interface interna de ambos os Mikrotiks seja uma bridge. Se os IPs 192.168.x.x dos Mikrotiks estiverem em uma interface comum, crie uma bridge em ambos, coloque apenas estas interfaces na bridge e mude o IP para a bridge.

    Servidor:
    Código :
    # cria um profile que vai adicionar a conexao l2tp a bridge (assume o nome da bridge bridge1)
    /ppp profile add bridge=bridge1 local-address=172.16.10.1 name=profile-l2tp
    # cria o servidor l2tp
    /interface l2tp-server set authentication=mschap2 default-profile=profile-l2tp enabled=yes max-mru=1440 max-mtu=1440 mrru=1700
    # cria um usuario
    /ppp secret add name=teste password=123abc profile=profile-l2tp service=l2tp remote-address=172.16.0.2

    Cliente
    Código :
    # cria o profile que adiciona a conexao na bridge
    /ppp profile add bridge=bridge1 name=profile-l2tp
    # cria o cliente l2tp
    /interface l2tp-client allow=mschap2 connect-to=IP-PUBLICO-DO-SERVIDOR max-mru=1460 max-mtu=1460 mrru=1700 name=l2tp-out1 password=abc123 profile=profile-l2tp user=teste

    Se tudo ocorrer certo, o que você vai ver são 2 interfaces virtuais que são criadas nos 2 Mikrotiks quando o L2TP está conectado... Estas interfaces são automaticamente adicionadas nas bridges internas de ambos os Mikrotiks e isto "liga" as bridges dos dois locais tornando possível uma máquina de um lado "pingar" e outra diretamente, sem roteamento necessário...

    Claro que pra isto funcionar, ambos os lados deveriam estar com na mesma rede e máscara...

    Não se esqueça também que com esta configuração as redes estão literalmente ligadas... Ou seja, o tráfego de uma vaza pra outra... Seu DHCP server, por exemplo, vai começar a fornecer IPs para o outro lado também
    blz intão, vlw pela dica vou tentar aki pra ver no que dá e depois posto o resultado



  11. #11

    Padrão Re: VPN para unir duas Redes Matriz Filial!

    amigo parece que esta funcionando mais ainda não consigo trocar informações com os outros pcs
    quando eu do um click em PPP/active Connections mostra que esta conectado, porem quando eu clico no winbox pra tentar ver as outras rbs não dá quando eu coloco meu pc para pingar nos outros pcs tbm não dá. o que pode ser isso?

  12. #12

    Padrão Re: VPN para unir duas Redes Matriz Filial!

    Bom, considerando o teu desenho... Se as máquinas realmente estiverem com rede/máscara diferente, não vai pingar...

    Faz um teste e coloca uma máquina de um lado com 192.168.100.1/24 e outra no com 192.168.100.2/24... Deveria pingar neste caso.

    Se não pingar, verifica se nos 2 lados, em Bridge, se as portas dinâmicas do L2TP estão incluídas na bridge.



  13. #13

    Padrão Re: VPN para unir duas Redes Matriz Filial!

    Citação Postado originalmente por mtrojahn Ver Post
    Bom, considerando o teu desenho... Se as máquinas realmente estiverem com rede/máscara diferente, não vai pingar...

    Faz um teste e coloca uma máquina de um lado com 192.168.100.1/24 e outra no com 192.168.100.2/24... Deveria pingar neste caso.

    Se não pingar, verifica se nos 2 lados, em Bridge, se as portas dinâmicas do L2TP estão incluídas na bridge.
    vlw marcelus pela dica deu certinho ganho minha estrelinha mais uma vez abraço precisando e estando ao meu alcanse terei o maior prazer em ajudalo..

  14. #14

    Padrão Re: VPN para unir duas Redes Matriz Filial!

    Mais um satisfeito!!!



  15. #15

    Padrão Re: VPN para unir duas Redes Matriz Filial!

    Conseguir fechar a VPN, até pingo o equipamentos da filial, mas não consigo abrir eles via navegador. O que pode ser?

  16. #16

    Padrão Re: VPN para unir duas Redes Matriz Filial!

    Citação Postado originalmente por mtrojahn Ver Post
    Bom, considerando o teu desenho... Se as máquinas realmente estiverem com rede/máscara diferente, não vai pingar...

    Faz um teste e coloca uma máquina de um lado com 192.168.100.1/24 e outra no com 192.168.100.2/24... Deveria pingar neste caso.

    Se não pingar, verifica se nos 2 lados, em Bridge, se as portas dinâmicas do L2TP estão incluídas na bridge.
    Primeiramente parabens pelo post, gostaria de uma sugestão sua no mesmo segmento de "Ligar" 2 redes, vou te colocar o que eu preciso e o que tenho...
    TENHO HOJE:
    matriz pc mikrotik faixa 192.168.0.1
    filial rb mimkotik faixa 192.168.1.1
    filial rb mikrotik faixa 192.168.2.1
    filial rb mikrotik faixa 192.168.0.1(unica filial na mesma faixa da matriz)
    *as maquinas nas 4 lojas tem ip fixo(intranet)
    *cada loja tem seu ip VALIDO/fixo(internet)
    *nao gostaria ter que colocar todas as lojas na mesma faixa de ip(intranet) pois tenho varios apontamentos dentro de cada rede/loja
    PRECISO "INTERLIGAR" as 4 lojas PARA:
    Compartilhar um software ERP( que soh funciona em intranet )
    Utilizar um programa de acesso remoto que soh funciona na intranet
    Acessar um DVR da GIGA( nao quero acessar via internet(diretamente)quero apenas dia intranet
    Talves compartilhar alguams impressoras e diretorios
    o que vc sugere ?