Página 4 de 4 PrimeiroPrimeiro 1234
+ Responder ao Tópico



  1. Citação Postado originalmente por ipunet Ver Post
    Vc desmarcou "Defaut Authenticate" ? No meu funciona ! adiciono apenas um usuário com o mac 00:00:00:00:00:00 e desmarco o "Defaut Authenticate", somente.
    No meu caso nao queria que aceitasse somente os cadastrados, queria que aceitasse todos que tenha um sinal razuavel

  2. Conseguiu?



  3. Oi pessoal, seguinte, tinha o mesmo problema de vocês, e não achava a solução na internet!
    Então sentei e criei esse script, que dropa os clientes com sinal abaixo do definido, espero que ajude vocês, aki salvou a lavoura.

    #Script Sinal Check
    #
    #Lista as estacoes que estao com Sinal Abaixo do limite com opcao para desconecta-las
    #
    # Autor: André Ximenes De Melo Junior (aximenes10@hotmail.com)
    #
    #Instrucoes de uso:
    # -- Adicionar o codigo completo em SYSTEM >> SCRIPTS
    # -- Por padrao o script nao vai derrubar nenhuma estacao, rode o script padrao antes de
    # configurar a variavel cut para 1, tendo certeza que o script esta OK.
    # -- O script pode ser executado pelo botao "run script" ou via linha de comando.
    # "/ system script run <nome do script>
    # -- O script so funciona em interfaces que o modo de operacao seja AP-BRIDGE
    # -- crie uma regra no Scheduler para auomatizar o uso
    # -- Testado na versão 6.33
    #
    #Informacoes:
    #
    #Variavel Smax -> deve ter o valor do Signal MAXIMO permitido.
    #Variavel cut -> deve ser 0 ou 1, 0 somente mostra, 1 mostra e desconecta a estacao.
    #Script Sinal Check
    #
    #Lista as estacoes que estao com Sinal acima do limite com opcao para desconecta-las
    #
    # Autor: André Ximenes De Melo Junior (aximenes10@hotmail.com)
    #
    #Instrucoes de uso:
    # -- Adicionar o codigo completo em SYSTEM >> SCRIPTS
    # -- Por padrao o script nao vai derrubar nenhuma estacao, rode o script padrao antes de
    # configurar a variavel cut para 1, tendo certeza que o script esta OK.
    # -- O script pode ser executado pelo botao "run script" ou via linha de comando.
    # "/ system script run <nome do script>
    # -- O script so funciona em interfaces que o modo de operacao seja AP-BRIDGE
    # -- crie uma regra no Scheduler para auomatizar o uso
    # -- Testado na versão 6.33
    #
    #Informacoes:
    #
    #Variavel Smax -> deve ter o valor do Signal MAXIMO permitido.
    #Variavel cut -> deve ser 0 ou 1, 0 somente mostra, 1 mostra e desconecta a estacao.
    ##################################################################
    #Configuracoes das variaveis valor do sinal sem o ( - )
    :local Smax 70;
    :local cut 1;

    ############ Script - NAO ALTERAR #####################################
    :local mac "";
    :local Smed "";
    :local removido "";
    :local Slimp "";
    :log warning ("[Sinal Check] Procurando clientes com Sinal Menor que " . $Smax);
    :foreach i in=[ / interface wireless find mode="ap-bridge" running] do={
    :local intname [ / interface wireless get $i name ];
    :log warning (" Interface: " . $intname);
    :foreach x in=[/interface wireless registration-table find interface=$intname] do={
    :set Smed [/interface wireless registration-table get value-name=signal-strength number=$x];
    :set Slimp [ick $Smed 1 3]
    #:log warning ("SINAL " . $Slimp);
    :set removido "";
    :if ($Slimp > $Smax) do={
    :set mac [ / interface wireless registration-table get $x mac-address];
    :if ($cut = 1) do= {
    :set removido " removido...";
    / interface wireless registration-table remove $x;
    };
    :log warning (" mac: " . $mac . "@" . $intname . " [" . $Smed . "]" . $removido);
    };
    };
    };
    ############ FIM #####################################
    Coloque isto numa regra dentro de Scripts e faça o scheduler a cada 30 segundos ou o tempo que quiser...






Tópicos Similares

  1. Cliente com sinal bom e ping ruim.
    Por ChrisKs4 no fórum Servidores de Rede
    Respostas: 6
    Último Post: 12-02-2014, 12:29
  2. Respostas: 19
    Último Post: 19-03-2012, 09:36
  3. Respostas: 8
    Último Post: 28-11-2011, 09:58
  4. Respostas: 13
    Último Post: 14-05-2011, 08:24
  5. Respostas: 3
    Último Post: 18-11-2007, 23:26

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L