+ Responder ao Tópico



  1. Olá pessoal, estou com um problema.

    Tenho os seguinte script.
    Código :
    :global mailde ["eumesmo@hotmail.com"];
    :global mailpara ["eumesmo@hotmail.com"];
    :global ipserver [:resolve "smtp.live.com"];
    :foreach h in=[/ip hotspot user find] do={
     
    :local user [/ip hotspot user get $h name]; 
    :local data [system clock get date]
    :local info "FAZENDO BACKUP DE CADASTROS DE USUARIOS"
     
    /tool e-mail send to=$mailpara subject="Backup de cadastros - Dia $data" file="hotspot/cadastro/$user.txt" body="BACKUP DE CADASTRO - DIA $data"
    :delay 15s
    :log info "BACKUP DE CADASTROS DE USUARIOS CONCLUIDO"
    }

    Acontece que o $user se refere a um arquivo com os dados do cliente (1 arquivo pra cada cliente) lá na pasta CADASTRO.
    Quando vou enviar o backup do cadastro do cliente, o mk envia um de cada vez (1 email pra cada arquivo).

    Teria como fazer um loop buscando todos os nomes dos clientes e pegar todos os arquivos de cadastro e enviar em um só email ? alguem ai sabe fazer isso ?

    Motivos: quando chega a 15 emails enviados com curto espaço de tempo pro mesmo email, o hotmail trava e pede pra digitar letra pra confirmar o cadastro. Outro motivo seria pra deixar tudo juntinho.. e ai teria apenas o titulo "Backup de cadastros - Dia $data".


    Só lembrando ... falta pouco pra pagina de hotspot inteligente ficar pronta.. só estou ajustando esses detalhes... pra quem ainda não viu.. aqui esta uma previa...



    mas ja houve mais evoluções e pretendo lançar ainda essa quinzena..

    Abraços... e desde já agradeço a quem puder ajudar.
    Última edição por h3lyo; 04-08-2011 às 13:45.

  2. Retirado o arquivo a pedido do autor.
    Última edição por peritinaicos; 22-11-2011 às 11:25.



  3. >>> Brincadeira HEM..>>






Tópicos Similares

  1. Ideia de backup de HDs com comando dd
    Por guilhermeibc no fórum Servidores de Rede
    Respostas: 10
    Último Post: 13-12-2006, 10:48
  2. Script de backup de usuarios, ascentos linux
    Por L3C4 no fórum Servidores de Rede
    Respostas: 0
    Último Post: 26-04-2006, 08:34
  3. Enviar emails na linha de comando?
    Por aprendiz_ce no fórum Servidores de Rede
    Respostas: 11
    Último Post: 11-04-2006, 09:19
  4. Mandar log de backup por email
    Por Bolinhazin no fórum Servidores de Rede
    Respostas: 3
    Último Post: 12-06-2005, 15:17
  5. Respostas: 10
    Último Post: 08-09-2004, 11:07

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L