+ Responder ao Tópico



  1. #1

    Padrão PULSEAUDIO como root

    Boa tarde!

    Gostaria de rodar o PulseAudio como root no Ubuntu mas, não estou conseguindo, alguém tem uma dica?

    Abs.;

    Saída do Comando:

    [email protected]:~# pulseaudio
    W: main.c: This program is not intended to be run as root (unless --system is specified).
    E: pid.c: Daemon already running.
    E: main.c: pa_pid_file_create() failed.
    [email protected]:~#

    Abs.;

  2. #2

    Padrão Re: PULSEAUDIO como root

    Citação Postado originalmente por tristan Ver Post
    Boa tarde!

    Gostaria de rodar o PulseAudio como root no Ubuntu mas, não estou conseguindo, alguém tem uma dica?

    Abs.;

    Saída do Comando:

    Código :
    [email protected]:~# pulseaudio
    W: main.c: This program is not intended to be run as root (unless --system is specified).
    E: pid.c: Daemon already running.
    E: main.c: pa_pid_file_create() failed.
    [email protected]:~#

    Abs.;
    Boa tarde.

    Que resultado você obtém com o comando abaixo?

    Código :
    /usr/bin/pulseaudio --start
    Saudações,

    Trober
    -
    -
    -
    -
    -



  3. #3

    Padrão Re: PULSEAUDIO como root

    exatamente a mesma mensagem de erro...

  4. #4

    Padrão Re: PULSEAUDIO como root

    Bom dia!

    Consegui configurar o áudio normalmente aqui sem necessitar do Pulseaudio.

    Muito obrigado pelas dicas.



  5. #5

    Padrão Re: PULSEAUDIO como root

    Bom dia!

    Que boa notícia.

    Compartilha conosco, para fins de histórico e referência futura, sua solução.

    Saudações,

    Trober
    -
    -
    -
    -
    -

  6. #6

    Padrão Re: PULSEAUDIO como root

    Opa!!

    Na verdade a solução foi bem simples:

    1 - Verifiquei pelo comando lsmod quais drivers haviam subido com o sistema:

    # lsmod
    Module Size Used by
    vmnet 41544 15
    vmblock 10946 1
    vsock 37874 0
    vmci 54019 2 vsock
    vmmon 63366 6
    snd_hda_codec_realtek 248710 1
    snd_hda_intel 21661 0
    snd_hda_codec 80498 2 snd_hda_codec_realtek,snd_hda_intel
    snd_hwdep 5424 1 snd_hda_codec
    snd_pcm_oss 36427 0
    snd_mixer_oss 13581 1 snd_pcm_oss
    snd_pcm 68662 3 snd_hda_intel,snd_hda_codec,snd_pcm_oss
    snd_seq_dummy 1358 0
    ath9k_htc 48225 0
    snd_seq_oss 26216 0
    mac80211 255996 1 ath9k_htc
    snd_seq_midi 4460 0
    snd_rawmidi 18745 1 snd_seq_midi
    ath9k_common 2466 1 ath9k_htc
    ath9k_hw 305324 2 ath9k_htc,ath9k_common
    snd_seq_midi_event 5720 2 snd_seq_oss,snd_seq_midi
    snd_seq 45875 6 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_seq_midi_event
    ath 13577 2 ath9k_htc,ath9k_hw
    snd_timer 17803 2 snd_pcm,snd_seq
    snd_seq_device 5281 5 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_rawmidi,snd_seq
    cfg80211 153414 3 ath9k_htc,mac80211,ath
    snd 50697 12 snd_hda_codec_realtek,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_seq_oss,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
    soundcore 6048 1 snd
    snd_page_alloc 6801 2 snd_hda_intel,snd_pcm
    rfkill 14987 1 cfg80211
    psmouse 52655 0
    serio_raw 3744 0
    ppdev 5096 0
    lp 7373 0
    parport_pc 26143 1
    joydev 8649 0
    parport 29468 3 ppdev,lp,parport_pc
    mac_hid 3029 0
    i915 476096 2
    usbhid 35443 0
    hid 69090 1 usbhid
    drm_kms_helper 31085 1 i915
    drm 178158 3 i915,drm_kms_helper
    intel_agp 9614 1 i915
    i2c_algo_bit 4916 1 i915
    intel_gtt 13296 3 i915,intel_agp
    skge 37978 0
    agpgart 27414 3 drm,intel_agp,intel_gtt
    video 10930 1 i915
    floppy 54673 0

    2 - Setei manualmente pelo modprob (driver) um a um até achar o driver que atendesse a minha necessidade, que, no meu caso foi o seguinte :

    # modprob snd_hda_codec_realtek

    Como sou iniciante no universo Linux, creio que existam dezenas de outras maneiras pra fazer o áudio funcionar, a que encontrei foi essa!

    Abs à todos!!