+ Responder ao Tópico



  1. #1

    Padrão FreeRadius + Mysql +DaloRadius como conectar o Mikroitk Hotspot para Add Clientes

    gente e o seguinte em uma maquina eu tenho o FreeRadius + Mysql + o sistema DaloRadius Rodando certinho!!!!

    Ip dessa Maquina e 192.168.2.6/24 ate ae ok ja cadastrei alguns testes no DaloRadius e o FreeRadius Liberar ele certinho la mostrando Access-Acept ok ate ae tudo bem

    agora em outra maquina tenho o Mikrotik 3.30 com 3 Placas 1 Ether 1 = LAN, 1 Ether2 = WAN, 1 Wlan = Wireless
    o ip da rede LAN 192.168.2.1/24, WAN 192.168.2.4 que recebe a Internet e a Wlan 10.0.0.1/24

    entao gente o que eu quero fazer e criar o cliente no FreeRadiu, criar ele no Mikrotik utilizando o sistema Hotspot
    ae quero saber como faço para interligar os dois Mikrotik + FreeRadius

    assim meu cliente tera que ter o Cadastro no FreeRadius e No mikrotik hotspot para ae sim ele poder navegar na internet
    peço ajuda de todos ME AJUDEM obrigado a todos que puder me ajudar

    aguardando o sistema FreeRadius esta no Linux Ubuntu 11.10 32 bits e o mikrotik em outra maquina

    obrigado a todos

  2. #2

    Padrão Re: FreeRadius + Mysql +DaloRadius como conectar o Mikroitk Hotspot para Add Clientes

    Olá AcesseNet,

    Eu já usei o DaloRadius até fizemos personalizações nele, só encontrei alguma dificuldade com relação ao HotSpot, não por falta de parametros mas pelo excesso, tem muita coisa pra configurar e ajustar então recomendo que você siga algum tutorial e leia a documentação disponível do autor.
    Não estou diziendo que será fácil ou que vai ser rápido, mas é um sistema interessante, com ótima apresentação e ainda por cima gratuito.

    Abraço



  3. #3

    Padrão Re: FreeRadius + Mysql +DaloRadius como conectar o Mikroitk Hotspot para Add Clientes

    Ou você cadastra ele no FreeRadius ou no Mikrotik, se cadastrar em ambos ele vai se conectar no local apenas.

    Para configurar seu hotspot a autenticar no FreeRadius;
    Primeiro SET o Server Profile para autenticação no radius.
    /ip hotspot profile set hsprof1 use-radius=yes radius-mac-format=XX:XX:XX:XX:XX:XX

    E não esqueça de adicionar o serviço hotspot em seu cliente radius.
    /radius set service=ppp,hotspot,wireless numbers=0

  4. #4

    Padrão Re: FreeRadius + Mysql +DaloRadius como conectar o Mikroitk Hotspot para Add Clientes

    farias meu amigo entao para eu fazer para que o mikrotik autentique e so eu cira o radius server e coloca o ip da maquina onde estar o FreeRadius ??? so isso obrigado
    entao assim o meu cliente tera que ter um cadastro no hotspot do mikrotik e um no FreeRadius Certo
    aguardando



  5. #5

    Padrão Re: FreeRadius + Mysql +DaloRadius como conectar o Mikroitk Hotspot para Add Clientes

    Bom ai para adicionar um serviço radius faça o seguinte

    /radius add service=wireless,hotspot address=IP_DO_FREERADIUS

    Service, são os serviços que vão usar o radius para autenticação.

    No mikrotik não terá dados do cliente ou seja, o cliente deve ter seus dados de login, senha, ip todos no radius.

  6. #6

    Padrão Re: FreeRadius + Mysql +DaloRadius como conectar o Mikroitk Hotspot para Add Clientes

    ok ate ae tudo bem agora como que eu faço o controle de banda no radius estou usando o FreeRadius com Mysql e entrando nele via Web pelo DaloRadius como faço so controle da banda la quero 128k 300k e 512k ok obrigado muito por estar me ajudando



  7. #7

    Padrão Re: FreeRadius + Mysql +DaloRadius como conectar o Mikroitk Hotspot para Add Clientes

    Não sei te dizer no DaloRadius onde fazer, mas no banco do freeradius é na tabela radgroupreply.

    Um exemplo;

    SELECT * FROM radgroupreply LIMIT 7;
    +----+-----------+-------------------------+----+-----------------------------------------------------+
    | id | groupname | attribute | op | value |
    +----+-----------+-------------------------+----+-----------------------------------------------------+
    | 1 | pppoe-800 | Framed-Compression | == | Van-Jacobson-TCP-IP |
    | 2 | pppoe-800 | Framed-Protocol | == | PPP |
    | 3 | pppoe-800 | Framed-MTU | == | 1492 |
    | 4 | pppoe-800 | Service-Type | == | Framed-User |
    | 5 | pppoe-800 | Mikrotik-Rate-Limit | := | 800k/800k |
    | 6 | pppoe-800 | MS-Primary-DNS-Server | := | 8.8.8.8 |
    | 7 | pppoe-800 | MS-Secondary-DNS-Server | := | 8.8.4.4 |
    +----+-----------+-------------------------+----+-----------------------------------------------------+

  8. #8
    Analista de Suporte em TI Avatar de demattos
    Ingresso
    Jul 2011
    Localização
    Criciuma/SC
    Posts
    1.923
    Posts de Blog
    3

    Padrão Re: FreeRadius + Mysql +DaloRadius como conectar o Mikroitk Hotspot para Add Clientes

    Acompanhando o topico, por que estou em estudos para migrar tudo para genrecnia com mikrotik, atualmente uso linux, mas pretendo implantar algo melhor e mais seguro



  9. #9

    Padrão Re: FreeRadius + Mysql +DaloRadius como conectar o Mikroitk Hotspot para Add Clientes

    o farias amigo to entedendo e isso esta me ajudando bastante so que como vi ae esta sendo usando o pppoe e tipo eu quero e o hotspot por ae ae coloco um sistema de enviar boleto e tal pro cliente quero fazer um provedor bem bacana e vc ta me ajudando pakas cara muito obrigado mesmo ate agora o freeradius esta indo bem aqui eu crio o teste e ele aceita normal mais to agarrado e como fazer com que ele apenas autentique o cliente e que os dados fiquem no mikrotik seria possivel isso se nao
    como eu faço para colocar o cliente no freeradius tipo cadastrar o IP + MAC + LOGIN + SENHA e que este cliente so possa se conecta com 1 unico pc para assim evitar clone de mac ou se ele passar os dados dele que se tenha a responsabilidade com os dados dele entede obrigado mais uma vez por me ajudar