+ Responder ao Tópico



  1. #1
    SUPORTE E CONSULTORIA Avatar de Acronimo
    Ingresso
    Oct 2008
    Localização
    Rio de Janeiro - RJ
    Posts
    2.109
    Posts de Blog
    1

    Padrão PCC / Load Balance de forma rápida e fácil para iniciantes

    Vejo diversos post ótimos aqui mostrando como é um bom pcc, mas quem esta iniciando no mikrotik tem certa dificuldade de fazer como manda o tuto, então pensando nisso e a pedido de alguns colegas eu fiz um script simples porém funcional de pcc
    é bem simples, use-o como um quebra galho para entender,






    ;;;;;;;;;;Pcc com 2 links


    ;;;;;;;;;;Primeiro renomei as interfaces


    EthClientes = saida pro servidor
    EthLink1 = modem 1 em bridg
    EthLink2 = modem 2 em bridg


    ;;;;;;;;;;segundo Fazer 2 PPPOE com os nomes abaixo


    Discador1
    Discador2


    OBS: quando vc fizer os discadores você deixa marcado SÓ a OPÇÂO "ADD DEFAUT ROUTE"


    ;;;;;;;;;Treceiro fazer o nat dos discadores


    /ip firewall nat
    add action=masquerade chain=srcnat comment="MASCARAMENTO PCC" disabled=no out-interface=\
    EthLink1
    add action=masquerade chain=srcnat comment="" disabled=no out-interface=EthLink2


    ;;;;;;;;;;Adicionar um IP no Adress


    192.168.10.1


    /ip address
    add address=192.168.10.1/24 broadcast=192.168.10.255 comment="IP PCC" disabled=no \
    interface=EthClientes network=192.168.10.0




    ;;;;;;;;;;;DNS


    200.165.132.155
    200.149.55.142


    não esquece de colocar o DNS e marca o "allow remote requests...


    ;;;;;;;;;;;Mangle


    /ip firewall mangle
    add action=accept chain=prerouting comment="Sem Balance" disabled=no dst-address-list=\
    sem_balance in-interface=EthClientes


    add action=mark-connection chain=input comment="" connection-state=new disabled=no \
    in-interface=EthLink1 new-connection-mark=conn_na passthrough=yes


    add action=mark-connection chain=input comment="" connection-state=new disabled=no \
    in-interface=EthLink2 new-connection-mark=conn_nb passthrough=yes


    add action=mark-connection chain=prerouting comment="" disabled=no dst-address-type=\
    !local in-interface=EthClientes new-connection-mark=conn_ma0 passthrough=yes \
    per-connection-classifier=both-addresses:6/0


    add action=mark-connection chain=prerouting comment="" disabled=no dst-address-type=\
    !local in-interface=EthClientes new-connection-mark=conn_mb1 passthrough=yes \
    per-connection-classifier=both-addresses:6/1


    add action=mark-routing chain=prerouting comment="" connection-mark=conn_ma0 disabled=no \
    in-interface=EthClientes new-routing-mark=to_nra passthrough=no


    add action=mark-routing chain=prerouting comment="" connection-mark=conn_mb1 disabled=no \
    in-interface=EthClientes new-routing-mark=to_nrb passthrough=no


    ;;;;;;;;;;;;;;Route


    /ip route
    add comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=Discador1


    add comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=Discador1 \
    routing-mark=to_nra


    add comment="" disabled=no distance=2 dst-address=0.0.0.0/0 gateway=Discador2


    add comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=Discador2 \
    routing-mark=to_nrb






    Agora vai o PULO DO GATO


    servidor MK 3.22 configuração


    primeiro em IP Address coloca o IP


    192.168.10.2/24


    segundo vc vai lá em route e coloca essa regra


    /ip route
    add comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=\
    192.168.10.1 scope=30 target-scope=10


    não esquece de colocar o DNS e marca o "allow remote requests"

  2. #2

    Padrão Re: PCC / Load Balance de forma rápida e fácil para iniciantes

    se for 4 linhas ????



  3. #3
    Suporte em Mikrotik Avatar de Genis
    Ingresso
    Nov 2006
    Localização
    INTERIOR-SP
    Posts
    1.591

    Padrão Re: PCC / Load Balance de forma rápida e fácil para iniciantes

    bom trabalho.

  4. #4
    Avatar de Idevaldo
    Ingresso
    Aug 2011
    Localização
    Rio Verde de Mato Grosso, MS
    Posts
    89

    Padrão Re: PCC / Load Balance de forma rápida e fácil para iniciantes

    Amigo, muito bom o tutorial. Só uma dúvida, e como fica as rotas estaticas para os bancos https?



  5. #5
    SUPORTE E CONSULTORIA Avatar de Acronimo
    Ingresso
    Oct 2008
    Localização
    Rio de Janeiro - RJ
    Posts
    2.109
    Posts de Blog
    1

    Padrão Re: PCC / Load Balance de forma rápida e fácil para iniciantes

    Citação Postado originalmente por Idevaldo Ver Post
    Amigo, muito bom o tutorial. Só uma dúvida, e como fica as rotas estaticas para os bancos https?
    Amigo como disse istp é



    Amigo como disse é um básico, para quem esta começando, tem um completo aki no under que esta rotas estaticas

  6. #6
    SUPORTE E CONSULTORIA Avatar de Acronimo
    Ingresso
    Oct 2008
    Localização
    Rio de Janeiro - RJ
    Posts
    2.109
    Posts de Blog
    1

    Padrão Re: PCC / Load Balance de forma rápida e fácil para iniciantes

    Citação Postado originalmente por Genis Ver Post
    bom trabalho.
    Obrigado Amigo Genis



  7. #7
    SUPORTE E CONSULTORIA Avatar de Acronimo
    Ingresso
    Oct 2008
    Localização
    Rio de Janeiro - RJ
    Posts
    2.109
    Posts de Blog
    1

    Padrão Re: PCC / Load Balance de forma rápida e fácil para iniciantes

    amigo hoje não existe mais este negocio de rotas para bancos, isso vai de balance antigo, onde tinha mais de 10 regras so no mangle, balace hoje é enxuto, https vai e volta pelo mesmo link, o pacote ele vai sair e voltar pelo mesmo link sem saltar para a regra posterior

  8. #8

    Padrão Re: PCC / Load Balance de forma rápida e fácil para iniciantes

    uma duvida, vamos supor tenho uma rb1100, quero por da eth1-5, link, e o restante das ether vai ser saida pra clientes, antenas, cabo, algumas vlans

    ai a pergunta, no pcc balance, é obrigatorio definir uma interface de saida? ou tem como por para sair o link balanceado da ether6 em diante?



  9. #9
    SUPORTE E CONSULTORIA Avatar de Acronimo
    Ingresso
    Oct 2008
    Localização
    Rio de Janeiro - RJ
    Posts
    2.109
    Posts de Blog
    1

    Padrão Re: PCC / Load Balance de forma rápida e fácil para iniciantes

    vc coloca as portas em uma bridge e seta ip na bridge, e na maquina que vc deseja, vc seta o gateway do balance

  10. #10

    Padrão Re: PCC / Load Balance de forma rápida e fácil para iniciantes

    poderia mandar um print com o exemplo?



  11. #11
    Suporte em Mikrotik Avatar de Genis
    Ingresso
    Nov 2006
    Localização
    INTERIOR-SP
    Posts
    1.591

    Padrão Re: PCC / Load Balance de forma rápida e fácil para iniciantes

    Citação Postado originalmente por brunobelas Ver Post
    poderia mandar um print com o exemplo?

    como assim? o script esta ai no inicio da pagina!

  12. #12
    SUPORTE E CONSULTORIA Avatar de Acronimo
    Ingresso
    Oct 2008
    Localização
    Rio de Janeiro - RJ
    Posts
    2.109
    Posts de Blog
    1

    Padrão Re: PCC / Load Balance de forma rápida e fácil para iniciantes

    Não amigo, não mandamos script, ou vc aprende pelo wiki mikrotik, ou no treinamento mtcna, ou contrata um técnico, (desculpe nao soou nada a favor de nada mastigado