+ Responder ao Tópico



  1. #1

    Padrão Cache Aumenta muito o Ping,do teste de velocidade

    Save salve rapaziada do under!!!
    seguinte,to com um pobleminha aki,no provedor que trabalho,usamos o mikrotik 3.30,com pppoe oq esta acontecendo
    é que configurei o cache-full no mk mesmo,ele é totalmente funcional,funciona mesmo,para vcs terem uma ideia encehmos um hd de 40 gb em 4 dias e isso por que ,temos 120 clientes,ontem montamos uma nova maquina,core2quad dois hds um de 160 pro sistema e outro de 1tera so pro cache 2gb de memoria ddrIII,emfim ta rodando perfeito,ao não ser por uma coisa,quando abilito o cache sobe o ping no teste de velocida,aki eu uso um link da gvt de 15 megas com uma media de 300 k por cliente,mais quando dou o ping pelo cmd o ping dos sites é normal,alguem poderia me ajudar?



    mais uma vez agradeço a força e a informação que todos do forum sempre tem repassado

  2. #2

    Padrão Re: Cache Aumenta muito o Ping,do teste de velocidade

    rapaz, peguei uma rb 450g, e monde um squid, pra vc q c vai viver feliz com a vida , e so alegria ...



  3. #3

    Padrão Re: Cache Aumenta muito o Ping,do teste de velocidade

    obrigado pela dica,não sou muito,fã de cache,prefiro trabalhar com sobra de link,mais nesse caso achei interessante,a funcionalidade,das configurações,por isso adotei,mais em nossa região o consumo é muito grande,trabalho com dois provedores,no outro não usamos nenhum cache apenas um link,de fibra,oq acelera a navegação é,um configuraçao no firewall com qos e l7.minha duvida era em cima da configuração vou postar ela

  4. #4

    Padrão Re: Cache Aumenta muito o Ping,do teste de velocidade

    essas regas peguei no youtube,não sei ao certo de que é a aoutoria,por então não vou colocar creditos





    /////////////////////////////////////////////////////////////////////////////////////




    /queue tree
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=5M \
    max-limit=5M name="2 - CACHE-FULL" packet-mark=proxyfull parent=\
    global-out priority=1 queue=default




    ////////////////////////////////////////////////////////////////////////////////////




    /ip firewall mangle
    add action=mark-connection chain=output comment="2-PROXY FULL" disabled=no \
    dscp=4 new-connection-mark=proxyfull passthrough=yes protocol=tcp src-port=\
    8080
    add action=mark-packet chain=output comment="" connection-mark=proxyfull \
    disabled=no new-packet-mark=proxyfull passthrough=yes
    add action=return chain=output comment="" connection-mark=proxyfull disabled=no






    /////////////////////////////////////////////////////////////////////////////////////




    /ip firewall nat
    add action=redirect chain=dstnat comment="Redirecionamento do Proxy" disabled=\
    no dst-port=80 protocol=tcp src-address=172.16.0.0/24 to-ports=8080




    ////////////////////////////////////////////////////////////////////////////////////




    /ip firewall filter
    add chain=input action=accept dst-port=8080 protocol=tcp comment="ACEITAR \
    CONEXOES PROXY" disabled=no


    ////////////////////////////////////////////////////////////////////////////////////




    /ip proxy
    set always-from-cache=yes cache-administrator=webmaster cache-hit-dscp=4 \
    cache-on-disk=yes enabled=yes max-cache-size=unlimited \
    max-client-connections=600 max-fresh-time=3d max-server-connections=600 \
    parent-proxy=0.0.0.0 parent-proxy-port=0 port=8080 serialize-connections=no \
    src-address=0.0.0.0


    ///////////////////////////////////////////////////////////////////////////////////




    /ip proxy access
    add action=allow comment="Portas Para MSN" disabled=no dst-port=1025-65535
    add action=deny comment="" disabled=no path=*ADSAdClient31.dll* redirect-to=\
    www.mkinfor.net/geronimo/msn.html
    add action=deny comment=\
    "allow CONNECT only to SSL ports 443 [https] and 563 [snews]" disabled=no \
    dst-port=!443,563 method=CONNECT
    add action=deny comment="" disabled=no path=*ork.user* redirect-to=\
    www.mkinfor.net/geronimo/orkut.html
    add action=deny comment="block telnet & spam e-mail relaying" disabled=no \
    dst-port=23-25


    ///////////////////////////////////////////////////////////////////////////////////




    /ip proxy cache
    add action=deny comment="" disabled=no dst-host=":cgi-bin \\\?"
    add action=deny comment="" disabled=no dst-host=https: path=/
    add action=allow comment="" disabled=no dst-host=http: path=\
    /www.rjnet.com.br/2velocimetro.php
    add action=allow comment="" disabled=no dst-host=http: path=/www.terra.com.br
    add action=deny comment="" disabled=no dst-host=":cgi-bin \\\\\\\?"
    add action=deny comment="" disabled=no dst-host=https: path=/
    add action=allow comment="" disabled=no dst-host=http: path=\
    /www.rapidus.com.br/velocidade/
    add action=allow comment="" disabled=no dst-host=http: path=/www.bol.com.br
    add action=allow comment="" disabled=no dst-host=http: path=/www.orkut.com
    add action=allow comment="" disabled=no dst-host=http: path=\
    /www.autonoma.com.br/medidor/meter.php
    add action=allow comment="" disabled=no dst-host=http: path=\
    /medidor.brisanet.com.br/
    add action=deny comment="" disabled=no dst-host=https: path=\
    /portal.directv.com.br
    add action=deny comment="" disabled=no dst-host=http: path=\
    /chat03.terra.com.br/
    add action=allow comment="" disabled=no dst-host=http*youtube*get_video*
    add action=allow comment="" disabled=no dst-host=http*youtube*video*
    add action=allow comment="" disabled=no dst-host=\
    "http*youtube*yva_get_video_inf o*"
    add action=allow comment="" disabled=no dst-host="\":\\\\\\\\.flv\$\""
    add action=allow comment="" disabled=no dst-host=http*globo*get_video*
    add action=allow comment="" disabled=no dst-host=http*globo*video*
    add action=allow comment="" disabled=no dst-host=http*googlevideo*get_video*
    add action=allow comment="" disabled=no dst-host=http*googlevideo*video*
    add action=allow comment="" disabled=no dst-host=http*video.google*get_video*
    add action=allow comment="" disabled=no dst-host=http*video.google*video*
    add action=allow comment="" disabled=no dst-host=http*videoplay*
    add action=allow comment="" disabled=no dst-host=http*74.125.15.83*get_video*
    add action=allow comment="" disabled=no dst-host=: path=:.swf*
    add action=deny comment="" disabled=no dst-host=":cgi-bin \\\?"
    add action=deny comment="" disabled=no dst-host=https: path=/
    add action=deny comment="" disabled=no dst-host=":cgi-bin \\\?"
    add action=deny comment="" disabled=no dst-host=start.com.br
    add action=deny comment="" disabled=no dst-host=http: path=/speed
    add action=deny comment="" disabled=no dst-host=https: path=/
    add action=allow comment="" disabled=no dst-host=":\\.exe\$"
    add action=allow comment="" disabled=no dst-host=":\\.zip\$"
    add action=allow comment="" disabled=no dst-host=":\\.mpeg\$"
    add action=allow comment="" disabled=no dst-host=":\\.avi\$"
    add action=allow comment="" disabled=no dst-host=":\\.pdf\$"
    add action=allow comment="" disabled=no dst-host=":\\.css\$"
    add action=allow comment="" disabled=no dst-host=":\\.rar\$"
    add action=allow comment="" disabled=no dst-host=":\\.mov\$"
    add action=allow comment="" disabled=no dst-host=":\\.mpg\$"
    add action=allow comment="" disabled=no dst-host=":\\.iso\$"
    add action=allow comment="" disabled=no dst-host=":\\.bin\$"
    add action=allow comment="" disabled=no dst-host=":\\.dat\$"
    add action=allow comment="" disabled=no dst-host=www.terra.com.br
    add action=deny comment="" disabled=no dst-host=":cgi-bin \\\\\\\?"
    add action=deny comment="" disabled=no dst-host=https:/
    add action=allow comment="" disabled=no dst-host=http: path=\
    /www.rapidus.com.br/velocidade/
    add action=allow comment="" disabled=no dst-host=http: path=/www.bol.com.br
    add action=allow comment="" disabled=no dst-host=http: path=/www.orkut.com
    add action=allow comment="" disabled=no dst-host=http: path=\
    /www.autonoma.com.br/medidor/meter.php
    add action=allow comment="" disabled=no dst-host=http: path=\
    /medidor.brisanet.com.br/
    add action=deny comment="" disabled=no dst-host=https: path=\
    /portal.directv.com.br
    add action=deny comment="" disabled=no dst-host=http://chat03.terra.com.br/
    add action=allow comment="" disabled=no dst-host=http*youtube*get_video*
    add action=allow comment="" disabled=no dst-host=http*youtube*video*
    add action=allow comment="" disabled=no dst-host=\
    "http*youtube*yva_get_video_inf o*"
    add action=allow comment="" disabled=no dst-host="\":\\\\\\\\.flv\$\""
    add action=allow comment="" disabled=no dst-host=http*globo*get_video*
    add action=allow comment="" disabled=no dst-host=http*globo*video*
    add action=allow comment="" disabled=no dst-host=http*googlevideo*get_video*
    add action=allow comment="" disabled=no dst-host=http*googlevideo*video*
    add action=allow comment="" disabled=no dst-host=http*video.google*get_video*
    add action=allow comment="" disabled=no dst-host=http*video.google*video*
    add action=allow comment="" disabled=no dst-host=http*videoplay*
    add action=allow comment="" disabled=no dst-host=http*74.125.15.83*get_video*
    add action=allow comment="" disabled=no dst-host=::.swf* path=""
    add action=deny comment="" disabled=no dst-host=":cgi-bin \\\?"
    add action=deny comment="" disabled=no dst-host=":cgi-bin \\\?"
    add action=deny comment="" disabled=no dst-host=start.com.br
    add action=deny comment="" disabled=no dst-host=http://speed path=""
    add action=allow comment="" disabled=no dst-host=":\\.exe\$"
    add action=allow comment="" disabled=no dst-host=":\\.zip\$"
    add action=allow comment="" disabled=no dst-host=":\\.mpeg\$"
    add action=allow comment="" disabled=no dst-host=":\\.avi\$"
    add action=allow comment="" disabled=no dst-host=":\\.pdf\$"
    add action=allow comment="" disabled=no dst-host=":\\.css\$"
    add action=allow comment="" disabled=no dst-host=":\\.rar\$"
    add action=allow comment="" disabled=no dst-host=":\\.mov\$"
    add action=allow comment="" disabled=no dst-host=":\\.mpg\$"
    add action=allow comment="" disabled=no dst-host=":\\.iso\$"
    add action=allow comment="" disabled=no dst-host=":\\.bin\$"
    add action=allow comment="" disabled=no dst-host=":\\.dat\$"



  5. #5

    Padrão Re: Cache Aumenta muito o Ping,do teste de velocidade

    continuando....
    ///////////////////////////////////////////////////////////////////////////////




    /ip firewall address-list
    add address=69.147.95.0/24 comment="\"\"\"\"YAHOO MAIL\"\"\"\"" disabled=no \
    list=nobalance
    add address=209.191.106.0/24 comment="\"\"\"\"YAHOO MAIL\"\"\"\"" disabled=no \
    list=nobalance
    add address=74.6.228.0/24 comment="\"\"\"\"YAHOO MAIL\"\"\"\"" disabled=no \
    list=nobalance
    add address=98.136.131.0/24 comment="\"\"\"\"YAHOO MAIL\"\"\"\"" disabled=no \
    list=nobalance
    add address=200.143.37.0/24 comment="\"\"\"\"WEBMOTORS\"\"\"\"" disabled=no \
    list=nobalance
    add address=65.54.0.0/16 comment=MSN1 disabled=no list=nobalance
    add address=207.46.0.0/16 comment=MSN2 disabled=no list=nobalance
    add address=64.4.0.0/16 comment=MSN3 disabled=no list=nobalance
    add address=200.143.0.0/16 comment=Pagdigital disabled=no list=nobalance
    add address=201.88.0.0/16 comment=f2b disabled=no list=nobalance
    add address=200.201.0.0/16 comment="caixa economica" disabled=no list=\
    nobalance
    add address=170.66.0.0/16 comment="bb do brasil" disabled=no list=nobalance
    add address=200.155.0.0/16 comment=bradesco disabled=no list=nobalance
    add address=200.196.0.0/16 comment=itau disabled=no list=nobalance
    add address=200.208.0.0/16 comment=sudameris disabled=no list=nobalance
    add address=200.220.0.0/16 comment=santander disabled=no list=nobalance
    add address=201.63.0.0/16 comment="wwws bradesco" disabled=no list=nobalance
    add address=65.55.0.0/16 comment=MSN4 disabled=no list=nobalance
    add address=74.52.0.0/16 comment="caixa economica" disabled=no list=nobalance
    add address=74.125.0.0/16 comment="caixa economica" disabled=no list=nobalance
    add address=174.133.0.0/16 comment="caixa economica" disabled=no list=\
    nobalance
    add address=200.219.137.0/24 comment="" disabled=no list=nobalance
    add address=200.252.8.0/24 comment="" disabled=no list=nobalance
    add address=201.2.207.0/24 comment="" disabled=no list=nobalance
    add address=200.196.226.0/24 comment="" disabled=no list=nobalance
    add address=201.24.72.0/24 comment="" disabled=no list=nobalance
    add address=78.46.46.139 comment="" disabled=no list=nobalance




    /////////////////////////////////////////////////////////////////////////////////




    /ip firewall nat
    add action=accept chain=dstnat comment=\
    "\"\"\"\"\"\"SERVI\C7OS NOBRES FORA DO PROXY\"\"\"\"\"\"" disabled=no \
    dst-address-list=nobalance dst-port=80 protocol=tcp


    //////////////////////////////////////////////////////////////////////////////////

  6. #6

    Padrão Re: Cache Aumenta muito o Ping,do teste de velocidade

    acho que o problema é max-cache-size=unlimited porque voce tem que dimensionar o tamanho maximo de cache comparando a sua memoria RAM, porque se vc tiver muito cache em HD e a RAM não tão suficiente a maquina vai agachar...

    Tanto que a GVT faz cache mas em RAM o que torna eficiente ... Vou pesquisar mas se nao me engano voce pode colocar para cada 1 GB de RAM 10 GB de cache



  7. #7

    Padrão Re: Cache Aumenta muito o Ping,do teste de velocidade


  8. #8

    Padrão Re: Cache Aumenta muito o Ping,do teste de velocidade

    mas pra q essa regra irmao me explica melhor ...



  9. #9

    Padrão Re: Cache Aumenta muito o Ping,do teste de velocidade

    bom,obrigado pela ajuda,efim
    é uma configuração padrão de cache full,o nat que redireciona o trafego para a por do proxy,uma marcação pelo dscp tos que envia os arquivos armazenado em cache com um controle maior do que o do cliente,um adress-list que diz os serviços que ficam fora do cache,por ultimo que tem acesso ao cache,um nat que redireciona o adress list para a porta 80 fazendo com os serviços fiquem fora do cache,um filtro que aceita as requisiçoes,um controle no qos-tree que controla a velocidade que os arquivos,vão para o cliente axo que no mais é isso,

  10. #10

    Padrão Re: Cache Aumenta muito o Ping,do teste de velocidade

    pessoal,Resolvi,depois de algumas,horas de estudo no wiki do mikrotik,não consegui resolver meu poblema da maneria que eu queria,mais desisti de usar o cache no mirktoik tah rodando o squid facil,é um ubunto com servidor squid ja instalado recomendo a quem esta com dificuldade,e o cache ful tah normal,o ping normalizou,e estah belezinha,coloquei um pach zph que me deu cache em alguamas paginas dinamicas ajudou bem,no mais é isso valeu a todos



  11. #11

    Padrão Re: Cache Aumenta muito o Ping,do teste de velocidade

    Massa!!

    bão que vc voltou aqui pra nos contar como resolveu...

  12. #12

    Padrão Re: Cache Aumenta muito o Ping,do teste de velocidade

    sempre,valeuuuu!!!!!!!!!!!!!!



  13. #13

    Padrão Re: Cache Aumenta muito o Ping,do teste de velocidade

    galera estou revendo as questao de ussar cache....vou pasar meu casa e a gradeso se auguem pode me ajuda..... fis tudo certinho esta fucionado ok so que quando o cache esta ativo ele aumenta o ping para 400m quando desligo fica em 10m isso e normal....

    e o video do youtube naum carega mais para fala a verdade nem entra no site mais
    sera que vc pode da essa ajuda para mais um aprendis do mikrotik......


    hoje eu usso o mikrotik 3.30 comprei a licensa 6 meu pcap e um core 2 duor com 4 gh de memoria e um hd de 160 ide e estou pensando em colocar dois satat de 1t