+ Responder ao Tópico



  1. #1

    Padrão Ubuntu 11.04 Problemas com NAT

    Olá Galera!

    Estou com um probleminha aqui com um Ubuntu 11.04, instalei ele e com meu modem adsl em bridge estou fazendo a conexão pppoe no server, configurei isto em modo gráfico. porém nas estações não funciona a internet normalmente... consigo acessar google.com.br, imagens, gmail, etc.... mas vários outros sites não acessa.... exemplo globo, terra etc...


    OBS:
    MODEM ADSL ------>eth0 SERVIDOR eth1-------> SWITCH
    meu rc.local está assim:

    iptables -F
    iptables -t nat -F
    iptables -t mangle -F
    modprobe ip_nat_ftp
    modprobe ip_tables
    modprobe ip_conntrack
    modprobe ipt_MASQUERADE
    modprobe iptable_filter
    modprobe iptable_nat

    echo 1 > /proc/sys/net/ipv4/ip_forward
    iptables -t nat -A POSTROUTING -j MASQUERADE




    Obrigado!

  2. #2
    Analista de Suporte em TI Avatar de demattos
    Ingresso
    Jul 2011
    Localização
    Criciuma/SC
    Posts
    1.923
    Posts de Blog
    3

    Padrão Re: Ubuntu 11.04 Problemas com NAT

    Verifica o dns, que esta no resolv.conf



  3. #3

    Padrão Re: Ubuntu 11.04 Problemas com NAT

    o resolv.conf fica no diretório "/etc/"

    mas como vc ta subindo um pppoe ele ja está especificando o DNS pra vc... acho q o correto seria vc acertar o DNS dos terminais também!

    Att.

  4. #4

    Padrão Re: Ubuntu 11.04 Problemas com NAT

    #cat /etc/resolv.conf
    nameserver 8.8.8.8
    nameserver 201.10.120.3
    nameserver 201.10.128.2


    nas estações estou utilizando 8.8.8.8

    Obrigado pela atenção!



  5. #5

    Padrão Re: Ubuntu 11.04 Problemas com NAT

    C:\Users\Suporte>ping globo.com - Absolutamente tudo sobre notícias, esportes e entretenimento


    Disparando globo.com - Absolutamente tudo sobre notícias, esportes e entretenimento [186.192.82.163] com 32 bytes de dados:
    Resposta de 186.192.82.163: bytes=32 tempo=52ms TTL=120
    Resposta de 186.192.82.163: bytes=32 tempo=58ms TTL=120
    Resposta de 186.192.82.163: bytes=32 tempo=54ms TTL=120
    Resposta de 186.192.82.163: bytes=32 tempo=53ms TTL=120


    Estatísticas do Ping para 186.192.82.163:
    Pacotes: Enviados = 4, Recebidos = 4, Perdidos = 0 (0% de
    perda),
    Aproximar um número redondo de vezes em milissegundos:
    Mínimo = 52ms, Máximo = 58ms, Média = 54ms

    Será problema de DNS nas estações?

  6. #6

    Padrão Re: Ubuntu 11.04 Problemas com NAT

    cara... pela resposta do seu ping ta resolvendo e navegando...
    verifica se não tem nada setado nas "Conexões" do I.E.

    outra... há tempos tive problemas parecidos mas era com site de bancos...

    em um dos terminais... vá em c:\windows\system32\drivers\etc\

    edite o arquivo "hosts" e veja se já está setado tipo

    IP -----> site

    se houver apague o conteúdo e tente novamente...

    Att.



  7. #7

    Padrão Re: Ubuntu 11.04 Problemas com NAT

    tenho 2 internet aqui para testes.... uma é o ubuntu quem faz o nat...10.1.1.0/24 e a outra é um centOS....192.168.0.0/24
    se eu colocar o mesmo terminal que não está funcionando a internet do ubuntu na rede 192.168.0.x funciona perfeito a internet.. ou seja não é problema de navegador, nem de configuração do windows, penso que pode ser falta de algum pacote no ubuntu

  8. #8

    Padrão Re: Ubuntu 11.04 Problemas com NAT

    entendi...
    experimenta alterar o DNS dos terminais para os correspondentes ao link então...

    ex.: speedy, net, gvt.

    experimenta fazer o teste com o openDns nos terminais...
    praticamente não há possibilidade de ser falta de algum pacote no ubuntu... já que vc disse que apenas alguns sites não resolve.

    Att.



  9. #9

    Padrão Re: Ubuntu 11.04 Problemas com NAT

    testei da seguinte forma... se eu colocar no meu rc.local assim:

    ifconfig eth0 192.168.254.254 netmask 255.255.255.0 up
    route add default gw 192.168.254.254

    ifconfig eth1 10.1.1.1 netmask 255.255.255.0 up

    echo 1 > /proc/sys/net/ipv4/ip_forward
    iptables -t nat -A POSTROUTING -j MASQUERADE

    e se eu colocar meu modem p/ fazer o pppoe funciona perfeito... ou seja... o servidor até faz o nat....consequentemente não tem problemas nos terminais, nem nos DNS. mas o problema é quando o servidor conecta o pppoe

  10. #10

    Padrão Re: Ubuntu 11.04 Problemas com NAT

    Ninguem ai sabe o que pode ser????



  11. #11

    Padrão Re: Ubuntu 11.04 Problemas com NAT

    o Sr tentou alterar os DNS nos terminais? pois de uma coisa eu tenho certeza... não se pode esperar resultados diferentes fazendo as coisas da mesma forma =)

    Experimenta compartilhar apenas o pppoe do serv:

    Código :
    iptables -t nat -A POSTROUTING -s 192.168.0.0/24 -o ppp+ -j MASQUERADE

    Mas antes... tente alterar os DNS dos terminais e fazer o teste!

    eu também não sei o que pode ser... porem apenas testando que vc vai conseguir desvendar o mistério...

    Att.

  12. #12

    Padrão Re: Ubuntu 11.04 Problemas com NAT

    Feito!, coloquei o modem fazendo nat, e fiz dmz p/ ele!!! mas fica esta dúvida... não funcionou o servidor ubuntu conectando pppoe e fazendo nat.

    sim Lincaum eu testei e testei várias formas não funcionou com outro dns nos terminais, inclusive testei vááários dns

    Obrigado a todos pelas respostas!